FRAGSTATS CONCEPTUAL BACKGROUND

Landscape Pattern Metrics

This document provides a brief overview of landscape pattern metrics as they are commonly applied in landscape ecology, as well as some key terms and concepts essential to using FRAGSTATS and quantifying landscape patterns. An understanding of the material in this section is prerequisite to the proper use of FRAGSTATS.

INTRODUCTION

WHAT IS A LANDSCAPE?

CLASSES OF LANDSCAPE PATTERN

PATCH-CORRIDOR-MATRIX MODEL

THE IMPORTANCE OF SCALE

LANDSCAPE CONTEXT

PERSPECTIVES ON CATEGORICAL MAP PATTERNS

PATCHES & PATCHINESS: LEVELS OF LANDSCAPE METRICS

LANDSCAPE METRICS

STRUCTURAL VERSUS FUNCTIONAL METRICS

LIMITATIONS IN THE USE AND INTERPRETATION OF METRICS

LITERATURE CITED


INTRODUCTION

Landscape ecology, if not ecology in general, is largely founded on the notion that environmental patterns strongly influence ecological processes (Turner 1989). The habitats in which organisms live, for example, are spatially structured at a number of scales, and these patterns interact with organism perception and behavior to drive the higher level processes of population dynamics and community structure (Johnson et al. 1992). Anthropogenic activities (e.g. development, timber harvest) can disrupt the structural integrity of landscapes and is expected to impede, or in some cases facilitate, ecological flows (e.g., movement of organisms) across the landscape (Gardner et al. 1993). A disruption in landscape patterns may therefore compromise its functional integrity by interfering with critical ecological processes necessary for population persistence and the maintenance of biodiversity and ecosystem health (With 2000). For these and other reasons, much emphasis has been placed on developing methods to quantify landscape patterns, which is considered a prerequisite to the study of pattern-process relationships (e.g., O'Neill et al. 1988, Turner 1990, Turner and Gardner 1991, Baker and Cai 1992, McGarigal and Marks 1995). This has resulted in the development of literally hundreds of indices of landscape patterns. This progress has been facilitated by recent advances in computer processing and geographic information (GIS) technologies. Unfortunately, according to Gustafson (1998), “the distinction between what can be mapped and measured and the patterns that are ecologically relevant to the phenomenon under investigation or management is sometimes blurred.”


WHAT IS A LANDSCAPE?

Landscape ecology by definition deals with the ecology of landscapes. Surprisingly, there are many different interpretations of the term “landscape.” The disparity in definitions makes it difficult to communicate clearly, and even more difficult to establish consistent management policies. Definitions of landscape invariably include an area of land containing a mosaic of patches or landscape elements (see below). Forman and Godron (1986) defined landscape as a heterogeneous land area composed of a cluster of interacting ecosystems that is repeated in similar form throughout. The concept differs from the traditional ecosystem concept in focusing on groups of ecosystems and the interactions among them. There are many variants of the definition depending on the research or management context.

For example, from a wildlife perspective, we might define landscape as an area of land containing a mosaic of habitat patches, often within which a particular "focal" or "target" habitat patch is embedded (Dunning et al. 1992). Because habitat patches can only be defined relative to a particular organism's perception and scaling of the environment (Wiens 1976), landscape size would differ among organisms. However, landscapes generally occupy some spatial scale intermediate between an organism's normal home range and its regional distribution. In-other-words, because each organism scales the environment differently (i.e., a salamander and a hawk view their environment on different scales), there is no absolute size for a landscape; from an organism-centered perspective, the size of a landscape varies depending on what constitutes a mosaic of habitat or resource patches meaningful to that particular organism.

This definition most likely contrasts with the more anthropocentric definition that a landscape corresponds to an area of land equal to or larger than, say, a large basin (e.g., several thousand hectares). Indeed, Forman and Godron (1986) suggested a lower limit for landscapes at a "few kilometers in diameter", although they recognized that most of the principles of landscape ecology apply to ecological mosaics at any level of scale. While this may be a more pragmatic definition than the organism-centered definition and perhaps corresponds to our human perception of the environment, it has limited utility in managing wildlife populations if you accept the fact that each organism scales the environment differently. From an organism-centered perspective, a landscape could range in absolute scale from an area smaller than a single forest stand (e.g., a individual log) to an entire ecoregion. If you accept this organism-centered definition of a landscape, a logical consequence of this is a mandate to manage habitats across the full range of spatial scales; each scale, whether it be the stand or watershed, or some other scale, will likely be important for a subset of species, and each species will likely respond to more than 1 scale.

KEY POINT It is not my intent to argue for a single definition of landscape. Rather, I wish to point out that there are many appropriate ways to define landscape depending on the phenomenon under consideration. The important point is that a landscape is not necessarily defined by its size; rather, it is defined by an interacting mosaic of patches relevant to the phenomenon under consideration (at any scale). It is incumbent upon the investigator or manager to define landscape in an appropriate manner. The essential first step in any landscape-level research or management endeavor is to define the landscape, and this is of course prerequisite to quantifying landscape patterns.


CLASSES OF LANDSCAPE PATTERN

Real landscapes (at any scale) contain complex spatial patterns in the distribution of resources that vary over time; quantifying these patterns and their dynamics is the purview of landscape pattern analysis. Landscape patterns can be quantified in a variety of ways depending on the type of data collected, the manner in which it is collected, and the objectives of the investigation. Broadly considered, landscape pattern analysis involves four basic types of spatial data corresponding to different representations of landscape pattern. These look rather different numerically, but they share a concern with the relative concentration of spatial variability:

(1) Spatial point patterns represent collections of entities where the geographic locations of the entities are of primary interest, rather than any quantitative or qualitative attribute of the entity itself. A familiar example is a map of all trees in a forest stand, wherein the data consists of a list of trees referenced by their geographic locations. Typically, the points would be labeled by species, and perhaps further specified by their sizes (a marked point pattern). The goal of point pattern analysis with such data is to determine whether the points are more or less clustered than expected by chance and/or to find the spatial scale(s) at which the points tend to be more or less clustered than expected by chance (Greig-Smith 1983, Dale 1999).

(2) Linear network patterns represent collections of linear landscape elements that intersect to form a network. A familiar example is a map of streams or riparian areas in a watershed, wherein the data consists of nodes and linkages (corridors that connect nodes); the intervening area is considered the matrix and is typically ignored (i.e., treated as ecologically neutral). Often, the nodes and corridors are further characterized by composition (e.g., vegetation type) and spatial character (e.g., width). As with point patterns, it is the geographic location and arrangement of nodes and corridors that is of primary interest. The goal of linear network pattern analysis with such data is to characterize the physical structure (e.g., corridor density, mesh size, network connectivity and circuitry) of the network, and a variety of metrics have been developed for this purpose (Forman 1995).

(3) Surface patterns represent quantitative measurements that vary continuously across the landscape; there are no explicit boundaries (i.e., patches are not delineated). Here, the data can be conceptualized as representing a three-dimensional surface, where the measured value at each geographic location is represented by the height of the surface. A familiar example is a digital elevation model, but any quantitative measurement can be treated this way (e.g., plant biomass, leaf area index, soil nitrogen, density of individuals). In many cases the data is collected at discrete sample locations separated by some distance. Analysis of the spatial dependencies (or autocorrelation) in the measured characteristic is the purview of geostatistics, and a variety of techniques exist for measuring the intensity and scale of this spatial autocorrelation (Legendre and Fortin 1989, Legendre and Legendre 1999). Techniques also exist that permit the kriging or modeling of these spatial patterns; that is, to interpolate values for unsampled locations using the empirically estimated spatial autocorrelation. These surface pattern techniques were developed to quantify spatial patterns from sampled data (n). When the data is exhaustive (i.e., the whole population, N) over the study landscape, like it is with the case of remotely sensed data, other techniques (e.g., two-dimensional spectral analysis, Ford and Renshaw 1984, Renshaw and Ford 1984, Legendre and Fortin 1989; or two-dimensional wavelet analysis, Bradshaw and Spies 1992) are more appropriate. All surface pattern techniques share a goal of describing the intensity and scale of pattern in the quantitative variable of interest. In all cases, while the location of the data points (or quadrats) is known and of interest, it is the values of the measurement taken at each point that are of primary concern. Here, the basic question is, "Are samples that are close together also similar with respect to the measured variable?” Alternatively, “What is the distance(s) over which values tend to be similar?”

(4) Categorical (or thematic; choropleth) map patterns represent data in which the system property of interest is represented as a mosaic of discrete patches. From an ecological perspective, patches represent relatively discrete areas of relatively homogeneous environmental conditions at a particular scale. The patch boundaries are distinguished by abrupt discontinuities (boundaries) in environmental character states from their surroundings of magnitudes that are relevant to the ecological phenomenon under consideration (Wiens 1976, Kotliar and Wiens 1990). A familiar example is a map of land cover types, wherein the data consists of polygons (vector format) or grid cells (raster format) classified into discrete land cover classes. There are a multitude of methods for deriving a categorical map (mosaic of patches) which has important implications for the interpretation of landscape pattern metrics (see below). Patches may be classified and delineated qualitatively through visual interpretation of the data (e.g., delineating vegetation polygons through interpretation of aerial photographs), as is typically the case with vector maps constructed from digitized lines. Alternatively, with raster grids (constructed of grid cells), quantitative information at each location may be used to classify cells into discrete classes and to delineate patches by outlining them, and there are a variety of methods for doing this. The most common and straightforward method is simply to aggregate all adjacent (touching) areas that have the same (or similar) value on the variable of interest. An alternative approach is to define patches by outlining them: that is, by finding the edges around patches (Fortin 1994, Fortin and Drapeau 1995, Fortin et al. 2000). An edge in this case is an area where the measured value changes abruptly (i.e., high local variance or rate of change). An alternative is to use a divisive approach, beginning with a single patch (the entire landscape) and then successively partitioning this into regions that are statistically homogeneous patches (Pielou 1984). A final method to create patches is to cluster them hierarchically, but with a constraint of spatial adjacency (Legendre and Fortin 1989). Regardless of data format (raster or vector) and method of classifying and delineating patches, the goal of categorical map pattern analysis with such data is to characterize the composition and spatial configuration of the patch mosaic, and a plethora of metrics has been developed for this purpose (Forman and Godron 1986, O'Neill et al. 1988, Turner 1990, Musick and Grover 1991, Turner and Gardner 1991, Baker and Cai 1992, Gustafson and Parker 1992, Li and Reynolds 1993, McGarigal and Marks 1995, Jaeger 2000).

Although a large part of landscape pattern analysis deals with the identification of scale and intensity of pattern, landscape metrics focus on the characterization of the geometric and spatial properties of categorical map patterns represented at a particular scale (grain and extent). Thus, while it is important to recognize the variety of types of landscape patterns and goals of landscape pattern analysis, I will focus on landscape metrics as they are applied in landscape ecology.


PATCH-CORRIDOR-MATRIX MODEL

Landscapes are composed of elements–the spatial components that make up the landscape. A convenient and popular model for conceptualizing and representing the elements in a categorical map pattern is known as the patch-corridor-matrix model (Forman 1995). Under this model, three major landscape elements are typically recognized, and the extent and configuration of these elements defines the pattern of the landscape.

(1) Patch.--Landscapes are composed of a mosaic of patches (Urban et al. 1987). Landscape ecologists have used a variety of terms to refer to the basic elements or units that make up a landscape, including ecotope, biotope, landscape component, landscape element, landscape unit, landscape cell, geotope, facies, habitat, and site (Forman and Godron 1986). Any of these terms, when defined, are satisfactory according to the preference of the investigator. Like the landscape, patches comprising the landscape are not self-evident; patches must be defined relative to the phenomenon under consideration. For example, from a timber management perspective a patch may correspond to the forest stand. However, the stand may not function as a patch from a particular organism's perspective. From an ecological perspective, patches represent relatively discrete areas (spatial domain) or periods (temporal domain) of relatively homogeneous environmental conditions where the patch boundaries are distinguished by discontinuities in environmental character states from their surroundings of magnitudes that are perceived by or relevant to the organism or ecological phenomenon under consideration (Wiens 1976). From a strictly organism-centered view, patches may be defined as environmental units between which fitness prospects, or "quality", differ; although, in practice, patches may be more appropriately defined by nonrandom distribution of activity or resource utilization among environmental units, as recognized in the concept of "Grain Response".

Patches are dynamic and occur on a variety of spatial and temporal scales that, from an organism-centered perspective, vary as a function of each animal's perceptions (Wiens 1976 and 1989, Wiens and Milne 1989). A patch at any given scale has an internal structure that is a reflection of patchiness at finer scales, and the mosaic containing that patch has a structure that is determined by patchiness at broader scales (Kotliar and Wiens 1990). Thus, regardless of the basis for defining patches, a landscape does not contain a single patch mosaic, but contains a hierarchy of patch mosaics across a range of scales. For example, from an organism-centered perspective, the smallest scale at which an organism perceives and responds to patch structure is its "grain" (Kotliar and Wiens 1990). This lower threshold of heterogeneity is the level of resolution at which the patch size becomes so fine that the individual or species stops responding to it, even though patch structure may actually exist at a finer resolution (Kolasa and Rollo 1991). The lower limit to grain is set by the physiological and perceptual abilities of the organism and therefore varies among species. Similarly, "extent" is the coarsest scale of heterogeneity, or upper threshold of heterogeneity, to which an organism responds (Kotliar and Wiens 1990, Kolasa and Rollo 1991). At the level of the individual, extent is determined by the lifetime home range of the individual (Kotliar and Wiens 1990) and varies among individuals and species. More generally, however, extent varies with the organizational level (e.g., individual, population, metapopulation) under consideration; for example the upper threshold of patchiness for the population would probably greatly exceed that of the individual. Therefore, from an organism-centered perspective, patches can be defined hierarchically in scales ranging between the grain and extent for the individual, deme, population, or range of each species.

Patch boundaries are artificially imposed and are in fact meaningful only when referenced to a particular scale (i.e., grain size and extent). For example, even a relatively discrete patch boundary between an aquatic surface (e.g., lake) and terrestrial surface becomes more and more like a continuous gradient as one progresses to a finer and finer resolution. However, most environmental dimensions possess 1 or more "domains of scale" (Wiens 1989) at which the individual spatial or temporal patches can be treated as functionally homogeneous; at intermediate scales the environmental dimensions appear more as gradients of continuous variation in character states. Thus, as one moves from a finer resolution to coarser resolution, patches may be distinct at some scales (i.e., domains of scale) but not at others.

KEY POINT It is not my intent to argue for a particular definition of patch. Rather, I wish to point out the following: (1) that patch must be defined relative to the phenomenon under investigation or management; (2) that, regardless of the phenomenon under consideration (e.g., a species, geomorphological disturbances, etc), patches are dynamic and occur at multiple scales; and (3) that patch boundaries are only meaningful when referenced to a particular scale. It is incumbent upon the investigator or manager to establish the basis for delineating among patches and at a scale appropriate to the phenomenon under consideration.

(2) Corridor.--Corridors are linear landscape elements that can be defined on the basis of structure or function. Forman and Godron (1986) define corridors as “narrow strips of land which differ from the matrix on either side. Corridors may be isolated strips, but are usually attached to a patch of somewhat similar vegetation.” These authors focus on the structural aspects of the linear landscape element. As a consequence of their form and context, structural corridors may function as habitat, dispersal conduits, or barriers. Three different types of structural corridors exist: (1) line corridors, in which the width of the corridor is too narrow to allow for interior environmental conditions to develop; (2) strip corridors, in which the width of the corridor is wide enough to allow for interior conditions to develop; and (3) stream corridors, which are a special category.

Corridors may also be defined on the basis of their function in the landscape. At least four major corridor functions have been recognized, as follows:

1. Habitat Corridor.--Linear landscape element that provides for survivorship, natality, and movement (i.e., habitat), and may provide either temporary or permanent habitat. Habitat corridors passively increase landscape connectivity for the focal organism(s).

2. Facilitated Movement Corridor.–Linear landscape element that provides for survivorship and movement, but not necessarily natality, between other habitat patches. Facilitated movement corridors actively increase landscape connectivity for the focal organism(s).

3. Barrier or Filter Corridor.–Linear landscape element that prohibits (i.e., barrier) or differentially impedes (i.e., filter) the flow of energy, mineral nutrients, and/or species across (i.e., flows perpendicular to the length of the corridor). Barrier or filter corridors actively decrease matrix connectivity for the focal process.

4. Source of Abiotic and Biotic Effects on the Surrounding Matrix.–Linear landscape element that modifies the inputs of energy, mineral nutrients, and/or species to the surrounding matrix and thereby effects the functioning of the surrounding matrix.

Most of the attention and debate has focused on facilitated movement corridors. It has been argued that this corridor function can only be demonstrated when the immigration rate to the target patch is increased over what it would be if the linear element was not present (Rosenberg et al. 1997). Unfortunately, as Rosenberg et al. point out, there have been few attempts to experimentally demonstrate this. In addition, just because a corridor can be distinguished on the basis of structure, it does not mean that it assumes any of the above functions. Moreover, the function of the corridor will vary among organisms due to the differences in how organisms perceive and scale the environment.

KEY POINT Corridors are distinguished from patches by their linear nature and can be defined on the basis of either structure or function or both. If a corridor is specified, it is incumbent upon the investigator or manager to define the structure and implied function relative to the phenomena (e.g., species) under consideration.

(3) Matrix.--A landscape is composed typically of several types of landscape elements (usually patches). Of these, the matrix is the most extensive and most connected landscape element type, and therefore plays the dominant role in the functioning of the landscape (Forman and Godron 1986). For example, in a large contiguous area of mature forest embedded with numerous small disturbance patches (e.g., timber harvest patches), the mature forest constitutes the matrix element type because it is greatest in areal extent, is mostly connected, and exerts a dominant influence on the area flora and fauna and ecological processes. In most landscapes, the matrix type is obvious to the investigator or manager. However, in some landscapes, or at a certain point in time during the trajectory of a landscape, the matrix element will not be obvious. Indeed, it may not be appropriate to consider any element as the matrix. Moreover, the designation of a matrix element is largely dependent upon the phenomenon under consideration. For example, in the study of geomorphological processes, the geological substrate may serve to define the matrix and patches; whereas, in the study of vertebrate populations, vegetation structure may serve to define the matrix and patches. In addition, what constitutes the matrix is dependent on the scale of investigation or management. For example, at a particular scale, mature forest may be the matrix with disturbance patches embedded within; whereas, at a coarser scale, agricultural land may be the matrix with mature forest patches embedded within.

It is important to understand how measures of landscape pattern are influenced by the designation of a matrix element. If an element is designated as matrix and therefore presumed to function as such (i.e., has a dominant influence on landscape dynamics), then it should not be included as another "patch" type in any metric that simply averages some characteristic across all patches (e.g., mean patch size, mean patch shape). Otherwise, the matrix will dominate the metric and serve more to characterize the matrix than the patches within the landscape, although this may itself be meaningful in some applications. From a practical standpoint, it is important to recognize this because in FRAGSTATS, the matrix can be excluded from calculations by designating its class value as background. If the matrix is not excluded from the calculations, it may be more meaningful to use the class-level statistics for each patch type and simply ignore the patch type designated as the matrix. From a conceptual standpoint, it is important to recognize that the choice and interpretation of landscape metrics must ultimately be evaluated in terms of their ecological meaningfulness, which is dependent upon how the landscape is defined, including the choice of patch types and the designation of a matrix.

KEY POINT It is incumbent upon the investigator or manager to determine whether a matrix element exists and should be designated given the scale and phenomenon under consideration.


THE IMPORTANCE OF SCALE

The pattern detected in any ecological mosaic is a function of scale, and the ecological concept of spatial scale encompasses both extent and grain (Forman and Godron 1986, Turner et al. 1989, Wiens 1989). Extent is the overall area encompassed by an investigation or the area included within the landscape boundary. From a statistical perspective, the spatial extent of an investigation is the area defining the population we wish to sample. Grain is the size of the individual units of observation. For example, a fine-grained map might structure information into 1-ha units, whereas a map with an order of magnitude coarser resolution would have information structured into 10-ha units (Turner et al. 1989). Extent and grain define the upper and lower limits of resolution of a study and any inferences about scale-dependency in a system are constrained by the extent and grain of investigation (Wiens 1989). From a statistical perspective, we cannot extrapolate beyond the population sampled, nor can we infer differences among objects smaller than the experimental units. Likewise, in the assessment of landscape pattern, we cannot detect pattern beyond the extent of the landscape or below the resolution of the grain (Wiens 1989).

As with the concept of landscape and patch, it may be more ecologically meaningful to define scale from the perspective of the organism or ecological phenomenon under consideration. For example, from an organism-centered perspective, grain and extent may be defined as the degree of acuity of a stationary organism with respect to short- and long-range perceptual ability (Kolasa and Rollo 1991). Thus, grain is the finest component of the environment that can be differentiated up close by the organism, and extent is the range at which a relevant object can be distinguished from a fixed vantage point by the organism (Kolasa and Rollo 1991). Unfortunately, while this is ecologically an ideal way to define scale, it is not very pragmatic. Indeed, in practice, extent and grain are often dictated by the scale of the imagery (e.g., aerial photo scale) being used or the technical capabilities of the computing environment.

It is critical that extent and grain be defined for a particular study and represent, to the greatest possible degree, the ecological phenomenon or organism under study, otherwise the landscape patterns detected will have little meaning and there is a good chance of reaching erroneous conclusions. For example, it would be meaningless to define grain as 1-ha units if the organism under consideration perceives and responds to habitat patches at a resolution of 1-m2. A strong landscape pattern at the 1-ha resolution may have no significance to the organism under study. Likewise, it would be unnecessary to define grain as 1-m2 units if the organism under consideration perceives habitat patches at a resolution of 1-ha. Typically, however, we do not know what the appropriate resolution should be. In this case, it is much safer to choose a finer grain than is believed to be important Remember, the grain sets the minimum resolution of investigation. Once set, we can always dissolve to a coarser grain. In addition, we can always specify a minimum mapping unit that is coarser than the grain. That is, we can specify the minimum patch size to be represented in a landscape, and this can easily be manipulated above the resolution of the data. It is important to note that the technical capabilities of GIS with respect to image resolution may far exceed the technical capabilities of the remote sensing equipment. Thus, it is possible to generate GIS images at too fine a resolution for the spatial data being represented, resulting in a more complex representation of the landscape than can truly be obtained from the data.

Information may be available at a variety of scales and it may be necessary to extrapolate information from one scale to another. In addition, it may be necessary to integrate data represented at different spatial scales. It has been suggested that information can be transferred across scales if both grain and extent are specified (Allen et al. 1987), yet it is unclear how observed landscape patterns vary in response to changes in grain and extent and whether landscape metrics obtained at different scales can be compared. The limited work on this topic suggests that landscape metrics vary in their sensitivity to changes in scale and that qualitative and quantitative changes in measurements across spatial scales will differ depending on how scale is defined (Turner et al. 1989). Therefore, in investigations of landscape pattern, until more is learned, it is critical that any attempts to compare landscapes measured at different scales be done cautiously.

KEY POINT One of the most important considerations in any landscape ecological investigation or landscape structural analysis is (1) to explicitly define the scale of the investigation or analysis, (2) to describe any observed patterns or relationships relative to the scale of the investigation, and (3) to be especially cautious when attempting to compare landscapes measured at different scales.


LANDSCAPE CONTEXT

Landscapes do not exist in isolation. Landscapes are nested within larger landscapes, that are nested within larger landscapes, and so on. In other words, each landscape has a context or regional setting, regardless of scale and how the landscape is defined. The landscape context may constrain processes operating within the landscape. Landscapes are "open" systems; energy, materials, and organisms move into and out of the landscape. This is especially true in practice, where landscapes are often somewhat arbitrarily delineated. That broad-scale processes act to constrain or influence finer-scale phenomena is one of the key principles of hierarchy theory (Allen and Star 1982) and 'supply-side' ecology (Roughgarden et al. 1987). The importance of the landscape context is dependent on the phenomenon of interest, but typically varies as a function of the "openness" of the landscape. The "openness" of the landscape depends not only on the phenomenon under consideration, but on the basis used for delineating the landscape boundary. For example, from a geomorphological or hydrological perspective, the watershed forms a natural landscape, and a landscape defined in this manner might be considered relatively "closed". Of course, energy and materials flow out of this landscape and the landscape context influences the input of energy and materials by affecting climate and so forth, but the system is nevertheless relatively closed. Conversely, from the perspective of a bird population, topographic boundaries may have little ecological relevance, and the landscape defined on the basis of watershed boundaries might be considered a relatively "open" system. Local bird abundance patterns may be produced not only by local processes or events operating within the designated landscape, but also by the dynamics of regional populations or events elsewhere in the species' range (Wiens 1981, 1989b, Vaisanen et al. 1986, Haila et al. 1987, Ricklefs 1987).

Landscape metrics quantify the pattern of the landscape within the designated landscape boundary only. Consequently, the interpretation of these metrics and their ecological significance requires an acute awareness of the landscape context and the openness of the landscape relative to the phenomenon under consideration. These concerns are particularly important for nearest-neighbor metrics. Nearest-neighbor distances are computed solely from patches contained within the landscape boundary. If the landscape extent is small relative to the scale of the organism or ecological processes under consideration and the landscape is an "open" system relative to that organism or process, then nearest-neighbor results can be misleading. Consider a small subpopulation of a species occupying a patch near the boundary of a somewhat arbitrarily defined (from the organism's perspective) landscape. The nearest neighbor within the landscape boundary might be quite far away, yet in reality the closest patch might be very close, but just outside the landscape boundary. The magnitude of this problem is a function of scale. Increasing the size of the landscape relative to the scale at which the organism under investigation perceives and responds to the environment will generally decrease the severity of this problem. In general, the larger the ratio of extent to grain (i.e., the larger the landscape relative to the average patch size), the less likely these and other metrics will be dominated by boundary effects.

KEY POINT The important point is that a landscape should be defined relative to both the patch mosaic within the landscape as well as the landscape context. Moreover, consideration should always be given to the landscape context and the openness of the landscape relative to the phenomenon under consideration when choosing and interpreting landscape metrics.


PERSPECTIVES ON CATEGORICAL MAP PATTERNS

There are at least two different perspectives on categorical map patterns that have profoundly influenced the development of landscape metrics and have important implications for the choice and interpretation of individual landscape metrics.

(1) Island Biogeographic Model.–In the island biogeographic model, the emphasis is on a single patch type; disjunct patches (e.g., habitat fragments) are viewed as analogues of oceanic islands embedded in an inhospitable or ecologically neutral background (matrix). This perspective emerged from the theory of island biogeography (MacArthur and Wilson 1967) and subsequent interest in habitat fragmentation (Saunders et al. 1991). Under this perspective, there is a binary patch structure in which the focal patches (fragments) are embedded in a neutral matrix. Here, the emphasis is on the extent, spatial character, and distribution of the focal patch type without explicitly considering the role of the matrix. Under this perspective, for example, connectivity may be assessed by the spatial aggregation of the focal patch type without consideration of how intervening patches affect the functional connectedness among patches of the focal class. The island biogeography perspective has been the dominant perspective since inception of the theory. The major advantage of the island model is its simplicity. Given a focal patch type, it is quite simple to represent the structure of the landscape in terms of focal patches contrasted sharply against a uniform matrix, and it is relatively simple to devise metrics that quantify this structure. Moreover, by considering the matrix as ecologically neutral, it invites ecologists to focus on those patch attributes, such as size and isolation, that have the strongest effect on species persistence at the patch level. The major disadvantage of the strict island model is that it assumes a uniform and neutral matrix, which in most real-world cases is a drastic over-simplification of how organisms interact with landscape patterns.

(2) Landscape Mosaic Model.–In the landscape mosaic model, landscapes are viewed as spatially complex, heterogeneous assemblages of patch types, which can not be simply categorized into discrete elements such as patches, matrix, and corridors (With 2000). Rather, the landscape is viewed from the perspective of the organism or process of interest. Patches are bounded by patches of other patch types that may be more or less similar to the focal patch type, as opposed to highly contrasting and often hostile habitats, as in the case of the island model. Connectivity, for example, may be assessed by the extent to which movement is facilitated or impeded through different patch types across the landscape. The landscape mosaic perspective derives from landscape ecology (Forman 1995) and has only recently emerged as a viable alternative to the island biogeographic model. The major advantage of the landscape mosaic model is its more realistic representation of how organisms perceive and interact with landscape patterns. Few organisms, for example, exhibit a binary (all or none) response to habitats (patch types), but rather use habitats proportionate to the fitness they confer to the organism. Moreover, movement among suitable habitat patches usually is a function of the character of the intervening habitats. The major disadvantage of the landscape mosaic model is that it requires detailed understanding of how organisms interact with landscape pattern, and this has delayed the development of additional metrics that adopt this perspective.


PATCHES & PATCHINESS: LEVELS OF LANDSCAPE METRICS

Patches form the basis (or building blocks) for categorical maps. Depending on the method used to derive patches (and therefore the data available), they can be characterized compositionally in terms of variables measured within them. This may include the mean (or mode, central, or max) value and internal heterogeneity (variance, range). However, in most applications, once patches have been established, the within-patch heterogeneity is ignored. Landscape pattern metrics instead focus on the spatial character and distribution of patches. While individual patches possess relatively few fundamental spatial characteristics (e.g., size, perimeter, and shape), collections of patches may have a variety of aggregate properties, depending on whether the aggregation is over a single class (patch type) or multiple classes, and whether the aggregation is within a specified subregion of a landscape or across the entire landscape. Commonly, landscape metrics may be defined at three levels.

(1) Patch-level metrics are defined for individual patches, and characterize the spatial character and context of patches. In most applications, patch metrics serve primarily as the computational basis for several of the landscape metrics, for example by averaging patch attributes across all patches in the class or landscape; the computed values for each individual patch may have little interpretive value. However, sometimes patch indices can be important and informative in landscape-level investigations. For example, many vertebrates require suitable habitat patches larger than some minimum size (e.g., Robbins et al. 1989), so it would be useful to know the size of each patch in the landscape. Similarly, some species are adversely affected by edges and are more closely associated with patch interiors (e.g., Temple 1986), so it would be useful to know the size of the core area for each patch in the landscape. The probability of occupancy and persistence of an organism in a patch may be related to patch insularity (sensu Kareiva 1990), so it would be useful to know the nearest neighbor of each patch and the degree of contrast between the patch and its neighborhood. The utility of the patch characteristic information will ultimately depend on the objectives of the investigation.

(2) Class-level metrics are integrated over all the patches of a given type (class). These may be integrated by simple averaging, or through some sort of weighted-averaging scheme to bias the estimate to reflect the greater contribution of large patches to the overall index. There are additional aggregate properties at the class level that result from the unique configuration of patches across the landscape. In many applications, the primary interest is in the amount and distribution of a particular patch type. A good example is in the study of habitat fragmentation. Habitat fragmentation is a landscape-level process in which contiguous habitat is progressively sub-divided into smaller, geometrically more complex (initially, but not necessarily ultimately), and more isolated habitat fragments as a result of both natural processes and human land use activities (McGarigal and McComb 1999). This process involves changes in landscape composition, structure, and function and occurs on a backdrop of a natural patch mosaic created by changing landforms and natural disturbances. Habitat loss and fragmentation is the prevalent trajectory of landscape change in several human-dominated regions of the world, and is increasingly becoming recognized as a major cause of declining biodiversity (Burgess and Sharpe 1981, Whitcomb et al. 1981, Noss 1983, Harris 1984, Wilcox and Murphy 1985, Terborgh 1989, Noss and Cooperrider 1994). Class indices separately quantify the amount and spatial configuration of each patch type and thus provide a means to quantify the extent and fragmentation of each patch type in the landscape.

(3) Landscape-level metrics are integrated over all patch types or classes over the full extent of the data (i.e., the entire landscape). Like class metrics, these may be integrated by a simple or weighted averaging, or may reflect aggregate properties of the patch mosaic. In many applications, the primary interest is in the pattern (i.e., composition and configuration) of the entire landscape mosaic. A good example is in the study of wildlife communities. Aldo Leopold (1933) noted that wildlife diversity was greater in more diverse and spatially heterogenous landscapes. Thus, the quantification of landscape diversity and heterogeneity has assumed a preeminent role in landscape ecology. Indeed, the major focus of landscape ecology is on quantifying the relationships between landscape pattern and ecological processes. Consequently, much emphasis has been placed on developing methods to quantify landscape pattern (e.g., O'Neill et al. 1988, Li 1990, Turner 1990, Turner and Gardner 1991) and a great variety of landscape-level metrics have been developed for this purpose.

It is important to note that while most metrics at higher levels are derived from patch-level attributes, not all metrics are defined at all levels. In particular, collections of patches at the class and landscape level have aggregate properties that are undefined (or trivial) at lower levels. The fact that most higher-level metrics are derived from the same patch-level attributes has the further implication that many of the metrics are correlated. Thus, they provide similar and perhaps redundant information (see below). Even though many of the class- and landscape-level metrics represent the same fundamental information, naturally the algorithms differ slightly (see below).

In addition, while many metrics have counterparts at all levels, their interpretations may be somewhat different. Patch-level metrics represent the spatial character and context of individual patches. Class-level metrics represent the amount and spatial distribution of a single patch type and may be interpreted as fragmentation indices. Landscape-level metrics represent the spatial pattern of the entire landscape mosaic and may be interpreted more broadly as landscape heterogeneity indices because they measure the overall landscape structure. Hence, it is important to interpret each metric in a manner appropriate to its level (patch, class, or landscape).


LANDSCAPE METRICS

The common usage of the term “landscape metrics” refers exclusively to indices developed for categorical map patterns. Landscape metrics are algorithms that quantify specific spatial characteristics of patches, classes of patches, or entire landscape mosaics. A plethora of metrics has been developed to quantify categorical map patterns. An exhaustive review of all published metrics, therefore, is beyond the scope of this chapter. These metrics fall into two general categories: those that quantify the composition of the map without reference to spatial attributes, and those that quantify the spatial configuration of the map, requiring spatial information for their calculation (McGarigal and Marks 1995, Gustafson 1998).

Composition is easily quantified and refers to features associated with the variety and abundance of patch types within the landscape, but without considering the spatial character, placement, or location of patches within the mosaic. Because composition requires integration over all patch types, composition metrics are only applicable at the landscape-level. There are many quantitative measures of landscape composition, including the proportion of the landscape in each patch type, patch richness, patch evenness, and patch diversity. Indeed, because of the many ways in which diversity can be measured, there are literally hundreds of possible ways to quantify landscape composition. Unfortunately, because diversity indices are derived from the indices used to summarize species diversity in community ecology, they suffer the same interpretative drawbacks. It is incumbent upon the investigator or manager to choose the formulation that best represents their concerns. The principle measures of composition are:

• Proportional Abundance of each Class.–One of the simplest and perhaps most useful pieces of information that can be derived is the proportion of each class relative to the entire map.

• Richness.--Richness is simply the number of different patch types.

• Evenness.--Evenness is the relative abundance of different patch types, typically emphasizing either relative dominance or its compliment, equitability. There are many possible evenness (or dominance) measures corresponding to the many diversity measures. Evenness is usually reported as a function of the maximum diversity possible for a given richness. That is, evenness is given as 1 when the patch mosaic is perfectly diverse given the observed patch richness, and approaches 0 as evenness decreases. Evenness is sometimes reported as its complement, dominance, by subtracting the observed diversity from the maximum for a given richness. In this case, dominance approaches 0 for maximum equitability and increases >0 for higher dominance.

• Diversity.--Diversity is a composite measure of richness and evenness and can be computed in a variety of forms (e.g., Shannon and Weaver 1949, Simpson 1949), depending on the relative emphasis placed on these two components.

Spatial configuration is much more difficult to quantify and refers to the spatial character and arrangement, position, or orientation of patches within the class or landscape. Some aspects of configuration, such as patch isolation or patch contagion, are measures of the placement of patch types relative to other patches, other patch types, or other features of interest. Other aspects of configuration, such as shape and core area, are measures of the spatial character of the patches. There are many aspects of configuration and the literature is replete with methods and indices developed for representing them (see previous references).

Configuration can be quantified in terms of the landscape unit itself (i.e., the patch). The spatial pattern being represented is the spatial character of the individual patches, even though the aggregation is across patches at the class or landscape level. The location of patches relative to each other is not explicitly represented. Metrics quantified in terms of the individual patches (e.g., mean patch size and shape) are spatially explicit at the level of the individual patch, not the class or landscape. Such metrics represent a recognition that the ecological properties of a patch are influenced by the surrounding neighborhood (e.g., edge effects) and that the magnitude of these influences are affected by patch size and shape. These metrics simply quantify, for the class or landscape as a whole, some attribute of the statistical distribution (e.g., mean, max, variance) of the corresponding patch characteristic (e.g., size, shape). Indeed, any patch-level metric can be summarized in this manner at the class and landscape levels. Configuration also can be quantified in terms of the spatial relationship of patches and patch types (e.g., nearest neighbor, contagion). These metrics are spatially explicit at the class or landscape level because the relative location of individual patches within the patch mosaic is represented in some way. Such metrics represent a recognition that ecological processes and organisms are affected by the overall configuration of patches and patch types within the broader patch mosaic.

A number of configuration metrics can be formulated either in terms of the individual patches or in terms of the whole class or landscape, depending on the emphasis sought. For example, perimeter-area fractal dimension is a measure of shape complexity (Mandelbrot 1982, Burrough 1986, Milne 1991) that can be computed for each patch and then averaged for the class or landscape, or it can be computed from the class or landscape as a whole by regressing the logarithm of patch perimeter on the logarithm of patch area. Similarly, core area can be computed for each patch and then represented as mean patch core area for the class or landscape, or it can be computed simply as total core area in the class or landscape. Obviously, one form can be derived from the other if the number of patches is known and so they are largely redundant; the choice of formulations is dependent upon user preference or the emphasis (patch or class/landscape) sought. The same is true for a number of other common landscape metrics. Typically, these metrics are spatially explicit at the patch level, not at the class or landscape level.

The principle aspects of configuration and a sample of representative metrics are:

• Patch size distribution and density.–The simplest measure of configuration is patch size, which represents a fundamental attribute of the spatial character of a patch. Most landscape metrics either directly incorporate patch size information or are affected by patch size. Patch size distribution can be summarized at the class and landscape levels in a variety of ways (e.g., mean, median, max, variance, etc.), or, alternatively, represented as patch density, which is simply the number of patches per unit area.

• Patch shape complexity.--Shape complexity relates to the geometry of patches--whether they tend to be simple and compact, or irregular and convoluted. Shape is an extremely difficult spatial attribute to capture in a metric because of the infinite number of possible patch shapes. Hence, shape metrics generally index overall shape complexity rather than attempt to assign a value to each unique shape. The most common measures of shape complexity are based on the relative amount of perimeter per unit area, usually indexed in terms of a perimeter-to-area ratio, or as a fractal dimension, and often standardized to a simple Euclidean shape (e.g., circle or square). The interpretation varies among the various shape metrics, but in general, higher values mean greater shape complexity or greater departure from simple Euclidean geometry. Other methods have been proposed--radius of gyration (Pickover 1990), contiguity (LaGro 1991), linearity index (Gustafson and Parker 1992), and elongation and deformity indices (Baskent and Jordan 1995)–but these have not yet become widely used (Gustafson 1998).

• Core Area.--Core area represents the interior area of patches after a user-specified edge buffer is eliminated. The core area is the area unaffected by the edges of the patch. This “edge effect” distance is defined by the user to be relevant to the phenomenon under consideration and can either be treated as fixed or adjusted for each unique edge type. Core area integrates patch size, shape, and edge effect distance into a single measure. All other things equal, smaller patches with greater shape complexity have less core area Most of the metrics associated with size distribution (e.g., mean patch size and variability) can be formulated in terms of core area.

• Isolation/Proximity.--Isolation/proximity refers to the tendency for patches to be relatively isolated in space (i.e., distant) from other patches of the same or similar (ecologically friendly) class. Because the notion of “isolation” is vague, there are many possible measures depending on how distance is defined and how patches of the same class and those of other classes are treated. If dij is the nearest-neighbor distance from patch i to another patch j of the same type, then the average isolation of patches can be summarized simply as the mean nearest-neighbor distance over all patches. Alternatively, isolation can be formulated in terms of both the size and proximity of neighboring patches within a local neighborhood around each patch using the isolation index of Whitcomb et al. (1981) or proximity index of Gustafson and Parker (1992), where the neighborhood size is specified by the user and presumably scaled to the ecological process under consideration. The original proximity index was formulated to consider only patches of the same class within the specified neighborhood. This binary representation of the landscape reflects an island biogeographic perspective on landscape pattern. Alternatively, this metric can be formulated to consider the contributions of all patch types to the isolation of the focal patch, reflecting a landscape mosaic perspective on landscape patterns.

• Contrast.–Contrast refers to the relative difference among patch types. For example, mature forest next to younger forest might have a lower-contrast edge than mature forest adjacent to open field, depending on how the notion of contrast is defined. This can be computed as a contrast-weighted edge density, where each type of edge (i.e., between each pair of patch types) is assigned a contrast weight. Alternatively, this can be computed as a neighborhood contrast index, where the mean contrast between the focal patch and all patches within a user-specified neighborhood is computed based on assigned contrast weights. Relative to the focal patch, if patch types with high contrast lead to greater isolation of the focal patch, as is often the case, then contrast will be inversely related to isolation (at least for those isolation measures that consider all patch types).

• Dispersion.--Dispersion refers to the tendency for patches to be regularly or contagiously distributed (i.e., clumped) with respect to each other. There are many dispersion indices developed for the assessment of spatial point patterns, some of which have been applied to categorical maps. A common approach is based on nearest-neighbor distances between patches of the same type. Often this is computed in terms of the relative variability in nearest-neighbor distances among patches; for example, based on the ratio of the variance to mean nearest neighbor distance. Here, if the variance is greater than the mean, then the patches are more clumped in distribution than random, and if the variance is less than the mean, then the patches are more uniformly distributed. This index can be averaged over all patch types to yield an average index of dispersion for the landscape. Alternative indices of dispersion based on nearest neighbor distances can be computed, such as the familiar Clark and Evans (1954) index.

• Contagion & Interspersion.–Contagion refers to the tendency of patch types to be spatially aggregated; that is, to occur in large, aggregated or “contagious” distributions. Contagion ignores patches per se and measures the extent to which cells of similar class are aggregated. Interspersion, on the other hand, refers to the intermixing of patches of different types and is based entirely on patch (as opposed to cell) adjacencies. There are several different approaches for measuring contagion and interspersion. One popular index that subsumes both dispersion and interspersion is the contagion index based on the probability of finding a cell of type i next to a cell of type j (Li and Reynolds 1993). This index increases in value as a landscape is dominated by a few large (i.e., contiguous) patches and decreases in value with increasing subdivision and interspersion of patch types. This index summarizes the aggregation of all classes and thereby provides a measure of overall clumpiness of the landscape. McGarigal and Marks (1995) suggest a complementary interspersion/juxtaposition index that increases in value as patches tend to be more evenly interspersed in a "salt and pepper" mixture. These and other metrics are generated from the matrix of pairwise adjacencies between all patch types, where the elements of the matrix are the proportions of edges in each pairwise type. There are alternative methods for calculating class-specific contagion using fractal geometry (Gardner and O’Neill 1991). Lacunarity is an especially promising method borrowed from fractal geometry by which contagion can be characterized across a range of spatial scales (Plotnick et al. 1993 and 1996, Dale 2000). The technique involves using a moving window and is concerned with the frequency with which one encounters the focal class in a window of different sizes. A log-log plot of lacunarity against window size expresses the contagion of the map, or its tendency to aggregate into discrete patches, across a range of spatial scales.

• Subdivision.--Subdivision refers to the degree to which a patch type is broken up (i.e., subdivided) into separate patches (i.e., fragments), not the size (per se), shape, relative location, or spatial arrangement of those patches. Because these latter attributes are usually affected by subdivision, it is difficult to isolate subdivision as an independent component. Subdivision can be evaluated using a variety of metrics already discussed; for example, the number, density, and average size of patches and the degree of contagion all indirectly evaluate subdivision. However, a suite of metrics derived from the cumulative distribution of patch sizes provide alternative and more explicit measures of subdivision (Jaeger 2000). When applied at the class level, these metrics can be used to measure the degree of fragmentation of the focal patch type. Applied at the landscape level, these metrics connote the graininess of the landscape; i.e., the tendency of the landscape to exhibit a fine- versus coarse-grain texture. A fine-grain landscape is characterized by many small patches (highly subdivided); whereas, a coarse-grain landscape is characterized by fewer large patches.

• Connectivity.--Connectivity generally refers to the functional connections among patches. What constitutes a "functional connection" between patches clearly depends on the application or process of interest; patches that are connected for bird dispersal might not be connected for salamanders, seed dispersal, fire spread, or hydrologic flow. Connections might be based on strict adjacency (touching), some threshold distance, some decreasing function of distance that reflects the probability of connection at a given distance, or a resistance-weighted distance function. Then various indices of overall connectedness can be derived based on the pairwise connections between patches. For example, one such index, connectance, can be defined on the number of functional joinings, where each pair of patches is either connected or not. Alternatively, from percolation theory, connectedness can be inferred from patch density or be given as a binary response, indicating whether or not a spanning cluster or percolating cluster exists; i.e., a connection of patches of the same class that spans across the entire landscape (Gardner et al. 1987). Connectedness can also be defined in terms of correlation length for a raster map comprised of patches defined as clusters of connected cells. Correlation length is based on the average extensiveness of connected cells. A map's correlation length is interpreted as the average distance one might traverse the map, on average, from a random starting point and moving in a random direction, i.e., it is the expected traversibility of the map (Keitt et al. 1997).


STRUCTURAL VERSUS FUNCTIONAL METRICS

Landscape metrics can also be classified according to whether or not they measure landscape patterns with explicit reference to a particular ecological process. Structural metrics can be defined as those that measure the physical composition or configuration of the patch mosaic without explicit reference to an ecological process. The functional relevance of the computed value is left for interpretation during a subsequent step. Most landscape metrics are of this type. Functional metrics, on the other hand, can be defined as those that explicitly measure landscape pattern in a manner that is functionally relevant to the organism or process under consideration. Functional metrics require additional parameterization prior to their calculation, such that the same metric can return multiple values depending on the user specifications. The difference between structural and functional metrics is best illustrated with an example. As conventionally computed, mean nearest neighbor distance is based on the distances between neighboring patches of the same class. The mosaic is in essence treated as a binary landscape (i.e., patches of the focal class versus everything else). The composition and configuration of the intervening matrix is ignored. Consequently, the same landscape can only return a single value for this metric. Clearly, this is a structural metric because the functional meaning of any particular computed value is left to subsequent interpretation. Conversely, connectivity metrics that consider the permeability of various patch types to movement of the organism or process of interest are functional metrics. Here, every patch in the mosaic contributes to the calculation of the metric. Moreover, there are an infinite number of values that can be returned from the same landscape, depending on the permeability coefficients assigned to each patch type. Given a particular parameterization, the computed metric is in terms that are already deemed functionally relevant.


LIMITATIONS IN THE USE AND INTERPRETATION OF METRICS

All landscape metrics represent some aspect of landscape pattern. However, the user must first define the landscape, including its extent and grain and the patches that comprise it, before any of these metrics can be computed. In addition, for many of the metrics, the user must specify additional input parameters such as edge effect distance, edge contrast weights, and search distance. Hence, the computed value of any metric is merely a function of how the investigator chose to define and scale the landscape. If the measured pattern of the landscape does not corresponding to a pattern that is functionally meaning for the organism or process under consideration, then the results will be meaningless. For example, the criteria for defining a patch may vary depending on how much variation will be allowed within a patch, on the minimum size of patches that will be mapped, and on the components of the system that are deemed ecologically relevant to the phenomenon of interest (Gustafson 1998). Ultimately, patches occur on a variety of scales, and a patch at any given scale has an internal structure that is a reflection of patchiness at finer scales, and the mosaic containing that patch has a structure that is determined by patchiness at broader scales (Kotliar and Wiens 1990). Thus, regardless of the basis for defining patches, a landscape does not contain a single patch mosaic, but contains a hierarchy of patch mosaics across a range of scales. Indeed, patch boundaries are artificially imposed and are in fact meaningful only when referenced to a particular scale (i.e., grain size and extent). It is incumbent upon the investigator to establish the basis for delineating among patches and at a scale appropriate to the phenomenon under consideration. Extreme caution must be exercised in comparing the values of metrics computed for landscapes that have been defined and scaled differently.

Given the subjectivity in defining patches, surface pattern techniques can provide an objective means to help determine the scale of patchiness (Gustafson 1998). In many studies, the identification of patches reflects a minimum mapping unit that is chosen for practical or technical reasons and not for ecological reasons. Surface pattern analysis can provide insight into the scale of patchiness and whether there are hierarchies of scale. This information can then provide the empirical basis for choosing the scale for mapping patches, rather than relying on subjective and somewhat arbitrary criteria. Despite the complimentary nature of surface pattern and categorical map pattern techniques, few studies have adopted this approach.

The format (raster versus vector) and scale (grain and extent) of the data can have a profound influence on the value of many metrics. Because vector and raster formats represent lines differently, metrics involving edge or perimeter will be affected by the choice of formats. Edge lengths will be biased upward in raster data because of the stair-step outline, and the magnitude of this bias will vary in relation to the grain or resolution of the image. In addition, the grain-size of raster format data can have a profound influence on the value of certain metrics. Metrics involving edge or perimeter will be affected; edge lengths will be biased upwards in proportion to the grain size–larger grains result in greater bias. Metrics based on cell adjacency information such as the contagion index of Li and Reynolds (1993) will be affected as well, because grain size effects the proportional distribution of adjacencies. In this case, as resolution is increased (grain size reduced), the proportional abundance of like adjacencies (cells of the same class) increases, and the measured contagion increases. Finally, the boundary of the landscape can have a profound influence on the value of certain metrics. Landscape metrics are computed solely from patches contained within the landscape boundary. If the landscape extent is small relative to the scale of the organism or ecological process under consideration and the landscape is an “open” system relative to that organism or process, then any metric will have questionable meaning. Metrics based on nearest neighbor distance or employing a search radius can be particularly misleading. Consider, for example, a local population of a bird species occupying a patch near the boundary of a somewhat arbitrarily defined landscape. The nearest neighbor within the landscape boundary might be quite far away; yet, in reality, the closest patch might be very close but just outside the designated landscape boundary. In addition, those metrics that employ a search radius (e.g., proximity index) will be biased for patches near the landscape boundary because the searchable area will be much less than a patch in the interior of the landscape. In general, boundary effects will increase as the landscape extent decreases relative to the patchiness or heterogeneity of the landscape.

In addition to these technical issues, current use of landscape metrics is constrained by the lack of a proper theoretical understanding of metric behavior. The interpretation of a landscape metric is contingent upon having an adequate understanding of how it responds to variation in landscape patterns (e.g., Gustafson and Parker 1992, Hargis et al. 1998, Jaeger 2000). Failure to understand the theoretical behavior of the metric can lead to erroneous interpretations (e.g., Jaeger 2000). Neutral models (Gardner et al. 1987, Gardner and O’Neill 1991, With 1997) provide an excellent way to examine metric behavior under controlled conditions because they control the process generating the pattern, allowing unconfounded links between variation in pattern and the behavior of the index (Gustafson 1998).

The interpretation of landscape metrics is further plagued by the lack of a proper spatial and temporal reference framework. Landscape metrics quantify the pattern of a landscape at a snapshot in time. Yet it is often difficult, if not impossible, to determine the ecological significance of the computed value without understanding the range of natural variation in landscape pattern. For example, in disturbance-dominated landscapes, patterns may fluctuate widely over time in response to the interplay between disturbance and succession processes (e.g., Wallin et al. 1996, He and Mladenoff 1999, Haydon et al. 2000, Wimberly et a. 2000). It is logical, therefore, that landscape metrics should exhibit statistical distributions that reflect the natural spatial and temporal dynamics of the landscape. By comparison to this distribution, a more meaningful interpretation can be assigned to any computed value. Unfortunately, despite widespread recognition that landscapes are dynamic, there is a dearth of empirical work quantifying the range of natural variation in landscape pattern metrics. This remains one of the greatest challenges confronting landscape pattern analysis.

Although the literature is replete with metrics now available to describe landscape pattern, there are still only two major components--composition and configuration, and only a few aspects of each of these. Metrics often measure multiple aspects of this pattern. Thus, there is seldom a one-to-one relationship between metric values and pattern. Most of the metrics are in fact correlated among themselves (i.e., they measure a similar or identical aspect of landscape pattern) because there are only a few primary measurements that can be made from patches (patch type, area, edge, and neighbor type), and most metrics are then derived from these primary measures. Some metrics are inherently redundant because they are alternate ways of representing the same basic information (e.g., mean patch size and patch density). In other cases, metrics may be empirically redundant; not because they measure the same aspect of landscape pattern, but because for the particular landscapes under investigation, different aspects of landscape pattern are statistically correlated. Several investigators have attempted to identify the major components of landscape pattern for the purpose of identifying a parsimonious suite of independent metrics (e.g., Li and Reynolds 1995, McGarigal and McComb 1995, Ritters et al. 1995). Although these studies suggest that patterns can be characterized by only a handful of components, consensus does not exist on the choice of individual metrics. These studies were constrained by the pool of metrics existing at the time of the investigation. Given the expanding development of functional metrics, particularly those based on a landscape mosaic perspective, it seems unlikely that a single parsimonious set exists. Ultimately, the choice of metrics should explicitly reflect some hypothesis about the observed landscape pattern and what processes or constraints might be responsible for that pattern.

In summary, the importance of fully understanding each landscape metric before it is selected for interpretation cannot be stressed enough. Specifically, these questions should be asked of each metric before it is selected for interpretation:

• Does it represent landscape composition or configuration, or both?

• What aspect of composition or configuration does it represent?

• Is it spatially explicit, and, if so, at the patch-, class-, or landscape-level?

• How is it effected by the designation of a matrix element?

• Does it reflect an island biogeographic or landscape mosaic perspective of landscape pattern

• How does it behave or respond to variation in landscape pattern?

• What is the range of variation in the metric under an appropriate spatio-temporal reference framework?

Based on the answers to these questions, does the metric represent landscape pattern in a manner and at a scale ecologically meaningful to the phenomenon under consideration? Only after answering these questions should one attempt to draw conclusions about the pattern of the landscape.


LITERATURE CITED

Allen, T. F. H., R. V. O'Neill, and T. W. Hoekstra. 987. Inter-level relations in ecological research and management: some working principles from hierarchy theory. J. of Applied Systems Analysis 14:63-79.

Allen, T. F. H., and T. B. Starr. 1982. Hierarchy: Perspectives for Ecological Complexity. University of Chicago Press, Chicago. 310 pp.

Baker, W. L., and Y. Cai. 1992. The r.le programs for multiscale analysis of landscape structure using the GRASS geographical information system. Landscape Ecology 7: 291-302.

Baskent, E. Z., and G. A. Jordan. 1995. Characterizing spatial structure of forest landscapes. Can. J. For. Res. 25:1830-49.

Bradshaw, G. A. 1991. Characterizing canopy gap structure in forests using wavelet analysis. J. Ecol. 80:205-215.

Burgess, R. L., and D.M. sharpe, eds. 1981. Forest Island Dynamics in Man-Dominated Landscapes. Springer-Verlag, New York.

Burrough, P. A. 1986. Principles of Geographical Information Systems for Land Resources Assessment. Monographs on Soil and Resources Survey No. 12. Clarendon Press, Oxford.

Clark, P. J., and F. C. Evans. 1954. Distance to nearest neighbor as a measure of spatial relationships in populations. Ecology 35:445-453.

Dale, M. R. T. 1999. Spatial pattern analysis in plant ecology. Cambridge University Press, Cambridge.

Dale, M. R. T. 2000. Lacunarity analysis of spatial pattern: a comparison. Landscape Ecol. 15:467-468.

Dunning, J. B., B. J. Danielson, and H. R. Pulliam. 1992. Ecological processes that affect populations in complex landscapes. Oikos 65:169-175.

Fahrig, L., and G. Merriam. 1985. Habitat patch connectivity and population survival. Ecology 66:1762-1768.

Fahrig, L., and J. Paloheimo. 1988. Effect of spatial arrangement of habitat patches on local population size. Ecology 69:468-475.

Ford, E. D., and E. Renshaw. 1984. The interpretation of process from pattern using two-dimensional spectral analysis: modeling single species patterns in vegetation. Vegetatio 56:113-123.

Forman, R. T. T., and M. Godron. 1986. Landscape ecology. Wiley, New York.

Forman, R. T. T. 1995. Land mosaics: the ecology of landscapes and regions. Cambridge University Press, Cambridge, England.

Fortin, M.-J. 1994. Edge detection algorithms for two-dimensional ecological data. Ecology 75:956-965.

Fortin, M.-J., R. J. Olson, S. Ferson, L. Iverson, C. Hunsaker, G. Edwards, D. Levine, K. Butera, and V. Klemas. 2000. Issues related to the detection of boundaries. Landscape Ecol. 15:453-466.

Fortin, M.-J., and P. Drapeau. 1995. Delineation of ecological boundaries: comparison of approaches and significance test. Oikos 72:323-332.

Gardner, R. H., B. T. Milne, M.G. Turner, and R.V. O'Neill. 1987. Neutral models for the analysis of broad-scale landscape pattern. Landscape Ecol. 1:19-28.

Gardner, R. H., and R. V. O'Neill. 1991. Pattern, process, and predictability: the use of neutral models for landscape analysis. Pages 289-307 in Turner and Gardner (1991)

Gardner, R. H., R. V. O’Neill, and M. G. Turner. 1993. Ecological implications of landscape fragmentation. Pages 208-226 in S. T. A. Pickett and M. G. McDonnell, editors. Humans as components of ecosystems: subtle human effects and ecology of population areas. Springer-Verlag, New York.

Greig-Smith, P. 1983. Quantitative plant ecology. University of California Press, Berkeley.

Gustafson, E. J., and G. R. Parker. 1992. Relationships between landcover proportion and indices of landscape spatial pattern. Landscape Ecology 7:101-110

Gustafson, E. J. 1998. Quantifying landscape spatial pattern: What is the state of the art. Ecosystems:143-156.

Haila, Y., I. K. Hanski, and S. Raivio. 1987. Breeding bird distribution in fragmented coniferous taiga in southern Finland. Ornis Fennica 64:90-106.

Hargis, C. D., J. A. Bissonette, and J. L. David. 1998. The behavior of landscape metrics commonly used in the study of habitat fragmentation. Landscape Ecol. 13:167-186.

Harris, L. D. 1984. The Fragmented Forest: Island Biogeographic Theory and the Preservation of Biotic Diversity. University of Chicago Press, Chicago. 211 pp.

Haydon, D. T., J. K. Friar, and E. R. Pianka. 2000. Fire-driven dynamic mosaics in the Great Victoria Desert, Australia. Landscape Ecol. 15:407-423.

He, H.S., and D.J. Mladenoff. 1999. Spatially explicit and stochastic simulation of forest-landscape fire disturbance and succession. Ecology 80:81-99.

Jaeger, J. A. G. 2000. Landscape division, splitting index, and effective mesh size: new measures of landscape fragmentation. Landscape Ecol. 15:115-130.

Johnson, A. R., B. T. Milne, J. A. Wiens, and T. O. Crist. 1992. Animal movements and population dynamics in heterogeneous landscapes. Landscape Ecol. 7:63-75.

Kareiva, P. 1990. Population dynamics in spatially complex environments: theory and data. Phil. Trans. R. Soc. Lond. B 330:175-190.

Keitt, T.H., D.L. Urban, and B.T. Milne. 1997. Detecting critical scales in fragmented landscapes. Conservation Ecol. 1(1):4. (online)

Kolasa, J., and C. D. Rollo. 1991. Introduction: The heterogeneity of heterogeneity: a glossary. Pages 1-23 In J. Kolasa and S. T. A. Pickett, eds., Ecological Heterogeneity. Springer-Verlag, New York.

Kotliar, N. B., and J. A. Wiens. 1990. Multiple scales of patchiness and patch structure: a hierarchical framework for the study of heterogeneity. Oikos 59:253-260.

LaGro, J., Jr. 1991. Assessing patch shape in landscape mosaics. Photogrammetric Eng. Remote Sens. 57:285-93.

Legendre, P., and M.-J. Fortin. 1989. Spatial pattern and ecological analysis. Vegetatio 80:107-38.

Legendre, P, and L. Legendre. 1999. Numerical Ecology, second edition. Elsevier Science, New York.

Leopold, A. 1933. Game Management. Charles Scribners, New York.

Li, H., and J.F. Reynolds. 1993. A new contagion index to quantify spatial patterns of landscapes. Landscape Ecol. 8:155-162.

Li, H., and J. F. Reynolds. 1995. On definition and quantification of heterogeneity. Oikos 73:280-284.

MacArthur, R.H., and E.O. Wilson. 1967. The theory of island biogeography. Princeton University Press, Princeton.

Mandelbrot, B. B. 1982. The Fractal Geometry of Nature. W. H. Freeman and Co., New York.

McGarigal, K., and B.J. Marks. 1995. FRAGSTATS: spatial pattern analysis program for quantifying landscape structure. Gen. Tech. Report PNW-GTR-351, USDA Forest Service, Pacific Northwest Research Station, Portland, OR.

McGarigal, K., and W.C. McComb. 1995. Relationships between landscape structure and breeding birds in the Oregon Coast Range. Ecol. Monogr. 65:235-260.

Milne, B.T. 1991. Lessons from applying fractal models to landscape patterns. Pages 199-235 in Turner, M.G., and R.H. Gardner, editors. Quantitative methods in landscape ecology. Springer-Verlag, New York.

Musick, H. B., and H. D. Grover. 1991. Image textural measures as indices of landscape pattern. Pages 289-307 in Turner, M.G., and R.H. Gardner, editors. Quantitative methods in landscape ecology. Springer-Verlag, New York.

Noss, R.F. 1983. A regional landscape approach to maintain diversity. BioScience 33:700-706.

Noss, R.F., and A.Y. Cooperrider. 1994. Saving Nature's Legacy : Protecting and Restoring Biodiversity. Island Press.

O'Neill, R.V., J.R. Krummel, R.H. Gardner, G. Sugihara, B. Jackson, D.L. DeAngelis, B.T. Milne, M.G. Turner, B. Zygmunt, S.W. Christensen, V.H. Dale, and R.L. Graham. 1988. Indices of landscape pattern. Landscape Ecol. 1:153-162.

Pickover, C. A. 1990. Computers, pattern, chaos and beauty: graphics from an unseen world. New York: St. Martin’s.

Pielou, E.C. 1984. The interpretation of ecological data. Wiley, new York.

Plotnick, R. E., R. H. Gardner, and R.V. O'Neill. 1993. Lacunarity indices as measures of landscape texture. Landscape Ecol. 8:201-211.

Plotnick, R. E., R. H. Gardner, W. W. Hargrove, K. Pretegaard, and M. Perlmutter.1996. Lacunarity analysis: a general technique for the analysis of spatial patterns. Phys. Rev. E53:5461-5468.

Renshaw, E., and E. D. Ford. 1984. The description of spatial pattern using two-dimensional spectral analysis. Vegetatio 56:75-85.

Ricklefs, R. E. 1987. Community diversity: relative roles of local and regional processes. Science 235:167-171.

Ritters, K. H., R. V. O'Neill, C. T. Hunsaker, J. D. Wickham, D. H. Yankee, S. P. Timmins, K. B. Jones, and B. L. Jackson. 1995. A factor analysis of landscape pattern and structure metrics. Landscape Ecol. 10: 23-40.

Robbins, C. S., D. K. Dawson, and B. A. Dowell. 1989. Habitat area requirements of breeding forest birds of the middle Atlantic states. Wildl. Monogr. 103. 34 pp.

Rosenberg, D. K., B. R. Noon, and E. C. Meslow. 1997. Biological corridors: form, function, and efficacy. BioScience 47:677-687.

Roughgarden, J., S. D. Gaines, and S. W. Pacala. 1987. Supply side ecology: the role of physical transport processes. Pages 491-518 In J. H. R. Gee and P. S. Giller, eds. Organization of Communities Past and Present. Blackwell Scientific Publications, Oxford.

Saunders, D. A., R. J. Hobbs, and C. R. Margules. 1991. Biological consequences of ecosystem fragmentation: a review. Cons. Biol. 5:18-32.

Shannon, C., and W. Weaver. 1949. The mathematical theory of communication. Univ. Illinois Press, Urbana.

Simpson, E. H. 1949. Measurement of diversity. Nature 163:688.

Temple, S. A. 1986. Predicting impacts of habitat fragmentation on forest birds: a comparison of two models. Pages 301-304 In J. Verner, M. L. Morrison, and C. J. Ralph, eds. Wildlife 2000: Modeling Habitat Relationships of Terrestrial Vertebrates. Univ. of Wisconsin Press, Madison, WI.

Terborgh, J. 1989. Where Have all the Birds Gone? Princeton University Press, New Jersey. 207 pp.

Turner, M. G. 1989. Landscape ecology: the effect of pattern on process. Ann. Rev. Ecol. Syst. 20:171-197.

Turner, M. G. 1990. Spatial and temporal analysis of landscape patterns. Landscape Ecol. 4:21-30.

Turner, M. G., and R. H. Gardner, editors. 1991. Quantitative methods in landscape ecology. Springer-Verlag, New York.

Urban, D. L., R. V. O'Neill, and H. H. Shugart, Jr. 1987. Landscape ecology: A hierarchical perspective can help scientist understand spatial patterns. BioScience 37:119-127.

Vaisanen, R. A., O. Jarvinen, and P. Rauhala. 1986. How are extensive, human-caused habitat alterations expressed on the scale of local bird populations in boreal forest? Ornis Scandinavica 17:282-292.

Wallin, D. O., F. J. Swanson, B. Marks, J. H. Cissel, and J. Kertis. 1996. Comparison of managed and pre-settlement landscape dynamics in forests of the Pacific Northwest, USA. Forest Ecology and Management 85:291-309.

Whitcomb, R. F., J. F. Lynch, M. K. Klimkiewwicz, C. S. Robbins, B. L. Whitcomb, and D. Bystrak. 1981. Effects of forest fragmentation on avifauna of the eastern deciduous forest. Pages 125-205 in R. L. Burgess and D. M. Sharpe, editors. Forest island dynamics in man-dominated landscapes. Springer-Verlag, New York.

Wiens, J. A. 1989. Spatial scaling in ecology. Functional Ecol. 3:385-397.

Wiens, J. A. 1981. Scale problems in avian censusing. Studies in Avian Biology 6:513-521.

Wiens, J.A. 1976. Population responses to patchy environments. Ann. Rev. Ecol. Syst. 7:81-120.

Wilcox, B.A., and D.D. Murphy. 1985. Conservation strategy: the effects of fragmentation on extinction. American Naturalist 125:879-887.

Wimberly, M. C., T. A. Spies, C. J. Long, and C. Whitlock. 2000. Simulating historical variability in the amount of old forests in the Oregon Coast Range. Conservation Biology 14:167-180.

With, K. A. 1997. The application of neutral landscape models in conservation biology. Conservation Biology 11:1069-1080.

With, K. A. 1999. Is landscape connectivity necessary and sufficient for wildlife management? Pages 97-115 in J. A. Rochelle, L. A. Lehmann, and J. Wisniewski, editors. Forest fragmentation: wildlife and management implications. Brill, The Netherlands.

With, K. A., and A.W. King. 1999a. Dispersal success on fractal landscapes: a consequence of lacunarity thresholds. Landscape Ecology 14:73-82.

With, K. A., and A.W. King. 1999b. Extinction thresholds for species in fractal landscapes. Conservation Biology 13:314-326.


FRAGSTATS USER GUIDELINES

Version 3

The following user guidelines are intended for version 3 only. Guidelines for version 2 can be downloaded with the earlier version of the software from the download page of this web site.

OVERVIEW

What is FRAGSTATS

Scale Considerations

Computer Requirements

Data Formats

Raster Considerations

Vector to Raster Conversion

Levels of Metrics

Output Files

Backgrounds, Borders, and Boundaries

INSTALLATION

Installation

RUNNING FRAGSTATS VIA THE GRAPHICAL USER INTERFACE

Step 1. Starting the FRAGSTATS GUI

Step 2. Setting Run Parameters

Step 3. Selecting and Parameterizing Patch, Class, and Landscape Metrics

Step 4. Working with Batch Files (optional)

Step 5. Modifying Class Properties (optional)

Step 6. Executing FRAGSTATS

Step 7. Browsing and Saving the Results

RUNNING FRAGSTATS VIA COMMAND LINE

Command Line Execution


What is FRAGSTATS

FRAGSTATS is a spatial pattern analysis program for categorical maps. The landscape subject to analysis is user-defined and can represent any spatial phenomenon. FRAGSTATS simply quantifies the areal extent and spatial configuration of patches within a landscape; it is incumbent upon the user to establish a sound basis for defining and scaling the landscape (including the extent and grain of the landscape) and the scheme upon which patches are classified and delineated. We strongly recommend that you read the FRAGSTATS Background document on landscape pattern metrics (also available at this web site). The output from FRAGSTATS is meaningful only if the landscape mosaic is meaningful relative to the phenomenon under consideration.


Scale Considerations

FRAGSTATS does not limit the scale (extent or grain) of the landscape subject to analysis. However, the distance- and area-based metrics computed in FRAGSTATS are reported in meters and hectares, respectively. Thus, landscapes of extreme extent and/or resolution may result in rather cumbersome numbers and/or be subject to rounding errors. However, FRAGSTATS outputs data files in ASCII format that can be manipulated using any database management program to rescale metrics or to convert them to other units (e.g., converting hectares to acres).


Computer Requirements

FRAGSTATS version 3 is a stand-alone program written in Microsoft Visual C++ for use in the Windows operating environment. FRAGSTATS was developed and tested on the Windows NT and 2000 operating systems, although it should run under all Windows operating systems. Note, FRAGSTATS is highly platform dependent, as it was developed in the Microscroft environment, so portability to other platforms is not easily accomplished. FRAGSTATS is a compute-intensive program; its performance is dependent on both processor speed and computer memory (RAM). Ultimately, the ability to process an image is dependent on the availability of sufficient memory, the speed of processing that image is dependent on processor speed. Of particular note is the memory constraint. FRAGSTATS loads the input grid into memory and then computes all requested calculations. Thus, you must have sufficient memory to load the grid and then enough leftover for processing and other operating system needs. To determine whether you have sufficient memory to load a particular grid, you can use the following formula: #cells*4bytes. Thus, if you have a 256 rows by 256 columns grid, the memory requirement to simply load the grid is 256 kb (256*256*4/1024 bytes/kb). Plus you need sufficient memory to process the grid, and this requirement depends on the number of patches and classes. These memory requirement are not particularly constraining in a standard analysis, unless you are working with huge images on an older computer. The solution to this problem if it arises–unfortunately–is to get a new machine with as much memory as possible. The memory requirement, however, is very constraining in the moving window analysis because FRAGSTATS requires enough memory for the input grid plus one output grid, plus enough leftover for other processing needs and system needs. If the moving window analysis is selected, FRAGSTATS checks to see if it can allocate enough memory for three grids (i.e., 1 input grid + 1 output grid + enough leftover to insure performance). In the above example, you would need at least 768 kb of memory to conduct a moving window analysis. Not too terribly constraining for most computers when analyzing relatively small landscapes. However, consider a 10,000x10,000 input grid; to conduct a moving window analysis you would need at least 1.14 Gb of RAM.


Data Formats

FRAGSTATS accepts raster images in a variety of formats, including ArcGrid, ASCII, BINARY, ERDAS, and IDRISI image files. FRAGSTATS does not accept Arc/Info vector coverages like the earlier version 2. All input data formats have the following common requirements:

• All input grids should be signed integer grids, ideally containing all non-zero class values (i.e., each cell should be assigned an integer value corresponding to its class membership or patch type). Note, FRAGSTATS assumes that the grids are ‘signed’ integer grids; inputting an ‘unsigned’ integer grid may cause problems. In addition, note that assigning the zero value to a class is allowable, but FRAGSTATS will reclassify all zero cell values to a new class value equal to 1 plus the largest class value in the input landscape. This procedure is necessary because a zero background class value may cause problems in the moving window analysis because a background value of zero in the output grid cannot be distinguished from a computed metric value of zero. In addition, a zero class value may cause problems when the landscape contains a border because zero cannot be negative, yet all cells in the border must be negative integers). Thus, all zero cells are assumed to be interior (i.e., inside the landscape of interest). For these reasons, it is simpler to avoid the use of zero class values altogether.

• All input grids should consist of square cells with cell size specified in meters. For certain input formats (ASCII and BINARY), this is not an issue because cells are assumed to be square and you are required to enter the cell size (in meters) in the graphical user interface. However, FRAGSTATS assumes that all other image formats (ArcGrid, ERDAS, and IDRISI) include header information that defines cell size. Consequently these images must have a metric projection (e.g., UTM) to ensure that cell size is given in metric units.

There are some additional special considerations for each input data format, as follows:

(1) Arc Grid created with Arc/Info. Note, to use Arc Grids you must have ArcView Spatial Analyst or ArcGIS installed on your computer and FRAGSTATS must have access to a certain .dll file found either in the ArcView Bin32 directory (for ArcView Spatial Analyst users) or the ArcGIS Bin directory (for ArcGIS users). Specifically, a path to the corresponding dll library file should be specified in the environmental settings under NT or Windows 2000 operating systems, or a path statement included in the autoexec.bat file, e.g., under Windows 98, as follows:

Windows NT: You can add the necessary Path variable or edit the existing one via the Control panel - System Properties - Environment tab. Add a new variable or edit the existing Path variable in the system variables, not the user variables (this will require administrative privileges). Add the full path to the appropriate .dll file. If you are using ArcView Spatial Analyst, the required file is the avgridio.dll file and it is typically installed in the following path: \esri\av_gis30\arcview\bin32. If you are using ArcGIS, the required file is the aigridio.dll file and it is typically installed in the following path: \esri\arcinfo\arcexe81\bin. Note, your software version number and path may be different so be sure to locate the .dll file on your computer and enter the correct path. If you are using both Spatial Analyst and ArcGIS, then you can enter either or both paths to the Path system variable.

Windows 2000/XP: You can add the necessary Path variable or edit the existing one via the Control panel - System Properties - Advanced tab - Environment Variables button. Add a new variable or edit the existing Path variable in the system variables, not the user variables (this will require administrative privileges). Then, following the instructions above for Windows NT.

Windows 95/98: You must add the necessary Path statement to the autoexec.bat file. First, search your computer for the autoexec.bat file and open it using any text editor. Then, either add a Path statement or edit the existing one. Add the full path to the appropriate .dll file. If you are using ArcView Spatial Analyst, the required file is the avgridio.dll file and it is typically installed in the following path: \esri\av_gis30\arcview\bin32. If you are using ArcGIS, the required file is the aigridio.dll file and it is typically installed in the following path: \esri\arcinfo\arcexe81\bin. Thus, the path statement should look something like: PATH c:\esri\av_gis30\arcview\bin32. Note, your software version number and path may be different so be sure to locate the .dll file on your computer and enter the correct path. If you are using both Spatial Analyst and ArcGIS, then you can enter either or both paths to the Path system variable. If you are adding the path to an existing path, simple use a semicolon to separate the unique paths in the Path statement. After saving the file you will need to reboot your machine for the change to take effect.

(2) ASCII file, no header. Each record should contain 1 image row. Cell values should be separated by a comma or a space(s). Note, it will be necessary to strip (delete) the header information from the image file if it exists, but be sure to keep it for later reference regarding background cell value, # rows, and # columns.

(3) 32-bit binary file, no header; no other limitations.

(4) 16-bit binary file, no header. Patch ID output file, if selected, will be output in signed 32-bit integer format to accommodate a greater number of patches. In addition, because moving window analysis requires floating points, if moving window analysis is selected, the output grids produced will be 32-bit floating point grids.

(5) 8-bit binary file, no header. Patch ID output file, if selected, will be output in signed 32-bit integer format to accommodate a greater number of patches. In addition, because moving window analysis requires floating points, if moving window analysis is selected, the output grids produced will be 32-bit floating point grids.

(5) ERDAS image files (.gis, .lan, and .img). FRAGSTATS accepts images from both ERDAS 7 (.gis and .lan) and ERDAS 8 (.gis, .lan, and .img), but the limitations are somewhat different, as follows:

ERDAS 8 Files.–FRAGSTATS accepts .gis, .lan, and .img files used by current versions of ERDAS IMAGINE, including signed 8-, 16-, and 32-bit integer grids. While .gis and .lan file formats are supported, their limitations make them less practical than .img (see discussion of ERDAS 7 files below). Care should be taken when preparing the data to be used with FRAGSTATS, especially when importing data from other formats (for instance from Arc Grid). Be sure to set the import options to ‘signed integer’. Regardless of the input integer format (8-, 16-, or 32-bit), the patch ID output file created by FRAGSTATS will be a signed 32-bit integer, and if moving window analysis is selected, all output grids will be 32-bit floating point. Multi-layered files are not rejected, but only layer one is processed and the outputs are all single layered. As noted above, cells must be square, not rectangular, and the measurement unit should be meters. If the measurement unit is not specified, then it is assumed to be meters. The cell size and measurement unit specification can be changed within ERDAS Imagine using the ImageInfo tool -> Change Map Model from the Edit menu. The projection information existing in the input file is passed unchanged to the output files. FRAGSTATS does not use this information internally.

ERDAS 7 files.-- FRAGSTATS accepts .gis and .lan files used by ERDAS 7, which are limited to unsigned 8- or 16-bit integer grids. FRAGSTATS will accept both 8-bit and 16-bit integer files and it will reject multi-layered files. While .gis and .lan file formats are supported, their limitations make them less practical than .img. In particular, ERDAS 7.x files are limited to unsigned integers (i.e., only positive integers), therefore landscape borders (which require negative class values) cannot be represented. Another consequence of this particular limitation is that FRAGSTATS-generated patch ID files will not fill the non-landscape cells (i.e., no data cells) with the usual value (minus the background class value), but with zero values. The restriction to 8- or 16-bit integers imposes some limitations when using the FRAGSTATS on large grids. Specifically, unsigned 16-bit integers can only take on values up to 65,534. Thus, class ID values are limited to integers within this range (note, this should not be a problem, since it is unlikely that anyone would have more than 65,534 patch types). Similarly, patch ID values in the patch ID output grid optionally produced by FRAGSTATS are limited to the same range, effectively limiting the number of patches in this output grid to 65,534. If the grid contains more than this number of patches, FRAGSTATS will not be able to output a unique ID for each patch and the user will have to somehow distinguish among patches with the same ID. Finally, because the moving window analysis requires 32-bit output files (in order to output floating point values), moving window analysis is not supported with ERDAS 7 files.

(6) IDRISI image files (.rdc). IDRISI currently supports signed 8- or 16-bit integers and 32-bit floating point grids. This imposes some limitations when using the FRAGSTATS on large grids. Specifically, signed 16-bit integers can only take on values between -32,768 and 32,767. Thus, class ID values are limited to integers within this range (note, this should not be a problem, since it is unlikely that anyone would have more than 32,767 patch types). Similarly, patch ID values in the patch ID output grid optionally produced by FRAGSTATS are limited to the same range, effectively limiting the number of patches in this output grid to 37,767. If the grid contains more than this number of patches, FRAGSTATS will not be able to output a unique ID for each patch and the user will have to somehow distinguish among patches with the same ID. Fortunately, IDRISI supports 32-bit floating point grids, which are produced in a moving window analysis.


Raster Considerations

It is important to realize that the depiction of edges in raster images is fundamentally constrained by the lattice grid structure. Consequently, raster images portray lines in stair-step fashion. The result is an upward bias in the measurement of edge length; that is, the measured edge length is always more than the true edge length. The magnitude of this bias depends on the grain or resolution of the image (i.e., cell size), and the consequences of this bias with regards to the use and interpretation of edge-based metrics must be weighed relative to the phenomenon under investigation.


Vector to Raster Conversion

In some investigations, it may be necessary to convert a vector coverage into a raster image in order to run FRAGSTATS. It is critical that great care be taken during the rasterization process and that the resulting raster image be carefully scrutinized for accurate representation of the original image. During the rasterization process, it is possible for disjunct patches to join and vice versa. This problem can be quite severe (e.g., resulting in numerous 1-cell patches) if the cell size chosen for the rasterization is too large relative to the minimum patch dimension in the vector image. In general, a cell size less than ½ the narrowest dimension of the smallest patches is necessary to avoid these problems.


Levels of Metrics

FRAGSTATS computes 3 groups of metrics. For a given landscape mosaic, FRAGSTATS computes several metrics for: (1) each patch in the mosaic; (2) each patch type (class) in the mosaic; and (3) the landscape mosaic as a whole. These metrics are described in detail in the FRAGSTATS Metrics documentation. In addition, FRAGSTATS computes the adjacency matrix (i.e., tally of the number of cell adjacencies between each pairwise combination of patch types, including like-adjacencies between cells of the same class), which is used in the computation of several class- and landscape-level metrics.


Output Files

Depending on which metrics are selected by the user, FRAGSTATS creates 4 output files corresponding to the three levels of metrics and the adjacency matrix. The user supplies a "basename" for the output files and FRAGSTATS appends the extensions .patch, .class, .land and .adj to the basename. All files created are comma-delimited ASCII files and viewable. These files are formatted to facilitate input into spreadsheets and database management programs:

• "basename".patch file.–Contains the patch metrics; the file contains 1 record (row) for each patch in the landscape; columns represent the selected patch metrics. If a batch file is analyzed, the file contains 1 record for each patch in each landscape specified in the batch file. The first record is a column header consisting of the acronyms for all the metrics that follow. For a single landscape, the patch output file would be structured as follows:

LID, PID, TYPE, AREA, PERIM, GYRATE, CORE

D:\testgrid, 9, forest, 1.0000, 400.0000, 38.1195, 0.1600

D:\testgrid, 0, shrub, 4.0000, 800.0000, 76.4478, 1.9600

Etc.

• "basename".class file.–Contains the class metrics; the file contains 1 record (row) for each class in the landscape; columns represent the selected class metrics. If a batch file is analyzed, the file contains 1 record for each class in each landscape specified in the batch file. The first record is a column header consisting of the acronyms for all the metrics that follow. For a single landscape, the class output file would be structured as follows:

LID, TYPE, CA, PLAND, NP, PD, LPI

D:\testgrid, forest, 8.0000, 22.5000, 4, 5.0000, 15.000

D:\testgrid, shrub, 21.0000, 26.2500, 3, 3.7500, 12.500

Etc.

• "basename".land file.–Contains the landscape metrics; the file contains 1 record (row) for the landscape; columns represent the selected landscape metrics. If a batch file is analyzed, the file contains 1 record for each landscape specified in the batch file. The first record is a column header consisting of the acronyms for all the metrics that follow. For a single landscape, the landscape output file would be structured as follows:

LID, TA, NP, PD, LPI, TE, ED

D:\testgrid, 80.0000, 12, 15.0000, 15.0000, 7800.0000, 97.500

• “basename”.adj file.–Contains the class adjacency matrix; the file contains a simple header in addition to 1 record (row) for each class in the landscape, and is given in the form of a 2-way matrix. Specifically, first record contains the input file name, including the full path. The second record and first column contain the class IDs (i.e., the grid integer values associated with each class), and the elements of the matrix are the tallies of cell adjacencies for each pairwise combination of classes. For a single landscape, the adjacency output file would be structured as follows:

D:\testgrid

Class ID / ID, 2, 3, 4, 5, Background

2, 6840, 130, 120, 10, 0

3, 120, 7960, 160, 40, 10

4, 100, 140, 9880, 40, 20

5, 10, 40, 30, 3080, 16

Note, the adjacency tallies are generated from the double-count method in which each cell side is counted twice–at least for all positively-valued nonbackground cells–and only the 4 orthogonal neighbors are considered. In addition, the matrix may not be symmetrical if a landscape border is present because landscape boundary edges are only counted once. For example, a cell of class 3 (inside the landscape) adjacent to a cell of class -5 (in the landscape border) results in an adjacency for class 3; specifically, a 3 (row) -5 (column) adjacency. It does not result in an adjacency for class 5 (row), because the border cells themselves are not evaluated. For this reason, the adjacency matrix must be read as follows: each row represents the adjacency tallies for cells of that class, and the sum of adjacencies across all columns represents the total number of adjacencies for that class. These row totals should equal the number of positively-valued cells (i.e., inside the landscape) of the corresponding class times 4 (i.e., 4 surfaces for each cell). These row totals are used in several of the contagion metrics. Note that the adjacency matrix includes a column for background adjacencies, which represent cell surfaces of the corresponding class adjacent to designated background. If there is no specified background in the input landscape and a landscape border is not present, then the background adjacencies represent the cell surfaces along the landscape boundary–which are treated as background in the absence of a border. If a border is provides and no background is specified, then the background adjacencies with equal zero because every cell surface, including those along the landscape boundary, will be adjacent to a real non-background class. If a batch file is analyzed, the adjacency matrices corresponding to each landscape specified in the batch file are appended to the same file.


Backgrounds, Borders, and Boundaries

FRAGSTATS accepts images in several forms, depending on whether the image contains background, and whether the landscape contains a border outside the landscape boundary (Fig. 1). The distinction among background, border, and boundary and how they affect the landscape analysis and the calculations of various metrics is a source of great confusion. Care should be taken to fully understand these distinctions before trying to run FRAGSTATS. We strongly suggest that you read through this section twice, once to familiarize yourself with the terminology and a second time to understand the implications.

Figure 1. Alternative image formats with regards to background (given a class value of 99 here) and border. The thick solid line represents the landscape boundary. Positive values are ‘inside’ the landscape of interest and contribute to the computed total landscape area; negative values are ‘outside’ the landscape of interest and are only utilized to determine edge types for patches along the landscape boundary.

Every image will include a landscape boundary that defines the perimeter of the landscape and surrounds the patch mosaic of interest. The boundary is simply an invisible line around the patch mosaic of interest. It is not given explicitly in the image; rather, it is defined by an imaginary line around the outermost cells of positively valued cells. The landscape boundary distinguishes between cells inside the landscape of interest from those outside, and thus ultimately determines the total landscape area. All positively valued cells are assumed to be inside the landscape of interest and are thus included in the total area of the landscape, regardless of whether they are classified as background (see below) or not. This is important, because many metrics include total landscape area in their calculation. Note, in most cases the landscape boundary will surround a single contiguous region of positively valued cells. However, it is possible to have disjunct regions of positively valued cells. In this case, the landscape boundary is not a single continuous line around the landscape of interest, but rather separate boundaries around each disjunct region of interest. The important point is that positively valued cells are inside the landscape of interest, while negatively valued cells are outside, and the landscape boundary is the imaginary line(s) that separate inside from outside. Hence, if the input image contains all positively valued cells, then the entire grid is assumed to be in the landscape of interest and the landscape boundary represents an imaginary line around the entire grid. If the input image contains negatively valued cells, then those cells are assumed to be outside the landscape of interest and thus outside the landscape boundary. In this case, the edge between positively and negatively valued cells represents the landscape boundary. The landscape boundary is important in the absence of a landscape border (see below) because FRAGSTATS needs to know how to treat the edges along the boundary in all edge calculations. In the absence of a border, the landscape boundary will be treated according to user specifications (see below).

An image may include background (also referred to as ‘mask’)--an undefined area either ‘interior’ or ‘exterior’ to the landscape of interest. Note that background can exist as ‘holes’ in the landscape and/or can partially or completely surround the landscape of interest. The background value can be any integer value. Positively valued cells of background are assumed to be ‘inside’ the landscape of interest; negatively valued cells of background are assumed to be ‘outside’ the landscape of interest. This distinction is important, as noted above, because positively valued background (interior background) will be included in the total landscape area, and thus affect many metrics, even though it will not be treated as a patch per se (see below). Further, via the graphical user interface (see below), any class or combination of classes can be treated (i.e., reclassified) as background for a particular analysis. There are several critical issues regarding how background is handled by FRAGSTATS:

1. Interior background (i.e., positively valued background) is included in the total landscape area and thus effects metrics that include total landscape area in their calculations. However, and this is quite tricky, interior background is in essence excluded from the total landscape area in a number of class and landscape metrics that involve summarizing patch or class metrics. For example, mean patch area is based on the average size of patches at the class or landscape level. If interior background is present, mean patch size as computed by FRAGSTATS will not equal the total landscape area divided by the number of patches, because the total landscape area includes background area not accounted for in any patch. Similarly, the area-weighted mean of any patch metric (i.e., distribution statistics at the class and landscape level; see FRAGSTATS Metrics documentation) weights each patch by its proportional area representation. Here, the proportional area of each patch is not based on the total landscape area, but rather the sum of all patch areas, which is equivalent to the total landscape area minus interior background. Similarly, a number of landscape metrics are computed from the proportion of the landscape in each class (e.g., Shannon’s and Simpson’s diversity). Here, proportional area of each class is not based on total landscape area because the proportions must sum to 1 across all classes. Instead, the proportions are based on the sum of all class areas, which is equivalent to the total landscape area minus interior background. Given the subtle differences in how interior background affects various metrics, it behooves you to carefully read the FRAGSTATS Metrics documentation pertaining to each metric you choose, assuming of course that interior background is an issue.

2. Exterior background (i.e., negatively valued background) essentially has no effect on the analysis or on the computation of any metrics. Exterior background is assumed to be ‘outside’ the landscape of interest. Thus, the extent of exterior background in the input landscape has no effect.

3. Background (both interior and exterior) cells adjacent to non-background classes represent edges that must be accounted for in all edge-related metrics. The user specifies how background edge segments should be handled in all edge-related calculations (see below).

An image also may include a landscape border; a strip of land surrounding the landscape of interest (i.e., outside the landscape boundary) within which patches have been delineated and classified. Patches in the border must be set to the negative of the appropriate patch type code. For example, if a border patch is a patch type of code 34, then its cell value must be -34. The border can be any width (as long as it is at least 1 cell wide) and provides information on patch type adjacency for patches on the edge of the landscape (i.e., along the landscape boundary). Essentially, patches in the border provide information on patch type adjacency for patches in the landscape of interest located along the landscape boundary; all other attributes of the patches in the border are ignored because they are outside the landscape of interest. Thus, the border affects only metrics where patch type adjacency is considered: core area, edge contrast, contagion and interspersion metrics.

Under most circumstances, it is probably not valid to assume that all edges function the same. Indeed, there is good evidence that edges vary in their affects on ecological processes and organisms depending on the nature of the edge (e.g., type of adjacent patches, degree of structural contrast, orientation, etc.). Accordingly, the user can specify a file containing edge contrast weights (described in more detail in the Contrast Metrics section of the FRAGSTATS Metrics documentation) for each combination of patch types (classes), including adjacencies involving background if it exists. Briefly, these weights represent the magnitude of edge contrast between adjacent patch types and must range between 0 (no contrast) and 1 (maximum contrast). Edge contrast weights are used to compute several edge-based metrics. If this weight file is not provided, these edge contrast metrics are simply not computed. Generally, if a landscape border is designated, a weight file will be specified as well, because one of the principal reasons for specifying a border is when information on edge contrast is deemed important. If a border is present, the edge contrast associated with all landscape boundary edge segments is made explicit due to knowledge of the abutting patch types. If a border is absent, then all edge segments along the landscape boundary are treated the same as background, as specified in the user-provided edge contrast weight file. Note, however, that the presence of a landscape border will have no affect on the edge contrast metrics if a contrast weight file is not specified--because these metrics will not be computed.

Similarly, the user can specify a file containing edge depths (described in more detail in the Core Area Metrics section of the FRAGSTATS Metrics documentation) for each combination of patch types (classes), including adjacencies involving background if it exists. Briefly, edge depths represent the distance at which edge effects penetrate into a patch and must be given in distance units (meters); edge depths can be any number ≥ 0. However, when implementing edge depths for the purpose of determining core areas, FRAGSTATS is constrained by minimum resolution established by the cell size. Thus, in effect, edge depths will be rounded to the nearest distance in increments of the cell size. For example, if the cell size is 30 m, and you specify a 100 m edge depth, the edge mask used to mask cells along the edge of a patch (i.e., eliminate them from the “core” of the patch) will be 3 cells wide (90 m), because it is not possible to use a mask that is 3.3 cells wide. Similarly, a specified edge depth of 50 m will in effect be rounded up to 2 cells (60 m). Therefore, it is generally advisable to specify edge depths in increments equal to the cell size. Edge depths are used to compute several core area-based metrics. If this edge depth file is not provided, these core area metrics are simply not computed. Typically, if a landscape border is designated, an edge depth file will be specified as well, because one of the principal reasons for specifying a border is when information on edge effects is deemed important. If a border is present, the edge depths associated with all landscape boundary edge segments is made explicit due to knowledge of the abutting patch types. If a border is absent, then all edge segments along the landscape boundary are treated the same as background, as specified in the user-provided edge depth file. Note, however, that the presence of a landscape border will have no affect on the core area metrics if an edge depth file is not specified–because these metrics will not be computed.

A landscape border is also useful for determining patch type adjacency for the contagion and interspersion indices. These metrics (described in more detail in the Contagion and Interspersion Metrics section of the FRAGSTATS Metrics documentation) require information on cell adjacency; that is, the abutting class values for the side of every cell. The proportional distribution of cell adjacencies is used to compute a variety of landscape texture metrics. Although a landscape border is not often designated for the primary purpose of computing these texture metrics, a border will inform the calculation of these metrics. If a border is present, the adjacencies associated with all landscape boundary edge segments is made explicit due to knowledge of the abutting patch types. If a border is absent, then all edge segments along the landscape boundary are treated the same as background and the corresponding cell adjacencies are ignored in the calculation of these metrics.

Metrics based on edge length (e.g., total edge or edge density) are affected by these considerations as well. If a landscape border is present, then edge segments along the boundary are evaluated to determine which segments represent ‘true’ edge and which do not. For example, an edge segment between cells with class value 5 (inside the landscape of interest) and cells with class value -5 (outside the landscape of interest; i.e., in the border) does not represent a true edge; in this case, the landscape boundary artificially bisects an otherwise contiguous patch and the edge is not counted in the calculations of total edge length. Conversely, an edge segment between class 5 and -3 represents a true edge and is counted. If a landscape border is absent, then a user-specified proportion of the landscape boundary is treated as true edge and the remainder is ignored. For example, if the user specifies that 50% of the landscape boundary should be treated as true edge, then 50% of the landscape boundary will be incorporated into the edge length metrics. Regardless of whether a landscape border is present or not, if a background class is specified, then a user-specified proportion of edge bordering background is treated as true edge and the remainder is ignored.

We recommend including a landscape border, especially if edge contrast, core area, or patch type adjacency is deemed important. In most cases, some portions of the landscape boundary will constitute ‘true’ edge (i.e., an edge with a contrast weight > 0) and others will not, and it will be difficult to estimate the proportion of the landscape boundary representing true edge. Moreover, it will be difficult to estimate the average edge contrast weight or edge depth for the entire landscape boundary. Thus, the decision on how to treat the landscape boundary will be somewhat subjective and may not accurately represent the landscape. In the absence of a landscape border, the affects of the decision regarding how to treat the landscape boundary on the landscape metrics will depend on landscape extent and heterogeneity. Larger and more heterogeneous landscapes will have a greater internal edge-to-boundary ratio and therefore the boundary will have less influence on the landscape metrics. Of course, only those metrics based on edge lengths and types are affected by the presence of a landscape border and the decision on how to treat the landscape boundary. When edge-based metrics are of particular importance to the investigation and the landscapes are small in extent and relatively homogeneous, the inclusion of a landscape border and the decision regarding the landscape boundary should be considered carefully.

So, let’s try to put all of this together. There are five types of metrics affected by landscape boundary, background, and border designations: (1) total landscape area, (2) edge length metrics, (3) core area metrics, (4) contrast metrics, and (5) contagion/interspersion metrics. Let’s consider several scenarios involving various combinations of background and border, and how each of these types of metrics will be treated under each scenario.

• Scenario 1.–Input landscape contains all positively valued cells of non-background classes (Fig. 1a). In this case, the entire grid is assumed to be in the landscape of interest and every cell belongs to a non-background class. The landscape boundary surrounds the entire grid and there is no border or background present.

Total landscape area.–All cells are included in the total landscape area calculation.

Edge length metrics.–User must specify the proportion of the landscape boundary to include as edge. All other edges are explicit.

Core area metrics.–The landscape boundary is treated like background; the user must specify the edge depth for cells abutting background in the edge depth file, and this depth is applied to the landscape boundary. All other edges are explicit; their edge depths are specified in the edge depth file.

Contrast metrics.–The landscape boundary is treated like background; the user must specify the edge contrast for cells abutting background in the edge contrast weight file, and this weight is applied to the landscape boundary. All other edges are explicit; their edge contrast weights are specified in the edge contrast weight file.

Contagion/interspersion metrics.–The landscape boundary is treated like background and is simply ignored since there is no information available on patch type adjacency.

• Scenario 2.–Input landscape contains all positively valued cells, but includes a background class (Fig. 1b). In this case, the entire grid is assumed to be in the landscape of interest , but some cells belong to a background class. Here, the background is interior because it is positively valued and thus inside the landscape of interest. The landscape boundary surrounds the entire grid and there is no border present.

Total landscape area.–All cells are included in the total landscape area calculation.

Edge length metrics.–User must specify the proportion of the landscape boundary and background edges to include as edge. All other edges are explicit.

Core area metrics.–The landscape boundary is treated like background; the user must specify the edge depth for cells abutting background in the edge depth file, and this depth is applied to both the landscape boundary and background edges. All other edges are explicit; their edge depths are specified in the edge depth file.

Contrast metrics.–The landscape boundary is treated like background; the user must specify the edge contrast for cells abutting background in the edge contrast weight file, and this weight is applied to both the landscape boundary and background edges. All other edges are explicit; their edge contrast weights are specified in the edge contrast weight file.

Contagion/interspersion metrics.–The landscape boundary and background are treated similarly; both are simply ignored when evaluating adjacencies since there is no information available on patch type adjacency in either case.

• Scenario 3.–Input landscape contains a mixture of positively valued cells and negatively valued background cells (Fig. 1c). Note, it doesn’t matter whether the negatively valued background cells are located entirely on the periphery of the positively valued cells (i.e., outside the landscape of interest) or located as holes in the interior of the landscape, or a combination of the two. In all cases, the positively valued cells are is assumed to be inside the landscape of interest , whereas the negatively valued background cells are assumed to be outside the landscape of interest and thus outside the landscape boundary. Here, the background is entirely exterior because it is all negatively valued and thus outside the landscape of interest. The landscape boundary separates contiguous regions of positively valued cells from the negatively valued cells and there is no border present. Alternatively, the exterior background could be considered border, but the use of border is generally reserved for situations involving negatively valued non-background cells.

Total landscape area.–All positively valued cells are included in the total landscape area calculation; negatively valued cells (here, all background) are ignored.

Edge length metrics.–User must specify the proportion of the landscape boundary and background edges (in this case, they are the same) to include as edge. All other edges are explicit.

Core area metrics.–The landscape boundary is treated like background; in this case, the entire landscape boundary is in fact also background. The user must specify the edge depth for cells abutting background in the edge depth file, and this depth is applied to the background edges (in this case, all on the landscape boundary). All other edges are explicit; their edge depths are specified in the edge depth file.

Contrast metrics.–The landscape boundary is treated like background; in this case, the entire landscape boundary is in fact also background. The user must specify the edge contrast for cells abutting background in the edge contrast weight file, and this weight is applied to the background edges (in this case, all on the landscape boundary). All other edges are explicit; their edge contrast weights are specified in the edge contrast weight file.

Contagion/interspersion metrics.–The landscape boundary and background (in this case, they are the same) are treated similarly; they are simply ignored when evaluating adjacencies since there is no information available on patch type adjacency.

• Scenario 4.–Input landscape contains a mixture of positively valued cells, including some positively valued background cells, and negatively valued background cells (Fig. 1d). Note, as in scenario 3, it doesn’t matter whether the negatively valued background cells are located entirely on the periphery of the positively valued cells (i.e., outside the landscape of interest) or located as holes in the interior of the landscape, or a combination of the two. In all cases, the positively valued cells are is assumed to be inside the landscape of interest , whereas the negatively valued background cells are assumed to be outside the landscape of interest and thus outside the landscape boundary. Here, the background is a combination of interior and exterior background. The landscape boundary separates contiguous regions of positively valued cells from the negatively valued cells and there is no border present. As noted in scenario 3, the exterior background could be considered border, but the use of border is generally reserved for situations involving negatively valued non-background cells.

Total landscape area.–All positively valued cells, including the ‘interior’ background, are included in the total landscape area calculation; negatively valued cells (here, all background) are ignored.

Edge length metrics.–User must specify the proportion of the landscape boundary (in this case, all background) and interior background edges to include as edge. All other edges are explicit.

Core area metrics.–The landscape boundary is treated like background; in this case, the entire landscape boundary is in fact also background. The user must specify the edge depth for cells abutting background in the edge depth file, and this depth is applied to all background edges (in this case, both on the landscape boundary and interior). All other edges are explicit; their edge depths are specified in the edge depth file.

Contrast metrics.–The landscape boundary is treated like background; in this case, the entire landscape boundary is in fact also background. The user must specify the edge contrast for cells abutting background in the edge contrast weight file, and this weight is applied to all background edges (in this case, both on the landscape boundary and interior). All other edges are explicit; their edge contrast weights are specified in the edge contrast weight file.

Contagion/interspersion metrics.–The landscape boundary (in this case, all background) and interior background are treated similarly; both are simply ignored when evaluating adjacencies since there is no information available on patch type adjacency in either case.

• Scenario 5.–Input landscape contains a mixture of positively valued non-background cells and negatively valued non-background cells (i.e., a true border; Fig. 1e). In this case, the positively valued cells are is assumed to be inside the landscape of interest , whereas the negatively valued cells are assumed to be outside the landscape of interest and thus outside the landscape boundary. The landscape boundary separates contiguous regions of positively valued cells from the negatively valued cells; no background exists; and there is a true border present. This is perhaps the ideal scenario because every cell is classified into a real class (i.e., no background) and a border is included to inform all edge, core, and adjacency calculations.

Total landscape area.–All positively valued cells are included in the total landscape area calculation; negatively valued cells are ignored.

Edge length metrics.–Because a border is present and there is no background, all edges are explicit; that is, the image provides explicit information on whether every edge segment along the boundary is a true edge or not. In this case, the user does not need to specify the proportion of the landscape boundary to include as edge. In fact, any user specification in this regard via the user interface will be disregarded.

Core area metrics.–Because a border is present and there is no background, all edges are explicit; that is, the image provides explicit information on the abutting patch types along the boundary. In this case, all edge depths are specified in the edge depth file.

Contrast metrics.–Because a border is present and there is no background, all edges are explicit; that is, the image provides explicit information on the abutting patch types along the boundary. In this case, all edge contrast weights are specified in the edge contrast weight file.

Contagion/interspersion metrics.–Because a border is present and there is no background, all edges are explicit; that is, the image provides explicit information on the abutting patch types along the boundary. In this case, all boundary edge segments are included in the adjacency calculations.

• Scenario 6.–Input landscape contains a mixture of positively valued cells, including both background and non-background classes, and negatively valued cells, including both background and non-background classes (Fig. 1f). This is the most complex scenario involving a complicated mixture in interior and exterior background and a border. In this case, all positively valued cells (including interior background) are is assumed to be inside the landscape of interest, whereas the negatively valued cells are assumed to be outside the landscape of interest and thus outside the landscape boundary. The landscape boundary separates contiguous regions of positively valued cells from the negatively valued cells. A true border is present, but it includes some background class. This is perhaps also an ideal scenario, like scenario 5, but contains a realistic, sometimes unavoidable, situation in which some areas must be classified as background, either because there is no information available from which to classify them, or because it is deemed desirable ecologically to treat these areas as undefined background.

Total landscape area.–All positively valued cells, including the interior background, are included in the total landscape area calculation; negatively valued cells are ignored.

Edge length metrics.–Because a border is present but contains some background and there is interior background, only a portion of edges are explicit; that is, some edges abut background (either interior or exterior) and it is not explicit whether they represent true edge or not. In this case, the user must specify the proportion of edges involving background to include as edge.

Core area metrics.–Because a border is present but contains some background and there is interior background, only a portion of edges are explicit. Here, all boundary edges involving background and interior background edges are treated the same. The user must specify the edge depth for cells abutting background in the edge depth file, and this depth is applied to all background edges (in this case, both on the landscape boundary and interior). All other edges are explicit; their edge depths are specified in the edge depth file.

Contrast metrics.–Because a border is present but contains background, and there is interior background, only a portion of edges are explicit. Here, all boundary edges involving background and interior background edges are treated the same. The user must specify the edge contrast weight for cells abutting background in the edge contrast weight file, and this weight is applied to all background edges (both on the landscape boundary and interior). All other edges are explicit; their contrast weights are specified in the edge contrast weight file.

Contagion/interspersion metrics.–Because a border is present but contains some background, and there is interior background, only a portion of edges are explicit. In this case, edge segments involving background (both on the landscape boundary and interior) are ignored in the adjacency calculations.


Installation

FRAGSTATS installation is quick and easy (hopefully). After downloading the fragstats.zip file, simply double click on the file and Winzip should open (if you don’t have Winzip or another file compression utility that can unzip files, you will need to download Winzip from the web). In Winzip, simply click on the “install” button and follow the onscreen instructions. Alternatively, you can extract the zipped files to a folder and click on the setup.exe file and follow the instructions; however, this approach will not automatically delete the installation files after the installation is complete. Once installed, FRAGSTATS is run by double clicking your mouse on the Fragstats.exe file. However, if you are using FRAGSTATS with Arc Grids, then ArcView Spatial Analyst or ArcGIS must be installed on your computer and FRAGSTATS must have access to the dll libraries found in the ArcView Bin32 or ArcGIS Bin directory. Specifically, the Fragstats.exe file must either be located and run from the same directory as the dll libraries (not the best option) or a path to the dll libraries must be specified in your environmental variables (preferable) or in the autoexec.bat file. For detailed instructions on installing Fragstats for use with ArcGrids, see the discussion on Overview--Data Formats .


Step 1. Starting the FRAGSTATS GUI

To start FRAGSTATS, simply double click on the Fragstats.exe file and (hopefully) the opening FRAGSTATS window will display (Fig. 2).

Figure 2. Anatomy of the FRAGSTATS opening user interface.

The anatomy of this opening window is quite simple, as it is similar to most windows-based programs. The title bar lists the name of the current or open parameterization file. The parameterization file contains the current parameterization scheme. When you first start FRAGSTATS, a parameterization file does not exist. Consequently, the title is listed as “untitled” until you save the current parameterization scheme under the File-Save option. Once you have saved the current parameterization or have retrieved a previously saved scheme, the title bar will list the open parameterization file. The menu bar consists of a few items that allow you to parameterize a FRAGSTATS run, edit certain files, and save and retrieve parameterization files. Each menu item has a drop-down list of options. The toolbar provides quick access to the frequently used File and Fragstats menu options. The log window provides a running log of the analysis. The status bar indicates the status of the program. Details of the parameterization process are described in Step 2. Here, each of the menu bar items are briefly described:

File Menu.–The File menu allows you to open an existing parameterization file or save the current parameterization file. Note, parameterization files are given the file extension .frg.

1. New.–Creates a new (or blank) parameterization file. It is not necessary to begin by creating a new file. A new file is automatically opened when you start FRAGSTATS. This option is used when you have a parameterization file currently open and wish to create a new file from scratch.

2. Open.–Opens an existing (previously saved) parameterization file.

3. Save.–Saves the current parameterization to a file with the extension .frg. Note, if you are saving a parameterization file for the first time, you will be prompted to specify a location and file name. If you are saving from an open parameterization file, this will overwrite the existing file without prompting you for a file name. This file contains all the parameter settings in the dialog boxes at the time the file was saved. This can be very useful if you are running FRAGSTATS repeatedly with the same or similar parameterization schemes.

4. Save as.–Saves the current parameterization file to a location and file name that you specify.

5. Exit.–Closes the program. The same effect is achieved by clicking on the X in the upper right corner of the window.

Fragstats Menu.–The Fragstats menu allows you to parameterize the analysis.

1. Set Run Parameters.–Opens a new dialog box that allows you to specify necessary parameters for running FRAGSTATS (see Step 2).

2. Select Patch Metrics.–Opens a new dialog box that allows you to select and parameterize the desired patch-level metrics. Note, this function is not active until the Run Parameters dialog box is successfully completed, and then only if patch metrics are selected in the run parameters.

3. Select Class Metrics.–Opens a new dialog box that allows you to select and parameterize the desired class-level metrics. Note, this function is not active until the Run Parameters dialog box is successfully completed, and then only if class metrics are selected in the run parameters.

4. Select Landscape Metrics.–Opens a new dialog box that allows you to select and parameterize the desired landscape-level metrics. Note, this function is not active until the Run Parameters dialog box is successfully completed, and then only if landscape metrics are selected in the run parameters.

5. Clear All Menus.–Clears the Run Parameters, Patch-, Class-, and Landscape Metrics dialog boxes.

6. Execute Fragstats.–Executes a FRAGSTATS run. An “execution finished” message will appear in the log window when FRAGSTATS processing is complete.

Tools Menu.–The Tools menu provides you with several miscellaneous options for creating and editing batch files, reclassifying classes and controlling class-level output, browsing results, and saving the log file.

1. Batch File Editor.–Allows you to create and edit batch files. See Step 4 on Using Batch Files for details on the batch file editor.

2. Class Properties.–Allows you to edit the properties of each class; that is, designate classes as background and disable the output for selected classes. See Step 5 on Modifying Class Properties for details.

3. Browse Results.–Allows you to browse and save the results of the analysis. See Step 7 on Browsing and Saving Results for details.

4. Clear Log.–Clears the log window of all text.

5. Save Log.–Saves the log window as an ASCII text file with the extension .log to a location and file name that you specify.

Help Menu.–The Help menu provides you with online help.

1. Help Content.–Allows you to access a familiar windows-based help interface with the standard content, index, and find options. The online help information is essentially the same as provided in this document and the FRAGSTATS Metrics document.

2. About Fragstats.–Lists the authors and the software release version.


Step 2. Setting Run Parameters

After opening the FRAGSTATS interface, the next step is to set the run parameters. By the selecting the set run parameters option in the Fragstats drop-down menu, the Run Parameters dialog box will display (Fig. 3).

Figure 3. The Run Parameters dialog box.

This dialog box contains all the essential input parameters required to run FRAGSTATS except for the selection of the metrics themselves. Here is where you define the input grid or batch file, specify the input data type, choose an analysis type, select the patch ID output option, choose a neighbor rule for patch delineation, specify a class properties file, and select the levels of metrics you want computed. This contains most of the information contained in the command line (or most of the prompts) in version 2. The order in which the run parameters are specified is not important, although there is a logical sequence for at least a few of the parameters. The parameters are stored only after the OK button is clicked.

1. Input File Type.–Chose between Landscape and Batch modes:

(1) Landscape.--If Landscape mode is selected, then FRAGSTATS expects the designated input file to be a single raster image; FRAGSTATS will produce the conventional output for that landscape.

(2) Batch File.--If Batch mode is selected, then FRAGSTATS will run the batch file specified in the Input File text box and produce output for all of the landscapes designated in the batch file. See Step 4 on Working with Batch Files for details on building a suitable batch file. If Batch mode is selected, then the Input Data Type (see below) and Grid Attributes (see below) will become inactive (grayed out in the interface) because these parameters will be specified uniquely for each input landscape in the batch file.

2. Input Data Type.–FRAGSTATS accepts several types of input image data formats. See Data Formats in the Overview section for details. Briefly, all input images should be integer grids with non-zero class values (i.e., each cell should be assigned an integer value corresponding to its class membership or patch type). Note, assigning the value 0 to a class may cause problems in the moving window analysis. In addition, all input grids should consist of square cells with the measurement units in meters. Choose one of the following:

(1) Arc Grid created with Arc/Info.

(2) ASCII file, no header.

(3) 8 bit binary file, no header.

(4) 16 bit binary file, no header.

(5) 32 bit binary file, no header.

(6) ERDAS image files (ERDAS 7 .gis or .lan, 8 or 16 bit files; and ERDAS 8 .img, 8, 16, or 32 bit files).

(7) IDRISI image files (.rdc).

3. Input File Name.--Specify an input file, where the input file is either the input image to be analyzed (landscape mode) or a batch file, by clicking on the file name button and navigating to the desired input file. If the Input Data Type is selected first, then navigation to the input file will default to files of the specified type. For example, if Arc Grid is selected as the Input Data Type, then the navigation window will reveal only Arc Grids. In addition, the label on the File Name button will reflect the Input Data Type. Once you have selected a file, the full path and file name will be displayed in the text box next to the File Name button.

4. Output File.–Specify a “basename” for the output files by clicking on the Output File button and navigating to the desired folder, and then entering a “basename” or selecting an existing file to overwrite. This basename will be given the extensions .patch, .class, .land and .adj for the corresponding patch, class, and landscape metrics and adjacency matrix. Note, you can automatically save the results to output files by checking the Automatically Save Results check box. In addition, it is not necessary to enter an output file basename here. The results can also be saved from the browse dialog box (see Step 7 on Browsing and Saving Results). However, if an output file name is specified here, then it will be used as the default basename when saving the results from the browse dialog box. If an output file name is not specified here, then you will be prompted to provide a basename later when saving the results. Note, if you specify an output file name that already exists, FRAGSTATS will prompt you as to whether you want to overwrite the existing files after execution of the program is complete.

5. Analysis Type.–Chose between Standard and Moving Window modes:

(1) Standard.--If Standard mode is selected, then FRAGSTATS will produce the conventional output for the input landscape(s) consisting of the .patch, .class, and .land files corresponding to the patch, class, and landscape metrics.

(2) Moving Window.--If Moving Window mode is selected, then FRAGSTATS will conduct a moving window analysis and output a new grid for each selected metric. In addition, if you select a moving window analysis, then you must specify the shape (round or square) and size (radius, in meters) of the window to be used. A window of the specified shape and size is passed over every positively valued cell in the grid (i.e., all cells inside the landscape of interest). However, only cells in which the entire window is contained within the landscape are evaluated (see Boundary Effects below). Within each window, each selected metric at the class or landscape level is computed and the value returned to the focal (center) cell. Patch metrics are not allowed in the moving window analysis. The moving window is passed over the grid until every positively valued cell (including positively valued background cells) containing a full window is assessed in this manner. Note, internal background cells containing real positively-valued classes in the window may receive a value in the output grid, despite the fact that the cell is background in the input grid. Specifically, if the entire window is internal background, then the cell will receive a minus background value in the output grid. There are several important considerations when using the moving window analysis type:

□ Window Shape and Size.–The user-specified window size refers to the radius (in meters) of a near-circular window or square window, depending on the shape chosen. If a square window is selected, the radius refers to the shortest distance between the focal cell and the side of the square window; hence, it refers to the distance from the focal cell to the side of the square in an orthogonal direction. The actual area of the window as implemented algorithmically will vary slightly from the area calculated mathematically based on the geometry of a circle or square for two reasons. First, the radius is given as the distance from the focal cell to the edge of the window. For example, given a cell size of 10 m and a circular window, a 40 m radius would be implemented as a mask 4 cells wide. The diameter of the window would equal 90 m–twice the radius plus the size of the focal cell–as opposed to 80 m. The addition of the focal cell to the diameter of the window is necessary to force the focal cell to always be located at the exact center of the window. Second, the specified radius (in meters) is always rounded to the nearest cell. Thus, if the radius is not perfectly divisible by the cell size, the actual window will be somewhat smaller or larger.

□ Boundary Effects.–Cells located close to the edge of the landscape (i.e., near the landscape boundary) will be biased in moving window calculations if the window intersects the landscape boundary. Consider a cell located on the landscape boundary. A normal window placed on that cell would extend well outside the landscape boundary, in fact, half the window would extent beyond the landscape where information on landscape structure is absent. In fact, any cell within the specified radius of a round window or ½ the length of a side of a square window will be biased in this way. There are several alternative ways of handling this bias. FRAGSTATS adopts a conservative method that involves simply not computing the metrics for focal cells containing a partial window (i.e., a window not fully contained within the input grid). Actually, FRAGSTATS returns the user-specified exterior (negative) background value for these cells. Thus, in practice, the output grid will contain a peripheral buffer of exterior background cells surrounding the core of the landscape–only the core (cells containing a full window) will contain metric values (Fig. 4a). Clearly, as landscape extent increases relative to window size, the magnitude and spatial extent of this boundary issue decreases. For this reason, care should be exercised in selecting a window size that minimizes the loss of information due to this boundary effect. An alternative approach for dealing with this boundary effect is to expand the extent of the input landscape to include a suitably wide expansion strip of positively valued and appropriately classified cells around the actual landscape of interest, where the width of this extension is equal to the radius of the window (Fig. 4b). In this manner, the core of the landscape in the output grid produced by the moving window analysis will align with the original landscape boundary of interest. It is important to realize that including a suitably wide landscape border (negatively valued, but classified cells) does not have the same effect. Border, by definition, consists of negatively valued cells outside the landscape of interest, and FRAGSTATS ignores all negatively valued cells when calculating metrics, except for the information provided on adjacency to positively valued cells. Thus, a window that includes cells in the landscape border, will effectively function like a ‘partial’ window, and therefore bias the calculation of all metrics.

Figure 4. (A) Moving window applied to an input grid without a border produces an output grid for each unique class-metric combination in which a strip the width of the window around the periphery of the grid is given a background value in the output grid. (B) A landscape border at least as wide as the window allows all cells inside the landscape boundary (dark line) (i.e., positive values) to be given the computed focal cell value.

□ Input Data Types.–Moving window analysis is restricted to input data types that can effectively handle floating point values. Thus, the 16-bit binary data format is not allowed in a moving window analysis and will be inactive in the Run Parameters dialog box if the moving window analysis type is selected. If this data type is included in a batch file used in conjunction with a moving window analysis, the corresponding records will be ignored.

□ Selection of Classes and Metrics.–For each selected metric and enabled class, FRAGSTATS outputs a separate grid (in the same format as the input grid). Thus, if the input landscape contains 10 classes and all of them are enabled in the class properties file (see Step 5 on Modifying Class Properties) and you select 1 class level metric, then FRAGSTATS outputs 10 grids, one for each class for the selected metric. In this case, each output grid represents a separate class, and the cell values represent the computed values of the selected metric for that class. Specifically, a window is placed over the first cell in the input landscape, the selected metric is computed for the first class, and this value is output to the corresponding cell in a new grid for that specific metric-class combination. The process is repeated for the next class, and so on, until all classes have been assessed. Next, the window is placed over the next cell and the process is repeated. The process is repeated in this manner until all positively valued cells containing a full window in the input landscape have been evaluated. The end result is a new grid for each class, in which the cell values represent the values of the computed metric. Accordingly, if you select 5 class-level metrics, then FRAGSTATS outputs 50 grids, one for each class-metric combination. If, in addition to these class metrics, you also select 3 landscape metrics, FRAGSTATS outputs an additional 3 grids, one for each landscape metric. Clearly, the number of output grids can increase quickly with several classes and several metrics. Thus, it is important to carefully select the most parsimonious set of classes and metrics. Note, windows containing no cells of the corresponding class, or in some cases just a single cell of the corresponding class, will be assigned a background value in the output grid.

□ Computer Processing and Memory Requirements.–The computer processing and memory demands of the moving window analysis are phenomenal. Consider a relatively small grid of 100 x 100 cells; i.e., 10,000 cells. The moving window analysis involves placing a window over every cell and computing one or more metrics. This is equivalent to doing 10,000 FRAGSTATS analyses. Now imagine that you have a larger grid of 1000 x 1000 cells; i.e., 1,000,000 cells. Clearly, the processing time quickly becomes overwhelming. In addition, the memory demands increase as a function of the size the input grid. FRAGSTATS must be able to allocate memory for at three grids, where each grid requires 4 bytes for every cell. See Computer Requirements in the Overview Section for a detailed description of the memory requirements. Clearly, given the limited memory available in most personal computers, it is quite possible that you will not have enough memory to do even a single unique class-metric combination, let alone the dozens or hundreds that could easily result if you selected several classes and several metrics. If more than one class-metric combinations are selected, FRAGSTATS will determine how many can be done given the available memory and then parse the job into separate passes. For example, if 20 class-metric combinations are selected, but available memory is sufficient for only 4 at a time, then FRAGSTATS will conduct 5 passes across the landscape, output 4 grids each pass. Given these considerations, it behooves you to use this option sparingly and with great patience until computer processing capabilities increase substantially. And don’t be too surprised if your computer is simply unable to allocate sufficient memory to do any moving window analysis.

□ Output Grid Naming Convention.–Given the number of possible output grids produced from a moving window analysis and limits on the file name length with some data types (e.g., Arc Grids), the output file naming convention is somewhat cumbersome. If a moving window analysis is selected, FRAGSTATS will create a new subdirectory beneath the directory containing the input file by appending “_MW1" (for moving window #1) to the name of the input file. Thus, a directory named “Test” containing the input file named “TestGrid” will have a new subdirectory under the Test directory named “TestGrid_MW1". This subdirectory will contain an output grid for each class-metric combination and landscape metric selected. For landscape metrics, the output grids are named using the metric acronym. For class metrics, the metric acronym is combined with the class ID value (see Step 5 on Modifying Class Properties) because each class has a separate output grid. For example, the landscape-level contagion metric (CONTAG) would be given the following grid name: CONTAG. The class-level clumpiness metric for class ID #3 would be given the following grid name: CLUMPY_3. See the list of metrics in the FRAGSTATS Metrics documentation for the metric acronyms. If a second moving window analysis is conducted on the same input file (e.g., using a different window size), a second directory is created by appending “_MW2" to the name of the input file. And so on for each subsequent moving window analysis.

• Grid Attributes.–Depending on Input Data Type, you will need to enter some information about the grid. Note, only the text boxes that are required for the corresponding Input Data Type will be active; all others will be grayed out. Fill in all text boxes that are active.

(1) Cell Size (in meters).–Enter the size of cells in meters in the input image. Cells must be square. The length of 1 side of a cell should be input.

(2) Background Value.–[Optional] Enter the value to be used for background cells. This is only required if there are cells interior or exterior to the landscape of interest that you want to treat as background (see Overview discussion). Note, it is possible to specify multiple class values as background, but this must be done from the Class Properties tool under the Tools menu. When this is done, the designated classes are reclassified to the background value specified here in the Grid Attributes. Note, all background cells are assigned this cell value, and this can have important implications if you select core area or edge contrast metrics. Specifically, if you wish to specify a non-zero edge depth or edge contrast weight to background edges, you must include this background class value in the pairwise combination of classes given in the edge depth and contrast weight files (see below).

(3) Number of Rows.–Enter the number of rows in the input image. This is only required if Input Data Type is ASCII or Binary.

(4) Number of Columns.–Enter the number of columns in the input image. This is only required if Input Data Type is ASCII or Binary.

• Unique Patch Ids.–Chose among the following three options for outputting a Patch ID image:

(1) Do Not Output ID Image.–A patch ID image will not be output.

(2) Create and Output ID Image.–A patch ID image will be created by FRAGSTATS and output in the same data type format as the Input Data Type. However, all binary input data formats as well as any ERDAS 8 input data format will be output in signed 32-bit integer format to accommodate a greater number of patches. The Patch ID image will contain a unique ID for each patch in the landscape. All background cells will be assigned a negative of the user-specified background value. This patch ID corresponds to the patch ID in the “basename”.patch output file. This image is needed if you wish to associate the patch-level output with specific patches. Note, the patch ID file will be named using the following convention:

Input file name + 4 or 8 (depending on neighbor rule) + ID

Thus, an input file named “test” analyzed with an 8-neighbor rule will be given the following patch ID file name: test8id. If you attempt to create and output an ID image that already exists, e.g., from a previous run, FRAGSTATS will ask you whether you want to overwrite the existing file. NOTE, if you are using Arc Grids and if you attempt to create and output an ID image with the same name as a grid that is currently open in another program, e.g., in ArcView, the grid will be corrupted and an error message will be written to the log window. In this case, the grid folder must be deleted, even after closing ArcView, before you can create and output an ID image with that name.

(3) Input Unique ID Image.–If you select this option, you must specify an existing patch ID image. The patch IDs on this image will correspond to the patch IDs in the “basename”.patch output file. Also, the data type of this file must be the same as the Input Data Type.

• Patch Neighbor Rule.–Chose between the 4-cell and 8-cell rule. The 4-cell rule considers only the 4 adjacent cells that share a side with the focal cell (i.e., orthogonal neighbors) for determining patch membership. The 8-cell rule considers all 8 adjacent cells, including the 4 orthogonal and 4 diagonal neighbors. Thus, if the 4-cell rule is selected, two cells of the same class that are diagonally touching will be considered as part of separate patches; if the 8-cell rule is selected, these will be considered part of the same patch. The choice of patch neighbor rule will affect most of the configuration metrics, but will have no affect on the composition metrics.

• Class Properties File.–Specify a Class Properties File by clicking on the corresponding button and navigating to the desired file. Note, FRAGSTATS uses the file extension .fdc for class properties files and will look for files with this extension by default when navigating. The .fdc extension is not mandatory, but using it can help keep files organized. Each record in the file should contain a numeric patch type value, the character descriptor for that patch type, a status indicator, and a background indicator. The syntax for this comma-delimited ASCII file is as follows:

ClassID, ClassName, Status, isBackground

□ ClassID is an integer value corresponding to a class value in the landscape.

□ ClassName is a descriptive name of the class; descriptive names can be any length and contain any characters, including spaces, but cannot include commas. This descriptive name is reported in all patch and class output files for the variable TYPE.

□ Status can take on the values: true, or t; and false, or f., and determines whether the corresponding class should be processed and added to the results or simply ignored in the output files. A “true” or “t” indicates that the class is enabled and should be output in the patch and class output files. A “false” or “f” indicates that the class is disabled and should not be output. Note, class status does not effect the computation of landscape metrics; disabled classes are still included, as necessary, in the computation of landscape metrics. Although there is some savings of computer processing by disabling a class, the primary effect is on the output. This feature allows you to “turn off” classes that you are not interested in so that you don’t have to view their statistics in the output files.

□ isBackground can take on the values: true, or t; and false, or f, and determines whether the corresponding class should be reclassified and treated as background (i.e., assigned the background value specified in the Grid Attributes. Note, classifying a class as background will have an effect on many landscape metrics (see Overview discussion).

The class properties file should contain a record for each class in the input landscape, and all arguments should be separated by a comma or space(s). For example:

1,shrubs,true,false

2,conifers,true, false

3,deciduous,true,false

4,other,false,true

etc.

In summary, the class properties file allows you to do three things: (1) specify character descriptors for each class in order to facilitate interpretation of the output files, (2) limit the output files to only the classes of interest, and (3) reclassify classes to background.

NOTE, if the class properties file is provided, the class names will be written to the output files. Otherwise, the class IDs (numeric patch type codes) will be written to the output files. In addition, if the class properties file is not provided, by default all classes in the input landscape will have class-level metrics computed and output to the class output file--assuming that class metrics are selected. In addition, if you do not specify a class properties file, then all cells that you wish to treat as background must have the background value specified in the Run Parameters dialog box, because there is no way to reclassify classes as background in FRAGSTATS without a class properties file.

• Output Statistics.–Select the levels of metrics you want computed:

(1) Patch Metrics.–If selected, patch metrics can be computed. However, individual patch metrics must be selected in the Patch Metrics dialog box (see Step 3), otherwise no patch metrics will be calculated.

(2) Class Metrics.–If selected, class metrics can be computed. However, individual class metrics must be selected in the Class Metrics dialog box (see Step 3), otherwise no class metrics will be calculated.

(3) Landscape Metrics.–If selected, landscape metrics can be computed. However, individual landscape metrics must be selected in the Landscape Metrics dialog box (see Step 3), otherwise no landscape metrics will be calculated.


Step 3. Selecting and Parameterizing Patch, Class, and Landscape Metrics

The next step is to select and parameterize the patch, class, and landscape metrics. Note, these options are available only if you select the respective output statistics in the Run Parameters dialog box. By the selecting the select patch metrics option in the Fragstats drop-down menu, the Patch Metrics dialog box will display (Fig. 5). Similarly, by selecting the select class metrics or select landscape metrics options, the corresponding dialog boxes will display. Each dialog box consists of a series of tabbed pages. Each tabbed page represents a group of related metrics. The organization of these metric groups is discussed in the Background Material documentation.

Figure 5. Patch metrics dialog box depicting the Area/Perimeter metrics tab. Each tab corresponds to a different suite of metrics.

The selection of metrics is relatively straightforward. On each tabbed page select the desired individual metrics using the check boxes, or select all of the metrics using the Select All button. If you select all the metrics, the button function will change to a Clear All function. Clicking on the button now will deselect all metrics. Each metric is discussed in detail in the FRAGSTATS Metrics documentation.

A number of metrics require you to provide additional parameters before they can be calculated. In some cases this involves simply selecting among the alternatives provided (e.g., by clicking on a radio button), in other cases this involves entering a number in a text box, and in still other cases, this involves specifying a separate user-supplied filed. These special requirements are described below in association with the corresponding tabbed page.

1. Area/Density/Edge Metrics.–If you select TOTAL EDGE or EDGE DENSITY on the Area/Density/Edge Metrics tab at either the class or landscape level, you must specify how you want to treat boundary and background edges (Fig. 6); specifically, what proportion of the landscape boundary and background class edges to treat as true edge and therefore included in the edge length calculations? Note, if a border is present, then only background edges are affected by this designation, since all other edges along the landscape boundary will be made explicit by the information in the border. If a border is absent, then all boundary and background edges are affected. See the Overview section for a more detailed discussion. There are three options:

(1) None.–Do not count any boundary/background as edge.

(2) All.–Count all boundary/background as edge.

(3) Partial.–Specify the proportion of boundary/background edge to treat as an edge (weight = fraction between 0 and 1). For example, if you specify .5, then half the total length of edge of involving the landscape boundary (if a border is absent) and any internal background will be included as edge in the affected metrics.

Figure 6. Class metrics dialog box with the Area/Density/Edge tab showing. The radio buttons associated with background/boundary are active it either Total Edge or Edge Density are checked.

2. Core Area Metrics.–If you select any core area metric at the patch, class, or landscape level, you must specify the depth-of-edge to use in determining what constitutes the core of a patch. There are two options:

(1) Enter constant edge depth.–If you wish to treat all edges the same, then check the corresponding check box and enter a non-zero distance (in meters). By default this box contains a zero, but you must enter a non-zero distance before closing the dialog box or you will receive an error message in the log window. Note, a zero depth-of-edge would result in the core area being equal to patch area, and thus would be redundant.

(2) Edge depth file.–Alternatively, you can specify a comma-delimited ASCII file that provides unique edge depths for each edge type (i.e., each pairwise combination of patch types). Simply click on the Edge Depth File button and navigate to the appropriate file. The file must be given in the form of a square two-way matrix, where each row represents a focal class and each column represents an adjacent or abutting class, and the cell values are the edge depths in meters. The format for this file is as follows:

FTABLE, 1stClassID, 2ndClassID, etc.

1stClassID, EdgeDepth_1-1, EdgeDepth_1-2, etc.

2ndClassID, EdgeDepth_2-1, EdgeDepth_2-2, etc.

etc.

• FTABLE must be specified in the first cell.

• 1stClassID is an integer value corresponding to a class value.

• 2ndClassID is an integer value corresponding to a class value.

• EdgeDepth_i-j is an integer value giving the depth-of-edge (in meters) for the corresponding edge type (i.e., for the focal class designated by the row ClassID and the adjacent class designated by the column ClassID). Note, it is advisable to provide edge depths in increments equal to the cell size, because FRAGSTATS will always round up or down to the nearest cell when applying the edge mask (see Overview discussion for details).

The edge depth file must be a square matrix (i.e., same number of rows and columns), must have the same list and order of ClassIDs as row headers and column headers, should contain a record for each unique pairwise combination of patch types (classes) in the input landscape (any missing class must be missing in both the rows and columns and will be assigned a zero edge depth for all edges involving that class), and all arguments should be separated by a comma. For example, given four classes the following file would be suitable:

FTABLE,1,2,3,4

1,0,30,70,40

2,30,0,40,40

3,30,40,0,50

4,30,40,50,0

NOTE, this table can be created and managed using any spreadsheet program (e.g., Excel) and then simply saved as a comma delimited file (.csv).

NOTE, this matrix can be asymmetrical; that is, upper right and lower left halves do not need to mirror each other. Accordingly, it is important to realize that the rows represent the focal class and the columns represent the adjacent or abutting class. Let’s consider the edge depths for focal class 1 in the example above, given in the second row of the table. The edge depths represent the depth-of-edge effect for patches of class 1 abutting patches of the classes given by the columns. Thus, the class 1 (row)–class 3 (column) edge type has an edge effect of 70 m; that is, the edge effect penetrates 70 m into class 1. Conversely, focal class 3 (row) adjacent to class 1 (column) has an edge effect of 30 m. Thus, the edge effect penetrates less into class 3 than into class 1. This asymmetry may be important in many applications; for example, when urban edge effects penetrate deeply into forest, but forest edge effects penetrate very little, if at all, into urban areas.

NOTE, the diagonals are typically given a zero edge depth, but it is possible to specify a nonzero diagonal. However, the only situation in which a patch can abut a patch of the same class is along the landscape boundary when a landscape border is present (see discussion on Background, Boundaries, and Borders). In this case, it is possible to specify a nonzero edge depth, although in most cases it would not be logical to do so.

NOTE, if you have background in the image, you need to include the background class value specified in the Run Parameters dialog box in the list of classes specified in the edge depth file, otherwise all background edges will be given a zero edge depth.

• Isolation/Proximity Metrics.--If you select either the PROXIMITY INDEX or SIMILARITY INDEX at the patch, class, or landscape level, you must specify the search radius (i.e., the distance [in meters] from a focal patch within which neighboring patches are evaluated). By default the search radius is zero, but you must enter a non-zero distance before closing the dialog box or you will receive an error message in the log window. In addition, if you select the similarity index at any level, you must specify a comma-delimited ASCII file that provides unique similarity weights for each pairwise combination of patch types. Simply click on the Similarity Weight File button to navigate to the appropriate file. Each record in the file should contain a numeric patch type value for each of the two classes and a similarity wieght. The syntax for this file is as follows:

FTABLE, 1stClassID, 2ndClassID, etc.

1stClassID, SimilarWeight_1-1, SimilarWeight_1-2, etc.

2ndClassID, SimilarWeight_2-1, SimilarWeight_2-2, etc.

etc.

• FTABLE must be specified in the first cell.

• 1stClassID is an integer value corresponding to a class value.

• 2ndClassID is an integer value corresponding to a class value.

• SimilarWeight_i-j is a fraction that must range between 0 (no similarity) and 1 (maximum similarity) that gives the similarity weight for the corresponding classes (i.e., for the focal class designated by the row ClassID and the adjacent class designated by the column ClassID).

The similarity weight file must be a square matrix (i.e., same number of rows and columns), must have the same list and order of ClassIDs as row headers and column headers, should contain a record for each unique pairwise combination of patch types (classes) in the input landscape (any missing class must be missing in both the rows and columns and will be assigned a zero similarity weight for combinations involving that class), and all arguments should be separated by a comma. For example, given four classes the following file would be suitable:

FTABLE,1,2,3,4

1,1,0.8,0,0.4

2,0,1,0.6,0.4

3,0.1,0.2,1,0.5

4,0.3,0.4,0.5,1

NOTE, this table can be created and managed using any spreadsheet program (e.g., Excel) and then simply saved as a comma delimited file (.csv).

NOTE, this matrix can be asymmetrical; that is, upper right and lower left halves do not need to mirror each other. Accordingly, it is important to realize that the rows represent the focal class and the columns represent other class combinations. Let’s consider the similarity weights for focal class 1 in the example above, given in the second row of the table. The similarity weights represent the degree of similarity between a patch of the focal class and a patch of another class. Thus, a patch of focal class 1 (row) has maximum similarity to a patch of the same class (weight = 1) and a similarity of 0.8 to a patch of class 2, but zero similarity to a patch of class 3. Conversely, a patch of focal class 3 (row) has a similarity of 0.1 to a patch of class 1. In most cases, however, it is more logical to think of similarity in terms of symmetrical weights.

NOTE, the diagonals are typically given a weight of one, because the similarity of two patches of the same class is generally assumed to be the maximum, but it is possible to specify a different value.

NOTE, if you have background in the image, you need to include the background class value specified in the Run Parameters dialog box in the list of classes specified in the similarity weight file, otherwise all background edges will be given a zero weight.

• Contrast Metrics.--If you select any contrast metric at the patch, class, or landscape level, you must specify a comma-delimited ASCII file that provides edge contrast weights for each pairwise combination of patch types. Simply click on the Edge Weight File button to navigate to the appropriate file. Each record in the file should contain a numeric patch type value for each of the two classes and an edge contrast weight. The syntax for this file is as follows:

FTABLE, 1stClassID, 2ndClassID, etc.

1stClassID, ContrastWeight_1-1, ContrastWeight_1-2, etc.

2ndClassID, ContrastWeight_2-1, ContrastWeight_2-2, etc.

etc.

• FTABLE must be specified in the first cell.

• 1stClassID is an integer value corresponding to a class value.

• 2ndClassID is an integer value corresponding to a class value.

• ContrastWeight is a fraction that must range between 0 (no contrast) and 1 (maximum contrast) that gives the edge contrast weight for the corresponding classes (i.e., for the focal class designated by the row ClassID and the adjacent class designated by the column ClassID).

The edge contrast weight file must be a square matrix (i.e., same number of rows and columns), must have the same list and order of ClassIDs as row headers and column headers, should contain a record for each unique pairwise combination of patch types (classes) in the input landscape (any missing class must be missing in both the rows and columns and will be assigned a zero edge contrast weight for combinations involving that class), and all arguments should be separated by a comma. For example, given four classes the following file would be suitable:

FTABLE,1,2,3,4

1,0,0.8,0.6,0.4

2,0.8,0,0.7,0.3

3,0.6,0.7,0,0.5

4,0.4,0.3,0.5,0

NOTE, this table can be created and managed using any spreadsheet program (e.g., Excel) and then simply saved as a comma delimited file (.csv).

NOTE, this matrix can be asymmetrical; that is, upper right and lower left halves do not need to mirror each other, although in most cases it is more logical to think of edge contrast as being symmetrical. Accordingly, it is important to realize that the rows represent the focal class and the columns represent adjacent or abutting classes. Let’s consider the edge contrast weights for focal class 1 in the example above, given in the second row of the table. A patch of focal class 1 (row) adjacent to a patch of class 2 (column) has a contrast weight of 0.8; that is, it is 80% of the maximum contrast (1). Likewise, an edge between focal class 1 (row) and adjacent class 3 (column) has a contrast weight of 0.6 (i.e., 60% of maximum).

NOTE, the diagonals are typically given a zero edge contrast weight, but it is possible to specify a nonzero diagonal. However, the only situation in which a patch can abut a patch of the same class is along the landscape boundary when a landscape border is present (see discussion on Background, Boundaries, and Borders). In this case, it is possible to specify a nonzero edge contrast weight, although in most cases it would not be logical to do so.

NOTE, if you have background in the image, you need to include the background class value specified in the Run Parameters dialog box in the list of classes specified in the edge contrast weight file, otherwise all background edges will be given a zero weight.


Step 4. Working with Batch Files (optional)

If you wish to analyze a single landscape, then simply select Landscape mode as the Input File Type in the Run Parameters dialog box (see Step 2) and skip this step. However, if you have many landscapes to analyze, you may want to run FRAGSTATS in batch mode by selecting Batch mode as the Input File Type option in the Run Parameters dialog box (Step 2). If you select Batch mode, you must also specify a properly formatted batch file by clicking on the Batch File Name button and navigating to the appropriate file. Note, FRAGSTATS uses the file extension .fbt for batch files and will look for files with this extension by default when navigating. The .fbt extension is not mandatory, but using it can help keep files organized. The batch file must be a comma-delimited ASCII file. Each line should specify the input landscape file name, cell size, background value, number of rows, number of columns, and input data type, in that order. The syntax for this file is as follows:

InputFileName, CellSize, Background, Rows, Columns, InputDataType

□ InputFileName is the full path and file name of the input landscape.

□ CellSize is an integer value corresponding to the cell size (in meters).

□ Background is an integer value corresponding to the designated background value. Note, any class designated as background in the Class Properties dialog box (see Step 5 on Modifying Class Properties) will be reclassified to this class value.

□ Rows is an integer value corresponding to the number of rows in the input image.

□ Columns is an integer value corresponding to the number of columns in the input image.

□ InputDataType is a character string identifying the input data format, with the following options corresponding to the various input data format types:

■ IDF_ARCGRID

■ IDF_ASCII

■ IDF_8BIT

■ IDF_16BIT

■ IDF_32BIT

■ IDF_ERDAS

■ IDF_IDRISI

The batch file should contain a record for each input landscape, and all arguments should be separated by a comma. The parameter values should reflect the Input Data Type for each input landscape. In other words, if the Input Data Type is ASCII or BINARY, then the record must contain all of the parameters specified above. However, if the Input Data Type is ARCGRID, ERDAS, or IDRISI, then the record need only contain the input landscape file name and the background value; the remaining parameters should be assigned “x”, as illustrated in the following example:

D:\Foo\Bar\ASCIIfilename,25,999,250,300,IDF_ASCII

D:\Foo\Bar\8BITfilename2,25,999,250,300,IDF_8BIT

D:\Foo\Bar\16BITfilename2,25,999,250,300,IDF_16BIT

D:\Foo\Bar\32BITfilename2,25,999,250,300,IDF_32BIT

D:\Foo\Bar\ARCGRIDfilename,x,999,x,x,IDF_ARCGRID

D:\Foo\Bar\ERDASfilename,x,999,x,x,IDF_ERDAS

D:\Foo\Bar\IDRISIfilename,x,999,x,x,IDF_IDRISI

etc.

NOTE, since Arc Grid files are actually folders containing multiple files, not single image files, the file naming convention is a bit different. In this case, the input file name should be given as the path to the Arc Grid folder. In addition, regardless of input data type, the cell size, background value, rows and columns can be different for each input landscape.

NOTE, running from a batch file does not eliminate the necessity of completing the parameterization of FRAGSTATS; it only provides a mechanism for running FRAGSTATS on more than one landscape without having to parameterize and run each landscape separately. Specifically, you still must set the remaining run parameters (Step 2) and select and parameterize the individual metrics (Step 3). The batch file only specifies the file name, input data type, and grid attributes for each input landscape; all other run parameters must be specified according to the directions in Steps 2 and 3.

Using the Batch File Editor

FRAGSTATS includes a Batch File Editor that allows you to build and edit batch files via a dialog box (Fig. 7) accessible via the Tools menu in the opening window:

Figure 7. Batch file editor dialog box.

• Using the Batch File Editor to Create a Batch File.–Although in most cases it will be more efficient to create a batch file using a text editor (because you can copy and paste lines easily), you can build one using the Batch File Editor by following these steps:

1. Add a Record.--When you first open the Batch File Editor, the main text window (Fig. 7) will be empty. You must first add a record to the empty batch file by selecting the Add Record option from the Edit drop-down menu or by simply clicking on the “+” button to the right of the main text window. When you do so, the text window will display “(invalid entry)” because the rest of the required information has not been entered yet.

2. Select File Type.–Next, select the appropriate input data type from the list of options available by pressing the down arrow button under File Type. For example, if the first input landscape is an Arc Grid, then select the Arc Grid file type.

3. Select Input File.–Next, select an input file by typing in the full path and file name or clicking on the navigation button to navigate to the file. Note, by selecting the File Type first (step 2 above), the navigation will be restricted by default to only files of the specified type.

4. Enter Relevant Grid Attributes.–Next, enter the relevant grid attributes given the selected file type. If the File Type is ArcGRID, ERDAS, or IDRISI, then you only need to enter a background value. If the File Type is ASCII or BINARY, then you need to enter the cell size, background value, and number of rows and columns.

5. Apply the Specified Parameters.–Click on the Apply button to the right of the main text window to apply the specified parameters. The record in the text window should change to reflect the specified parameters. Note, if you enter inappropriate values in the text window, the record will be marked as “(invalid entry)” and you will need to make the necessary changes.

6. Repeat the Process for each Input Landscape.–Repeat steps 1-5 for each input landscape that you want to include in the batch file. Note, you can specify different input file types and grid attributes for each record.

7. Save and Close Batch File.–When you are finished adding records to the batch file, and you are certain that all entries are valid, then you can save the batch file. You can save this file and remain in the Batch File Editor via the File-Save or File-Save As options, or you can save this file and close the Editor in several ways: (1) by clicking on the Close button to the right of the main text window, (2) by clicking on the “X” in upper right corner of the Editor window, or (3) by selecting the File-Close option. In all cases, you will be prompted to enter a file name if it is a new batch file, or you will be queried to save the changes if the file name already exists.

• Using the Batch File Editor to Edit Batch Files.–In some cases you may need to edit an existing batch file. You can use the Batch File Editor to edit an existing file by following these steps:

1. Open Existing Batch File.–Open an existing batch file using the File-Open menu item. Note, you can edit a newly created batch file using these same procedures. The main text window (Fig. 7) should display the contents of the batch file. Any invalid records will be labeled as such.

2. Modify the Arguments of Existing Records.–You can modify the arguments associated with each record by changing the relevant parameter and applying the changes. For example, if the selected record does not contain a valid file type argument, select the appropriate file type from the available options by clicking on the down arrow button under File Type, and then click on the Apply button located to the right of the main text window. The file type argument should get updated in the selected record. Any or all of the arguments can be changed before applying the changes.

3. Add and Delete Records.–You can easily add and delete records from the batch file. To add a record simply follow Steps 1-5 described above under ‘Using the Batch File Editor to Create a Batch File’. To delete a record, simply select the record and delete it via the Edit-Delete menu option or by depressing the “-” button located to the right of the main text window.

4. Promote and Demote Records.–You can change the order of records by promoting or demoting their position in the batch file. Simply select the record by clicking on the record in the main text window and then use the Edit-Promote/Demote menu options or depress the up or down arrows located to the right of the main text window.

5. Save and Close Batch File.–When you are finished editing the batch file, and you are certain that all entries are valid, you can save the file as before via the File-Save or File-Save As options. Alternatively, you can save this file and close the Editor in several ways: (1) by clicking on the Close button to the right of the main text window, (2) by clicking on the “X” in upper right corner of the Editor window, or (3) by selecting the File-Close option. In all cases, you will be prompted as to whether to save the changes to the existing file.


Step 5. Modifying Class Properties (optional)

FRAGSTATS includes a Class Properties Editor that allows you to edit the class properties file described under Step 2 and modify the way in which each class is handled in the analysis. Specifically, the Class Properties Editor allows you to change the class name (or character description) and class ID (numerical value) of each class, and designate whether each class should be included in the class output files and/or reclassified as background. The Class Properties Editor is accessed via the Tools menu in the opening window (Fig. 8).

Figure 8. Class properties dialog box.

Note, the Class Properties Editor does not allow you to create a class properties file. Currently, this must be done outside of FRAGSTATS (using any text editor) according to the specifications given previously in Step 2. Here, you can quickly edit the existing file to make temporary changes for the current analysis. The changes remain in effect for the duration of the current FRAGSTATS session, or until you clear the current parameterization scheme or load a new class properties file. This prevents you from having to modify and save a class properties file for every analysis scenario. Note, you cannot edit a class properties file until you have specified one in the Run Parameters dialog box (Step 2).

• Modifying the Class Name.–You can change a class name (i.e., the character description reported in the patch- and class-level output files) by selecting the desired class (by clicking on the class name in the main text window) and then typing in the new name in the character box next to Name. Note, you cannot use identical class names for different class ID values. Therefore, if you type in a name that already exists, the change will not take effect. In addition, FRAGSTATS automatically sorts class names alphabetically, so the new name may cause the class to shift positions in the list of classes given in the main text window.

• Modifying the Class ID.–Similarly, you can change a class ID (i.e., integer value associated with a given class name) by selecting the desired class (by clicking on the class name in the main text window), and then typing in the new class ID in the corresponding character box. Note, you cannot use identical class ID’s for different class names. Therefore, if you type in a class ID that already exists, the change will not take effect.

• Enabling/Disabling Classes.–You can change the enable/disable status of a class by checking or unchecking the Enabled check box. Enabling a class means that it will be analyzed and output in the patch- and class-level output files. Note, this will have no effect if Patch Metrics or Class metrics are not selected in the Run Parameters dialog box. Disabling a class means that the corresponding patch- and class-level metrics will not be output, but it will have no effect on the landscape metrics.

• Designating Background Classes.–You can reclassify a class to background (i.e., reclassify it to the background value given in the Run Parameters dialog box) by checking the IsBackground check box. Note, you must first specify a background value in the Run Parameters dialog box before you can affect these changes. Designating a class as background will automatically disable it from the output. Moreover, it will have an effect on many metrics (see Overview Section). Note, if a class ID value is the same as the background class value specified in the Run Parameters dialog box, both the Enable and IsBackground check boxes will be inactive. To reactivate these, you must specify a different background value in the Run Parameters dialog box. In addition, designating a class as background in the class properties file can have unintended affects on core area and edge contrast metrics if the full implications are not understood. As noted above, designating a class as background in the class properties editor will result in the reclassification of the corresponding cells to the background value given in the Run Parameters dialog box. To affect changes in how these edges are treated in core area and contrast metrics, you must include the specified background class value in the edge depth and edge contrast weight files, otherwise these edges will be given the default edge depth and contrast weight of zero–possibly an unintended effect.

• Saving the Class Properties File.–You can save the changes to the class properties file by clicking on the Save As button. This will permanently save the changes made to the file.


Step 6. Executing FRAGSTATS

Now you are finally ready to execute FRAGSTATS. By selecting the Execute option in the Fragstats drop-down menu on the opening window, or clicking on the Execute button on the Tool bar, the program is off and running. An “execution finished” message appears when the processing is complete. Note, a progress indicator on the Status bar displays the progress of the run. For a single landscape Input File Type, a green progress bar is displayed. For a batch Input File Type, a message is displayed that indicates the record number (i.e., input landscape) being processed.


Step 7. Browsing and Saving the Results

The final step is to browse the output and, if desired, save it to a file (actually several files). The Browse dialog box allows you to quickly view and evaluate the results of an analysis before actually saving it to a file(s). This can save you the time of opening the results in a separate text editor or importing the data to a spreadsheet before “seeing”’ the output. Note, you can automatically save results to output files by checking the automatically save results check box in the Run Parameters dialog box and entering a “basename” for the output files. The Browse tool (Fig. 9) is accessed via the Tools menu in the opening window.

Figure 9. Browse dialog box.

The Browse dialog box consists of three main parts: (1) run list, (2) tabbed window displaying patch, class, and landscape metrics, and (3) options for deleting and saving results.

1. Run list.–The Run list window lists the FRAGSTATS runs completed using the currently open parameterization file. Each time you execute FRAGSTATS (step 6), the results are associated with a run number. The first time you execute after parameterizing FRAGSTATS (steps 2-5), the results will be associated with Run 1. The next time you execute, e.g., after modifying one or more run parameters (step 2) or selecting a different suite of metrics (step 3), the results will be associated with Run 2. And so on for every subsequent run. To view the results of a particular run, simply click on the run number in the run list and the results displayed in the metrics display window will change accordingly. If you open a new parameterization file (File-New) or open a different parameterization file (File-Open), the Browse dialog box will be cleared of all runs and the associated data.

2. Metrics Display Window.–The metrics display window contains three tabs for displaying the three levels of metrics: patch, class, and landscape. Click on the corresponding tab to change the level displayed. Note, the tabs will only contain data if the corresponding metrics were selected for the analysis.

3. Deleting and Saving Results.–The results of a run can be cleared from the display or saved to file. The following options are available:

(1) Save Run As.–Saves the associated output files to a location and “basename” of your choice. Note, the “basename” will be combined with the .patch, .class, and .land extensions for the corresponding output files, as well as the .adj extension for the adjacency matrix if the save ADJ file box is checked. If you had entered an output file name in the Run Parameters dialog box (step 2), then it will be used as the default basename here; although you can change it here if desired. If you attempt to save to a file name that already exists, you will be prompted as to whether you want to overwrite this file or not. Note, saving to a file of the same name will not append results to the existing file (as in FRAGSTATS 2), because there is no guarantee that the output file structure will be the same. If you wish to append the results of several runs with identical output formats, then you should build a batch file and run in Batch mode. The results from a batch file will be output to a single file because the structure is guaranteed to be the same for every input landscape.

(2) Clear All.–Clears all the runs from the Browse window. Note, once deleted, these runs cannot be recovered.

(3) Clear This.–Clears only the currently selected run (in the run list) from the Browse window. Again, once deleted, this run cannot be recovered.

(4) Close.–Closes the Browse window. Closing the Browse window does not delete the runs or the associated data, it simply closes the window so that you can conduct additional runs. Reopening the Browse window will display these runs again. Note, however, that if you close the Browse window and then open a new parameterization file (File-New) or open a different parameterization file (File-Open), the Browse dialog box will be cleared of all runs and the associated data.


Command Line Execution

FRAGSTATS can now be executed via a command line to allow you to run FRAGSTATS from within another user program. The command line control is limited to specifying a FRAGSTATS parameterization file (.frg). In essence, you can call up FRAGSTATS, specify an existing parameterization file, and execute FRAGSTATS from a single command line. However, the FRAGSTATS parameterization file must be created via the Graphical User Interface in the usual way–there are simply too many parameters to make full specification via the command line a practical alternative. The syntax for this command line call is as follows:

Fragstats ParameterizationFile.frg /c

□ Fragstats argument simply calls and executes the program. The .exe extension is optional (i.e., either Fragstats or Fragstats.exe will work) and it is NOT case sensitive. If the Fragstats executable is NOT in the current folder OR is NOT specified in the system’s Path variable, then the full path to the executable is required, as follows: Drive:\path_to_Fragstats\Fragstats ParameterizationFile.frg /c

□ ParameterizationFile is the name of the FRAGSTATS parameterization file created using the standard FRAGSTATS graphical user interface. This file specifies all required and user-selected parameters of the analysis. It should be parameterized completely according to the instructions given elsewhere for Running FRAGSTATS via the Graphical User Interface . Note, FRAGSTATS parameterization files are assigned the .frg extension and this should be included in the argument.

□ /c is a switch that closes FRAGSTATS after the execution is completed; it is NOT case sensitive. If this argument is omitted, then the FRAGSTATS GUI will remain open after each call until the user executes FRAGSTATS from the GUI and closes the window. Thus, omitting this switch simply opens the FRAGSTATS GUI, but nothing more. Thus, if you are going to call FRAGSTATS many times in a program, I strongly suggest using this switch.

There are several considerations when using the command line:

1. When executed from a command line, FRAGSTATS output will automatically be saved to file. If an output file is not named in the specified parameterization file, FRAGSTATS will use the name of the input image as the basename for the output files, and the extensions .patch, .class, .land, and .adj will be extended to the basename for the corresponding output files. In addition, since the output to file is automatic, it is not necessary to check the Automatically Save Results check box.

2. If the same output file basename is specified in multiple parameterization files, the results of each run will be appended to the same output file. Each run will have a header line, consisting of the metric acronyms in one row, followed by one or more rows containing the metric values associated with each patch, class, or landscape output. Note, if the parameterization files differ with respect to the selection of metrics, then the output formats will vary (i.e., each output will contain a different number and/or set of metrics). In this case, the columns associated with each metric will not necessarily line up across runs. If, on the other hand, the parameterization file is identical with respect to the choice of metrics, then the output formats will be constant and the columns will align properly.

3. If the parameterization file cannot be loaded (because it is not the right format or cannot be found) an error message will pop up and the application will close as soon as the message is acknowledged by the user. Meanwhile the batch file is blocked, although it may continue after the application closes. There is probably no point into continuing the batch file after such a problem; it should be fixed, then the whole batch restarted.

4. Note, there may be some confusion over when to use the Batch file option associated with the standard FRAGSTATS GUI run and the command line version of FRAGSTATS. The Batch file option is used when you want to run the same parameterization file on many different input images and save the results to a single file, or files depending on which level of metrics are selected in the parameterization file. The command line version is useful in at least two situations–there may be others. First, you may want to run many different parameterization files on the same input image or on many different input images. The command line allows you to specify a unique parameterization file for each run, unlike the Batch file option which uses a single common parameterization file for each run. Second, you may want to iteratively analyze and process an input image, modifying the image after each run based on the results. For example, you could input a landscape, run FRAGSTATS, modify the landscape by, say, reclassifying all cells belonging to patches meeting certain criteria based on certain patch metrics, and then run FRAGSTATS again on the modified landscape, and then repeat the process many times.


FRAGSTATS METRICS

This document contains a description of each metric computed in FRAGSTATS. Metrics are grouped into patch, class, and landscape metrics and according to the component of pattern they measure. Each metric is given in mathematical terms and described in narrative terms, and the measurement units and theoretical range in values are reported.

INTRODUCTION AND OVERVIEW

Patch Metrics

Class Metrics

Landscape Metrics

General Comments

AREA/DENSITY/EDGE METRICS

SHAPE METRICS

CORE AREA METRICS

ISOLATION/PROXIMITY METRICS

CONTRAST METRICS

CONTAGION/INTERSPERSION METRICS

CONNECTIVITY METRICS

DIVERSITY METRICS

LITERATURE CITED


AREA/DENSITY/EDGE METRICS

Background

FRAGSTATS Metrics

Limitations

Code | Metric (acronym)
Patch Metrics
P4 | Patch Area ( AREA )
P5 | Patch Perimeter ( PERIM )
P6 | Radius of Gyration ( GYRATE )
Class Metrics
C3 | Total (Class) Area ( CA )
C4 | Percentage of Landscape ( PLAND )
C5 | Number of Patches ( NP )
C6 | Patch Density ( PD )
C7 | Total Edge ( TE )
C8 | Edge Density ( ED )
C9 | Landscape Shape Index ( LSI )
C124 | Normalized Landscape Shape Index ( nLSI )
C10 | Largest Patch Index ( LPI )
C11-C16 | Patch Area Distribution ( AREA_MN , _AM , _MD , _RA , _SD , _CV )
C17-C22 | Radius of Gyration Distribution ( GYRATE_MN , _AM , _MD , _RA , _SD , _CV )
Landscape Metrics
L3 | Total Area ( TA )
L5 | Number of Patches ( NP )
L6 | Patch Density ( PD )
L7 | Total Edge ( TE )
L8 | Edge Density ( ED )
L9 | Landscape Shape Index ( LSI )
L10 | Largest Patch Index ( LPI )
L11-L16 | Patch Area Distribution ( AREA_MN , _AM , _MD , _RA , _SD , _CV )
L17-L22 | Radius of Gyration Distribution ( GYRATE_MN , _AM , _MD , _RA , _SD , _CV )


Background.--This group of metrics represents a loose collection of metrics that deal with the number and size of patches and the amount of edge created by these patches. Although these metrics could easily be subdivided into separate groups or assigned to other already recognized groups, there is enough similarity in the basic patterns assessed by these metrics to include them under one umbrella.

The area of each patch comprising a landscape mosaic is perhaps the single most important and useful piece of information contained in the landscape. Not only is this information the basis for many of the patch, class, and landscape indices, but patch area has a great deal of ecological utility in its own right. For example, there is considerable evidence that bird species richness and the occurrence and abundance of some species are strongly correlated with patch size (e.g., Robbins et al. 1989). Most species have minimum area requirements: the minimum area needed to meet all life history requirements. Some of these species require that their minimum area requirements be fulfilled in contiguous habitat patches; in other words, the individual habitat patch must be larger than the species minimum area requirement for them to occupy the patch. These species are sometimes referred to as “area-sensitive” species. Thus, patch size information alone could be used to model species richness, patch occupancy, and species distribution patterns in a landscape given the appropriate empirical relationships derived from field studies.

Similarly, the size and number of patches comprising a class or the entire landscape mosaic is perhaps the most basic aspect of landscape pattern that can affect myriad processes. For example, although there are myriad effects of habitat fragmentation on individual behavior, habitat use patterns, and intra- and inter-specific interactions, many of these effects are caused by: (1) a reduction in habitat area (area effects), and (2) an increase in the proportion of edge-influenced habitat (edge effects). Briefly, as a species’ habitat is lost from the landscape (without being fragmented), at some point there will be insufficient area of habitat to support a viable population, and with continued loss eventually there will be insufficient area of habitat to support even a single individual and the species will be extirpated from the landscape. This area relationship is expected to vary among species depending on their minimum area requirements. Moreover, the area threshold for occupancy may occur when total habitat area is still much greater than the individual’s minimum area requirement. For example, an individual may not occupy available habitat unless there are other individuals of the same species occupying the same or nearby patches of habitat, or an individual’s occupancy may be influenced by what other species are occupying the patch. Similarly, as habitat is lost and simultaneously fragmented into smaller and more isolated patches, at some point there will be insufficient area of suitable habitat within a home range size area to support an individual. In either case, the effect of habitat area on the occurrence and abundance of a species (or species) is referred to as the “area effect.” This is the ultimate consequence of habitat loss and fragmentation–insufficient habitat quantity and quality to support individuals and viable populations.

Total amount of edge in a landscape is important to many ecological phenomena. In particular, a great deal of attention has been given to wildlife-edge relationships (Thomas et al. 1978 and 1979, Strelke and Dickson 1980, Morgan and Gates 1982, Logan et al. 1985). In landscape ecological investigations, much of the presumed importance of spatial pattern is related to edge effects. The forest edge effect, for example, results primarily from differences in wind and light intensity and quality reaching a forest patch that alter microclimate and disturbance rates (e.g., Gratkowski 1956, Ranney et al. 1981, Chen and Franklin 1990). These changes, in combination with changes in seed dispersal and herbivory, can influence vegetation composition and structure (Ranney et al. 1981). The proportion of a forest patch that is affected in this manner is dependent, therefore, upon patch shape and orientation, and by adjacent land cover. A large but convoluted patch, for example, could be entirely edge habitat. It is now widely accepted that edge effects must be viewed from an organism-centered perspective because edge effects influence organisms differently; some species have an affinity for edges, some are unaffected, and others are adversely affected.

One of the most dramatic and well-studied consequences of habitat fragmentation is an increase in the proportional abundance of edge-influenced habitat. Early wildlife management efforts were focused on maximizing edge habitat because it was believed that most species favored habitat conditions created by edges and that the juxtaposition of different habitats would increase species diversity (Leopold 1933). Indeed this concept of edge as a positive influence guided land management practices for most of the twentieth century. Recent studies, however, have suggested that changes in microclimate, vegetation, invertebrate populations, predation, brood parasitism, and competition along forest edges (i.e., edge effects) has resulted in the population declines of several vertebrate species dependent upon forest interior conditions (e.g., Strelke and Dickson 1980, Whitcomb et al. 1981, Kroodsma 1982, Brittingham and Temple 1983, Wilcove 1985, Temple 1986, Noss 1988, Yahner and Scott 1988, Robbins et al. 1989). In fact, many of the adverse effects of forest fragmentation on organisms seem to be directly or indirectly related to these so-called edge effects. Forest interior species, therefore, may be sensitive to patch shape because for a given patch size, the more complex the shape, the larger the edge-to-interior ratio. Total class edge in a landscape, therefore, often is the most critical piece of information in the study of fragmentation, and many of the class indices directly or indirectly reflect the amount of class edge. Similarly, the total amount of edge in a landscape is directly related to the degree of spatial heterogeneity in that landscape.


FRAGSTATS Metrics.--FRAGSTATS computes several simple statistics representing area and perimeter (or edge) at the patch, class, and landscape levels. Area metrics quantify landscape composition, not landscape configuration. As noted above, the area (AREA) of each patch comprising a landscape mosaic is perhaps the single most important and useful piece of information contained in the landscape. However, the size of a patch may not be as important as the extensiveness of the patch for some organisms and processes. Radius of gyration (GYRATE) is a measure of patch extent; that is, how far across the landscape a patch extends its reach. All other things equal, the larger the patch, the larger the radius of gyration. Similarly, holding area constant, the more extensive the patch (i.e., elongated and less compact), the greater the radius of gyration. The radius of gyration can be considered a measure of the average distance an organism can move within a patch before encountering the patch boundary from a random starting point. When aggregated at the class or landscape level, radius of gyration provides a measure of landscape connectivity (known as correlation length) that represents the average traversability of the landscape for an organism that is confined to remain within a single patch.

Class area (CA) and percentage of landscape (PLAND) are measures of landscape composition; specifically, how much of the landscape is comprised of a particular patch type. This is an important characteristic in a number of ecological applications. For example, an important by-product of habitat fragmentation is habitat loss. In the study of forest fragmentation, therefore, it is important to know how much of the target patch type (habitat) exists within the landscape. In addition, although many vertebrate species that specialize on a particular habitat have minimum area requirements (e.g., Robbins et al. 1989), not all species require that suitable habitat to be present in a single contiguous patch. For example, northern spotted owls have minimum area requirements for late-seral forest that varies geographically; yet, individual spotted owls use late-seral forest that may be distributed among many patches (Forsman et al. 1984). For this species, late-seral forest area might be a good index of habitat suitability within landscapes the size of spotted owl home ranges (Lehmkuhl and Raphael 1993). In addition to its direct interpretive value, class area (in absolute or relative terms) is used in the computations for many of the class and landscape metrics.

FRAGSTATS computes several simple statistics representing the number or density of patches, the average size or radius of gyration of patches, and the variation in patch size or radius of gyration at the class and landscape levels. These metrics usually are best considered as representing landscape configuration, even though they are not spatially explicit measures. Number of patches (NP) or patch density (PD) of a particular habitat type may affect a variety of ecological processes, depending on the landscape context. For example, the number or density of patches may determine the number of subpopulations in a spatially-dispersed population, or metapopulation, for species exclusively associated with that habitat type. The number of subpopulations could influence the dynamics and persistence of the metapopulation (Gilpin and Hanski 1991). The number or density of patches also can alter the stability of species interactions and opportunities for coexistence in both predator-prey and competitive systems (Kareiva 1990). The number or density of patches in a landscape mosaic (pooled across patch types) can have the same ecological applicability, but more often serves as a general index of spatial heterogeneity of the entire landscape mosaic. A landscape with a greater number or density of patches has a finer grain; that is, the spatial heterogeneity occurs at a finer resolution. Although the number or density of patches in a class or in the landscape may be fundamentally important to a number of ecological processes, often it does not have any interpretive value by itself because it conveys no information about the area or distribution of patches. Number or density of patches is probably most valuable, however, as the basis for computing other, more interpretable, metrics.

In addition to these primary metrics, FRAGSTATS also summarizes the distribution of patch area and extent (radius of gyration) across all patches at the class and landscape levels. For example, the distribution of patch area (AREA) is summarized by its mean and variability. These summary measures provide a way to characterize the distribution of area among patches at the class or landscape level. For example, progressive reduction in the size of habitat fragments is a key component of habitat fragmentation. Thus, a landscape with a smaller mean patch size for the target patch type than another landscape might be considered more fragmented. Similarly, within a single landscape, a patch type with a smaller mean patch size than another patch type might be considered more fragmented. Thus, mean patch size can serve as a habitat fragmentation index, although the limitations discussed below may reduce its utility in this respect.

Mean patch size at the class level is a function of the number of patches in the class and total class area. In contrast, patch density is a function of total landscape area. Therefore, at the class level, these two indices represent slightly different aspects of class structure. For example, two landscapes could have the same number and size distribution of patches for a given class and thus have the same mean patch size; yet, if total landscape area differed, patch density could be very different between landscapes. Alternatively, two landscapes could have the same number of patches and total landscape area and thus have the same patch density; yet, if class area differed, mean patch size could be very different between landscapes. These differences should be kept in mind when selecting class metrics for a particular application. In addition, although mean patch size is derived from the number of patches, it does not convey any information about how many patches are present. A mean patch size of 10 ha could represent 1 or 100 patches and the difference could have profound ecological implications. Furthermore, mean patch size represents the average condition. Variation in patch size may convey more useful information. For example, a mean patch size of 10 ha could represent a class with 5 10-ha patches or a class with 2-, 3-, 5-, 10-, and 30-ha patches, and this difference could be important ecologically. For these reasons, mean patch size is probably best interpreted in conjunction with total class area, patch density (or number of patches), and patch size variability. At the landscape level, mean patch size and patch density are both a function of number of patches and total landscape area. In contrast to the class level, these indices are completely redundant (assuming there is no internal background). Although both indices may be useful for "describing" 1 or more landscapes, they would never be used simultaneously in a statistical analysis of landscape structure.

In many ecological applications, second-order statistics, such as the variation in patch size, may convey more useful information than first-order statistics, such as mean patch size. Variability in patch size measures a key aspect of landscape heterogeneity that is not captured by mean patch size and other first-order statistics. For example, consider 2 landscapes with the same patch density and mean patch size, but with very different levels of variation in patch size. Greater variability indicates less uniformity in pattern either at the class level or landscape level and may reflect differences in underlying processes affecting the landscapes. Variability is a difficult thing to summarize in a single metric. FRAGSTATS computes three of the simplest measures of variability–range, standard deviation, and coefficient of variation.

Patch size standard deviation (AREA_SD) is a measure of absolute variation; it is a function of the mean patch size and the difference in patch size among patches. Thus, although patch size standard deviation conveys information about patch size variability, it is a difficult parameter to interpret without doing so in conjunction with mean patch size because the absolute variation is dependent on mean patch size. For example, two landscapes may have the same patch size standard deviation, e.g., 10 ha; yet one landscape may have a mean patch size of 10 ha, while the other may have a mean patch size of 100 ha. In this case, the interpretations of landscape pattern would be very different, even though absolute variation is the same. Specifically, the former landscape has greatly varying and smaller patch sizes, while the latter has more uniformly-sized and larger patches. For this reason, patch size coefficient of variation (AREA_CV) is generally preferable to standard deviation for comparing variability among landscapes. Patch size coefficient of variation measures relative variability about the mean (i.e., variability as a percentage of the mean), not absolute variability. Thus, it is not necessary to know mean patch size to interpret the coefficient of variation. Nevertheless, patch size coefficient of variation also can be misleading with regards to landscape structure in the absence of information on the number of patches or patch density and other structural characteristics. For example, two landscapes may have the same patch size coefficient of variation, e.g., 100%; yet one landscape may have 100 patches with a mean patch size of 10 ha, while the other may have 10 patches with a mean patch size of 100 ha. In this case, the interpretations of landscape structure could be very different, even though the coefficient of variation is the same. Ultimately, the choice of standard deviation or coefficient of variation will depend on whether absolute or relative variation is more meaningful in a particular application. Because these measures are not wholly redundant, it may be meaningful to interpret both measures in some applications.

It is important to keep in mind that both standard deviation and coefficient of variation assume a normal distribution about the mean. In a real landscape, the distribution of patch sizes may be highly irregular. It may be more informative to inspect the actual distribution itself, rather than relying on summary statistics such as these that make assumptions about the distribution and therefore can be misleading. Also, note that patch size standard deviation and coefficient of variation can equal 0 under 2 different conditions: (1) when there is only 1 patch in the landscape; and (2) when there is more than 1 patch, but they are all the same size. In both cases, there is no variability in patch size, yet the ecological interpretations could be different.

FRAGSTATS computes several statistics representing the amount of perimeter (or edge) at the patch, class, and landscape levels. Edge metrics usually are best considered as representing landscape configuration, even though they are not spatially explicit at all. At the patch level, edge is a function of patch perimeter (PERIM). At the class and landscape levels, edge can be quantified in other ways. Total edge (TE) is an absolute measure of total edge length of a particular patch type (class level) or of all patch types (landscape level). In applications that involve comparing landscapes of varying size, this index may not be useful. Edge density (ED) standardizes edge to a per unit area basis that facilitates comparisons among landscapes of varying size. However, when comparing classes or landscapes of identical size, total edge and edge density are completely redundant. Alternatively, the amount of edge present in a class or landscape can be compared to that expected for a maximally compact class or landscape of the same size but with a simple geometric shape (square) and no internal edge, respectively. Landscape shape index (LSI) does this. This index measures the perimeter-to-area ratio for the landscape as a whole. This index is similar to the habitat diversity index proposed by Patton (1975), except that we apply the index at the class level as well. LSI is identical to the shape index at the patch level (SHAPE), except that it is based on class area and the associated class perimeter at the class level and the total landscape area and all edges at the landscape level. The minimum value of LSI is always equal to 1 when either the class is maximally compact (at the class level) or the landscape consists of a single patch (at the landscape level). However, the maximum value of LSI varies at the class level with class area. Hence, FRAGSTATS also computes a normalized landscape shape index (nLSI) in which the metric is rescaled by the minimum and maximum values.

Note, shape complexity and aggregation or contagion are closely related concepts. Holding area constant, as shape complexity increases (as measured by any of the perimeter-area ratio measures described above) the patch, class, or entire patch mosaic becomes increasingly disaggregated (i.e., less contagious). For this reason, many of the shape metrics described here are closely related, at least in concept, to the Contagion metrics described elsewhere.


Limitations.--Area metrics have limitations imposed by the scale of investigation. Minimum patch size and landscape extent set the lower and upper limits of these area metrics, respectively. These are critical limits to recognize because they establish the lower and upper limits of resolution for the analysis of landscape composition and configuration. Otherwise, area metrics have few limitations. All edge indices are affected by the resolution of the image. Generally, the finer the resolution (i.e., the greater the detail with which edges are delineated), the greater the edge length. At coarse resolutions, edges may appear as relatively straight lines; whereas, at finer resolutions, edges may appear as highly convoluted lines. Thus, values calculated for edge metrics should not be compared among images with different resolutions. In addition, patch perimeter and the length of edges will be biased upward in raster images because of the stair-step patch outline, and this will affect all edge indices. The magnitude of this bias will vary in relation to the grain or resolution of the image, and the consequences of this bias with regards to the use and interpretation of these indices must be weighed relative to the phenomenon under investigation.


(P4) Area
 |  | aij = area (m2) of patch ij.
Description | AREA equals the area (m2) of the patch, divided by 10,000 (to convert to hectares).
Units | Hectares
Range | AREA > 0, without limit. The range in AREA is limited by the grain and extent of the image; in a particular application, AREA may be further limited by the specification of a minimum patch size that is larger than the grain.
Comments | The area of each patch comprising a landscape mosaic is perhaps the single most important and useful piece of information contained in the landscape. Not only is this information the basis for many of the patch, class, and landscape indices, but patch area has a great deal of ecological utility in its own right. Note that the choice of the 4-neighbor or 8-neighbor rule for delineating patches will have an impact on this metric.


(P5) Perimeter
 |  | pij = perimeter (m) of patch ij.
Description | PERIM equals the perimeter (m) of the patch, including any internal holes in the patch, regardless of whether the perimeter represents ‘true’ edge or not (e.g., the case when a patch is artificially bisected by the landscape boundary when a landscape border is present).[pij =intTrue+intBack+extTrue+extBack+extLike]
Units | Meters
Range | PERIM > 0, without limit.
Comments | Patch perimeter is another fundamental piece of information available about a landscape and is the basis for many class and landscape metrics. Specifically, the perimeter of a patch is treated as an edge, and the intensity and distribution of edges constitutes a major aspect of landscape pattern. In addition, the relationship between patch perimeter and patch area is the basis for most shape indices.


(P6) Radius of Gyration
 |  | hijr = distance (m) between cell ijr [located within patch ij] and the centroid of patch ij (the average location), based on cell center-to-cell center distance. z = number of cells in patch ij.
Description | GYRATE equals the mean distance (m) between each cell in the patch and the patch centroid.
Units | Meters
Range | GYRATE ≥ 0, without limit. GYRATE = 0 when the patch consists of a single cell and increases without limit as the patch increases in extent. GYRATE achieves its maximum value when the patch comprises the entire landscape.
Comments | Radius of gyration is a measure of patch extent; thus it is effected by both patch size and patch compaction. Note that the choice of the 4-neighbor or 8-neighbor rule for delineating patches will have an impact on this metric.


(C3) Total (Class) Area
 |  | aij = area (m2) of patch ij.
Description | CA equals the sum of the areas (m2) of all patches of the corresponding patch type, divided by 10,000 (to convert to hectares); that is, total class area.
Units | Hectares
Range | CA > 0, without limit. CA approaches 0 as the patch type becomes increasing rare in the landscape. CA = TA when the entire landscape consists of a single patch type; that is, when the entire image is comprised of a single patch.
Comments | Class area is a measure of landscape composition; specifically, how much of the landscape is comprised of a particular patch type. In addition to its direct interpretive value, class area is used in the computations for many of the class and landscape metrics.


(C4) Percentage of Landscape
 |  | Pi = proportion of the landscape occupied by patch type (class) i. aij = area (m2) of patch ij. A = total landscape area (m2).
Description | PLAND equals the sum of the areas (m2) of all patches of the corresponding patch type, divided by total landscape area (m2), multiplied by 100 (to convert to a percentage); in other words, PLAND equals the percentage the landscape comprised of the corresponding patch type. Note, total landscape area (A) includes any internal background present.
Units | Percent
Range | 0 < PLAND ≤ 100 PLAND approaches 0 when the corresponding patch type (class) becomes increasingly rare in the landscape. PLAND = 100 when the entire landscape consists of a single patch type; that is, when the entire image is comprised of a single patch.
Comments | Percentage of landscape quantifies the proportional abundance of each patch type in the landscape. Like total class area, it is a measure of landscape composition important in many ecological applications. However, because PLAND is a relative measure, it may be a more appropriate measure of landscape composition than class area for comparing among landscapes of varying sizes.


(C5) Number of Patches
 |  | ni = number of patches in the landscape of patch type (class) i.
Description | NP equals the number of patches of the corresponding patch type (class).
Units | None
Range | NP ≥ 1, without limit. NP = 1 when the landscape contains only 1 patch of the corresponding patch type; that is, when the class consists of a single patch.
Comments | Number of patches of a particular patch type is a simple measure of the extent of subdivision or fragmentation of the patch type. Although the number of patches in a class may be fundamentally important to a number of ecological processes, often it has limited interpretive value by itself because it conveys no information about area, distribution, or density of patches. Of course, if total landscape area and class area are held constant, then number of patches conveys the same information as patch density or mean patch size and may be a useful index to interpret. Number of patches is probably most valuable, however, as the basis for computing other, more interpretable, metrics. Note that the choice of the 4-neighbor or 8-neighbor rule for delineating patches will have an impact on this metric.


(C6) Patch Density
 |  | ni = number of patches in the landscape of patch type (class) i. A = total landscape area (m2).
Description | PD equals the number of patches of the corresponding patch type divided by total landscape area (m2), multiplied by 10,000 and 100 (to convert to 100 hectares). Note, total landscape area (A) includes any internal background present.
Units | Number per 100 hectares
Range | PD > 0, constrained by cell size. PD is ultimately constrained by the grain size of the raster image, because the maximum PD is attained when every cell is a separate patch. Therefore, ultimately cell size will determine the maximum number of patches per unit area. However, the maximum density of patches of a single class is attained when every other cell is of that focal class (i.e., in a checker board manner; because adjacent cells of the same class would be in the same patch).
Comments | Patch density is a limited, but fundamental, aspect of landscape pattern. Patch density has the same basic utility as number of patches as an index, except that it expresses number of patches on a per unit area basis that facilitates comparisons among landscapes of varying size. Of course, if total landscape area is held constant, then patch density and number of patches convey the same information. Like number of patches, patch density often has limited interpretive value by itself because it conveys no information about the sizes and spatial distribution of patches. Note that the choice of the 4-neighbor or 8-neighbor rule for delineating patches will have an impact on this metric.


(C7) Total Edge
 |  | eik = total length (m) of edge in landscape involving patch type (class) i; includes landscape boundary and background segments involving patch type i.
Description | TE equals the sum of the lengths (m) of all edge segments involving the corresponding patch type. If a landscape border is present, TE includes landscape boundary segments involving the corresponding patch type and representing ‘true’ edge only (i.e., abutting patches of different classes). If a landscape border is absent, TE includes a user-specified proportion of landscape boundary segments involving the corresponding patch type. Regardless of whether a landscape border is present or not, TE includes a user-specified proportion of internal background edge segments involving the corresponding patch type. [eik = intTrue+(intBack*w)+extTrue+(extBack*w)]
Units | Meters
Range | TE ≥ 0, without limit. TE = 0 when there is no class edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of the corresponding patch type and the user specifies that none of the landscape boundary and background edge be treated as edge.
Comments | Total edge at the class level is an absolute measure of total edge length of a particular patch type. In applications that involve comparing landscapes of varying size, this index may not be as useful as edge density (see below). However, when comparing landscapes of identical size, total edge and edge density are completely redundant.


(C8) Edge Density
 |  | eik = total length (m) of edge in landscape involving patch type (class) i; includes landscape boundary and background segments involving patch type i. A = total landscape area (m2).
Description | ED equals the sum of the lengths (m) of all edge segments involving the corresponding patch type, divided by the total landscape area (m2), multiplied by 10,000 (to convert to hectares). If a landscape border is present, ED includes landscape boundary segments involving the corresponding patch type and representing ‘true’ edge only (i.e., abutting patches of different classes). If a landscape border is absent, ED includes a user-specified proportion of landscape boundary segments involving the corresponding patch type. Regardless of whether a landscape border is present or not, ED includes a user-specified proportion of internal background edge segments involving the corresponding patch type. Note, total landscape area (A) includes any internal background present.[eij = intTrue+(intBack*w)+extTrue+(extBack*w)]
Units | Meters per hectare
Range | ED ≥ 0, without limit. ED = 0 when there is no class edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of the corresponding patch type and the user specifies that none of the landscape boundary and background edge be treated as edge.
Comments | Edge density at the class level has the same utility and limitations as Total Edge (see Total Edge description), except that edge density reports edge length on a per unit area basis that facilitates comparison among landscapes of varying size.


(C9) Landscape Shape Index

ei = total length of edge (or perimeter) of class i in terms of number of cell surfaces; includes all landscape boundary and background edge segments involving class i.

min ei = minimum total length of edge (or perimeter) of class i in terms of number of cell surfaces (see below).

Description

LSI equals the total length of edge (or perimeter) involving the corresponding class, given in number of cell surfaces, divided by the minimum length of class edge (or perimeter) possible for a maximally aggregated class, also given in number of cell surfaces, which is achieved when the class is maximally clumped into a single, compact patch. If ai is the area of class i (in terms of number of cells)[note, this is equivalent to the sum of patch areas across all patches of class i] and n is the side of the largest integer square smaller than ai (denoted [image] ) and m = ai - n2, then the minimum edge or perimeter of class i, min-ei, will take one of the three forms (Milne 1991, Bogaert et al. 2000):

min-ei = 4n, when m = 0, or

min-ei = 4n + 2, when n2 < ai ≤ n(1+n), or

min-ei = 4n + 4, when ai > n(1+n).

Units

None

Range

LSI ≥ 1, without limit.

LSI = 1 when the landscape consists of a single square or maximally compact (i.e., almost square) patch of the corresponding type; LSI increases without limit as the patch type becomes more disaggregated (i.e., the length of edge within the landscape of the corresponding patch type increases).

Comments

Landscape shape index provides a simple measure of class aggregation or clumpiness and, as such, is very similar to the Aggregation index. The differences lie in whether aggregation is measured via class edge (or perimeter) surfaces (as in LSI) or via internal like adjacencies (as in AI). Since these surface counts are inversely related to each other (i.e., holding area constant, as the perimeter count increases, the internal adjacency count must decrease, and vice versa), these metrics largely measure the same thing. Note, previous versions of FRAGSTATS used a slightly different definition of LSI; hence, the results will differ from previous runs.


(C124) Normalized Landscape Shape Index

ei = total length of edge (or perimeter) of class i in terms of number of cell surfaces; includes all landscape boundary and background edge segments involving class i.

min ei = minimum total length of edge (or perimeter) of class i in terms of number of cell surfaces (see below).

max ei = maximum total length of edge (or perimeter) of class i in terms of number of cell surfaces (see below).

Description

nLSI equals the total length of edge (or perimeter) involving the corresponding class, given in number of cell surfaces, minus the minimum length of class edge (or perimeter) possible for a maximally aggregated class, also given in number of cell surfaces, which is achieved when the class is maximally clumped into a single, compact patch, divided by the maximum minus the minimum length of class edge. If ai is the area of class i (in terms of number of cells)[note, this is equivalent to the sum of patch areas across all patches of class i] and n is the side of the largest integer square smaller than ai (denoted [image] ) and m = ai - n2, then the minimum edge or perimeter of class i, min-ei, will take one of the three forms (Milne 1991, Bogaert et al. 2000):

min-ei = 4n, when m = 0, or

min-ei = 4n + 2, when n2 < ai ≤ n(1+n), or

min-ei = 4n + 4, when ai > n(1+n).

If A is the landscape area, including all internal background (in terms of number of cells), B = number of cells on the boundary (perimeter) of the landscape, Z = total length of landscape boundary (perimeter) given in number of cell surfaces, and Pi = proportion of the landscape comprised of the corresponding class, then the maximum edge or perimeter of class i, max-ei, will take one of the three forms:

max-ei = 4ai, when Pi ≤ 0.5, or

max-ei = 3A - 2ai, when A is even; 0.5 < Pi ≤ (0.5A + 0.5B)/A, or

max-ei = 3A - 2ai + 3, when A is odd; 0.5 < Pi ≤ (0.5A + 0.5B)/A, or

max-ei = Z + 4(A - ai), when Pi > (0.5A + 0.5B)/A

Note, the formula for max-ei recognizes the fact that as Pi increases beyond 0.5, the maximum total length of edge is achieved when the cells of the focal class fill in first along the boundary of the landscape. Unfortunately, the formulas given above for Pi > 0.5 are only an approximation for this effect. An analytical solution is not possible given the infinite number of landscape shapes possible. In addition, the formula for min-ei assumes that the maximally aggregated class is a single square or almost square patch. However, if the landscape shape is highly irregular, then as the proportional class area Pi approaches 1, the shape of the landscape will constrain the minimum class edge possible (i.e., the actual min-ei << the theoretical min-ei) and nLSI will biased high (i.e., the class will appear to be relatively less aggregated than it actually is). However, for square or rectangular landscapes, or classes with Pi << 1, there is either no bias or it is trivial.

Units

None

Range

0 ≤ nLSI ≤ 1

nLSI = 0 when the landscape consists of a single square or maximally compact (i.e., almost square) patch of the corresponding type; LSI increases as the patch type becomes increasingly disaggregated and is 1 when the patch type is maximally disaggregated (i.e., a checkerboard when Pi ≤ 0.5). Note, nLSI is undefined and reported as N/A in the output files whenever max-ei = min-ei, which exists when the class consists either of a single cell, comprises all but 1 cell, or comprises the entire landscape, because it is impossible to distinguish between clumped, random and dispersed distributions in these cases.

Comments

Normalized Landscape shape index is the normalized version of the landscape shape index (LSI) and, as such, provides a simple measure of class aggregation or clumpiness. The normalization essentially rescales LSI to the minimum and maximum values possible for any class area. When the patch type is relatively rare (say Pi < 0.1) or relative dominant (say Pi > 0.5), the range between the minimum and maximum total edge (or perimeter) is relatively small; whereas when the patch type is intermediate in abundance (say Pi = 0.5), the range is quite large. nLSI essentially measures the degree of aggregation given this variable range. Note, just as LSI and the Aggregation Index (AI) are closely related, the normalized versions of these metrics are related, in fact perfectly so. For this reason, the normalized version of AI is not computed since it is completely redundant with nLSI. In addition, given the considerations given above regarding the computational method that assumes a square or almost square shape for a maximally compact class and the bias this creates if the landscape is highly irregular and the percentage of the landscape comprised of the focal class is high, it is advisable to avoid using this metric under these conditions of bias. Also, for these reasons, this metric is not available in the Moving Window analysis mode when a circular window shape is selected.


(C10) Largest Patch Index
 |  | aij = area (m2) of patch ij. A = total landscape area (m2).
Description | LPI equals the area (m2) of the largest patch of the corresponding patch type divided by total landscape area (m2), multiplied by 100 (to convert to a percentage); in other words, LPI equals the percentage of the landscape comprised by the largest patch. Note, total landscape area (A) includes any internal background present.
Units | Percent
Range | 0 < LPI ≤ 100 LPI approaches 0 when the largest patch of the corresponding patch type is increasingly small. LPI = 100 when the entire landscape consists of a single patch of the corresponding patch type; that is, when the largest patch comprises 100% of the landscape.
Comments | Largest patch index at the class level quantifies the percentage of total landscape area comprised by the largest patch. As such, it is a simple measure of dominance.


(L3) Total Area
 |  | A = total landscape area (m2).
Description | TA equals the total area (m2) of the landscape, divided by 10,000 (to convert to hectares). Note, total landscape area (A) includes any internal background present.
Units | Hectares
Range | TA > 0, without limit.
Comments | Total area (TA) often does not have a great deal of interpretive value with regards to evaluating landscape pattern, but it is important because it defines the extent of the landscape. Moreover, total landscape area is used in the computations for many of the class and landscape metrics.


(L5) Number of Patches
 |  | N = total number of patches in the landscape.
Description | NP equals the number of patches in the landscape. Note, NP does not include any internal background patches (i.e., within the landscape boundary) or any patches at all in the landscape border, if present.
Units | None
Range | NP ≥ 1, without limit. NP = 1 when the landscape contains only 1 patch.
Comments | Number of patches often has limited interpretive value by itself because it conveys no information about area, distribution, or density of patches. Of course, if total landscape area is held constant, then number of patches conveys the same information as patch density or mean patch size and may be a useful index to interpret. Number of patches is probably most valuable, however, as the basis for computing other, more interpretable, metrics. Note that the choice of the 4-neighbor or 8-neighbor rule for delineating patches will have an impact on this metric.


(L6) Patch Density
 |  | N = total number of patches in the landscape. A = total landscape area (m2).
Description | PD equals the number of patches in the landscape, divided by total landscape area (m2), multiplied by 10,000 and 100 (to convert to 100 hectares). Note, PD does not include background patches or patches in the landscape border, if present. However, total landscape area (A) includes any internal background present.
Units | Number per 100 hectares
Range | PD > 0, constrained by cell size. PD is ultimately constrained by the grain size of the raster image, because the maximum PD is attained when every cell is a separate patch.
Comments | Patch density is a limited, but fundamental, aspect of landscape pattern. Patch density has the same basic utility as number of patches as an index, except that it expresses number of patches on a per unit area basis that facilitates comparisons among landscapes of varying size. Of course, if total landscape area is held constant, then patch density and number of patches convey the same information. Like number of patches, patch density often has limited interpretive value by itself because it conveys no information about the sizes and spatial distribution of patches. Note that the choice of the 4-neighbor or 8-neighbor rule for delineating patches will have an impact on this metric.


(L7) Total Edge
 |  | E = total length (m) of edge in landscape.
Description | TE equals the sum of the lengths (m) of all edge segments in the landscape. If a landscape border is present, TE includes landscape boundary segments representing ‘true’ edge only (i.e., abutting patches of different classes). If a landscape border is absent, TE includes a user-specified proportion of the landscape boundary. Regardless of whether a landscape border is present or not, TE includes a user-specified proportion of internal background edge.[E =intTrue+(intBack*w)+extTrue+(extBack*w)]
Units | Meters
Range | TE ≥ 0, without limit. TE = 0 when there is no edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of a single patch and the user specifies that none of the landscape boundary and background edge be treated as edge.
Comments | Total edge is an absolute measure of total edge length of a particular patch type. In applications that involve comparing landscapes of varying size, this index may not be as useful as edge density (see below). However, when comparing landscapes of identical size, total edge and edge density are completely redundant.


(L8) Edge Density
 |  | E = total length (m) of edge in landscape. A = total landscape area (m2).
Description | ED equals the sum of the lengths (m) of all edge segments in the landscape, divided by the total landscape area (m2), multiplied by 10,000 (to convert to hectares). If a landscape border is present, ED includes landscape boundary segments representing ‘true’ edge only (i.e., abutting patches of different classes). If a landscape border is absent, ED includes a user-specified proportion of the landscape boundary. Regardless of whether a landscape border is present or not, ED includes a user-specified proportion of internal background edge. Note, total landscape area (A) includes any internal background present.[E = intTrue+(intBack*w)+extTrue+(extBack*w)]
Units | Meters per hectare
Range | ED ≥ 0, without limit. ED = 0 when there is no edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of a single patch and the user specifies that none of the landscape boundary and background edge be treated as edge.
Comments | Edge density has the same utility and limitations as Total Edge (see Total Edge description), except that edge density reports edge length on a per unit area basis that facilitates comparison among landscapes of varying size.


(L9) Landscape Shape Index
 |  | E = total length of edge in landscape in terms of number of cell surfaces; includes all landscape boundary and background edge segments. min E = minimum total length of edge in landscape in terms of number of cell surfaces (see below).
Description | LSI equals the total length of edge in the landscape, given in number of cell surfaces, divided by the minimum total length of edge possible, also given in number of cell surfaces, which is achieved when the landscape consists of a single patch. If A is the landscape area, including all internal background (in terms of number of cells), and n is the side of the largest integer square smaller than A (denoted [image] ) and m = A - n2, then the minimum edge or perimeter of the landscape, min-E, will take one of the three forms (Milne 1991, Bogaert et al. 2000): min-E = 4n, when m = 0, or min-E = 4n + 2, when n2 < A ≤ n(1+n), or min-E = 4n + 4, when A > n(1+n).
Units | None
Range | LSI ≥ 1, without limit. LSI = 1 when the landscape consists of a single square (or almost square) patch; LSI increases without limit as landscape shape becomes more irregular and/or as the length of edge within the landscape increases.
Comments | Landscape shape index provides a standardized measure of total edge or edge density that adjusts for the size of the landscape. Because it is standardized, it has a direct interpretation, in contrast to total edge, for example, that is only meaningful relative to the size of the landscape. LSI can also be interpreted as a measure of patch aggregation or disaggregation, similar to the class-level interpretation. Specifically, as LSI increases, the patches become increasingly disaggregated.


(L10) Largest Patch Index
 |  | aij = area (m2) of patch ij. A = total landscape area (m2).
Description | LPI equals the area (m2) of the largest patch in the landscape divided by total landscape area (m2), multiplied by 100 (to convert to a percentage); in other words, LPI equals the percent of the landscape that the largest patch comprises. Note, total landscape area (A) includes any internal background present.
Units | Percent
Range | 0 < LPI ≤ 100 LPI approaches 0 when the largest patch in the landscape is increasingly small. LPI = 100 when the entire landscape consists of a single patch; that is, when the largest patch comprises 100% of the landscape.
Comments | Largest patch index quantifies the percentage of total landscape area comprised by the largest patch. As such, it is a simple measure of dominance.


SHAPE METRICS

Background

FRAGSTATS Metrics

Limitations

Code | Metric (acronym)
Patch Metrics
P7 | Perimeter-Area Ratio ( PARA )
P8 | Shape Index ( SHAPE )
P9 | Fractal Dimension Index ( FRAC )
P10 | Linearity Index ( LINEAR )
P11 | Related Circumscribing Circle ( CIRCLE )
P12 | Contiguity Index ( CONTIG )
Class Metrics
C23 | Perimeter-Area Fractal Dimension ( PAFRAC )
C24-C29 | Perimeter-Area Ratio Distribution ( PARA_MN , _AM , _MD , _RA , _SD , _CV )
C30-C35 | Shape Index Distribution ( SHAPE_MN , _AM , _MD , _RA , _SD , _CV )
C36-C41 | Fractal Index Distribution ( FRAC_MN , _AM , _MD , _RA , _SD , _CV )
C42-C47 | Linearity Index Distribution ( LINEAR_MN , _AM , _MD , _RA , _SD , _CV )
C48-C53 | Related Circumscribing Circle Distribution ( CIRCLE_MN , _AM , _MD , _RA , _SD , _CV )
C54-C59 | Contiguity Index Distribution ( CONTIG_MN , _AM , _MD , _RA , _SD , _CV )
Landscape Metrics
L23 | Perimeter-Area Fractal Dimension ( PAFRAC )
L24-L29 | Perimeter-Area Ratio Distribution ( PARA_MN , _AM , _MD , _RA , _SD , _CV )
L30-L35 | Shape Index Distribution ( SHAPE_MN , _AM , _MD , _RA , _SD , _CV )
L36-L41 | Fractal Index Distribution ( FRAC_MN , _AM , _MD , _RA , _SD , _CV )
L42-L47 | Linearity Index Distribution ( LINEAR_MN , _AM , _MD , _RA , _SD , _CV )
L48-L53 | Related Circumscribing Circle Distribution ( CIRCLE_MN , _AM , _MD , _RA , _SD , _CV )
L54-L59 | Contiguity Index Distribution ( CONTIG_MN , _AM , _MD , _RA , _SD , _CV )


Background.--The interaction of patch shape and size can influence a number of important ecological processes. Patch shape has been shown to influence inter-patch processes such as small mammal migration (Buechner 1989) and woody plant colonization (Hardt and Forman 1989), and may influence animal foraging strategies (Forman and Godron 1986). However, the primary significance of shape in determining the nature of patches in a landscape seems to be related to the ‘edge effect’ (see discussion of edge effects for Area/Density/Edge Metrics).


FRAGSTATS Metrics.--FRAGSTATS computes several metrics that quantify landscape configuration in terms of the complexity of patch shape at the patch, class, and landscape levels. Most of these shape metrics are based on perimeter-area relationships. Perhaps the simplest shape index is a straightforward perimeter-area ratio (PARA). A problem with this metric as a shape index is that it varies with the size of the patch. For example, holding shape constant, an increase in patch size will cause a decrease in the perimeter-area ratio. Patton (1975) proposed a diversity index based on shape for quantifying habitat edge for wildlife species and as a means for comparing alternative habitat improvement efforts (e.g., wildlife clearings). This shape index (SHAPE) measures the complexity of patch shape compared to a standard shape (square or almost square) of the same size, and therefore alleviates the size dependency problem of PARA. This shape index is widely applicable in landscape ecological research (Forman and Godron 1986).

Another other basic type of shape index based on perimeter-area relationships is the fractal dimension index. In landscape ecological research, patch shapes are frequently characterized via the fractal dimension (Krummel et al. 1987, Milne 1988, Turner and Ruscher 1988, Iverson 1989, Ripple et al. 1991). The appeal of fractal analysis is that it can be applied to spatial features over a wide variety of scales. Mandelbrot (1977, 1982) introduced the concept of fractal, a geometric form that exhibits structure at all spatial scales, and proposed a perimeter-area method to calculate the fractal dimension of natural planar shapes. The perimeter-area method quantifies the degree of complexity of the planar shapes. The degree of complexity of a polygon is characterized by the fractal dimension (D), such that the perimeter (P) of a patch is related to the area (A) of the same patch by P ≈ √AD (i.e., log P ≈ ½D log A). For simple Euclidean shapes (e.g., circles and rectangles), P ≈ √A and D = 1 (the dimension of a line). As the polygons become more complex, the perimeter becomes increasingly plane-filling and P ≈ A with D → 2. Although fractal analysis typically has not been used to characterize individual patches in landscape ecological research, we use this relationship to calculate the fractal dimension of each patch separately. Note that the value of the fractal dimension calculated in this manner is dependent upon patch size and/or the units used (Rogers 1993). Thus, varying the cell size of the input image will affect the patch fractal dimension. Therefore, caution should be exercised when using this fractal dimension index as a measure of patch shape complexity.

Fractal analysis usually is applied to the entire landscape mosaic using the perimeter-area relationship A = k P2/D, where k is a constant (Burrough 1986). If sufficient data are available, the slope of the line obtained by regressing log(P) on log(A) is equal to 2/D (Burrough 1986). Note, fractal dimension computed in this manner is equal to 2 divided by the slope; D is not equal to the slope (Krummel et al. 1987) nor is it equal to 2 times the slope (e.g., O'Neill et al. 1988, Gustafson and Parker 1992). We refer to this index as the perimeter-area fractal dimension (PAFRAC) in FRAGSTATS. Because this index employs regression analysis, it is subject to spurious results when sample sizes are small. In landscapes with only a few patches, it is not unusual to get values that greatly exceed the theoretical limits of this index. Thus, this index is probably only useful if sample sizes are large (e.g., n > 20; although PAFRAC is computed in FRAGSTATS if n ≥ 10). If insufficient data are available, an alternative to the regression approach is to calculate the mean patch fractal dimension (FRAC_MN) based on the fractal dimension of each patch, or the area-weighted mean patch fractal dimension (FRAC_AM) at the class and landscape levels by weighting patches according to their size, although these metrics do not have the same interpretation or utility as PAFRAC. In contrast to the fractal dimension of a single patch, which provides an index of shape complexity for that patch, the perimeter-area fractal dimension of a patch mosaic provides an index of patch shape complexity across a wide range of spatial scales (i.e., patch sizes). Specifically, it describes the power relationship between patch area and perimeter, and thus describes how patch perimeter increases per unit increase in patch area. If, for example, small and large patches alike have simple geometric shapes, then PAFRAC will be relatively low, indicating that patch perimeter increases relatively slowly as patch area increases. Conversely, if small and large patches have complex shapes, then PAFRAC will be much higher, indicating that patch perimeter increases more rapidly as patch area increases–reflecting a consistency of complex patch shapes across spatial scales. The fractal dimension of patch shapes, therefore, is suggestive of a common ecological process or anthropogenic influence affecting patches across a wide range of scales, and differences between landscapes can suggest differences in the underlying pattern-generating process (e.g., Krummel 1987).

An alternative method of assessing shape is based is based on the medial axis transformation (MAT) of the patch (Gustafson and Parker 1992). The MAT skeleton is derived from a depth map of the patch, where each pixel value represents the distance (in pixels) to the nearest edge. The MAT skeleton is then produced by removing all pixels from the depth map except local maxima (pixels with no neighbors having greater values). The linearity index (LINEAR) is based on the fact that elongated patches of a given area have MAT skeletons closer to their edges than square patches of the same area. This index reflects linear features of the patch which may not necessarily be the overall elongation of the patch. Dendritic patterns result in higher values of LINEAR due to the elongated appendages of the patch. Inflated values may also result from patches with even small interior openings since these represent edge, and the MAT skeleton will surround the openings, resulting in lower MAT values than if the openings were not present.

Another method of assessing shape is based on ratio of patch area to the area of the smallest circumscribing circle. Related circumscribing circle (CIRCLE) uses smallest circumscribing circle instead of the smallest circumscribing square despite the raster data format because it is much simpler to implement. In contrast to the linearity index, related circumscribing circle provides a measure of overall patch elongation. A highly convoluted but narrow patch can have a high linearity index if the medial axial skeleton is close to the patch edge, but have a low related circumscribing circle index due to the relative compactness of the patch. Conversely, a narrow and elongated patch can have a high linearity index as well as a high related circumscribing circle index. This index may be particularly useful for distinguishing patches that are both linear (narrow) and elongated.

A final method of assessing patch shape is based on the spatial connectedness, or contiguity, of cells within a grid-cell patch to provide an index on patch boundary configuration and thus patch shape (LaGro 1991). Contiguity index (CONTIG) is quantified by convolving a 3x3 pixel template with a binary digital image in which the pixels within the patch of interest are assigned a value of 1 and the background pixels (all other patch types) are given a value of zero. A template value of 2 is assigned to quantify horizontal and vertical pixel relationships within the image and a value of 1 is assigned to quantify diagonal relationships. This combination of integer values weights orthogonally contiguous pixels more heavily than diagonally contiguous pixels, yet keeps computations relatively simple. The center pixel in the template is assigned a value of 1 to ensure that a single-pixel patch in the output image has a value of 1, rather than 0. The value of each pixel in the output image, computed when at the center of the moving template, is a function of the number and location of pixels, of the same class, within the nine cell image neighborhood. Specifically, the contiguity value for a pixel in the output image is the sum of the products, of each template value and the corresponding input image pixel value, within the nine cell neighborhood. Thus, large contiguous patches result in larger contiguity index values.


Limitations.--All shape indices based on perimeter-area relationships have important limitations. First, perimeter lengths are biased upward in raster images because of the stair-stepping pattern of line segments, and the magnitude of this bias varies in relation to the grain or resolution of the image. Thus, the computed perimeter-area ratio will be somewhat higher than it actually is in the real-world. Second, as an index of "shape", the perimeter-to-area ratio method is relatively insensitive to differences in patch morphology. Thus, although patches may possess very different shapes, they may have identical areas and perimeters. For this reason, shape indices based on perimeter-area ratios are not useful as measures of patch morphology; they are best considered as measures of overall shape complexity. Alternative indices of shape that are not based on perimeter-area rations are less troubled by these limitations. But these too, generally do not distinguish patch morphology, but instead emphasize one or more aspects of shape complexity (e.g., elongation).


(P7) Perimeter-Area Ratio
 |  | pij = perimeter (m) of patch ij. aij = area (m2) of patch ij.
Description | PARA equals the ratio of the patch perimeter (m) to area (m2).[pij =intTrue+intBack+extTrue+extBack+extLike]
Units | None
Range | PARA > 0, without limit.
Comments | Perimeter-area ratio is a simple measure of shape complexity, but without standardization to a simple Euclidean shape (e.g., square). A problem with this metric as a shape index is that it varies with the size of the patch. For example, holding shape constant, an increase in patch size will cause a decrease in the perimeter-area ratio.


(P8) Shape Index
 |  | pij = perimeter of patch ij in terms of number of cell surfaces. min pij = minimum perimeter of patch ij in terms of number of cell surfaces (see below).
Description | SHAPE equals patch perimeter (given in number of cell surfaces) divided by the minimum perimeter (given in number of cell surfaces) possible for a maximally compact patch (in a square raster format) of the corresponding patch area. If aij is the area of patch ij (in terms of number of cells) and n is the side of a largest integer square smaller than aij, and m = aij - n2, then the minimum perimeter of patch ij, min-pii will take one of the three forms (Milne 1991, Bogaert et al. 2000): min-pii = 4n, when m = 0, or min-pii = 4n + 2, when n2 < aij ≤ n(1+n), or min-pii = 4n + 4, when aij > n(1+n).
Units | None
Range | SHAPE ≥ 1, without limit. SHAPE = 1 when the patch is maximally compact (i.e., square or almost square) and increases without limit as patch shape becomes more irregular.
Comments | Shape index corrects for the size problem of the perimeter-area ratio index (see previous description) by adjusting for a square (or almost square) standard and, as a result, is the simplest and perhaps most straightforward measure of overall shape complexity. Note, the minimum perimeter for an aggregate of like-valued square pixels (aij) is calculated as above. For large patches, say aij > 100 pixels, the minimum perimeter asymptotically approaches [image] , the perimeter of an exact square of size aij. Previous versions of FRAGSTATS used this large patch approximation in the shape index. Thus, the results will not agree exactly with previous runs, although the differences will be nontrivial only in cases involving very small patches.

.


(P9) Fractal Dimension Index
 |  | pij = perimeter (m) of patch ij. aij = area (m2) of patch ij.
Description | FRAC equals 2 times the logarithm of patch perimeter (m) divided by the logarithm of patch area (m2); the perimeter is adjusted to correct for the raster bias in perimeter.[pij = intTrue+intBack+extTrue+extBack+extLike]
Units | None
Range | 1 ≤ FRAC ≤ 2 A fractal dimension greater than 1 for a 2-dimensional patch indicates a departure from Euclidean geometry (i.e., an increase in shape complexity). FRAC approaches 1 for shapes with very simple perimeters such as squares, and approaches 2 for shapes with highly convoluted, plane-filling perimeters.
Comments | Fractal dimension index is appealing because it reflects shape complexity across a range of spatial scales (patch sizes). Thus, like the shape index (SHAPE), it overcomes one of the major limitations of the straight perimeter-area ratio as a measure of shape complexity.


(P10) Linearity Index
 |  | aij* = area of patch ij in terms of number of cells. b = average cell value of the medial axis transformation (MAT) of a patch. r = 0 if the MAT skeleton contains side-by-side rows; 1 if not.
Description | LINEAR equals the area of the patch (in number of pixels) divided by 2 times the average value of the MAT skeleton minus 0 if the MAT skeleton contains side-by-side rows, 1 if not, quantity squared, minus 1, over the area of the patch (in number of cells).
Units | None
Range | 0 ≤ LINEAR < 1 LINEAR = 0 for square patches and approaches 1 for large patches which are all edge. Dividing by patch area normalizes the index since the maximum possible value of the numerator for a patch equals its area (when b = 1).
Comments | Linearity index (Gustafson and Parker 1992) is based on the medial axis transformation (MAT) of the patch. Note, this index is not influenced by patch size.


(P11) Related Circumscribing Circle
 |  | aij = area (m2) of patch ij. aijs = area (m2) of smallest circumscribing circle around patch ij.
Description | CIRCLE equals 1 minus patch area (m2) divided by the area (m2) of the smallest circumscribing circle. Note, the smallest circumscribing circle is computed mathematically based on the geometry of a true circle, despite the raster data format. In addition, to ensure that the minimum value is always zero, the diameter of the circumscribing circle is computed as the maximum distance between periphery cells based on outer edge-to-outer edge distance, as opposed to cell center-to-cell center distance used in all nearest neighbor calculations.
Units | None
Range | 0 ≤ CIRCLE < 1 CIRCLE = 0 for circular patches and approaches 1 for elongated, linear patches one cell wide. CIRCLE = 0 for one cell patches.
Comments | Related circumscribing circle (CIRCLE) uses the smallest circumscribing circle instead of the smallest circumscribing square despite the raster data format because it is much simpler to implement. In contrast to the linearity index, related circumscribing circle provides a measure of overall patch elongation. A highly convoluted but narrow patch can have a high linearity index if the medial axial skeleton is close to the patch edge, but have a low related circumscribing circle index due to the relative compactness of the patch. Conversely, a narrow and elongated patch can have a high linearity index as well as a high related circumscribing circle index. This index may be particularly useful for distinguishing patches that are both linear (narrow) and elongated.


(P12) Contiguity Index

cijr = contiguity value for pixel r in patch ij.

v = sum of the values in a 3-by-3 cell template (13 in this case).

aij = area of patch ij in terms of number of cells.

Description

CONTIG equals the average contiguity value (see comments) for the cells in a patch (i.e., sum of the cell values divided by the total number of pixels in the patch) minus 1, divided by the sum of the template values (13 in this case) minus 1. Note, 1 is subtracted from both the numerator and denominator to confine the index to a range of 1

Units

None

Range

0 ≤ CONTIG ≤ 1

CONTIG equals 0 for a one-pixel patch and increases to a limit of 1 as patch contiguity, or connectedness, increases.

Comments

Contiguity index assesses the spatial connectedness, or contiguity, of cells within a grid-cell patch to provide an index of patch boundary configuration and thus patch shape (LaGro 1991). CONTIG is quantified by convolving a 3x3 pixel template with a binary digital image in which the pixels within the patch of interest are assigned a value of 1 and the background pixels (all other patch types) are given a value of zero. A template value of 2 is assigned to quantify horizontal and vertical pixel relationships within the image and a value of 1 is assigned to quantify diagonal relationships. This combination of integer values weights orthogonally contiguous pixels more heavily than diagonally contiguous pixels, yet keeps computations relatively simple. The center pixel in the template is assigned a value of 1 to ensure that a single-pixel patch in the output image has a value of 1, rather than 0. The value of each pixel in the output image, computed when at the center of the moving template, is a function of the number and location of pixels, of the same class, within the nine cell image neighborhood. Specifically, the contiguity value for a pixel in the output image is the sum of the products, of each template value and the corresponding input image pixel value, within the nine cell neighborhood. Thus, large contiguous patches result in larger contiguity index values.


(C23) Perimeter-Area Fractal Dimension

aij = area (m2) of patch ij.

pij = perimeter (m) of patch ij.

ni = number of patches in the landscape of patch type (class) i.

Description

PAFRAC equals 2 divided by the slope of regression line obtained by regressing the logarithm of patch area (m2) against the logarithm of patch perimeter (m). That is, 2 divided by the coefficient b1 derived from a least squares regression fit to the following equation: ln(area) = b0 + b1⋅ln(perim). Note, PAFRAC excludes any background patches.[pij =intTrue+intBack+extTrue+extBack+extLike]

Units

None

Range

1 ≤ PAFRAC ≤ 2

A fractal dimension greater than 1 for a 2-dimensional landscape mosaic indicates a departure from a Euclidean geometry (i.e., an increase in patch shape complexity). PAFRAC approaches 1 for shapes with very simple perimeters such as squares, and approaches 2 for shapes with highly convoluted, plane-filling perimeters. PAFRAC employs regression techniques and is subject to small sample problems. Specifically, PAFRAC may greatly exceed the theoretical range in values when the number of patches is small (e.g., <10), and its use should be avoided in such cases. In addition, PAFRAC requires patches to vary in size. Thus, PAFRAC is undefined and reported as "N/A" in the "basename".class file if all patches are the same size or there is < 10 patches. Note, PAFRAC may exceed the theoretical range in some cases, especially when the sample size is near the minimum allowable (10)

Comments

Perimeter-area fractal dimension is appealing because it reflects shape complexity across a range of spatial scales (patch sizes). However, like its patch-level counterpart (FRACT), perimeter-area fractal dimension is only meaningful if the log-log relationship between perimeter and area is linear over the full range of patch sizes. If it is not (and this must be determined separately), then fractal dimension should be computed separately for the range of patch sizes over which it is constant. Note, because this index employs regression analysis, it is subject to spurious results when sample sizes are small. In landscapes with only a few patches, it is not unusual to get values that greatly exceed the theoretical limits of this index. Thus, this index is probably most useful if sample sizes are large (e.g., n ≥ 20), although FRAGSTATS computes the index for moderate sample sizes as well (i.e., n ≥10). In addition, it is important to realize that the perimeter-area fractal dimension computed in FRAGSTATS is based on the regression of log area on log perimeter; that is, ln(area) = b0 + b1⋅ln(perim). It is equally valid to compute fractal dimension by regressing log perimeter on log area; that is, ln(perim) = b0 + b1⋅ln(area), in which case the fractal dimension (D) is equal to 2 times the slope (b1). These two approaches give slightly different answers and it is not clear that one is superior to the other. Both approaches are used in practice, so it behooves you to note the manner by which fractal dimension is computed when comparing among studies.


(L23) Perimeter-Area Fractal Dimension
 |  | aij = area (m2) of patch ij. pij = perimeter (m) of patch ij. N = total number of patches in the landscape.
Description | PAFRAC equals 2 divided by the slope of regression line obtained by regressing the logarithm of patch area (m2) against the logarithm of patch perimeter (m). That is, 2 divided by the coefficient b1 derived from a least squares regression fit to the following equation: ln(area) = b0 + b1⋅ln(perim). Note, PAFRAC excludes any background patches.[pij =intTrue+intBack+extTrue+extBack+extLike]
Units | None
Range | 1 ≤ PAFRAC ≤ 2 A fractal dimension greater than 1 for a 2-dimensional landscape mosaic indicates a departure from a Euclidean geometry (i.e., an increase in patch shape complexity). PAFRAC approaches 1 for shapes with very simple perimeters such as squares, and approaches 2 for shapes with highly convoluted, plane-filling perimeters. PAFRAC employs regression techniques and is subject to small sample problems. Specifically, PAFRAC may exceed the theoretical range in values when the number of patches is small (e.g., <10), and its use should be avoided in such cases. In addition, PAFRAC requires patches to vary in size. Thus, PAFRAC is undefined and reported as "N/A" in the "basename".land file if all patches are the same size or there is < 10 patches. Note, PAFRAC may exceed the theoretical range in some cases, especially when the sample size is near the minimum allowable (10).
Comments | Perimeter-area fractal dimension at the landscape level is identical to the class level (see previous comments), except here all patches in the landscape are included in the regression of patch area against patch perimeter.


CORE AREA METRICS

Background

FRAGSTATS Metics

Limitations

Code | Metric (acronym)
Patch Metrics
P13 | Core Area ( CORE )
P14 | Number of Core Areas ( NCA )
P15 | Core Area Index ( CAI )
P16 | Average Depth Index ( ADEPTH )
P17 | Maximum Depth Index ( MDEPTH )
Class Metrics
C60 | Total Core Area ( TCA )
C61 | Core Area Percentage of Landscape ( CPLAND )
C62 | Number of Disjunct Core Areas ( NDCA )
C63 | Disjunct Core Area Density ( DCAD )
C64-C69 | Core Area Distribution ( CORE_MN , _AM , _MD , _RA , _SD , _CV )
C70-C75 | Disjunct Core Area Distribution ( DCORE_MN , _AM , _MD , _RA , _SD , _CV )
C76-C81 | Core Area Index Distribution ( CAI_MN , _AM , _MD , _RA , _SD , _CV )
Landscape Metrics
L60 | Total Core Area ( TCA )
L62 | Number of Disjunct Core Areas ( NDCA )
L63 | Disjunct Core Area Density ( DCAD )
L64-L69 | Core Area Distribution ( CORE_MN , _AM , _MD , _RA , _SD , _CV )
L70-L75 | Disjunct Core Area Distribution ( DCORE_MN , _AM , _MD , _RA , _SD , _CV )
L76-L81 | Core Area Index Distribution ( CAI_MN , _AM , _MD , _RA , _SD , _CV )


Background.– Core area is defined as the area within a patch beyond some specified depth-of-edge influence (i.e., edge distance) or buffer width. Like patch shape, the primary significance of core area in determining the character and function of patches in a landscape appears to be related to the ‘edge effect.’ As discussed elsewhere (see Area/Density/Edge Metrics), edge effects result from a combination of biotic and abiotic factors that alter environmental conditions along patch edges compared to patch interiors. The nature of the edge effect differs among organisms and ecological processes (Hansen and di Castri 1992). For example, some bird species are adversely affected by predation, competition, brood parasitism, and perhaps other factors along forest edges. Core area has been found to be a much better predictor of habitat quality than patch area for these forest interior specialists (Temple 1986). Unlike patch area, core area is affected by patch shape. Thus, while a patch may be large enough to support a given species, it still may not contain enough suitable core area to support the species. In some cases, it seems likely that edge effects would vary in relation to the type and nature of the edge (e.g., the degree of floristic and structural contrast and orientation). Thus, FRAGSTATS allows the user to specified an edge depth file that contains edge influence distances for every pairwise combination of patch types. In the absence of such information, the user can specify a single edge depth for all edge types.

In raster images, there are different ways to determine core area. FRAGSTATS employs a method involving the use of a variably-sized masked placed on cells on the perimeter of a patch, where the mask size varies depending the specified edge depth associated with the corresponding combination of patch types. Actually, the mask is placed over cells just outside the patch perimeter; referred to here as ‘bounding’ cells. Briefly, a mask is placed over each bounding cell. The mask itself is near circular in shape (as circular as you can get in the raster world) and sized according to the specified edge depth. Note, the resolution of the mask is constrained by cell size; thus, the mask is rounded up or down to the nearest cell given the specified edge depth. For example, given a 30 m cell size and a specified edge depth of 50 m, the mask will be rounded up to 2 cells (60 m) wide in the orthogonal directions. The non-orthogonal directions will be rounded similarly, producing a near circular mask. Cells within the mask are eliminated from the ‘core’ of the patch. After all bounding cells are treated in this manner, the remaining cells not masked constitute the ‘core’ of the patch.


FRAGSTATS Metics.--FRAGSTATS computes several metrics based on core area at the patch, class, and landscape levels. Most of the indices dealing with number or density of patches, size of patches, and variability in patch size have corresponding core area indices computed in the same manner after eliminating the specified edge from all patches. For example, patch area, class area, total landscape area, and the percentage of landscape in each patch type all have counterparts computed after eliminating edge area defined by the specified edge depth; these are core area (CORE) at the patch level, total core area (TCA) at the class and landscape levels, and core area percent of landscape (CPLAND) at the class level. The latter index quantifies the core area in each patch type as a percentage of total landscape area. For organisms strongly associated with patch interiors, this index may provide a better measure of habitat availability than its counterpart, percentage of landscape (PLAND). In contrast to their counterparts, these core area indices integrate into a single measure the affects of patch area, patch shape, and edge effect distance. Therefore, although they quantify landscape composition, they are affected by landscape configuration. For this reason, these metrics at the class level may be useful in the study of habitat loss and fragmentation.

From an organism-centered perspective, a single patch may actually contain several disjunct patches of suitable interior habitat, and it may be more appropriate to consider disjunct core areas as separate patches. For this reason, FRAGSTATS computes the number of core areas (NCORE) in each patch, as well as the number in each class and the landscape as a whole (NDCA). If core area is deemed more important than total area, then these indices may be more applicable than their counterparts, but they are subject to the same limitations as their counterparts (number of patches) because they are not standardized with respect to area. For this reason, number of core areas can be reported on a per unit area basis (disjunct core area density, DCAD) that has the same ecological applicability as its counterpart (patch density), except that all edge area is eliminated from consideration. Conversely, this information can be represented as mean core area (CORE_MN). Like their counterparts, note the difference between core area density and mean core area at the class level. Specifically, core area density is based on total landscape area; whereas, mean core area is based on total core area for the class. In contrast, at the landscape level, they are both based on total landscape area and are therefore completely redundant (at least if the landscape contains no background). Furthermore, mean core area can be defined in 2 ways. First, mean core area can be defined as the mean core area per patch (CORE_MN). Thus, patches with no core area are included in the average, and the total core area in a patch is considered together as 1 observation, regardless of whether the core area is contiguous or divided into 2 or more disjunct areas within the patch. Alternatively, mean core area can be defined as the mean area per disjunct core (DCORE_MN). The distinction between these 2 ways of defining mean core area should be noted.

FRAGSTATS also computes an index that quantifies core area as a percentage of total area. The core area index (CAI) at the patch level quantifies the percentage of the patch that is comprised of core area. Similarly, at the class and landscape levels core area index area-weighted mean (CAI_AM) quantifies core area for the entire class or landscape as a percentage of total class or landscape area, respectively. Note, that this is equivalent to the total core area index reported in FRAGSTATS 2.0. The core area index is basically an edge-to-interior ratio like many of the shape indices (see Shape Metrics), the main difference being that the core area index treats edge as an area of varying width and not as a line (perimeter) around each patch. In addition, the core area index is a relative measure; it does not reflect patch size, class area, or total landscape area; it merely quantifies the percentage of available area, regardless of whether it is 10 ha or 1,000 ha, comprised of core. This index does not confound area and configuration like the previous core area indices; rather, it isolates the configuration effect. For this reason, the core area index is probably best interpreted in conjunction with total area at the corresponding scale. For example, in conjunction with total class area, this index could serve as an effective fragmentation index for a particular class.

An alternative method of assessing core area is based is based on the medial axis transformation (MAT) of the patch (Gustafson and Parker 1992). The MAT skeleton is derived from a depth map of the patch, where each pixel value represents the distance (in pixels) to the nearest edge. The MAT skeleton is then produced by removing all pixels from the depth map except local maxima (pixels with no neighbors having greater values). The resulting MAT skeleton gives the depth to the extreme core of the patch. As such, it provides explicit information on how far the ‘core’ of the patch is from the nearest edge. The average depth index (ADEPTH) and maximum depth index (MDEPTH) provide two different ways to summarize the depth of the MAT skeleton. Like most other core area metrics, indices based on the MAT skeleton integrate the effects of patch area and shape. Holding area constant, more convoluted shapes will tend to have MAT skeletons closer to the perimeter. Similarly, holding shape constant, larger patches will have MAT skeletons farther from the perimeter. However, in contrast to all other core area metrics, metrics based on the MAT skeleton do not depend on user-specified edge depths. Thus, the ecological interpretation of these metrics is done after-the-fact based on the ecological phenomena under consideration; whereas the functional relevance of edge effects is explictly incorporated into the edge depths used in all other core area metrics.


Limitations.--All core area indices are affected by the interaction of patch size, patch shape, and the specified edge depths, except for those based on the MAT skeleton as noted above. In particular, increasing edge depths or shape complexity, or decreasing patch size will decrease core area, and vice versa. On the one hand, this may be desirable as an integrative measure that has explicit functional relevance to the organism or process under consideration. On the other hand, there are potential pitfalls associated with integrative measures like core area. In particular, the confounding of patch area and configuration effects can complicate interpretation. For example, if the core area is small, it indicates that very little core area is available, but it does not discriminate between a small patch (area effect) and a large patch with a complex shape (configuration effect). In addition, core area is meaningful only if the specified depth-of-edge distance is meaningful to the phenomenon under investigation. Unfortunately, in many cases there is no empirical basis for specifying any particular depth-of-edge effect and so it must be chosen somewhat arbitrarily. The usefulness of core area as a metric is directly related to the arbitrariness in the specified edge depths, and this should be clearly understood when using these metrics.

Ultimately, the utility of core area metrics compared to their patch area counterparts depends on the resolution, minimum patch dimensions, and edge influence distance(s) employed. For example, given a landscape with a resolution of 1 m2 and minimum patch dimensions of 100 x 100 m, if an edge influence distance of 1 m is specified, then core area and patch area will be nearly identical and core area will be relatively insensitive to differences in patch size and shape. In this case, core area offers little over its patch area counterpart.


(P13) Core Area
 |  | aijc = core area (m2) of patch ij based on specified edge depths (m).
Description | CORE equals the area (m2) within the patch that is further than the specified depth-of-edge distance from the patch perimeter, divided by 10,000 (to convert to hectares). Edge segments along the landscape boundary are treated like background (as specified in the edge depth file) unless a landscape border is present, in which case the boundary edge types are made explicit by the information in the border.
Units | Hectares
Range | CORE ≥ 0, without limit. CORE = 0 when every location within the patch is within the specified depth-of-edge distance from the patch perimeter. CORE approaches AREA as the specified depth-of-edge distance(s) decreases and as patch shape is simplified.
Comments | Core area represents the area in the patch greater than the specified depth-of-edge distance from the perimeter. Note, that a single depth-of-edge distance can be used for all edges or the user can specify a edge depth file that provides unique distances for each pairwise combination of patch types.


(P14) Number of Core Areas
 |  | nijc = number of disjunct core areas in patch ij based on specified edge depths (m).
Description | NCORE equals the number of disjunct core areas contained within the patch boundary.
Units | None
Range | NCORE ≥ 0, without limit. NCORE = 0 when CORE = 0 (i.e., every location within the patch is within the specified depth-of-edge distance from the patch perimeter). NCORE > 1 when, because of shape, the patch contains disjunct core areas.
Comments | A disjunct core is a spatially contiguous (and therefore distinct) core area (see Core Area description). Depending on the size and shape of the patch and the specified depth-of-edge distance(s), a single patch may actually contain several disjunct core areas. From an organism- or process-centered perspective, it may be more appropriate to consider disjunct core areas as separate patches.


(P15) Core Area Index
 |  | aijc = core area (m2) of patch ij based on specified edge depths (m). aij = area (m2) of patch ij.
Description | CAI equals the patch core area (m2) divided by total patch area (m2), multiplied by 100 (to convert to a percentage); in other words, CAI equals the percentage of a patch that is core area.
Units | Percent
Range | 0 ≤ CAI < 100 CAI = 0 when CORE = 0 (i.e., every location within the patch is within the specified depth-of-edge distance(s) from the patch perimeter); that is, when the patch contains no core area. CAI approaches 100 when the patch, because of size, shape, and edge width, contains mostly core area.
Comments | Core area index is a relative index that quantifies core area as a percentage of patch area (i.e., the percentage of the patch that is comprised of core area).


(P16) Average Depth Index
Description | ADEPTH equals the average value of the MAT skeleton (in number of cells)[ times the cell size (m) minus the cell size (m). The subtraction is necessary to adjust the minimum value to zero for an average MAT of 1 cell.
Units | Meters
Range | ADEPTH > 0, without limit. ADEPTH = 0 for a linear patch one cell wide. Here, every cell in the patch would be on the edge and therefore the patch would have no depth. ADEPTH increases as the patch increases in size and becomes more Euclidean in shape.
Comments | Average depth index (Gustafson and Parker 1992) is based on the medial axis transformation (MAT) of the patch. The average depth index is based on the fact that elongated patches of a given area have MAT skeletons closer to their edges (and therefore a smaller average distance) than square patches of the same area. Here, we compute the index in terms of absolute distance (meters) rather than number of cells, to give the index more direct interpretive value. The average depth index represents the average depth to the core of the patch and is therefore sensitive to both patch size and shape. Holding shape constant, larger patches will have greater average depth to the MAT. Similarly, holding area constant, more compact and Euclidean shapes will have greater average depth to the MAT.


(P17) Maximum Depth Index
Description | MDEPTH equals the maximum value of the MAT skeleton (in number of cells) times the cell size (m) minus the cell size (m). The subtraction is necessary to adjust the minimum value to zero for a maximum MAT of 1 cell.
Units | Meters
Range | MDEPTH > 0, without limit. MDEPTH = 0 for a linear patch one cell wide. Here, every cell in the patch would be on the edge and therefore the patch would have no depth. MDEPTH increases as the patch increases in size and becomes more Euclidean in shape.
Comments | Maximum depth index (Gustafson and Parker 1992) is based on the medial axis transformation (MAT) of the patch. The maximum depth index describes the “fattest” part of the patch, and thereby discriminates among patches on the basis of the deepest portion of the patch despite any appendages. Here, we compute the index in terms of absolute distance (meters) rather than number of cells, to give the index more direct interpretive value. Note, the maximum depth index describes the most compact and widest part of the patch and is therefore sensitive to both patch size and shape. Holding shape constant, larger patches will have greater maximum depth to the MAT. Similarly, holding area constant, more compact and Euclidean shapes will have greater maximum depth to the MAT.


(C60) Total Core Area
 |  | aijc = core area (m2) of patch ij based on specified edge depths (m).
Description | TCA equals the sum of the core areas of each patch (m2) of the corresponding patch type, divided by 10,000 (to convert to hectares).
Units | Hectares
Range | TCA ≥ 0, without limit. TCA = 0 when every location within each patch of the corresponding patch type is within the specified depth-of-edge distance(s) from the patch perimeters. TCA approaches total class area (CA) as the specified depth-of-edge distance(s) decreases and as patch shapes are simplified.
Comments | Total core area is defined the same as core area (CORE) at the patch level (see Core Area), but here core area is aggregated (summed) over all patches of the corresponding patch type.


(C61) Core Area Percentage of Landscape
 |  | aijc = core area (m2) of patch ij based on specified edge depths (m). A = total landscape area (m2).
Description | CPLAND equals the sum of the core areas of each patch (m2) of the corresponding patch type, divided by total landscape area (m2), multiplied by 100 (to convert to a percentage); in other words, CPLAND equals the percentage the landscape comprised of core area of the corresponding patch type. Note, total landscape area (A) includes any internal background present.
Units | Percent
Range | 0 ≤ CPLAND < 100 CPLAND approaches 0 when core area of the corresponding patch type (class) becomes increasingly rare in the landscape, because of increasing smaller patches and/or more convoluted patch shapes. CPLAND approaches 100 when the entire landscape consists of a single patch type (i.e., when the entire image is comprised of a single patch) and the specified depth-of-edge distance(s) approaches zero.
Comments | Core area percentage of landscape is defined the same as core area (CORE) at the patch level (see Core Area), but here core area is aggregated (summed) over all patches of the corresponding patch type and computed as a percentage of the total landscape area, which facilitates comparison among landscape of varying size.


(C62) Number of Disjunct Core Areas
 |  | nijc = number of disjunct core areas in patch ij based on specified edge depths (m).
Description | NDCA equals the sum of the number of disjunct core areas contained within each patch of the corresponding patch type; that is, the number of disjunct core areas contained within the landscape.
Units | None
Range | NDCA ≥ 0, without limit. NDCA = 0 when TCA = 0 (i.e., every location within patches of the corresponding patch type are within the specified depth-of-edge distance(s) from the patch perimeters). NDCA > 1 when, due to patch shape complexity, a patch contains more than 1 core area.
Comments | Number of disjunct core areas is defined the same at the patch level (see Number of Core Areas), but here it is aggregated (summed) over all patches of the corresponding patch type. Number of disjunct core areas is an alternative to the number of patches when it makes sense to treat the core areas as functionally distinct patches.


(C63) Disjunct Core Area Density
 |  | nijc = number of disjunct core areas in patch ij based on specified edge depths (m). A = total landscape area (m2).
Description | DCAD equals the sum of number of disjunct core areas contained within each patch of the corresponding patch type, divided by total landscape area (m2), multiplied by 10,000 and 100 (to convert to 100 hectares). Note, total landscape area (A) includes any internal background present.
Units | Number per 100 hectares
Range | DCAD ≥ 0, without limit. DCAD = 0 when TCA = 0 (i.e., every location within patches of the corresponding patch type are within the specified depth-of-edge distance(s) from the patch perimeters); in other words, when there are no core areas.
Comments | Disjunct core area density, like its counterpart, patch density (PD),expresses number of disjunct core areas on a per unit area basis that facilitates comparisons among landscapes of varying size. Of course, if total core area is held constant, then disjunct core area density and number of disjunct core areas convey the same information.


(L60) Total Core Area
 |  | aijc = core area (m2) of patch ij based on specified edge depths (m).
Description | TCA equals the sum of the core areas of each patch (m2), divided by 10,000 (to convert to hectares).
Units | Hectares
Range | TCA ≥ 0, without limit. TCA = 0 when every location within every patch is within the specified depth-of-edge distance(s) from the patch perimeters. TCA approaches total landscape area as the specified depth-of-edge distance(s) decreases and as patch shapes are simplified.
Comments | Total core area is defined the same as core area (CORE) at the patch level (see Core Area), but here core area is aggregated (summed) over all patches.


(L62) Number of Disjunct Core Areas
 |  | nijc = number of disjunct core areas in patch ij based on specified edge depths (m).
Description | NDCA equals the sum of the number of disjunct core areas contained within each patch in the landscape; that is, the number of disjunct core areas contained within the landscape.
Units | None
Range | NDCA ≥ 0, without limit. NCA = 0 when TCA = 0 (i.e., every location within every patch is within the specified depth-of-edge distance(s) from the patch perimeters); in other words, when there are no core areas. NDCA > 1 when, due to patch size and shape, at least one core area exists.
Comments | Number of disjunct core areas is defined the same at the patch level (see Number of Core Areas), but here it is aggregated (summed) over all patches. Number of disjunct core areas is an alternative to the number of patches when it makes sense to treat the core areas as functionally distinct patches.


(L63) Disjunct Core Area Density
 |  | nijc = number of disjunct core areas in patch ij based on specified edge depths (m). A = total landscape area (m2).
Description | DCAD equals the sum of number of disjunct core areas contained within each patch, divided by total landscape area (m2), multiplied by 10,000 and 100 (to convert to 100 hectares). Note, total landscape area (A) includes any internal background present.
Units | Number per 100 hectares
Range | DCAD ≥ 0, without limit. DCAD = 0 when TCA = 0 (i.e., every location within every patch is within the specified depth-of-edge distance(s) from the patch perimeters); in other words, when there are no core areas. DCAD > 1 when, due to patch size and shape, at least one core area exists.
Comments | Disjunct core area density, like its counterpart, patch density (PD),expresses number of disjunct core areas on a per unit area basis that facilitates comparisons among landscapes of varying size. Of course, if total core area is held constant, then disjunct core area density and number of disjunct core areas convey the same information.


ISOLATION/PROXIMITY METRICS

Background

FRAGSTATS Metrics

Limitations

Code | Metric (acronym)
Patch Metrics
P18 | Proximity Index ( PROX )
P19 | Similarity Index ( SIMI )
P20 | Euclidean Nearest Neighbor Distance ( ENN )
P21 | Functional Nearest Neighbor Distance ( FNN )
Class Metrics
C82-C87 | Proximity Index Distribution ( PROX_MN , _AM , _MD , _RA , _SD , _CV )
C88-C93 | Similarity Index Distribution ( SIMI_MN , _AM , _MD , _RA , _SD , _CV )
C94-C99 | Euclidean Nearest Neighbor Distance Distribution ( ENN_MN , _AM , _MD , _RA , _SD , _CV )
C100-C105 | Functional Nearest Neighbor Distance Distribution ( FNN_MN , _AM , _MD , _RA , _SD , _CV )
Landscape Metrics
L82-L87 | Proximity Index Distribution ( PROX_MN , _AM , _MD , _RA , _SD , _CV )
L88-L93 | Similarity Index Distribution ( SIMI_MN , _AM , _MD , _RA , _SD , _CV )
L94-L99 | Euclidean Nearest Neighbor Distance Distribution ( ENN_MN , _AM , _MD , _RA , _SD , _CV )
L100-L105 | Functional Nearest Neighbor Distance Distribution ( FNN_MN , _AM , _MD , _RA , _SD , _CV )


Background.--Isolation deals explicitly with the spatial and temporal context of habitat patches, rather than the spatial character of the patches themselves. Isolation of habitat patches is a critical factor in the dynamics of spatially structured populations. For example, there has been a proliferation of mathematical models on population dynamics and species interactions in spatially subdivided populations (Kareiva 1990), and results suggest that the dynamics of local plant and animal populations in a patch are influenced by their proximity to other subpopulations of the same or competing species. Patch isolation plays a critical role in island biogeographic theory (MacArthur and Wilson 1967) and metapopulation theory (Levins 1970, Gilpin and Hanski 1991). The role of patch isolation (e.g., as measured by interpatch distance) in metapopulations has had a preeminent role in conservation efforts for endangered species (e.g., Lamberson et al. 1992, McKelvey et al. 1992).

Isolation is particularly important in the context of habitat fragmentation. Several authors have claimed, for example, that patch isolation explains why fragmented habitats often contain fewer bird species than contiguous habitats (Moore and Hooper 1975, Forman et al. 1976, Helliwell 1976, Whitcomb et al. 1981, Hayden et al. 1985, Dickman 1987). Specifically, as habitat is lost and fragmented, residual habitat patches become more isolated from each other in space and time. One of the more immediate consequence of this is the disruption of movement patterns and the resulting isolation of individuals and local populations. This has important metapopulation consequences. As habitat is fragmented, it is broken up into remnants that are isolated to varying degrees. Because remnant habitat patches are relatively small and therefore support fewer individuals, there will be fewer local (within patch) opportunities for intra-specific interactions. This may not present a problem for individuals (and the persistence of the population) if movement among patches is largely unimpeded by intervening habitats in the matrix and connectivity across the landscape can be maintained. However, if movement among habitat patches is significantly impeded or prevented, then individuals (and local populations) in remnant habitat patches may become functionally isolated. The degree of isolation for any fragmented habitat distribution will vary among species depending on how they perceive and interact with landscape patterns (Dale et al. 1994, With and Crist 1995, Pearson et al. 1996, With et al. 1997, With 1999); less vagile species with very restrictive habitat requirements and limited gap-crossing ability will likely be most sensitive to isolation effects.

Habitat patches can become functionally isolated in several ways. First, the patch edge may act as a filter or barrier that impedes or prevents movement, thereby disrupting emigration and dispersal from the patch (Wiens et al. 1985). Some evidence for this exists for small mammals (e.g., Wegner and Merriam 1979, Chasko and Gates 1982, Bendell and Gates 1987, Yahner 1986), but the data are scarce for other vertebrates. Whether edges themselves can limit movement presumably depends on what species are trying to cross the edge and on the structure of the edge habitat (Kremsater and Bunnell 1999). Second, the distance from remnant habitat patches to other neighboring habitat patches may influence the likelihood of successful movement of individuals among habitat patches. Again, the distance at which movement rates significantly decline will vary among species depending on how they scale the environment. In general, larger organisms can travel longer distances. Therefore, a 100 m-wide agricultural field may be a complete barrier to dispersal for small organisms such as invertebrates (e.g., Mader 1984), yet be quite permeable for larger and more vagile organisms such as birds. Lastly, the composition and structure of the intervening landscape mosaic may determine the permeability of the landscape to movements. Note that under an island biogeographic perspective, habitat patches exist in a uniform sea that is hostile to both survival and dispersal. In this case, the matrix is presumed to contain no meaningful structure and isolation is influenced largely by the distance among favorable habitat patches. However, under a landscape mosaic perspective, habitat patches are bounded by other patches that may be more or less similar (as opposed to highly contrasting and hostile) and connectivity is assessed by the extent to which movement is facilitated or impeded through different habitat types across the landscape. Each habitat may differ in its “viscosity” or resistance to movement, facilitating movement through certain elements of the landscape and impeding it in others. Again, the degree to which a given landscape structure facilitates or impedes movement will vary among organisms. Regardless of how habitat patches become isolated, whether it be due to properties of the edges themselves, the distance between patches, or properties of the intervening matrix, the end result is the same–fewer individual movements among habitat patches.

Unfortunately, because of the many factors that influence the functional isolation of a patch, it is a difficult thing to capture in a single measure. In the context of fragmentation, isolation can be measured as the time since the habitat was physically subdivided, but this is fraught with practical difficulties. For example, rarely do we have accurate historical data from which to determine when each patch was isolated. Moreover, given that fragmentation is an ongoing process, it can be difficult to objectively determine at what point the habitat becomes subdivided, since this is largely a function of scale. Isolation can be measured in the spatial dimension in several ways, depending on how one views the concept of isolation. The simplest measures are based on Euclidean distance between nearest neighbors (McGarigal and Marks 1995) or the cumulative area of neighboring habitat patches (weighted by nearest neighbor distance) within some ecological neighborhood (Gustafson and Parker 1992). These measures adopt an island biogeographic perspective, as they treat the landscape as a binary mosaic consisting of habitat patches and uniform matrix. Thus, the context of a patch is defined by the proximity and area of neighboring habitat patches; the role of the matrix is ignored. However, these measures can be modified to take into account other habitat types in the so-called matrix and their affects on the insularity of the focal habitat. For example, simple Euclidean distance can be modified to account for functional differences among organisms. The functional distance between patches clearly depends on how each organism scales and interacts with landscape patterns (With 1999); in other words, the same gap between patches may not be perceived as a relevant disconnection for some organisms, but may be an impassable barrier for others. Similarly, the matrix can be treated as a mosaic of patch types that contribute differentially to the isolation of the focal habitat. For example, isolation can be measured by the degree of contrast (i.e., the magnitude of differences in one or more attributes between adjacent patch types) between the focal habitat and neighboring patches.


FRAGSTATS Metrics.--FRAGSTATS computes several isolation metrics based on nearest-neighbor distance at the patch, class, and landscape levels. Nearest-neighbor distance is defined as the distance from a patch to a neighboring patch of the same or different class, based on the nearest cell center-to-cell center. That is, the distance between the two closest cells from the respective patches, based on the distance between their cell centers. Note, this is a change from version 2.0 which based nearest neighbor distance on cell edge-to-edge distance. These metrics are all fundamentally patch-level metrics (i.e., measured for each patch) that can be summarized at the class or landscape levels.

FRAGSTATS computes two metrics that adopt an island biogeographic perspective on patch isolation: (1) Euclidean nearest neighbor distance and (2) proximity index. Euclidean nearest neighbor distance (ENN) is perhaps the simplest measure of patch context and has been used extensively to quantify patch isolation. Here, nearest neighbor distance is defined using simple Euclidean geometry as the shortest straight-line distance between the focal patch and its nearest neighbor of the same class. Even though nearest neighbor distance is often used to evaluate patch isolation, it is important to recognize that the single nearest patch may not fully represent the ecological neighborhood of the focal patch. For example, a neighboring patch 100 m away that is 1 ha is size may not be as important to the effective isolation of the focal patch as a neighboring patch 200 m away, but 1000 ha in size. To overcome this limitation, the proximity index (PROX) was developed by Gustafson and Parker (1992)[see also Gustafson and Parker 1994, Gustafson et al. 1994, Whitcomb et al. 1981]. This index considers the size and proximity of all patches whose edges are within a specified search radius of the focal patch. The index is computed as the sum, over all patches of the corresponding patch type whose edges are within the search radius of the focal patch, of each patch size divided by the square of its distance from the focal patch. Note that FRAGSTATS uses the distance between the focal patch and each of the other patches within the search radius, similar to the isolation index of Whitcomb et al. (1981), rather than the nearest-neighbor distance of each patch within the search radius (which could be to a patch other than the focal patch), as in Gustafson and Parker (1992). The proximity index quantifies the spatial context of a (habitat) patch in relation to its neighbors of the same class; specifically, the index distinguishes sparse distributions of small habitat patches from configurations where the habitat forms a complex cluster of larger patches. All other things being equal, a patch located in a neighborhood (defined by the search radius) containing more of the corresponding patch type than another patch will have a larger index value. Similarly, all other things being equal, a patch located in a neighborhood in which the corresponding patch type is distributed in larger, more contiguous, and/or closer patches than another patch will have a larger index value. Thus, the proximity index measures both the degree of patch isolation and the degree of fragmentation of the corresponding patch type within the specified neighborhood of the focal patch.

At the class and landscape levels, FRAGSTATS computes several distribution statistics associated with the Euclidean nearest neighbor distance and proximity index. At the class level, the mean proximity index measures the degree of isolation and fragmentation of the corresponding patch type and the performance of the index under various scenarios is described in detail by Gustafson and Parker (1994). FRAGSTATS also summarizes the proximity index at the landscape level by aggregating across all patches in the landscape, although the performance of this index as a measure of overall landscape pattern has not been evaluated quantitatively. Similarly, at the class and landscape levels, FRAGSTATS computes the mean and variability in Euclidean nearest neighbor distance. At the class level, mean nearest-neighbor distance can only be computed if there are at least 2 patches of the corresponding type. At the landscape level, mean nearest-neighbor distance considers only patches that have neighbors. Thus, there could be 10 patches in the landscape, but 8 of them might belong to separate patch types and therefore have no neighbor within the landscape. In this case, mean nearest-neighbor distance would be based on the distance between the 2 patches of the same type. These 2 patches could be close together or far apart. In either case, the mean nearest-neighbor distance for this landscape may not characterize the entire landscape very well. For this reason, these metrics should be interpreted carefully when landscapes contain rare patch types.

In addition to these first-order statistics, the variability in nearest-neighbor distance measures a key aspect of landscape heterogeneity. Specifically, the standard deviation (SD)in Euclidean nearest neighbor distance (ENN_SD) is a measure of patch dispersion; a small SD relative to the mean implies a fairly uniform or regular distribution of patches across landscapes, whereas a large SD relative to the mean implies a more irregular or uneven distribution of patches. The distribution of patches may reflect underlying natural processes or human-caused disturbance patterns. In absolute terms, the magnitude of nearest-neighbor SD is a function of the mean nearest-neighbor distance and variation in nearest-neighbor distance among patches. Thus, while SD does convey information about nearest neighbor variability, it is a difficult parameter to interpret without doing so in conjunction with the mean nearest-neighbor distance. For example, 2 landscapes may have the same nearest-neighbor SD, e.g., 100 m; yet 1 landscape may have a mean nearest-neighbor distance of 100 m, while the other may have a mean nearest-neighbor distance of 1,000 m. In this case, the interpretations of landscape pattern would be very different, even though the absolute variation is the same. Specifically, the former landscape has a more irregular but concentrated pattern of patches, while the latter has a more regular but dispersed pattern of patches. For these reasons, coefficient of variation (CV) often is preferable to SD for comparing variability among landscapes. Coefficient of variation measures relative variability about the mean (i.e., variability as a percentage of the mean), not absolute variability, and is akin to the familiar indices of dispersion in point patterns based on the variance to mean ratio in nearest neighbor distance (e.g., Clark and Evans 1954). Thus, it is not necessary to know the mean nearest-neighbor distance to interpret this metric. Even so, nearest-neighbor CV can be misleading with regards to landscape structure without also knowing the number of patches or patch density and other structural characteristics. For example, 2 landscapes may have the same nearest-neighbor CV, e.g., 100%; yet 1 landscape may have 100 patches with a mean nearest-neighbor distance of 100 m, while the other may have 10 patches with a mean nearest-neighbor distance of 1,000 m. In this case, the interpretations of overall landscape pattern could be very different, even though nearest-neighbor CV is the same; although the identical CV’s indicate that both landscapes have the same regularity or uniformity in patch distribution. Finally, both SD and CV assume a normal distribution about the mean. In a real landscape, nearest-neighbor distribution may be highly irregular. In this case, it may be more informative to inspect the actual distribution itself (e.g., plot a histogram of the nearest neighbor distances for the corresponding patches), rather than relying on summary statistics such as SD and CV that make assumptions about the distribution and therefore can be misleading.

FRAGSTATS computes two isolation metrics that adopt a landscape mosaic perspective on patch isolation: (1) functional nearest neighbor distance and (2) similarity index. Similarity index (SIMI) is a modification of the proximity index, the difference being that similarity considers the size and proximity of all patches, regardless of class, whose edges are within a specified search radius of the focal patch. The similarity index quantifies the spatial context of a (habitat) patch in relation to its neighbors of the same or similar class; specifically, the index distinguishes sparse distributions of small and insular habitat patches from configurations where the habitat forms a complex cluster of larger, hospitable (i.e., similar) patches. All other things being equal, a patch located in a neighborhood (defined by the search radius) deemed more similar (i.e., containing greater area in patches with high similarity) than another patch will have a larger index value. Similarly, all other things being equal, a patch located in a neighborhood in which the similar patches are distributed in larger, more contiguous, and/or closer patches than another patch will have a larger index value. Essentially, the similarity index performs much the same way as the proximity index, but instead of focusing on only a single patch type (i.e., island biogeographic perspective), it considers all patch types in the mosaic (i.e., landscape mosaic perspective). Thus, the similarity index is a more comprehensive measure of patch isolation than the proximity index for organisms and processes that perceive and respond to patch types differentially.

Similarly, functional nearest-neighbor distance (FNN) accounts for one of the major shortcomings of using Euclidean distance to assess ecological relationships; namely, that the shortest geographic distance may not be the shortest ecological distance as perceived by an organism or process. The character of the intervening landscape can significantly alter the rate of flow of the organism or process of interest. Therefore, it may be more meaningful to assess distance using a least cost path approach. Here, in effect, the distance across a cell is weighted by the degree of resistance it offers to the ecological flow of interest. Thus, the functional distance between two patches is increased proportionate the degree of resistance in the intervening landscape.


Limitations.--There are significant limitations associated with the use of isolation metrics that must be understood before they are used. The most important limitation of these particular metrics is that nearest-neighbor distances are computed solely from patches contained within the landscape boundary. If the landscape extent is small relative to the scale of the organism or ecological processes under consideration and the landscape is an "open" system relative to that organism or process, then nearest-neighbor results can be misleading. For example, consider a small subpopulation of a bird species occupying a patch near the boundary of a somewhat arbitrarily defined (from a bird's perspective) landscape. The nearest neighbor within the landscape boundary might be quite far away, yet in reality the closest patch might be very close, but just outside the designated landscape boundary. The magnitude of this problem is a function of scale. Increasing the size of the landscape relative to the scale at which the organism under investigation perceives and responds to the environment will decrease the severity of this problem.

Similarly, the proximity and similarity indices involve a search window around the focal patch. Thus, these metrics may be biased low for patches located within the search radius distance from the landscape boundary because a portion of the search area will be outside the area under consideration. The magnitude is of this problem is also a function of scale. Increasing the size of the landscape relative to the average patch size and/or decreasing the search radius will decrease the severity of this problem at the class and landscape levels. However, at the patch level, regardless of scale, individual patches located within the search radius of the boundary will have biased indices. In addition, these indices evaluate the landscape context of patches at a specific scale of analysis defined by the size of the search radius. Therefore, these indices are only meaningful if the specified search radius has some ecological relevance to the phenomenon under consideration. Otherwise, the results will be arbitrary and therefore meaningless.

Lastly, functional nearest-neighbor distance and the similarity index are functional metrics in that they require additional parameterization, in this case, resistance coefficients that are unique to the ecological phenomenon under consideration. Consequently, as with any functional metric, their relevance depends entirely on the meaningfulness of the resistance coefficients applied. If these are arbitrary assignments or based on weak observational data, results will be arbitrary and therefore meaningless.


(P18) Proximity Index
 |  | aijs = area (m2) of patch ijs within specified neighborhood (m) of patch ij. hijs = distance (m) between patch ijs and patch ijs, based on patch edge-to-edge distance, computed from cell center to cell center.
Description | PROX equals the sum of patch area (m2) divided by the nearest edge-to-edge distance squared (m2) between the patch and the focal patch of all patches of the corresponding patch type whose edges are within a specified distance (m) of the focal patch. Note, when the search buffer extends beyond the landscape boundary, only patches contained within the landscape are considered in the computations. In addition, note that the edge-to-edge distances are from cell center to cell center.
Units | None
Range | PROX ≥ 0. PROX = 0 if a patch has no neighbors of the same patch type within the specified search radius. PROX increases as the neighborhood (defined by the specified search radius) is increasingly occupied by patches of the same type and as those patches become closer and more contiguous (or less fragmented) in distribution. The upper limit of PROX is affected by the search radius and the minimum distance between patches.
Comments | Proximity index was developed by Gustafson and Parker (1992) and considers the size and proximity of all patches whose edges are within a specified search radius of the focal patch. Note that FRAGSTATS uses the distance between the focal patch and each of the other patches within the search radius, similar to the isolation index of Whitcomb et al. (1981), rather than the nearest-neighbor distance of each patch within the search radius (which could be to a patch other than the focal patch), as in Gustafson and Parker (1992). The index is dimensionless (i.e., has no units) and therefore the absolute value of the index has little interpretive value; instead it is used as a comparative index.


(P19) Similarity Index
 |  | aijs = area (m2) of patch ijs within specified neighborhood (m) of patch ij. dik = similarity between patch types i and k. hijs = distance (m) between patch ijs and patch ijs, based on patch edge-to-edge distance, computed from cell center to cell center.
Description | SIMI equals the sum, over all neighboring patches with edges within a specified distance (m) of the focal patch, of neighboring patch area (m2) times a similarity coefficient between the focal patch type and the class of the neighboring patch (0-1), divided by the nearest edge-to-edge distance squared (m2) between the focal patch and the neighboring patch. Note, when the search buffer extends beyond the landscape boundary, only patches contained within the landscape are considered in the computations. In addition, note that the edge-to-edge distances are from cell center to cell center.
Units | None
Range | SIMI ≥ 0 SIMI = 0 if all the patches within the specified neighborhood have a zero similarity coefficient. SIMI increases as the neighborhood (defined by the specified search radius) is increasingly occupied by patches with greater similarity coefficients and as those similar patches become closer and more contiguous and less fragmented in distribution. The upper limit of SIMI is affected by the search radius and minimum distance between patches.
Comments | Similarity index is a modification of the proximity index (see Proximity Index description), the difference being that similarity considers the size and proximity of all patches, regardless of class, whose edges are within a specified search radius of the focal patch. Like the proximity index, this index is dimensionless (i.e., has no units) and therefore the absolute value of the index has little interpretive value; instead it is used as a comparative index.


(P20) Euclidean Nearest-Neighbor Distance
 |  | hij = distance (m) from patch ij to nearest neighboring patch of the same type (class), based on patch edge-to-edge distance, computed from cell center to cell center.
Description | ENN equals the distance (m) to the nearest neighboring patch of the same type, based on shortest edge-to-edge distance. Note that the edge-to-edge distances are from cell center to cell center.
Units | Meters
Range | ENN > 0, without limit. ENN approaches 0 as the distance to the nearest neighbor decreases. The minium ENN is constrained by the cell size, and is equal to twice the cell size when the 8-neighbor patch rule is used or the distance between diagonal neighbors when the 4-neighbor rule is used. The upper limit is constrained by the extent of the landscape. ENN is undefined and reported as "N/A" in the “basename”.patch file if the patch has no neighbors (i.e., no other patches of the same class).
Comments | Euclidean nearest-neighbor distance is perhaps the simplest measure of patch context and has been used extensively to quantify patch isolation. Here, nearest neighbor distance is defined using simple Euclidean geometry as the shortest straight-line distance between the focal patch and its nearest neighbor of the same class.


(P21) Functional Nearest-Neighbor Distance
 |  | hij* =distance (m) from patch ij to its nearest neighboring patch of the same type (class), based on least cost path edge-to-edge distance, computed from cell center to cell center.
Description | FNN equals the distance (m) to the nearest neighboring patch of the same type, based on the least cost path edge-to-edge distance. Note that the edge-to-edge distances are from cell center to cell center.
Units | Meters
Range | FNN > 0, without limit. FNN approaches 0 as the distance to the nearest neighbor decreases. The minium FNN is constrained by the cell size, and is equal to twice the cell size when the 8-neighbor patch rule is used or the distance between diagonal neighbors when the 4-neighbor rule is used. The upper limit is constrained by the extent of the landscape. FNN is undefined and reported as "N/A" in the “basename”.patch file if the patch has no neighbors (i.e., no other patches of the same class).
Comments | Functional nearest-neighbor distance accounts for one of the major shortcomings of using Euclidean distance to assess ecological relationships; namely, that the shortest geographic distance may not be the shortest ecological distance as perceived by an organism or process.


CONTRAST METRICS

Background

FRAGSTATS Metrics

Limitations

Code | Metric (acronym)
Patch Metrics
P22 | Edge Contrast Index ( ECON )
Class Metrics
C106 | Contrast-Weighted Edge Density ( CWED )
C107 | Total Edge Contrast Index ( TECI )
C108-C113 | Edge Contrast Index Distribution ( ECON_MN , _AM , _MD , _RA , _SD , _CV )
Landscape Metrics
L106 | Contrast-Weighted Edge Density ( CWED )
L107 | Total Edge Contrast Index ( TECI )
L108-L113 | Edge Contrast Index Distribution ( ECON_MN , _AM , _MD , _RA , _SD , _CV )


Background.--Contrast refers to the magnitude of difference between adjacent patch types with respect to one or more ecological attributes at a given scale that are relevant to the organism or process under consideration. The contrast between a patch and its neighborhood can influence a number of important ecological processes (Forman and Godron 1986). The ‘edge effects’ described elsewhere (see Area/Density/Edge Metrics), for example, are influenced by the degree of contrast between patches. Microclimatic changes (e.g., wind, light intensity and quality, etc.) are likely to extend farther into a patch along an edge with high structural contrast than along an edge with low structural contrast (Ranney et al. 1981). Similarly, the adverse affects of brown-headed cowbird nest parasitism on some forest-dwelling neotropical migratory bird species are likely to be greatest along high-contrast forest edges (e.g., between mature forest patches and grassland), because cowbirds prefer to forage in early-seral habitats and parasitize nests in late-seral habitats (Brittingham and Temple 1983). In addition, patch isolation may be a function of the contrast between a patch and its ecological neighborhood. In particular, the degree of contrast between a habitat patch and the surrounding landscape may influence dispersal patterns and survival, and thus indirectly affect the degree of patch isolation. Similarly, an organism's ability to use the resources in adjacent patches, as in the process of landscape supplementation (Dunning et al. 1992), may depend on the nature of the boundary between the patches. The boundary between patches can function as a barrier to movement, a differentially-permeable membrane that facilitates some ecological flows but impedes others, or as a semipermeable membrane that partially impairs flows (Wiens et al. 1985, Hansen and di Castri 1992). The contrast along an edge may influence its function in this regard. For example, high-contrast edges may prohibit or inhibit some organisms from seeking supplementary resources in surrounding patches. Conversely, some species (e.g., great horned owl, Bubo virginianus) seem to prefer the juxtaposition of patch types with high contrast, as in the process of landscape complementation (Dunning et al. 1992).

Clearly, edge contrast can assume a variety of meanings for different ecological processes. Therefore, contrast can be defined in a variety of ways, but it always reflects the magnitude of difference between patches with respect to one or more ecological attributes at a given scale that are important to the phenomenon under investigation (Kotliar and Wiens 1990, Wiens et al. 1985). Similar to Romme (1982), FRAGSTATS employs weights to represent the magnitude of edge contrast between adjacent patch types; weights must range between 0 (no contrast) and 1 (maximum contrast). Under most circumstances, it is probably not valid to assume that all edges function similarly. Often there will not be a strong empirical basis for establishing a weighting scheme, but a reasoned guess based on a theoretical understanding of the phenomenon is probably better than assuming all edges are alike. For example, from an avian habitat use standpoint, we might weight edges somewhat subjectively according to the degree of structural and floristic contrast between adjacent patches, because a number of studies have shown these features to be important to many bird species (Thomas et al. 1978 and 1979, Logan et al. 1985).


FRAGSTATS Metrics.–FRAGSTATS computes several indices based on edge contrast at the patch, class, and landscape levels. At the patch level, the edge contrast index (ECON) measures the degree of contrast between a patch and its immediate neighborhood. Each segment of the patch perimeter is weighted by the degree of contrast with the adjacent patch. Total patch perimeter is reduced proportionate to the degree of contrast in the perimeter and reported as a percentage of the total perimeter. Thus, a patch with a 10% edge contrast index has very little contrast with its neighborhood; it has the equivalent of 10% of its perimeter in maximum-contrast edge. Conversely, a patch with a 90% edge contrast index has high contrast with its neighborhood. Note that this index is a relative measure. Given any amount of edge, it measures the degree of contrast in that edge. In other words, high values of ECON mean that the edge present, regardless of whether it is 10 m or 1,000 m, is of high contrast, and vice versa. At the class and landscape levels, FRAGSTATS computes a total edge contrast index (TECI). Like its patch-level counterpart, this index quantifies edge contrast as a percentage of maximum possible. However, this index ignores patch distinctions; it quantifies edge contrast for the landscape as a whole. FRAGSTATS also computes distribution statistics for the edge contrast index at the class and landscape levels. The mean edge contrast index (ECON_MN), for example, quantifies the average edge contrast for patches of a particular patch type (class level) or for all patches in the landscape.

These edge contrast indices are relative measures. Given any amount or density of edge, they measure the degree of contrast in that edge. High values of these indices mean that the edge present, regardless of whether it is 10 m or 1,000 m, is of high contrast, and vice versa. For this reason, these indices are probably best interpreted in conjunction with total edge or edge density. Because of this, FRAGSTATS also computes an index that incorporates both edge density and edge contrast in a single index. Contrast-weighted edge density (CWED) standardizes edge to a per unit area basis that facilitates comparison among landscapes of varying size. Unlike edge density, however, this index reduces the length of each edge segment proportionate to the degree of contrast. Thus, 100 m/ha of maximum-contrast edge (i.e., weight = 1) is unaffected; but 100 m/ha of edge with a contrast weight of 0.2 is reduced by 80% to 20 m/ha of contrast-weighted edge. This index measures the equivalent maximum-contrast edge density. For example, an edge density of 100 means that there are 100 meters of edge per hectare in the landscape. A contrast-weighted edge density of 80 for the same landscape means that there are an equivalent of 80 meters of maximum-contrast edge per hectare in the landscape. A landscape with 100 m/ha of edge and an average contrast weight of 0.8 would have twice the contrast-weighted edge density (80 m/ha) as a landscape with only 50 m/ha of edge but with the same average contrast weight (40 m/ha). Thus, both edge density and edge contrast are reflected in this index. For many ecological phenomena, edge types function differently. Consequently, comparing total edge density among landscapes may be misleading because of differences in edge types. This contrast-weighted edge density index attempts to quantify edge from the perspective of its functional significance. Thus, landscapes with the same contrast-weighted edge density are presumed to have the same total magnitude of edge effects from a functional perspective.

All edge contrast indices consider landscape boundary and background segments even if they have an edge contrast weight of zero. In the absence of a landscape border, the landscape boundary is assigned as background edge and treated according to the background contrast weight specified in the contrast weight file. In the presence of a landscape border, all landscape boundary edges are made explicit by the information present in the border and are assigned the appropriate contrast weight given in the contrast weight file. Regardless of whether a border is present or not, all background edges, both internal (positively valued) and external (negatively valued), are assigned the background contrast weight specified in the contrast weight file. Assigning a meaningful contrast weight to the boundary and background presents a special challenge because, in practice, background (and the boundary, in the absence of a border) often represents area for which nothing is known. Thus, it can be difficult to assign a single contrast weight that applies equally well to all background/boundary edges. A landscape border is often included to avoid this problem, because all boundary edges are made explicit; however, even a border doesn’t eliminate the problem of assigning a weight to background if it exists. The potential severity of the boundary/background problem depends on the size and heterogeneity of the landscape and the extent of background edge. Larger and more heterogeneous landscapes without little or no background will have proportionately less total edge located along the boundary and/or background.


Limitations.–Edge contrast indices are limited by the considerations discussed elsewhere for metrics based on total edge length (see Area/Density/Edge Metrics). These indices are only calculated if an edge contrast weight file is specified. The usefulness of these indices is directly related to the meaningfulness of the weighting scheme used to quantify edge contrast. Careful consideration should be given to devising weights that reflect any empirical and theoretical knowledge and understanding of the phenomenon under consideration. If the weighting scheme does not accurately represent the phenomenon under investigation, then the results will be spurious.


(P22) Edge Contrast Index
 |  | pijk = length (m) of edge of patch ij adjacent to patch type (class) k. dik = dissimilarity (edge contrast weight) between patch types i and k. pij = length (m) of perimeter of patch ij.
Description | ECON equals the sum of the patch perimeter segment lengths (m) multiplied by their corresponding contrast weights, divided by total patch perimeter (m), multiplied by 100 (to convert to a percentage). Edge segments along the landscape boundary are treated like background (as specified in the edge contrast weight file) unless a landscape border is present, in which case the boundary edge types are made explicit by the information in the border. [pijk*dik= (intTrue*d)+(intBack*d)+(extTrue*d)+(extBack*d)+(extLike*d)][pij = intTrue+intBack+extTrue+extBack+extLike]
Units | Percent
Range | 0 ≤ ECON ≤ 100 ECON = 0 if the landscape consists of only 1 patch and the landscape boundary consists of all background (i.e., in the absence of a border) and is give a zero-contrast weight (d = 0). Also, ECON = 0 when all of the patch perimeter segments involve patch type adjacencies that have been given a zero-contrast weight in the edge contrast weight file. ECON = 100 when the entire patch perimeter is maximum-contrast edge (d = 1). ECON < 100 when a portion of the patch perimeter is less than maximum-contrast edge (d < 1).
Comments | Edge Contrast Index is founded on the notion that all edges are not created equal. To account for this, the notion of edge “contrast” was created. This index is a relative measure of the amount of contrast along the patch perimeter.


(C106) Contrast-Weighted Edge Density
 |  | eik = total length (m) of edge in landscape between patch types (classes) i and k; includes landscape boundary segments involving patch type i. dik = dissimilarity (edge contrast weight) between patch types i and k. A = total landscape area (m2).
Description | CWED equals the sum of the lengths (m) of each edge segment involving the corresponding patch type multiplied by the corresponding contrast weight, divided by the total landscape area (m2), multiplied by 10,000 (to convert to hectares). Edge segments along the landscape boundary are treated like background (as specified in the edge contrast weight file) unless a landscape border is present, in which case the boundary edge types are made explicit by the information in the border. Note, total landscape area (A) includes any internal background present.[eik*dik =(intTrue*d)+(intBack*d)+(extTrue*d)+(extBack*d)+(extLike*d)]
Units | Meters per hectare
Range | CWED ≥ 0, without limit. CWED = 0 when there is no class edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of the corresponding patch type and the user specifies that background edge be given a zero-contrast weight (d = 0). CWED increases as the amount of class edge in the landscape increases and/or as the contrast in edges involving the corresponding patch type increase (i.e., contrast weight approaches 1).
Description | Contrast-weighted edge density standardizes edge to a per unit area basis that facilitates comparison among landscapes of varying size


(C107) Total Edge Contrast Index

eik = total length (m) of edge in landscape between patch types (classes) i and k; includes landscape boundary segments involving patch type i.

e*ik = total length (m) of edge in landscape between patch types (classes) i and k; includes the entire landscape boundary and all background edge segments, regardless of whether they represent edge or not.

dik = dissimilarity (edge contrast weight) between patch types i and k.

Description

TECI equals the sum of the lengths (m) of each edge segment involving the corresponding patch type multiplied by the corresponding contrast weight, divided by the sum of the lengths (m) of all edge segments involving the same type, multiplied by 100 (to convert to a percentage). Edge segments along the landscape boundary are treated like background (as specified in the edge contrast weight file) unless a landscape border is present, in which case the boundary edge types are made explicit by the information in the border. [eik*dik= (intTrue*d)+(intBack*d)+(extTrue*d)+(extBack*d)+(extLike*d)][eik = intTrue+intBack+extTrue+extBack+extLike]

Units

Percent

Range

0 ≤ TECI ≤ 100

TECI = 0 when there is no class edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of the corresponding patch type and the user specifies that background edge be given a zero-contrast weight (d = 0). TECI approaches 0 as the contrast in edges involving the corresponding patch type lesson (i.e., contrast weight approaches 0). TECI = 100 when all class edge is maximum contrast (d = 1).

Description

Total edge contrast index is similar to the edge contrast index at the patch level, only here it is applied to all edges of the corresponding patch type


(L106) Contrast-Weighted Edge Density
 |  | eik = total length (m) of edge in landscape between patch types (classes) i and k; includes landscape boundary segments involving patch type i. dik = dissimilarity (edge contrast weight) between patch types i and k. A = total landscape area (m2).
Description | CWED equals the sum of the lengths (m) of each edge segment in the landscape multiplied by the corresponding contrast weight, divided by the total landscape area (m2), multiplied by 10,000 (to convert to hectares). Edge segments along the landscape boundary are treated like background (as specified in the edge contrast weight file) unless a landscape border is present, in which case the boundary edge types are made explicit by the information in the border. Note, total landscape area (A) includes any internal background present.[eik*dik =(intTrue*d)+(intBack*d)+(extTrue*d)+(extBack*d)+(extLike*d)]
Units | Meters per hectare
Range | CWED ≥ 0, without limit. CWED = 0 when there is no edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of the corresponding patch type and the user specifies that background edge be given a zero-contrast weight (d = 0). CWED increases as the amount of edge in the landscape increases and/or as the contrast in edges increase (i.e., contrast weight approaches 1).
Description | Contrast-weighted edge density standardizes edge to a per unit area basis that facilitates comparison among landscapes of varying size


(L107) Total Edge Contrast Index

eik = total length (m) of edge in landscape between patch types (classes) i and k; includes landscape boundary segments involving patch type i.

E* = total length (m) of edge in landscape; includes entire landscape boundary and background edge segments regardless of whether they represent edge or not.

dik = dissimilarity (edge contrast weight) between patch types i and k.

Description

TECI equals the sum of the lengths (m) of each edge segment in the landscape multiplied by the corresponding contrast weight, divided by the total length (m) of edge in the landscape, multiplied by 100 (to convert to a percentage). Edge segments along the landscape boundary are treated like background (as specified in the edge contrast weight file) unless a landscape border is present, in which case the boundary edge types are made explicit by the information in the border. [eik*dik =(intTrue*d)+(intBack*d)+(extTrue*d)+(extBack*d)+(extLike*d)][E = intTrue+intBack+extTrue+extBack+extLike]

Units

Percent

Range

0 ≤ TECI ≤ 100

TECI = 0 when there is no edge in the landscape; that is, when the entire landscape and landscape border, if present, consists of a single patch or the user specifies that all edge types be given a zero-contrast weight (d = 0). TECI approaches 0 as the contrast in edges lesson (i.e., contrast weight approaches 0). TECI = 100 when all edge is maximum contrast (d = 1).

Description

Total edge contrast index is similar to the edge contrast index at the patch level, only here it is applied to all edges across the landscape.


CONTAGION/INTERSPERSION METRICS

Background

FRAGSTATS Metrics

Limitations

Code | Metric (acronym)
Class Metrics
C114 | Percentage of Like Adjacencies ( PLADJ )
C115 | Clumpiness Index ( CLUMPY )
C116 | Aggregation Index ( AI )
C117 | Interspersion & Juxtaposition Index ( IJI )
C118 | Mass Fractal Dimension ( MFRAC )
C119 | Landscape Division Index ( DIVISION )
C120 | Splitting Index ( SPLIT )
C121 | Effective Mesh Size ( MESH )
Landscape Metrics
L114 | Percentage of Like Adjacencies ( PLADJ )
L115 | Contagion ( CONTAG )
L116 | Aggregation Index ( AI )
L117 | Interspersion & Juxtaposition Index ( IJI )
L118 | Landscape Division Index ( DIVISION )
L119 | Splitting Index ( SPLIT )
L120 | Effective Mesh Size ( MESH )


Background.–Contagion refers to the tendency of patch types to be spatially aggregated; that is, to occur in large, aggregated or “contagious” distributions. Interspersion, on the other hand, refers to the intermixing of patches of different types and is based solely on patch (as opposed to cell) adjacencies. Contagion and interspersion are both aspects of landscape texture; they both reflect the adjacency of patch types, but do so in a different manner. Contagion reflects both the dispersion (i.e., the spatial distribution) and intermixing of patch types, whereas interspersion reflects only the latter. Thus, as a measure of landscape texture, contagion subsumes interspersion.

Contagion is also closely allied to the concept of subdivision. In its narrowest sense, contagion ignores patches per se and measures the extent to which cells of similar class are aggregated. In other words, contagion reflects the overall clumpiness of the landscape without explicit reference to the patches. Subdivision, on the other hand, refers explicitly to the degree to which patch types are broken up (i.e., subdivided) into separate patches (i.e., fragments), not the shape, relative location, or spatial arrangement of those patches. These differences are subtle, but important–at least computationally, if not conceptually. Contagion (at the landscape level) deals with both the dispersion and interspersion of patch types, while subdivision deals only with the dispersion of patch types, not interspersion. This distinction is relatively straightforward. The confusion between contagion and subdivision lies in how they handle dispersion. Contagion deals specifically with the ‘aggregation’ of patch types; it is affected only by the clumpiness of cells of the same class. Computationally, contagion is computed from the proportion of cell adjacencies that involve the same class (i.e., like-adjacencies); it doesn’t matter what patch a cell belongs to or how many patches there are, only how many of the cell sides are like-adjacencies. Large, compact patches have a high proportion of like-adjacencies and therefore produce high contagion. Conversely, large, but highly convoluted (e.g., linear) patches have a low proportion of like-adjacencies and therefore produce low contagion–despite the similarity in patch sizes. Accordingly, the number and size of disjunct patches–that is, the subdivision of the landscape–affects contagion only indirectly by affecting the proportion of like adjacencies. Thus, contagion reflects the ‘compactness’ of patches, not the number and size of patches per se–although in real landscapes compactness and size are often highly correlated. Subdivision, on the other hand, deals with the aggregation of patch types, like contagion, but deals explicitly with the number and size of patches as well. Indeed, the subdivision metrics computed by FRAGSTATS (described below) are based on the cumulative patch size distribution, not cell adjacencies. Large, contiguous patches, even if they are highly elongated or convoluted, are undivided and therefore produce low subdivision. Despite the theoretical and conceptual differences between contagion and subdivision, in practice these two aspects of landscape texture are often highly confounded. For this reason, it is easier to consider contagion and subdivision together, as we have done here.

Contagion and interspersion broadly refer to the overall texture of the entire landscape mosaic, as described above. However, contagion and interspersion can be applied at the class level as well, although their meaning changes somewhat. At the class level, interspersion has basically the same interpretation; it refers to the intermixing of the focal patch type with the other patch types. The distinction here is the focus on a single patch type and its adjacencies to other patch types, as opposed to the intermixing of all patches. Similarly, contagion at the class level refers to the tendency of a single focal patch type to be spatially aggregated; that is, to occur in large, aggregated or “contagious” distributions. Here, the distinction between class and landscape levels is important. Recall that at the landscape level, contagion refers to both the dispersion and interspersion of patch types. At the class level, however, contagion refers to the spatial aggregation of the focal patch type without reference to its interspersion. Consequently, measures of class-level contagion are quite different computationally from measures of contagion computed at the landscape level. At the class level, contagion is more closely akin to the concept of subdivision because it deals exclusively with the aggregation or disaggregation (i.e., fragmentation) of the focal class–although the subtle distinction between contagion and subdivision regarding dispersion described above still applies.

The texture of a landscape is a fundamental aspect of landscape pattern and is important in many ecological processes. The subdivision of a patch type of course plays a crucial role in the process of habitat fragmentation. Specifically, habitat fragmentation involves the disaggregation and subdivision of contiguous habitat into disaggregated and/or disjunct patches. As habitat fragmentation proceeds, habitat contagion decreases, habitat subdivision increases, and eventually ecological function is impaired (Saunders et al.1991). Specifically, the subdivision and isolation of populations caused by this fragmentation can lead to reduced dispersal success and patch colonization rates which may result in a decline in the persistence of individual populations and an enhanced probability of regional extinction for entire populations across the landscape (e.g., Lande 1987; With and King 1999a,b; With 1999). In addition, the subdivision and interspersion of patch types may affect the propagation of disturbances across a landscape (Franklin and Forman 1987). Specifically, a patch type that is highly disaggregated and/or subdivided may be more resistant to the propagation of some disturbances (e.g., disease, fire, etc.), and thus more likely to persist in a landscape than a patch type that is highly aggregated and/or contiguous. Conversely, highly disaggregated and/or subdivided patch types may suffer higher rates of disturbance for some disturbance types (e.g. windthrow) than more aggregated and /or contiguous distributions. Similarly, interspersion is presumed to affect the quality of habitat for many species that require different patch types to meet different life history requisites, as in the process of landscape complementation (Dunning et al. 1992). Indeed, the notion of habitat interspersion has had a preeminent role in wildlife management during the past century. Wildlife management efforts are often focused on maximizing habitat interspersion because it is believed that the juxtaposition of different habitats will increase species diversity (Leopold 1933).


FRAGSTATS Metrics.–There are several different approaches for measuring contagion and interspersion. One popular index that subsumes both dispersion and interspersion is the contagion index (CONTAG) based on the probability of finding a cell of type i next to a cell of type j. This index was proposed first by O'Neill et al. (1988) and subsequently it has been widely used (Turner and Ruscher 1988, Turner 1989, Turner et al. 1989, Turner 1990a and b, Graham et al. 1991, Gustafson and Parker 1992). Li and Reynolds (1993) showed that the original formula was incorrect; they introduced 2 forms of an alternative contagion index that corrects this error and has improved performance. FRAGSTATS computes one of the contagion indices proposed by Li and Reynolds (1993). This contagion index is based on raster “cell" adjacencies, not "patch" adjacencies, and consists of the sum, over patch types, of the product of 2 probabilities: (1) the probability that a randomly chosen cell belongs to patch type i (estimated by the proportional abundance of patch type i), and (2) the conditional probability that given a cell is of patch type i, one of its neighboring cells belongs to patch type j (estimated by the proportional abundance of patch type i adjacencies involving patch type j). The product of these probabilities equals the probability that 2 randomly chosen adjacent cells belong to patch type i and j. This contagion index is appealing because of the straightforward and intuitive interpretation of this probability.

The contagion index has been widely used in landscape ecology because it seems to be an effective summary of overall clumpiness on categorical maps (Turner 1989). In addition, in many landscapes, it is highly correlated with indices of patch type diversity and dominance (Ritters et al. 1995) and thus may be an effective surrogate for those important components of pattern (O’Neill et al. 1996). Contagion measures both patch type interspersion (i.e., the intermixing of units of different patch types) as well as patch dispersion (i.e., the spatial distribution of a patch type) at the landscape level. All other things being equal, a landscape in which the patch types are well interspersed will have lower contagion than a landscape in which patch types are poorly interspersed. Contagion measures the extent to which patch types are aggregated or clumped (i.e., dispersion); higher values of contagion may result from landscapes with a few large, contiguous patches, whereas lower values generally characterize landscapes with many small and dispersed patches. Thus, holding interspersion constant, a landscape in which the patch types are aggregated into larger, contiguous patches will have greater contagion than a landscape in which the patch types are fragmented into many small patches. Contagion measures dispersion in addition to patch type interspersion because cells, not patches, are evaluated for adjacency. Landscapes consisting of large, contiguous patches have a majority of internal cells with like adjacencies. In this case, contagion is high because the proportion of total cell adjacencies comprised of like adjacencies is very large and the distribution of adjacencies among edge types is very uneven.

Unfortunately, as alluded to above, there are alternative procedures for computing contagion, and this has contributed to some confusion over the interpretation of published contagion values (see Ritters et al. 1996 for a discussion). Briefly, to calculate contagion, the adjacency of patch types is first summarized in an adjacency or co-occurrence matrix, which shows the frequency with which different pairs of patch types (including like adjacencies between the same patch type) appear side-by-side on the map (note, FRAGSTATS includes only the 4 orthogonal neighbors, not diagonal neighbors, regardless of the choice of neighbor rules for defining patches). Although this would seem to be a simple task, it is the source of differences among procedures for calculating contagion. The difference arises out of the option to count each immediately-adjacent pixel pair once or twice. In the single-count method, each pixel adjacency is counted once and the order of pixels is not preserved; whereas, in the double-count method, each pixel adjacency is counted twice and the order of pixels is preserved. Ritters et al. (1996) discuss the merits of both approaches. FRAGSTATS adopts the double-count method in which pixel order is preserved, with two exceptions. If a landscape border is present, the adjacencies along the landscape boundary (i.e., those between cells inside the landscape and those in the border) are only counted once, and they are tallied for the cells inside the landscape. For example, an adjacency on the landscape boundary between class 2 (inside the landscape) and class -3 (in the landscape border) is recorded as a 2-3 adjacency in the adjacency matrix, not a 3-2. Thus, if a landscape border is present, the adjacency matrix includes double-counts for all internal cell adjacencies and single-counts for all adjacencies on the landscape boundary not involving background. In effect, this gives double the weight to the internal adjacencies than those on the boundary, although the effect will be trivial in most landscapes because the boundary edges will represent a relative minor proportion of the total adjacencies. Similarly, all adjacencies involving background (both internal, i.e., inside the landscape, and external, i.e., on the landscape boundary) are counted only once, and they are tallied for the non-background cells. Essentially, each non-background cell inside the landscape (i.e., positively valued cell) is visited and the four cell sides are evaluated and tallied in the adjacency matrix. Since background cells and all cells in the landscape border, if present, are not visited per se, the edges involving these cells only get tallied once in association with the non-background cell inside the landscape.

McGarigal and Marks (1995) introduced a complementary interspersion and juxtaposition index (IJI) that increases in value as patches tend to be more evenly interspersed in a "salt and pepper" mixture. Unlike the earlier contagion indices that are based on raster cell adjacencies, this index is based on patch adjacencies; only the patch perimeters are considered in determining the total length of each unique edge type. Each patch is evaluated for adjacency with all other patch types; like adjacencies are not possible because a patch can never be adjacent to a patch of the same type. Because this index is a measure of patch adjacency and not cell adjacency, the interpretation is somewhat different than the contagion index. The interspersion index measures the extent to which patch types are interspersed (not necessarily dispersed); higher values result from landscapes in which the patch types are well interspersed (i.e., equally adjacent to each other), whereas lower values characterize landscapes in which the patch types are poorly interspersed (i.e., disproportionate distribution of patch type adjacencies). The interspersion index is not directly affected by the number, size, contiguity, or dispersion of patches per se, as is the contagion index. Consequently, a landscape containing 4 large patches, each a different patch type, and a landscape of the same extent containing 100 small patches of 4 patch types will have the same index value if the patch types are equally interspersed (or adjacent to each other based on the proportion of total edge length in each edge type); whereas, the value of contagion would be quite different. Like the contagion index, the interspersion index is a relative index that represents the observed level of interspersion as a percentage of the maximum possible given the total number of patch types.

It is important to note the differences between the contagion index and the interspersion and juxtaposition index. Contagion is affected by both interspersion and dispersion. The interspersion and juxtaposition index, in contrast, is affected only by patch type interspersion and not necessarily by the size, contiguity, or dispersion of patches. Thus, although often indirectly affected by dispersion, the interspersion and juxtaposition index directly measures patch type interspersion, whereas contagion measures a combination of both patch type interspersion and dispersion. In addition, contagion and interspersion are typically inversely related to each other. Higher contagion generally corresponds to lower interspersion and vice versa. Finally, in contrast to the interspersion and juxtaposition index, the contagion index is strongly affected by the grain size or resolution of the image. Given a particular patch mosaic, a smaller grain size will result in greater contagion because of the proportional increase in like adjacencies from internal cells. The interspersion and juxtaposition index is not affected in this manner because it considers only patch edges. This scale effect should be carefully considered when attempting to compare results from different studies.

Other contagion-like metrics can be generated from the matrix of pairwise adjacencies between patch types. FRAGSTATS computes the percentage of like adjacencies (PLADJ), which is computed as the sum of the diagonal elements (i.e., like adjacencies) of the adjacency matrix divided by the total number of adjacencies. A landscape containing greater aggregation of patch types (e.g., larger patches with compact shapes) will contain a higher proportion of like adjacencies than a landscape containing disaggregated patch types (e.g., smaller patches and more complex shapes). In contrast to the contagion index, this metric measures only patch type dispersion, not interspersion, and is unaffected by the method used to summarize adjacencies. At the class level, this metric is computed as the percentage of like adjacencies of the focal class. A highly contagious (aggregated) patch type will contain a higher percentage of like adjacencies. Conversely, a highly fragmented (disaggregated) patch type will contain proportionately fewer like adjacencies. As such, this index provides an effective measure of class-specific contagion that isolates the dispersion (as opposed to interspersion) component of configuration. However, this index requires careful interpretation because it varies in relation to the proportion of the landscape comprised of the focal class (Pi). It has been shown that PLADJ for class i will equal Pi for a completely random map (Gardner and O’Neill 1991). If the focal class is more dispersed than is expected of a random distribution (i.e., overdispersed), then PLADJ < Pi. If the focal class is more contagiously distributed, then PLADJ > Pi. Thus, although PLADJ provides an absolute measure of aggregation of the focal class, it is difficult to interpret as a measure of contagion without adjusting for Pi.

FRAGSTATS computes two class-specific indices based on PLADJ that adjust for Pi in different ways. The clumpiness index (CLUMPY) introduced here is computed such that it ranges from -1 when the patch type is maximally disaggregated to 1 when the patch type is maximally clumped. It returns a value of zero for a random distribution, regardless of Pi. Values less than zero indicate greater dispersion (or disaggregation) than expected under a spatially random distribution, and values greater than zero indicate greater contagion. Hence, this index provides a measure of class-specific contagion that effectively isolates the configuration component from the area component and, as such, provides an effective index of fragmentation of the focal class that is not confounded by changes in class area. The aggregation index (AI) is computed as a percentage based on the ratio of the observed number of like adjacencies (ei,i), based on the single-count method, to the maximum possible number of like adjacencies (max_ei,i) given Pi (He et al. 2000). Note, the single-count method of tallying adjacencies is employed to be consistent with the published algorithm. The maximum number of like adjacencies is achieved when the class is clumped into a single compact patch, which does not have to be a square. The trick here is in determining the maximum value of ei,i for any Pi,. He et al. (2000) provide the formula for computing max_ei,i. The index ranges from 0 when there is no like adjacencies (i.e., when the class is maximally dissagregated) to 1 when ei,i reaches the maximum (i.e., when the class is maximally aggregated).

There are alternative methods for calculating class-specific contagion using fractal geometry (Gardner and O’Neill 1991). FRAGSTATS computes the mass fractal dimension (MFRAC) for each class, which is based on the scaling relationship between box mass (i.e., the number of pixels of a focal class within a window) and the size of the box defining the window (r). Specifically, a range of box sizes is used to delineate windows, from 3 pixels on a side (r=3) to a maximum of approximately ⅓ of the landscape. For each box size, the mean number of pixels of the focal class is determined by centering the box on every pixel of that class and counting the number of pixels of that class in the box sample. Mass fractal dimension is equal to the slope derived from regressing the log of the mean number of pixels for each box size on the log of the box lengths (Voss 1988, Milne 1991). Mass fractal dimension decreases as the percentage of the landscape comprised of the focal class decreases. After accounting for this relationship, higher values of mass fractal dimension are associated with higher contagion.

Lacunarity is another method borrowed from fractal geometry by which class-specific contagion can be characterized across a range of spatial scales (Plotnick et al. 1993 and 1996, Dale 2000). Consider a binary ("on/off") raster map of dimension m. The technique involves using a moving window and is concerned with the frequency with which one encounters the focal class in a window of different sizes, similar to the mass fractal dimension. To do this, a gliding box is constructed of dimension r, and a frequency distribution of tallies of S=1,2, ..., r2 "on" cells is constructed. In this gliding, the box is moved over one cell at a time, so that the boxes overlap during the sliding. Define n(S,r) as the number of boxes that tally S "on" cells for a box of size r. There are N(r)=(m-r+1)2 boxes of size r, and the probability associated with n(S,r) is Q(S,r)=n(S,r)/N(r). The first and second moments of Q are used to define lacunarity L (lambda) for this box size as a variance to mean-square ratio. This is repeated for a range of box sizes r. A log-log plot of lacunarity against window size expresses the contagion of the map, or its tendency to aggregate into discrete patches, across a range of spatial scales. Note that as r increases, the tally n(S,r) converges on the mean and its variance converges on 0. Thus, for very large boxes L=1 and ln(L)=0. At the smallest box size (r=1), L(1) = 1/p, where p is the proportion of the map occupied ("on"). Thus, for the finest resolution of a map, L depends solely on p. At intermediate scales, lacunarity expresses the contagion of the map, or its tendency to clump into discrete patches. So the lacunarity plot summarizes the contagion of the map across all scales.

As noted in the background discussion, contagion and subdivision are closely related concepts. Both refer to the aggregation of patch types, but subdivision deals explicitly with the degree to which patch types are broken up (i.e., subdivided) into separate patches (i.e., fragments). Subdivision can be evaluated using a wide variety of metrics already described; for example, the number, density, and average size of patches and the degree of contagion all indirectly relate to subdivision. However, these metrics have been criticized for their insensitivity and inconsistent behavior across a wide range of subdivision patterns. Jaeger (2000) discussed the limitations of these metrics for evaluating habitat fragmentation and concluded that most of these metrics do not behave in a consistent and logical manner across all phases of the fragmentation process. He introduced a suite of metrics derived from the cumulative distribution of patch sizes that provide alternative and more explicit measures of subdivision. When applied at the class level, these metrics can be used to measure the degree of fragmentation of the focal patch type. Applied at the landscape level, these metrics measure the graininess of the landscape; i.e., the tendency of the landscape to exhibit a fine- versus coarse-grain texture. A fine-grain landscape is characterized by many small patches (highly subdivided); whereas, a coarse-grain landscape is characterized by fewer large patches.

FRAGSTATS computes three of the subdivision metrics proposed by Jaeger (2000). All of these metrics are based on the notion that two animals, placed randomly in different areas somewhere in a region, will have a certain likelihood of being in the same undissected area (i.e., the same patch), which is a function of the degree of subdivision of the landscape. The landscape division index (DIVISION) is based on the degree of coherence (C), which is defined as the probability that two animals placed in different areas somewhere in the region of investigation might find each other. Degree of coherence is based on the cumulative patch area distribution and is represented graphically as the area above the cumulative area distribution curve. Degree of coherence represents the probability that two animals, which have been able to move throughout the whole region before the landscape was subdivided, will be found in the same patch after the subdivision is in place. The degree of landscape division is simply the complement of coherence and is defined as the probability that two randomly chosen places in the landscape are not situated in the same undissected patch. Graphically, the degree of landscape division is equal to the area below the cumulative area distribution curve.

The splitting index (SPLIT) is defined as the number of patches one gets when dividing the total landscape into patches of equal size in such a way that this new configuration leads to the same degree of landscape division as obtained for the observed cumulative area distribution. The splitting index can be interpreted to be the “effective mesh number” of a patch mosaic with a constant patch size dividing the landscape into S patches, where S is the splitting index. The effective mesh size (MESH) simply denotes the size of the patches when the landscape is divided into S areas (each of the same size) with the same degree of landscape division as obtained for the observed cumulative area distribution. Thus, all three subdivision metrics are easily computed from the cumulative patch area distribution. These measures have the particular advantage over other conventional measures of subdivision (e.g., mean patch size, patch density) in that they are insensitive to the omission or addition of very small patches. In practice, this makes the results more reproducible as investigators do not always use the same lower limit of patch size. Jaeger (2000) argues that the most important and advantageous feature of these new measures is that effective mesh size is ‘area-proportionately additive’; that is, it characterizes the subdivision of a landscape independently of its size. In fact, these three measures are closely related to the area-weighted mean patch size (AREA_AM) discussed previously, and under certain circumstances are perfectly redundant. The distinctions are discussed below for each metric.


Limitations.–All measures based on the adjacency matrix (i.e., the number of adjacencies between each pair of patch types) that include like-adjacencies (i.e., percentage of like adjacencies, clumpiness index, aggregation index, and contagion) are strongly affected by the grain size or resolution of the image. Given a particular patch mosaic, a smaller grain size will result in a proportional increase in like adjacencies. Given this scale dependency, these metrics are best used if the scale is held constant. Note, interspersion is not affected by resolution directly because only patch edges are considered. In addition, there are alternative ways to consider cell adjacencies. Adjacencies may include only the 4 cells sharing a side with the focal cell, or they may include the diagonal neighbors as well. FRAGSTATS uses the 4-neighbor approach for the purpose of calculating these metrics. Further, there are at least two basic approaches for counting cell adjacencies, referred to as the single count and double count methods. As noted above, FRAGSTATS adopts the double count method in which pixel order is preserved. In this method, all non-background cells inside the landscape (i.e., positively-valued cells ) are visited and the four sides of each cell are tallied in the adjacency matrix. As a result, all cell sides involving non-background classes inside the landscape are tallied twice (hence the term double count), but all cell sides involving background or landscape border (i.e., negatively-valued cells) are only counted once, as those cells are not themselves visited. Finally, mass fractal dimension and lacunarity involve the use of moving windows of many sizes; these can be computationally demanding and for large landscapes may take a very long time to compute.

Metrics based on fractal geometry such as mass fractal dimension are subject to several limitations (as discussed by Hargis et al. 1998). First, the simplifications of landscape pattern produced during the mapping process yield images that are not truly fractal, and the application of fractal measures in the strictest sense is therefore questionable. Fractal geometry assumes that the quantity being measured and the ruler length of measurement have a linear relationship when both are logarithmically transformed (Voss 1988). If this condition is not met, the object (in this case, the landscape) may not be fractal. Any smoothing or renormalization of landscape patterns during the mapping process may cause this relationship to deviate from linearity, and the use of fractal dimension may be questionable. Second, landscape extent and grain affect the ability to derive an accurate scaling relationship between box size and mass. A large ratio of extent to grain is needed to produce a reasonable range of box sizes for generating an accurate slope. Finally, the relationship between grain and average patch size can affect the accuracy and meaningfulness of the derived fractal dimension. If map resolution allows only two or three box sizes before the sample box exceeds the size of the average patch, the slope derived from these points is questionable. In this case, when larger box sizes are added to the regression line, any interesting differences are lost in the averaging process.

The subdivision metrics based on the cumulative patch size distribution are essentially free of any known limitations. Perhaps the greatest limitation is that they have not yet been used extensively by landscape ecologists, so their behavior under various conditions has not been fully explored. In addition, it is important to keep in mind the similarities and differences between these metrics and the closely related concept of contagion.


(C114) Percentage of Like Adjacencies

gii = number of like adjacencies (joins) between pixels of patch type (class) i based on the double-count method.

gik = number of adjacencies (joins) between pixels of patch types (classes) i and k based on the double-count method.

Description

PLADJ equals the number of like adjacencies involving the focal class, divided by the total number of cell adjacencies involving the focal class; multiplied by 100 (to convert to a percentage). In other words, the percentage of cell adjacencies involving the corresponding patch type that are like adjacencies. All background edge segments are included in the sum of all adjacencies involving the focal class, including landscape boundary segments if a border is not provided. Cell adjacencies are tallied using the double-count method in which pixel order is preserved, at least for all internal adjacencies (i.e., involving cells on the inside of the landscape). If a landscape border is present, adjacencies on the landscape boundary are counted only once, as are all adjacencies with background.[gii = intLike+extLike][gik = intTrue+intLike+extTrue+extLike]

Units

Percent

Range

0 ≤ PLADJ ≤ 100

PLADJ equals 0 when the corresponding patch type is maximally disaggregated (i.e., every cell is a different patch) and there are no like adjacencies. This occurs when the class is subdivided into one cell patches. Note, this condition can only be achieved when the proportion of the landscape comprised of the focal class (Pi) is ≤ 0.5. When Pi = 0.5, this occurs only when the class is distributed as a perfect checkerboard. When Pi > 0.5, the checkerboard begins to fill in and there will exist like adjacencies. PLADJ increases as the corresponding patch type becomes increasingly aggregated such that the proportion of like adjacencies increases. PLADJ = 100 when the landscape consists of single patch and all adjacencies are between the same class, and the landscape contains a border comprised entirely of the same class. If the landscape consists of single patch but does not contain a border, PLADJ will be less than 100 due to the background edge segments in the tally of adjacencies involving the focal class. Finally, PLADJ is undefined and reported as “N/A” in the “basename”.class file if the class consists of a single cell.

Comments

Percentage of like adjacencies is calculated from the adjacency matrix, which shows the frequency with which different pairs of patch types (including like adjacencies between the same patch type) appear side-by-side on the map. PLADJ measures the degree of aggregation of the focal patch type. Thus, it is a measure of class-specific contagion. Regardless of how much of the landscape is comprised of the focal class (Pi), this index will be minimum if the patch type is maximally dispersed (or disaggregated), and it will be maximum if the patch type is maximally contagious. However, this index does not account for the fact that the percentage of like adjacencies for a random distribution equals Pi. If the percentage of like adjacencies is less than Pi, then the patch type is more dispersed than expected of a random landscape. Conversely, if the percentage of like adjacencies is greater than Pi, then the patch type is contagiously distributed. Note, this metric measures only dispersion and not interspersion, and thus may be a useful index of fragmentation of the focal class when interpreted in conjunction with Pi.


(C115) Clumpiness Index

gii = number of like adjacencies (joins) between pixels of patch type (class) i based on the double-count method.

gik = number of adjacencies (joins) between pixels of patch types (classes) i and k based on the double-count method.

min-ei = minimum perimeter (in number of cell surfaces) of patch type (class) i for a maximally clumped class.

Pi = proportion of the landscape occupied by patch type (class) i.

Description

CLUMPY equals the proportional deviation of the proportion of like adjacencies involving the corresponding class from that expected under a spatially random distribution. If the proportion of like adjacencies (Gi) is less than the proportion of the landscape comprised of the focal class (Pi) and Pi < 0.5, then CLUMPY equals Gi minus Pi, divided by Pi; else, CLUMPY equals Gi minus Pi, divided by 1 minus Pi. Note, it can be shown that Gi equals 1 when the patch type is maximally clumped, but this requires adjustment for the perimeter of the class. If ai is the area of class i (in terms of number of cells) and n is the side of a largest integer square smaller than ai, and m = ai - n2, then the minimum perimeter of class i (i.e., when it is maximally clumped), min-ei, will take one of the three forms (Milne 1991, Bogaert et al. 2000):

min-ei = 4n, when m = 0, or

min-ei = 4n + 2, when n2 < ai ≤ n(1+n), or

min-ei = 4n + 4, when ai > n(1+n).

Note, gii in the numerator includes only internal like adjacencies; like adjacencies involving cells in the border are not included. The sum of gik in the denominator includes all adjacencies involving the focal class, including adjacencies involving background and all adjacencies involving the landscape boundary, regardless of whether a border is present or not. Cell adjacencies are tallied using the double-count method in which pixel order is preserved. Note, Pi is based on the total landscape area (A) including any internal background present.

Units

None

Range

-1 ≤ CLUMPY ≤ 1

Given any Pi , CLUMPY equals -1 when the focal patch type is maximally disaggregated; CLUMPY equals 0 when the focal patch type is distributed randomly, and approaches 1 when the patch type is maximally aggregated. Note, CLUMPY is undefined and reported as N/A in the output files when the class consists either of a single cell, comprises all but 1 cell, or comprises the entire landscape, because it is impossible to distinguish between clumped, random and dispersed distributions in these cases.

Comments

Clumpiness index is calculated from the adjacency matrix, which shows the frequency with which different pairs of patch types (including like adjacencies between the same patch type) appear side-by-side on the map. Clumpiness is scaled to account for the fact that the proportion of like adjacencies (Gi) will equal Pi for a completely random distribution (see previous discussion). The formula is contingent upon Gi and Pi because the minimum value of Gi has two forms which depend on Pi. Specifically, when Pi ≤ 0.5, Gi = 0 when the class is maximally disaggregated (i.e., subdivided into one cell patches) and is 1 when the class is maximally clumped. However, when Pi ≥ 0.5, Gi = 2Pi -1 when the class is maximally disaggregated and approaches 1 when the class is maximally clumped.


(C116) Aggregation Index

gii = number of like adjacencies (joins) between pixels of patch type (class) i based on the single-count method.

max-gii = maximum number of like adjacencies (joins) between pixels of patch type (class) i (see below) based on the single-count method.

Description

AI equals the number of like adjacencies involving the corresponding class, divided by the maximum possible number of like adjacencies involving the corresponding class, which is achieved when the class is maximally clumped into a single, compact patch; multiplied by 100 (to convert to a percentage). If ai is the area of class i (in terms of number of cells) and n is the side of a largest integer square smaller than ai, and m = ai - n2, then the largest number of shared edges for class i, max-gii will take one of the three forms:

max-gii = 2n(n-1) , when m = 0, or

max-gii = 2n(n-1) + 2m -1, when m ≤ n, or

max-gii = 2n(n-1) + 2m -2, when m > n.

Note, because of the design of the metric, like adjacencies are tallied using the single-count method, and all landscape boundary edge segments are ignored, even if a border is provided.

Units

Percent

Range

0 ≤ AI ≤ 100

Given any Pi , AI equals 0 when the focal patch type is maximally disaggregated (i.e., when there are no like adjacencies); AI increases as the focal patch type is increasingly aggregated and equals 100 when the patch type is maximally aggregated into a single, compact patch. AI is undefined and reported as “N/A" in the "basename".class file if the class consists of a single cell. Note, AI is closely related to the Landscape Shape Index (LSI), only the latter is based on perimeter surfaces as opposed in internal like adjacencies. Both metrics can be normalized to reflect the fact the minimum and maximum values vary depending on Pi; the range of possible values is greatest when Pi = 0.5. The normalized versions of LSI and AI are completely redundant; thus, FRAGSTATS only computes the normalized LSI (nLSI) metric.

Comments

Aggregation index is calculated from an adjacency matrix, which shows the frequency with which different pairs of patch types (including like adjacencies between the same patch type) appear side-by-side on the map. Aggregation index takes into account only the like adjacencies involving the focal class, not adjacencies with other patch types. In addition, in contrast to all of the other metrics based on adjacencies, the aggregation index is based on like adjacencies tallied using the single-count method, in which each cell side is counted only once. Consequently, the tallies given in the “basename”.adj output file are not correct for this metric. Further, because of the design of the metric, landscape boundary edge segments are ignored, even if a border is provided FRAGSTATS handles this case by distinguishing between internal like adjacencies (i.e., like adjacencies involving cells inside the landscape) and external like adjacencies (i.e., like adjacencies between cells inside the landscape and those in the border). Only internal like adjacencies are used in the calculation of this metric; a landscape border has no affect on this metric. The aggregation index is scaled to account for the maximum possible number of like adjacencies given any Pi. The maximum aggregation is achieved when the patch type consists of a single, compact patch, which is not necessarily a square patch.


(C117) Interspersion and Juxtaposition Index
 |  | eik = total length (m) of edge in landscape between patch types (classes) i and k. m = number of patch types (classes) present in the landscape, including the landscape border, if present.
Description | IJI equals minus the sum of the length (m) of each unique edge type involving the corresponding patch type divided by the total length (m) of edge (m) involving the same type, multiplied by the logarithm of the same quantity, summed over each unique edge type; divided by the logarithm of the number of patch types minus 1; multiplied by 100 (to convert to a percentage). In other words, the observed interspersion over the maximum possible interspersion for the given number of patch types. Note, IJI considers all patch types present on an image, including any present in the landscape border, if present. All background edge segments are ignored, as are landscape boundary segments if a border is not provided, because adjacency information for these edge segments is not available and the intermixing of the focal class with background is assumed to be irrelevant.[eik = intTrue+extTrue]
Units | Percent
Range | 0 < IJI ≤ 100 IJI approaches 0 when the corresponding patch type is adjacent to only 1 other patch type and the number of patch types increases. IJI = 100 when the corresponding patch type is equally adjacent to all other patch types (i.e., maximally interspersed and juxtaposed to other patch types). IJI is undefined and reported as “N/A" in the "basename".class file if the number of patch types is less than 3.
Comments | Interspersion and juxtaposition index is based on patch adjacencies, not cell adjacencies like the contagion index. As such, it does not provide a measure of class aggregation like the contagion index, but rather isolates the interspersion or intermixing of patch types.


(C118) Mass Fractal Dimension

r = number of cells on side of box.

nr = number of cells of corresponding class in box of size r.

Description

MFRAC equals the slope of the regression line obtained by regressing the logarithm of mean box mass (mean number of cells of focal class in box) against the logarithm of box size (number pixels on a side) for boxes centered on all cells of the focal class. That is, MFRAC is the coefficient b1 derived from a least squares regression fit to the following equation: ln(box mass) = b0 + b1⋅ln(box size).

Units

None

Range

0 < MFRAC ≤ 2

MFRAC approaches 0 when the percentage of the landscape comprised of the focal class approaches zero. MFRAC increases as an increasing percentage of the landscape is comprised of the focal class and it is maximally aggregated. MFRAC approaches 2 when the focal class comprises 100% of the landscape.

Comments

Mass fractal dimension is based on the scaling relationship between box mass (i.e., the number of pixels of a focal class within a window) and the size of the box defining the window. Specifically, a range of box sizes is used to delineate windows, from 3 pixels on a side to a maximum of approximately ⅓ of the landscape extent. For each box size, the mean number of pixels of the focal class is determined by centering the box on every pixel of that class and counting the number of pixels of that class in the box sample. Mass fractal dimension is equal to the slope derived from regressing the log of the mean number of pixels for each box size on the log of the box lengths. An alternative form of calculating this measure, known as the box dimension, is derived by placing a grid over the entire landscape and counting the number of pixels of the selected class in each grid cell, and repeating this procedure using grids of increasingly finer resolutions. According to Voss (1988), both approaches yield comparable results.


(C119) Landscape Division Index
 |  | aij = area (m2) of patch ij. A = total landscape area (m2).
Description | DIVISION equals 1 minus the sum of patch area (m2) divided by total landscape area (m2), quantity squared, summed across all patches of the corresponding patch type. Note, total landscape area (A) includes any internal background present.
Units | Proportion
Range | 0 ≤ DIVISION < 1 DIVISION = 0 when the landscape consists of single patch. DIVISION approaches 1 when the focal patch type consists of single, small patch one cell in area. As the proportion of the landscape comprised of the focal patch type decreases and as those patches decrease in size, DIVISION approaches 1.
Comments | Division is based on the cumulative patch area distribution and is interpreted as the probability that two randomly chosen pixels in the landscape are not situated in the same patch of the corresponding patch type. Note, the similarity with Simpson’s diversity index, only here the sum is across the proportional area of each patch in the focal class, rather than the proportional area of each patch ‘type’ in the landscape. Note, DIVISION is redundant with effective mesh size (MESH) below, i.e., they are perfectly, but inversely, correlated, but both metrics are included because of differences in units and interpretation. DIVISION is interpreted as a probability, whereas MESH is given as an area.


(C120) Splitting Index
 |  | aij = area (m2) of patch ij. A = total landscape area (m2).
Description | SPLIT equals the total landscape area (m2) squared divided by the sum of patch area (m2) squared, summed across all patches of the corresponding patch type. Note, total landscape area (A) includes any internal background present.
Units | None
Range | 1 ≤ SPLIT ≤ number of cells in the landscape area squared SPLIT = 1 when the landscape consists of single patch. SPLIT increases as the focal patch type is increasingly reduced in area and subdivided into smaller patches. The upper limit of SPLIT is constrained by the ratio of landscape area to cell size and is achieved when the corresponding patch type consists of a single one pixel patch.
Comments | Split is based on the cumulative patch area distribution and is interpreted as the effective mesh number, or number of patches with a constant patch size when the corresponding patch type is subdivided into S patches, where S is the value of the splitting index.


(C121) Effective Mesh Size

aij = area (m2) of patch ij.

A = total landscape area (m2).

Description

MESH equals the sum of patch area squared, summed across all patches of the corresponding patch type, divided by the total landscape area (m2), divided by 10,000 (to convert to hectares). Note, total landscape area (A) includes any internal background present.

Units

Hectares

Range

ratio of cell size to landscape area ≤ MESH ≤ total landscape area (A)

The lower limit of MESH is constrained by the ratio of cell size to landscape area and is achieved when the corresponding patch type consists of a single one pixel patch. MESH is maximum when the landscape consists of a single patch.

Comments

Mesh is based on the cumulative patch area distribution and is interpreted as the size of the patches when the corresponding patch type is subdivided into S patches, where S is the value of the splitting index. Note, MESH is redundant with DIVISION above, i.e., they are perfectly, but inversely, correlated, but both metrics are included because of differences in units and interpretation. DIVISION is interpreted as a probability, whereas MESH is given as an area. In addition, note the similarity between MESH and area-weight mean patch size (AREA_AM). Conceptually, these two metrics are closely related, but computationally they are quite different at the class level. Specifically, AREA_AM gives the area-weight mean patch size of patches of the corresponding class, where the proportional area of each patch is based on total class area (i.e., the total area of patches of the corresponding patch type). MESH, on the other hand, also gives the area-weighted mean patch size of patches of the corresponding patch size, but the proportional area of each patch is based on the total landscape area, not the class area. In this way, MESH takes into account the patch size distribution of the corresponding class as well as the total landscape area comprised of that class. Thus, holding the patch size distribution (of the corresponding class) constant, as the landscape extent increases (and the percent of the landscape comprised of this class decreases), MESH for the corresponding class will decrease. Hence, AREA_AM provides an absolute measure of patch structure, whereas MESH provides a relative measure of patch structure.


(L114) Percentage of Like Adjacencies

gii = number of like adjacencies (joins) between pixels of patch type (class) i based on the double-count method .

gik = number of adjacencies (joins) between pixels of patch types (classes) i and k based on the double-count method.

Description

PLADJ equals sum of the number of like adjacencies for each patch type, divided by the total number of cell adjacencies in the landscape; multiplied by 100 (to convert to a percentage). In other words, the proportion of cell adjacencies involving the same class. PLADJ considers all patch types present on an image, including any present in the landscape border, if present. All background edge segments are included in the denominator, including landscape boundary segments if a border is not provided. Cell adjacencies are tallied using the double-count method in which pixel order is preserved, at least for all internal adjacencies (i.e., involving cells on the inside of the landscape). If a landscape border is present, adjacencies on the landscape boundary are counted only once, as are all adjacencies with background. [gii =intLike+extLike][gik = intTrue+intLike+extTrue+extLike]

Units

Percent

Range

0 ≤ PLADJ ≤ 100

PLADJ equals 0 when the patch types are maximally disaggregated (i.e., every cell is a different patch type) and there are no like adjacencies. PLADJ = 100 when all patch types are maximally aggregated ( i.e., when the landscape consists of single patch and all adjacencies are between the same class), and the landscape contains a border comprised entirely of the same class. If the landscape consists of single patch but does not contain a border, PLADJ will be less than 100 due to the background edge segments along the boundary included in the tally of all adjacencies. PLADJ is undefined and reported as “N/A” in the “basename”.land file if the landscape consists of a single non-background cell.

Comments

Percentage of like adjacencies is calculated from the adjacency matrix, which shows the frequency with which different pairs of patch types (including like adjacencies between the same patch type) appear side-by-side on the map. PLADJ measures the degree of aggregation of patch types. Thus, a landscape containing larger patches with simple shapes will contain a higher percentage of like adjacencies than a landscape with smaller patches and more complex shapes. In contrast to the contagion index at the landscape level, this metric measures only dispersion and not interspersion. Note, regardless of how much of the landscape is comprised of each class, this index will be minimum if all patch types are maximally dispersed (or disaggregated), and it will be maximum if all patch types are maximally contagious.


(L115) Contagion Index

Pi =proportion of the landscape occupied by patch type (class) i.

gik =number of adjacencies (joins) between pixels of patch types (classes) i and k based on the double-count method.

m =number of patch types (classes) present in the landscape, including the landscape border if present.

Description

CONTAG equals minus the sum of the proportional abundance of each patch type multiplied by the proportion of adjacencies between cells of that patch type and another patch type, multiplied by the logarithm of the same quantity, summed over each unique adjacency type and each patch type; divided by 2 times the logarithm of the number of patch types; multiplied by 100 (to convert to a percentage). In other words, the observed contagion over the maximum possible contagion for the given number of patch types. Note, CONTAG considers all patch types present on an image, including any present in the landscape border, if present, and considers like adjacencies (i.e., cells of a patch type adjacent to cells of the same type). All background edge segments are ignored, as are landscape boundary segments if a border is not provided, because adjacency information for these edge segments is not available and the intermixing of the classes with background is assumed to be irrelevant. Cell adjacencies are tallied using the double-count method in which pixel order is preserved, at least for all internal adjacencies (i.e., involving cells on the inside of the landscape). If a landscape border is present, adjacencies on the landscape boundary are counted only once as are all adjacencies with background. Note, Pi is based on the total landscape area (A) excluding any internal background present.[gik = intTrue+intLike+extTrue+extLike]

Units

Percent

Range

0 < CONTAG ≤ 100

CONTAG approaches 0 when the patch types are maximally disaggregated (i.e., every cell is a different patch type) and interspersed (equal proportions of all pairwise adjacencies). CONTAG = 100 when all patch types are maximally aggregated; i.e., when the landscape consists of single patch. CONTAG is undefined and reported as “N/A” in the “basename”.land file if the number of patch types is less than 2, or all classes consist of one cell patches adjacent to only background.

Comments

Contagion is inversely related to edge density. When edge density is very low, for example, when a single class occupies a very large percentage of the landscape, contagion is high, and vice versa. In addition, note that contagion is affected by both the dispersion and interspersion of patch types. Low levels of patch type dispersion (i.e., high proportion of like adjacencies) and low levels of patch type interspersion (i.e., inequitable distribution of pairwise adjacencies results in high contagion, and vice versa.


(L116) Aggregation Index

gii = number of like adjacencies (joins) between pixels of patch type (class) i based on the single-count method.

max-gii = maximum number of like adjacencies (joins) between pixels of patch type (class) i (see below) based on the single-count method.

Pi = proportion of landscape comprised of patch type (class) i.

Description

AI equals the number of like adjacencies involving the corresponding class, divided by the maximum possible number of like adjacencies involving the corresponding class, which is achieved when the class is maximally clumped into a single, compact patch, multiplied the proportion of the landscape comprised of the corresponding class, summed over all classes and multiplied by 100 (to convert to a percentage). If Ai is the area of class i (in terms of number of cells) and n is the side of a largest integer square smaller than Ai, and m = Ai - n2, then the largest number of shared edges for class i, max-gii will take one of the three forms:

max-gii = 2n(n-1), when m = 0,

max-gii = 2n(n-1) + 2m -1, when m ≤ n, or

max-gii = 2n(n-1) + 2m -2, when m > n.

Note, because of the design of the metric, like adjacencies are tallied using the single-count method, and all landscape boundary edge segments are ignored, even if a border is provided. Also, Pi is based on the total landscape area (A) excluding any background present.

Units

Percent

Range

0 ≤ AI ≤ 100

Given any Pi , AI equals 0 when the patch types are maximally disaggregated (i.e., when there are no like adjacencies); AI increases as the landscape is increasingly aggregated and equals 100 when the landscape consists of a single patch. AI is undefined and reported as “N/A" in the "basename".land file if each class consists of a single cell (and hence is undefined).

Comments

Aggregation index is calculated from an adjacency matrix at the class level (see class-level AI comments). At landscape level, the index is computed simply as an area-weighted mean class aggregation index, where each class is weighted by its proportional area in the landscape. The index is scaled to account for the maximum possible number of like adjacencies given any landscape composition.


(L117) Interspersion and Juxtaposition Index
 |  | eik = total length (m) of edge in landscape between patch types (classes) i and k. E = total length (m) of edge in landscape, excluding background. m = number of patch types (classes) present in the landscape, including the landscape border, if present.
Description | IJI equals minus the sum of the length (m) of each unique edge type divided by the total landscape edge (m), multiplied by the logarithm of the same quantity, summed over each unique edge type; divided by the logarithm of the number of patch types times the number of patch types minus 1 divided by 2; multiplied by 100 (to convert to a percentage). In other words, the observed interspersion over the maximum possible interspersion for the given number of patch types. Note, IJI considers all patch types present on an image, including any present in the landscape border, if present. All background edge segments are ignored, as are landscape boundary segments if a border is not provided, because adjacency information for these edge segments is not available and the intermixing of classes with background is assumed to be irrelevant. [eik = intTrue+extTrue][E = intTrue+extTrue]
Units | Percent
Range | 0 < IJI ≤ 100 IJI approaches 0 when the distribution of adjacencies among unique patch types becomes increasingly uneven. IJI = 100 when all patch types are equally adjacent to all other patch types (i.e., maximum interspersion and juxtaposition). IJI is undefined and reported as "N/A" in the "basename".land file if the number of patch types is less than 3.
Comments | Interspersion and juxtaposition index is based on patch adjacencies, not cell adjacencies like the contagion index. As such, it does not provide a measure of class aggregation like the contagion index, but rather isolates the interspersion or intermixing of patch types.


(L118) Landscape Division Index
 |  | aij = area (m2) of patch ij. A = total landscape area (m2).
Description | DIVISION equals 1 minus the sum of patch area (m2) divided by total landscape area (m2), quantity squared, summed across all patches in the landscape. Note, total landscape area (A) includes any internal background present.
Units | Proportion
Range | 0 ≤ DIVISION < 1 DIVISION = 0 when the landscape consists of single patch. DIVISION is achieves its maximum value when the landscape is maximally subdivided; that is, when every cell is a separate patch.
Comments | Division is based on the cumulative patch area distribution and is interpreted as the probability that two randomly chosen pixels in the landscape are not situated in the same patch. Note, the similarity with Simpson’s diversity index, only here the sum is across the proportional area of each patch, rather than the proportional area of each patch type in the landscape. Note, DIVISION is redundant with effective mesh size (MESH) below, i.e., they are perfectly, but inversely, correlated, but both metrics are included because of differences in units and interpretation. DIVISION is interpreted as a probability, whereas MESH is given as an area. In addition, as described below (see MESH), DIVISION is perfectly redundant with area-weighted mean patch size (AREA_AM) when there is no background.


(L119) Splitting Index
 |  | aij = area (m2) of patch ij. A = total landscape area (m2).
Description | SPLIT equals the total landscape area (m2) squared divided by the sum of patch area (m2) squared, summed across all patches in the landscape. Note, total landscape area (A) includes any internal background present.
Units | None
Range | 1 ≤ SPLIT ≤ number of cells in the landscape squared SPLIT = 1 when the landscape consists of single patch. SPLIT increases as the landscape is increasingly subdivided into smaller patches and achieves its maximum value when the landscape is maximally subdivided; that is, when every cell is a separate patch.
Comments | Split is based on the cumulative patch area distribution and is interpreted as the effective mesh number, or number of patches with a constant patch size when the landscape is subdivided into S patches, where S is the value of the splitting index.


(L120) Effective Mesh Size

aij = area (m2) of patch ij.

A = total landscape area (m2).

Description

MESH equals 1 divided by the total landscape area (m2) multiplied by the sum of patch area (m2) squared, summed across all patches in the landscape. Note, total landscape area (A) includes any internal background present.

Units

Hectares

Range

cell size ≤ MESH ≤ total landscape area (A)

The lower limit of MESH is constrained by the cell size and is achieved when the landscape is maximally subdivided; that is, when every cell is a separate patch. MESH is maximum when the landscape consists of a single patch.

Comments

Mesh is based on the cumulative patch area distribution and is interpreted as the size of the patches when the landscape is subdivided into S patches, where S is the value of the splitting index. Note, MESH is redundant with DIVISION above, i.e., they are perfectly, but inversely, correlated, but both metrics are included because of differences in units and interpretation. DIVISION is interpreted as a probability, whereas MESH is given as an area. In addition, note the similarity between MESH and area-weight mean patch size (AREA_AM). Conceptually and computationally, these two metrics are almost identical at the landscape level, and under most circumstances will return identical values. Specifically, AREA_AM gives the area-weight mean patch size, where the proportional area of each patch is based on total landscape area excluding any background (i.e., background is excluded from the total landscape area). MESH also gives the area-weighted mean patch size, but the proportional area of each patch is based on the total landscape area including any background. Background is included in the so-called ‘pedestal’ of Jaeger (2000). Thus, if there is no internal background, these metrics will return identical values. If there is internal background, these metrics will return different values, and the magnitude of the difference will depend on the proportional extent of background. In the latter case, the choice of metrics depends on how you want to consider background.


CONNECTIVITY METRICS

Background

FRAGSTATS Metrics

Limitations

Code | Metric (acronym)
Class Metrics
C121 | Patch Cohesion Index ( COHESION )
C122 | Connectance Index ( CONNECT )
C123 | Traversability Index ( TRAVERSE )
Landscape Metrics
L121 | Patch Cohesion Index ( COHESION )
L122 | Connectance Index ( CONNECT )
L123 | Traversability Index ( TRAVERSE )


Background.–Connectivity refers to the degree to which a landscape facilitates or impedes ecological flows (e.g., the movement of organisms among habitat patches and therefore the rate of movement among local populations in a metapopulation). An abrupt change in the connectivity of the landscape, for example, as might be caused by habitat loss and fragmentation, may interfere with dispersal success, such that formerly widespread populations may suddenly become fragmented into small, isolated populations. This may in turn lead to an abrupt decline in patch occupancy (metapopulation dynamics) and ultimately extinction of the population across the landscape (extinction thresholds).

Although connectivity is considered a “vital element of landscape structure” (Taylor et al., 1993), it has eluded precise definition and has been difficult to quantify and implement in practice. In part, this is due to differences between the “structural connectedness” of patch types (or habitat) and the “functional connectedness” of the landscape as perceived by an organism or ecological process. Structural connectedness refers to the physical continuity of a patch type (or a habitat) across the landscape. Contiguous habitat is physically connected, but once subdivided, for example, as a result of habitat fragmentation, it becomes physically disconnected. Structural connectedness can be evaluated by a combination of measures of habitat extent, subdivision, and contagion. The notion of structural connectedness adopts an island biogeographic perspective because the focus is on the physical continuity of a single patch type. What constitutes "functional connectedness" between patches, on the other hand, clearly depends on the organism or process of interest; patches that are connected for bird dispersal might not be connected for salamanders, seed dispersal, fire spread, or hydrologic flow. As With (1999) notes, “what ultimately influences the connectivity of the landscape from the organism’s perspective is the scale and pattern of movement (scale at which the organism perceives the landscape) relative to the scale and pattern of patchiness (structure of the landscape); ...i.e., a species’ gap-crossing or dispersal ability relative to the gap-size distribution on the landscape”(Dale et al. 1994, With and Crist 1995, Pearson et al. 1996, With et al. 1997). Functional connectedness, therefore, relates to the interaction of ecological flows (including organisms) with landscape pattern. Functional connections might be based on: (1) strict adjacency (touching) or some threshold distance (a maximum dispersal distance); (2) some decreasing function of distance that reflects the probability of connection at a given distance; or (3) a resistance-weighted distance function, e.g., where the distance between two patches is computed as the least cost distance on a resistance surface, where each intervening location between habitat patches is assigned a resistance value based on its permeability to movement by the focal organism. Then various indices of overall connectedness can be derived based on the pairwise connections between patches.


FRAGSTATS Metrics.–Although connectivity can be evaluated using a wide variety of FRAGSTATS metrics that indirectly say something about either the structural or functional connectedness of the landscape, FRAGSTATS computes a few metrics whose sole purpose is to measure connectivity. Patch cohesion (COHESION) was proposed by Schumaker (1996) to quantify the connectivity of habitat as perceived by organisms dispersing in binary landscapes. Patch cohesion is computed from the information contained in patch area and perimeter. Briefly, it is proportional to the area-weighted mean perimeter-area ratio divided by the area-weighted mean patch shape index (i.e., standardized perimeter-area ratio). It is well known that, on random binary maps, patches gradually coalesce as the proportion of habitat cells increases, forming a large, highly connected patch (termed a percolating cluster) that spans that lattice at a critical proportion (pc) that varies with the neighbor rule used to delineate patches (Staufer 1985, Gardner et al. 1987). Patch cohesion has the interesting property of increasing monotonically until an asymptote is reached near the critical proportion. Another index, connectance (CONNECT), can be defined on the number of functional joinings, where each pair of patches is either connected or not based on some criterion. FRAGSTATS computes connectance using a threshold distance specified by the user and reports it as a percentage of the maximum possible connectance given the number of patches. The threshold distance can be based on either Euclidean distance or functional distance, as described elsewhere (see Isolation/Proximity Metrics). Connectedness can also be defined in terms of correlation length for a raster map comprised of patches defined as clusters of connected cells. Correlation length is based on the average extensiveness of connected cells, and is computed as the area-weighted mean radius of gyration across all patches in the class or landscape. Correlation length is not included with the connectivity metrics in the FRAGSTATS graphical user interface because it is already included as a distribution metric for patch radius of gyration (GYRATE_AM) under the Area/Density/Edge metrics. A map's correlation length is interpreted as the average distance one might traverse the map, on average, from a random starting point and moving in a random direction, i.e., it is the expected traversability of the map (Keitt et al. 1997).

Finally, FRAGSTATS also computes a traversability index (TRAVERSE) based on the idea of ecological resistance. A hypothetical organism in a highly traversable neighborhood cell can reach a large area with minimal crossing of “hostile” cells. This metric uses a resistance-weighted spread algorithm to determine the area that can be reached from each cell in a focal patch. The focal cell gets an organism-specific “bank account,” which represents, say, an energy budget available to the organism for dispersal from the focal cell. The size of the account is selected to reflect the organism’s dispersal or movement ability, and translates into ecological neighborhood size around a focal cell. Each patch type (including the focal patch type) is assigned a cost, based on a user-specified resistance matrix. Specifically, relative to a each focal patch type, each patch type is assigned a resistance coefficient in the form of weights ranging from 1 (minimum resistance, usually associated with focal patch type) to any higher number that reflects the relative increase in resistance associated with each patch type. The index is computed at the individual cell level as follows. The metric is computed by simulating movement away from the focal cell in all directions, where there is a cost to move through every cell. Even a cell of the same patch type will have a cost, usually set to 1, so that under the best circumstances (i.e., minimum resistance), there will exist a maximum dispersal area based on the specified account or energy budget. Note that assigning a (small) cost for traveling through the focal community (typically a cost of 1) results in a linearly decaying function. Moving through more resistant cells costs more and drains the account faster. Thus, depending on the resistance of the actual landscape in the vicinity of the focal cell, there will be a certain area that a dispersing organism can access. This area represents the least-cost hull around the focal cell, or the maximum distance that can be moved from the cell in all directions until the “bank account” is depleted. This dispersal area, given as a percentage of the maximum dispersal area under conditions of minimum resistance, provides a measure of the traversability of the landscape in the vicinity of the focal cell. Averaging this index across cells at the patch, class, or landscape level provides an index of traversability.


Limitations.–These metrics are limited in a variety of ways. First, patch cohesion is based on perimeter and area calculations and is therefore subject to the same limitations discussed elsewhere (see Area/Density/Edge Metrics) for edge calculations. Moreover, despite its appealing performance under certain conditions (e.g., Schumaker 1996), this index is plagued by the lack of a straightforward and intuitive interpretation. As a result, it remains largely untested in other ecological applications. Like all distance-based metrics, connectance suffers from the same limitations as nearest-neighbor distance (see Isolation/Proximity Metrics). Specifically, only patches within the landscape are considered when determining if a patch is connected or not, despite the fact that a patches’ nearest neighbor may be just outside the landscape boundary. Finally, like all functional metrics, the traversability index requires substantial knowledge of the organism or process under consideration in order to specify meaningful resistance coefficients. If the weighting scheme does not accurately represent the phenomenon under investigation, then the results will be spurious.


(C121) Patch Cohesion Index
 |  | pij = perimeter of patch ij in terms of number of cell surfaces. aij = area of patch ij in terms of number of cells. A = total number of cells in the landscape.
Description | COHESION equals 1 minus the sum of patch perimeter (in terms of number of cell surfaces) divided by the sum of patch perimeter times the square root of patch area (in terms of number of cells) for patches of the corresponding patch type, divided by 1 minus 1 over the square root of the total number of cells in the landscape, multiplied by 100 to convert to a percentage. Note, total landscape area (A) excludes any internal background present.[pij =intTrue+intBack+extTrue+extBack+extLike]
Units | None
Range | 0 ≤ COHESION < 100 COHESION approaches 0 as the proportion of the landscape comprised of the focal class decreases and becomes increasingly subdivided and less physically connected. COHESION increases monotonically as the proportion of the landscape comprised of the focal class increases until an asymptote is reached near the percolation threshold (see background discussion). COHESION is given as 0 if the landscape consists of a single non-background cell.
Comments | Patch cohesion index measures the physical connectedness of the corresponding patch type. Below the percolation threshold, patch cohesion is sensitive to the aggregation of the focal class. Patch cohesion increases as the patch type becomes more clumped or aggregated in its distribution; hence, more physically connected. Above the percolation threshold, patch cohesion does not appear to be sensitive to patch configuration (Gustafson 1998).


(C122) Connectance Index
 |  | cijk = joining between patch j and k (0 = unjoined, 1 = joined) of the corresponding patch type (i), based on a user specified threshold distance. ni = number of patches in the landscape of the corresponding patch type (class).
Description | CONNECT equals the number of functional joinings between all patches of the corresponding patch type (sum of cijk where cijk = 0 if patch j and k are not within the specified distance of each other and cijk = 1 if patch j and k are within the specified distance), divided by the total number of possible joinings between all patches of the corresponding patch type, multiplied by 100 to convert to a percentage.
Units | Percent
Range | 0 ≤ CONNECT ≤ 100 CONNECT = 0 when either the focal class consists of a single patch or none of the patches of the focal class are "connected" (i.e., within the user-specified threshold distance of another patch of the same type). CONNECT = 100 when every patch of the focal class is "connected."
Comments | Connectance is defined on the number of functional joinings between patches of the corresponding patch type, where each pair of patches is either connected or not based on a user-specified distance criterion. Connectance is reported as a percentage of the maximum possible connectance given the number of patches. Note, connectance can be based on either Euclidean distance or functional distance, as described elsewhere (see Isolation/Proximity Metrics), although this is not implemented yet. Also, note that Euclidean distances are calculated from cell center to cell center. Thus, two patches that have 10 10-m cells between them have a computed distance of 110 m, not 100 m.


(C123) Traversability Index
 |  | tir = least cost hull area around the rth cell in the focal patch type (i). zi = total number of cells in the focal patch type (i). tmax = maximum least cost hull area around a cell of the focal patch type (i) given minimum resistance.
Description | TRAVERSE equals the sum of the least cost hull area across all cells in the focal patch type, divided by the number of cells in the focal patch type (i.e., the mean least cost hull area for the focal patch type), divided by the maximum least cost hull area; multiplied by 100 to convert to a percentage.
Units | Percent
Range | 0 ≤ TRAVERSE ≤ 100 TRAVERSE equals 0 when the focal patch is a single cell and it is surrounded by hostile patch types that prevent any movement (i.e., function as barriers). This is achieved when the resistance coefficient for the neighboring patch type(s) is greater than the user-specified bank account for the focal cell. TRAVERSE equals 100 when the focal patch is surrounded by minimally resistant patch types (i.e., resistance weight = 1).
Comments | Traversability index is computed at the cell level and then averaged across cells in the focal patch. As a result, this metric requires substantial computations and may take considerable time to compute for a large landscape. In addition, this metric requires the user to specify an appropriate resistance matrix containing coefficients for each pairwise combination of patch types, as well as a scaling factor that governs the size of the maximum least cost hull; that is, the size of the area surrounding the focal cell that is accessible given minimum resistance. The size of maximum least cost hull is based on a user-specified maximum distance or neighborhood distance. Based on this distance, FRAGSTATS computes the “bank account” needed to achieve a circular least cost hull with a radius equal to this distance.


(L121) Patch Cohesion Index
 |  | pij = perimeter of patch ij in terms of number of cell surfaces. aij = area of patch ij in terms of number of cells. A = total number of cells in the landscape.
Description | COHESION equals 1 minus the sum of patch perimeter (in terms of number of cells) divided by the sum of patch perimeter times the square root of patch area (in terms of number of cells) for all patches in the landscape, divided by 1 minus 1 over the square root of the total number of cells in the landscape, multiplied by 100 to convert to a percentage. Note, total landscape area (A) excludes any internal background present.[pij =intTrue+intBack+extTrue+extBack+extLike]
Units | None
Range | The behavior of this metric at the landscape level has not yet been evaluated.
Comments | Patch cohesion index at the class level measures the physical connectedness of the corresponding patch type. However, at the landscape level, the behavior of this metric has not yet been evaluated.


(L122) Connectance Index
 |  | cijk = joining between patch j and k (0 = unjoined, 1 = joined) of the same patch type, based on a user-specified threshold distance. ni = number of patches in the landscape of each patch type (i).
Description | CONNECT equals the number of functional joinings between all patches of the same patch type (sum of cijk where cijk = 0 if patch j and k are not within the specified distance of each other and cijk = 1 if patch j and k are within the specified distance), divided by the total number of possible joinings between all patches of the same type, multiplied by 100 to convert to a percentage.
Units | Percent
Range | 0 ≤ CONNECT ≤ 100 CONNECT = 0 when either the landscape consists of a single patch, or all classes consist of a single patch, or none of the patches in the landscape are "connected" (i.e., within the user-specified threshold distance of another patch of the same type). CONNECT = 100 when every patch in the landscape is "connected."
Comments | Connectance is defined on the number of functional joinings between patches of the same type, where each pair of patches is either connected or not based on a user-specified distance criterion. Connectance is reported as a percentage of the maximum possible connectance given the number of patches. Note, connectance can be based on either Euclidean distance or functional distance, as described elsewhere (see Isolation/Proximity Metrics), although this is not implemented yet. Also, note that Euclidean distances are calculated from cell center to cell center. Thus, two patches that have 10 10-m cells between them have a computed distance of 110 m, not 100 m.


(L123) Traversability Index
 |  | tr = least cost hull area around the rth cell in the landscape. Z = total number of cells in the landscape. tmax = maximum least cost hull area around a focal cell of any type given minimum resistance.
Description | TRAVERSE equals the sum of the least cost hull area across all cells in the landscape, divided by the number of cells in the landscape (i.e., the mean least cost hull area for the landscape), divided by the maximum least cost hull area; multiplied by 100 to convert to a percentage.
Units | Percent
Range | 0 ≤ TRAVERSE ≤ 100 TRAVERSE equals 0 when every cell is a separate patch and is surrounded by hostile patch types that prevent any movement (i.e., function as barriers). This is achieved when the resistance coefficients for all patch type(s) are greater than the user-specified bank account. TRAVERSE equals 100 when every cell is surrounded by minimally resistant patch types (i.e., resistance weight = 1). This can occur when the landscape consists of a single patch type or when all resistance coefficients are set to the minimum value. However, in the latter case, the use of this metric would be pointless.
Comments | Traversability index is computed at the cell level and then averaged across cells in the landscape. As a result, this metric requires substantial computations and may take considerable time to compute for a large landscape. In addition, this metric requires the user to specify an appropriate resistance matrix containing coefficients for each pairwise combination of patch types, as well as a scaling factor that governs the size of the maximum least cost hull; that is, the size of the area surrounding the focal cell that is accessible given minimum resistance. The size of maximum least cost hull is based on a user-specified maximum distance or neighborhood distance. Based on this distance, FRAGSTATS computes the “bank account” needed to achieve a circular least cost hull with a radius equal to this distance.


DIVERSITY METRICS

Background

FRAGSTATS Metrics

Limitations

Code | Metric (acronym)
Landscape Metrics
L124 | Patch Richness ( PR )
L125 | Patch Richness Density ( PRD )
L126 | Relative Patch Richness ( RPR )
L127 | Shannon’s Diversity Index ( SHDI )
L128 | Simpson’s Diversity Index ( SIDI )
L129 | Modified Simpson’s Diversity Index ( MSIDI )
L130 | Shannon’s Evenness Index ( SHEI )
L131 | Simpson’s Evenness Index ( SIEI )
L132 | Modified Simpson’s Evenness Index ( MSIEI )


Background.–Diversity measures have been used extensively in a variety of ecological applications. They originally gained popularity as measures of plant and animal species diversity. There has been a proliferation of diversity indices and we will make no attempt to review them here. FRAGSTATS computes 3 diversity indices. These diversity measures are influenced by 2 components--richness and evenness. Richness refers to the number of patch types present; evenness refers to the distribution of area among different types. Richness and evenness are generally referred to as the compositional and structural components of diversity, respectively. Some indices (e.g., Shannon's diversity index) are more sensitive to richness than evenness. Thus, rare patch types have a disproportionately large influence on the magnitude of the index. Other indices (e.g., Simpson's diversity index) are relatively less sensitive to richness and thus place more weight on the common patch types. These diversity indices have been applied by landscape ecologists to measure one aspect of landscape structure--landscape composition (e.g., Romme 1982, O'Neill et al. 1988, Turner 1990a).


FRAGSTATS Metrics.–FRAGSTATS computes several statistics that quantify diversity at the landscape level. These metrics quantify landscape composition at the landscape level; they are not affected by the spatial configuration of patches. The most popular diversity index is Shannon's diversity index (SHDI) based on information theory (Shannon and Weaver 1949). The value of this index represents the amount of "information" per individual (or patch, in this case). Information is a somewhat abstract mathematical concept that we will not attempt to define. The absolute magnitude of Shannon's diversity index is not particularly meaningful; therefore, it is used as a relative index for comparing different landscapes or the same landscape at different times. Simpson's diversity index (SIDI) is another popular diversity measure that is not based on information theory (Simpson 1949). Simpson's index is less sensitive to the presence of rare types and has an interpretation that is much more intuitive than Shannon's index. Specifically, the value of Simpson's index represents the probability that any two cells selected at random would be different patch types. Thus, the higher the value the greater the likelihood that any 2 randomly drawn cells would be different patch types. Because Simpson's index is a probability, it can be interpreted in both absolute and relative terms. FRAGSTATS also computes a modified Simpson's diversity index (MSIDI) based on Pielou's (1975) modification of Simpson's diversity index; this index was used by Romme (1982). The modification eliminates the intuitive interpretation of Simpson's index as a probability, but transforms the index into one that belongs to a general class of diversity indices to which Shannon's diversity index belongs (Pielou 1975). Thus, the modified Simpson's and Shannon's diversity indices are similar in many respects and have the same applicability.

Patch richness (PR) measures the number of patch types present; it is not affected by the relative abundance of each patch type or the spatial arrangement of patches. Therefore, two landscapes may have very different structure yet have the same richness. For example, one landscape may be comprised of 96% patch type A and 1% each of patch types B-E, whereas another landscape may be comprised of 20% each of patch types A-E. Although patch richness would be the same, the functioning of these landscapes and the structure of the animal and plant communities would likely be greatly different. Because richness does not account for the relative abundance of each patch type, rare patch types and common patch types contribute equally to richness. Nevertheless, patch richness is a key element of landscape structure because the variety of landscape elements present in a landscape can have an important influence on a variety of ecological processes. Because many organisms are associated with a single patch type, patch richness often correlates well with species richness.

Richness is partially a function of scale. Larger areas are generally richer because there is generally greater heterogeneity over larger areas than over comparable smaller areas. This contributes to the species-area relationship predicted by island biogeographic theory (MacArthur and Wilson 1967). Therefore, comparing richness among landscapes that vary in size can be problematic. Patch richness density (PRD) standardizes richness to a per area basis that facilitates comparison among landscapes, although it does not correct for this interaction with scale. FRAGSTATS also computes a relative richness index. Relative patch richness (RPR) is similar to patch richness, but it represents richness as a percentage of the maximum potential richness as specified by the user (Romme 1982). This form may have more interpretive value than absolute richness or richness density in some applications. Note that relative patch richness and patch richness are completely redundant and would not be used simultaneously in any subsequent statistical analysis.

Evenness measures the other aspect of landscape diversity--the distribution of area among patch types. There are numerous ways to quantify evenness and most diversity indices have a corresponding evenness index derived from them. In addition, evenness can be expressed as its compliment--dominance (i.e., evenness = 1 - dominance). Indeed, dominance has often been the chosen form in landscape ecological investigations (e.g., O'Neill et al. 1988, Turner et al. 1989, Turner 1990a), although we prefer evenness because larger values imply greater landscape diversity. FRAGSTATS computes 3 evenness indices (Shannon's evenness index, SHEI; Simpson's evenness index, SIEI; modified Simpson's evenness index, MSIEI), corresponding to the 3 diversity indices. Each evenness index isolates the evenness component of diversity by controlling for the contribution of richness to the diversity index. Evenness is expressed as the observed level of diversity divided by the maximum possible diversity for a given patch richness. Maximum diversity for any level of richness is achieved when there is an equal distribution of area among patch types. Therefore, the observed diversity divided by the maximum diversity (i.e., equal distribution) for a given number of patch types represents the proportional reduction in the diversity index attributed to lack of perfect evenness. As the evenness index approaches 1, the observed diversity approaches perfect evenness. Because evenness is represented as a proportion of maximum evenness, Shannon's evenness index does not suffer from the limitation of Shannon's diversity index with respect to interpretability.


Limitations.–The use of diversity measures in community ecology has been heavily criticized because diversity conveys no information on the actual species composition of a community. Species diversity is a community summary measure that does not take into account the uniqueness or potential ecological, social, or economical importance of individual species. A community may have high species diversity yet be comprised largely of common or undesirable species. Conversely, a community may have low species diversity yet be comprised of especially unique, rare, or highly desired species. Although these criticisms have not been discussed explicitly with regards to the landscape ecological application of diversity measures, these criticisms are equally valid when diversity measures are applied to patch types instead of species. In addition, diversity indices like Shannon’s index and Simpson’s index combine richness and evenness components into a single measure, even though it is usually more informative to evaluate richness and evenness independently.


(L124) Patch Richness
 |  | m = number of patch types (classes) present in the landscape, excluding the landscape border if present.
Description | PR equals the number of different patch types present within the landscape boundary.
Units | None
Range | PR ≥ 1, without limit
Comments | Patch richness is perhaps the simplest measure of landscape composition, but note that it does not reflect the relative abundances of patch types. Note, this metric is redundant with both patch richness density and relative patch richness.


(L125) Patch Richness Density
 |  | m = number of patch types (classes) present in the landscape, excluding the landscape border if present. A = total landscape area (m2).
Description | PR equals the number of different patch types present within the landscape boundary divided by total landscape area (m2), multiplied by 10,000 and 100 (to convert to 100 hectares). Note, total landscape area (A) includes any internal background present.
Units | Number per 100 hectares
Range | PRD > 0, without limit
Comments | Patch richness density standardizes richness to a per area basis that facilitates comparison among landscapes. Note, this metric is redundant with both patch richness and relative patch richness.


(L126) Relative Patch Richness
 |  | m = number of patch types (classes) present in the landscape, excluding the landscape border if present.
Description | RPR equals the number of different patch types present within the landscape boundary divided by the maximum potential number of patch types specified by the user, based on the particular patch type classification scheme, multiplied by 100 (to convert to percent).
Units | Percent
Range | 0 < RPR ≤ 100 RPR approaches 0 when the landscape contains a single patch type, yet the number of potential patch types is very large. RPR = 100 when all possible patch types are represented in the landscape.
Comments | Relative patch richness is similar to patch richness, but it represents richness as a percentage of the maximum potential richness as specified by the user. Note, this metric is redundant with both patch richness and patch richness density.


(L127) Shannon's Diversity Index
 |  | Pi = proportion of the landscape occupied by patch type (class) i.
Description | SHDI equals minus the sum, across all patch types, of the proportional abundance of each patch type multiplied by that proportion. Note, Pi is based on total landscape area (A) excluding any internal background present.
Units | Information
Range | SHDI ≥ 0, without limit SHDI = 0 when the landscape contains only 1 patch (i.e., no diversity). SHDI increases as the number of different patch types (i.e., patch richness, PR) increases and/or the proportional distribution of area among patch types becomes more equitable.
Comments | Shannon’s diversity index is a popular measure of diversity in community ecology, applied here to landscapes. Shannon’s index is somewhat more sensitive to rare patch types than Simpson’s diversity index.


(L128) Simpson's Diversity Index
 |  | Pi = proportion of the landscape occupied by patch type (class) i.
Description | SIDI equals 1 minus the sum, across all patch types, of the proportional abundance of each patch type squared. Note, Pi is based on total landscape area (A) excluding any internal background present.
Units | None
Range | 0 ≤ SIDI < 1 SIDI = 0 when the landscape contains only 1 patch (i.e., no diversity). SIDI approaches 1 as the number of different patch types (i.e., patch richness, PR) increases and the proportional distribution of area among patch types becomes more equitable.
Comments | Simpson’s diversity index is another popular diversity measure borrowed from community ecology. Simpson's index is less sensitive to the presence of rare types and has an interpretation that is much more intuitive than Shannon's index. Specifically, the value of Simpson's index represents the probability that any 2 pixels selected at random would be different patch types.


(L129) Modified Simpson's Diversity Index
 |  | Pi = proportion of the landscape occupied by patch type (class) i.
Description | MSIDI equals minus the logarithm of the sum, across all patch types, of the proportional abundance of each patch type squared. Note, Pi is based on total landscape area (A) excluding any internal background present.
Units | None
Range | MSIDI ≥ 0, without limit MSIDI = 0 when the landscape contains only 1 patch (i.e., no diversity). MSIDI increases as the number of different patch types (i.e., patch richness, PR) increases and the proportional distribution of area among patch types becomes more equitable.
Comments | Modified Simpson's diversity index eliminates the intuitive interpretation of Simpson's index as a probability, but transforms the index into one that belongs to a general class of diversity indices to which Shannon's diversity index belongs.


(L130) Shannon's Evenness Index
 |  | Pi = proportion of the landscape occupied by patch type (class) i. m = number of patch types (classes) present in the landscape, excluding the landscape border if present.
Description | SHEI equals minus the sum, across all patch types, of the proportional abundance of each patch type multiplied by that proportion, divided by the logarithm of the number of patch types. In other words, the observed Shannon's Diversity Index divided by the maximum Shannon's Diversity Index for that number of patch types. Note, Pi is based on total landscape area (A) excluding any internal background present.
Units | None
Range | 0 ≤ SHEI ≤ 1 SHDI = 0 when the landscape contains only 1 patch (i.e., no diversity) and approaches 0 as the distribution of area among the different patch types becomes increasingly uneven (i.e., dominated by 1 type). SHDI = 1 when distribution of area among patch types is perfectly even (i.e., proportional abundances are the same).
Comments | Shannon’s evenness index is expressed such that an even distribution of area among patch types results in maximum evenness. As such, evenness is the complement of dominance.


(L131) Simpson's Evenness Index
 |  | Pi = proportion of the landscape occupied by patch type (class) i. m = number of patch types (classes) present in the landscape, excluding the landscape border if present.
Description | SIEI equals 1 minus the sum, across all patch types, of the proportional abundance of each patch type squared, divided by 1 minus 1 divided by the number of patch types. In other words, the observed Simpson's Diversity Index divided by the maximum Simpson's Diversity Index for that number of patch types. Note, Pi is based on total landscape area (A) excluding any internal background present.
Units | None
Range | 0 ≤ SIEI ≤ 1 SIDI = 0 when the landscape contains only 1 patch (i.e., no diversity) and approaches 0 as the distribution of area among the different patch types becomes increasingly uneven (i.e., dominated by 1 type). SIDI = 1 when distribution of area among patch types is perfectly even (i.e., proportional abundances are the same).
Comments | Simpson’s evenness index is expressed such that an even distribution of area among patch types results in maximum evenness. As such, evenness is the complement of dominance.


(L132) Modified Simpson's Evenness Index
 |  | Pi = proportion of the landscape occupied by patch type (class) i. m = number of patch types (classes) present in the landscape, excluding the landscape border if present.
Description | MSIEI equals minus the logarithm of the sum, across all patch types, of the proportional abundance of each patch type squared, divided by the logarithm of the number of patch types. In other words, the observed modified Simpson's diversity index divided by the maximum modified Simpson's diversity index for that number of patch types. Note, Pi is based on total landscape area (A) excluding any internal background present.
Units | None
Range | 0 ≤ MSIEI ≤ 1 MSIDI = 0 when the landscape contains only 1 patch (i.e., no diversity) and approaches 0 as the distribution of area among the different patch types becomes increasingly uneven (i.e., dominated by 1 type). MSIDI = 1 when distribution of area among patch types is perfectly even (i.e., proportional abundances are the same).
Comments | Modified Simpson’s evenness index is expressed such that an even distribution of area among patch types results in maximum evenness. As such, evenness is the complement of dominance.


Class Metrics

Class metrics are computed for every patch type or class in the landscape; the resulting class output file contains a row (observation vector) for every class, where the columns (fields) represent the individual metrics. The first two columns include header information about the class:

(C1) Landscape ID.--The first field in the class output file is landscape ID (LID). Landscape ID is set to the name of the input image obtained from the input file (see Run Parameters).

(C2) Patch Type.--The second field in the class output file is patch type (TYPE). FRAGSTATS contains an option to name an ASCII file (class properties file) that contains character descriptors for each patch type. If the class descriptor option is not used, FRAGSTATS will write the numeric patch type codes to TYPE.

There are two basic types of metrics at the class level: (1) indices of the amount and spatial configuration of the class, and (2) distribution statistics that provide first- and second-order statistical summaries of the patch metrics for the focal class. The latter are used to summarize the mean, area-weighted mean, median, range, standard deviation, and coefficient of variation in the patch attributes across all patches in the focal class. Because the distribution statistics are computed similarly for all class metrics, they are described in common below:

Class Distribution Statistics.--Class metrics measure the aggregate properties of the patches belonging to a single class or patch type. Some class metrics go about this by characterizing the aggregate properties without distinction among the separate patches that comprise the class. These metrics are defined elsewhere. Another way to quantify the configuration of patches at the class level is to summarize the aggregate distribution of the patch metrics for all patches of the corresponding patch type. In other words, since the class represents an aggregation of patches of the same type, we can characterize the class by summarizing the patch metrics for the patches that comprise each class. There are many possible first- and second-order statistics that can be used to summarize the patch distribution. FRAGSTATS computes the following: (1) mean (MN), (2) area-weighted mean (AM), (3) median (MD), (4) range (RA), (5) standard deviation (SD), and (6) coefficient of variation (CV). FRAGSTATS computes these distribution statistics for all patch metrics at the class level. In the class output file, these metrics are labeled by concatenating the metric acronym with an underscore and the distribution statistic acronym. For example, patch area (AREA) is summarized at the class level by each of the distribution statistics and reported in the class output file as follows: mean patch area (AREA_MN), area-weighted mean patch area (AREA_AM), median patch area (AREA_MD), range in patch area (AREA_RA), standard deviation in patch area (AREA_SD), and coefficient of variation in patch area (AREA_CV).

MN (Mean) equals the sum, across all patches of the corresponding patch type, of the corresponding patch metric values, divided by the number of patches of the same type. MN is given in the same units as the corresponding patch metric.

AM (area-weighted mean) equals the sum, across all patches of the corresponding patch type, of the corresponding patch metric value multiplied by the proportional abundance of the patch [i.e., patch area (m2) divided by the sum of patch areas].

MD (median) equals the value of the corresponding patch metric for the patch representing the midpoint of the rank order distribution of patch metric values for patches of the corresponding patch type.

RA (range) equals the value of the corresponding patch metric for the largest observed value minus the smallest observed value (i.e., the difference between the maximum and minimum observed values) for patches of the corresponding patch type.

SD (standard deviation) equals the square root of the sum of the squared deviations of each patch metric value from the mean metric value of the corresponding patch type, divided by the number of patches of the same type; that is, the root mean squared error (deviation from the mean) in the corresponding patch metric. Note, this is the population standard deviation, not the sample standard deviation.

CV (coefficient of variation) equals the standard deviation divided by the mean, multiplied by 100 to convert to a percentage, for the corresponding patch metric.


General Comments

Not all groups of metrics (see previous list) have metrics at all levels. For example, diversity metrics only exist at the landscape level. Also note that the organizational hierarchy used here is opposite of that used in the FRAGSTATS graphical user interface (GUI). In the GUI, metrics are first grouped by level (patch, class, and landscape) and then further grouped by the aspect of landscape pattern measured. The GUI organization strives to be consistent with the way most users conduct a FRAGSTATS analysis. Often times, for example, users are only interested in class level metrics. Here, however, the discussion of the metrics is facilitated by reversing the hierarchy and first grouping them according the aspect of pattern measured, then by the level of organization (patch, class, and landscape). In this manner, issues common to all metrics that relate to the same aspect of landscape pattern can be discussed once.

Following this convention, each metrics section begins with a brief introduction to the metrics in the group, followed by an overview of the various metrics computed by FRAGSTATS and a discussion of important limitations in their use and interpretation. Following this overview, each metric is defined, including a mathematical definition, measurement units, theoretical range in values, and any special considerations or limitations in the use of the metric. For each metric, the mathematical formula is described in narrative terms to facilitate interpretation of the formula. The acronym for the metric given on the left-hand side of the equation is the field name used in the ASCII output files. To facilitate interpretation of the algorithm, we intentionally separate from each equation any constants used to rescale the metric. For example, in many cases the right-hand side of the equation is multiplied by 100 to convert a proportion to a percentage, or multiplied or divided by 10,000 to convert m2 to hectares. These conversion factors are separated out by parentheses even though they may be factored into the equation differently in the computational form of the algorithm.


INTRODUCTION AND OVERVIEW

FRAGSTATS computes several statistics for each patch and class (patch type) in the landscape and for the landscape as a whole. At the class and landscape level, some of the metrics quantify landscape composition, while others quantify landscape configuration. Landscape composition and configuration can affect ecological processes independently and interactively (see FRAGSTATS Background document). Thus, it is especially important to understand for each metric what aspect of landscape pattern is being quantified. In addition, many of the metrics are partially or completely redundant; that is, they quantify a similar or identical aspect of landscape pattern. In most cases, redundant metrics will be very highly or even perfectly correlated. For example, at the landscape level, patch density (PD) and mean patch size (MPS) will be perfectly correlated because they represent the same information. These redundant metrics are alternative ways of representing the same information; they are included in FRAGSTATS because the preferred form of representing a particular aspect of landscape pattern will differ among applications and users. It behooves the user to understand these redundancies, because in most applications only 1 of each set of redundant metrics should be employed. It is important to note that in a particular application, some metrics may be empirically redundant as well; not because they measure the same aspect of landscape pattern, but because for the particular landscapes under investigation, different aspects of landscape pattern are statistically correlated. The distinction between this form of redundancy and the former is important, because little can be learned by interpreting metrics that are inherently redundant, but much can be learned about landscapes by interpreting metrics that are empirically redundant.

Many of the patch indices have counterparts at the class and landscape levels. For example, many of the class indices (e.g., mean shape index) represent the same basic information as the corresponding patch indices (e.g., patch shape index), but instead of considering a single patch, they consider all patches of a particular type simultaneously. Likewise, many of the landscape indices are derived from patch or class characteristics. Consequently, many of the class and landscape indices are computed from patch and class statistics by summing or averaging over all patches or classes. Even though many of the class and landscape indices represent the same fundamental information, naturally the algorithms differ slightly. Class indices represent the spatial distribution and pattern within a landscape of a single patch type; whereas, landscape indices represent the spatial pattern of the entire landscape mosaic, considering all patch types simultaneously. Thus, even though many of the indices have counterparts at the class and landscape levels, their interpretations may be somewhat different. Most of the class indices can be interpreted as fragmentation indices because they measure the configuration of a particular patch type; whereas, most of the landscape indices can be interpreted more broadly as landscape heterogeneity indices because they measure the overall landscape pattern. Hence, it is important to interpret each index in a manner appropriate to its scale (patch, class, or landscape).

In the sections that follow, each metric computed in FRAGSTATS is described in detail. Metrics are grouped according to the aspect of landscape pattern measured (as described in the Background Material), as follows:

• Area/density/edge metrics

• Shape metrics

• Core area metrics

• Isolation/proximity metrics

• Contrast metrics

• Contagion/interspersion metrics

• Connectivity metrics

• Diversity metrics

Within each of these groups, metrics are further grouped into patch, class, and landscape metrics, as follows:

• Patch level metrics

• Class level metrics

• Landscape level metrics


Landscape Metrics

Landscape metrics are computed for entire patch mosaic; the resulting landscape output file contains a single row (observation vector) for the landscape, where the columns (fields) represent the individual metrics. The first column includes header information about the landscape:

(L1) Landscape ID.--The first field in the landscape output file is landscape ID (LID). Landscape ID is set to the name of the input image obtained from the input file (see Run Parameters).

Like class metrics, there are two basic types of metrics at the landscape level: (1) indices of the composition and spatial configuration of the landscape, and (2) distribution statistics that provide first- and second-order statistical summaries of the patch metrics for the entire landscape. The latter are used to summarize the mean, area-weighted mean, median, range, standard deviation, and coefficient of variation in the patch attributes across all patches in the landscape. Because the distribution statistics are computed similarly for all landscape metrics, they are described in common below:

Landscape Distribution Statistics.--Landscape metrics measure the aggregate properties of the entire patch mosaic. Some landscape metrics go about this by characterizing the aggregate properties without distinction among the separate patches that comprise the mosaic. These metrics are defined elsewhere. Another way to quantify the configuration of patches at the landscape level is to summarize the aggregate distribution of the patch metrics for all patches in the landscape. In other words, since the landscape represents an aggregation of patches, we can characterize the landscape by summarizing the patch metrics. There are many possible first- and second-order statistics that can be used to summarize the patch distribution. FRAGSTATS computes the following: (1) mean (MN), (2) area-weighted mean (AM), (3) median (MD), (4) range (RA), (5) standard deviation (SD), and (6) coefficient of variation (CV). FRAGSTATS computes these distribution statistics for all patch metrics at the landscape level. In the landscape output file, these metrics are labeled by concatenating the metric acronym with an underscore and the distribution statistic acronym. For example, patch area (AREA) is summarized at the class level by each of the distribution statistics and reported in the class output file as follows: mean patch area (AREA_MN), area-weighted mean patch area (AREA_AM), median patch area (AREA_MD), range in patch area (AREA_RA), standard deviation in patch area (AREA_SD), and coefficient of variation in patch area (AREA_CV). Note, the acronyms for the distribution statistics are the same at the class and landscape levels, so they can only be distinguished by the output file they belong to (i.e., “.basename”.class or “basename”.land).

MN (Mean) equals the sum, across all patches in the landscape, of the corresponding patch metric values, divided by the total number of patches. MN is given in the same units as the corresponding patch metric.

AM (area-weighted mean) equals the sum, across all patches in the landscape, of the corresponding patch metric value multiplied by the proportional abundance of the patch [i.e., patch area (m2) divided by the sum of patch areas]. Note, the proportional abundance of each patch is determined from the sum of patch areas rather than the total landscape area, because the latter may include internal background area not associated with any patch.

MD (median) equals the value of the corresponding patch metric for the patch representing the midpoint of the rank order distribution of patch metric values based on all patches in the landscape.

RA (range) equals the value of the corresponding patch metric for the largest observed value minus the smallest observed value (i.e., the difference between the maximum and minimum observed values) for all patches in the landscape.

SD (standard deviation) equals the square root of the sum of the squared deviations of each patch metric value from the mean metric value computed for all patches in the landscape, divided by the total number of patches; that is, the root mean squared error (deviation from the mean) in the corresponding patch metric. Note, this is the population standard deviation, not the sample standard deviation.

CV (coefficient of variation) equals the standard deviation divided by the mean, multiplied by 100 to convert to a percentage, for the corresponding patch metric.


Patch Metrics

Patch metrics are computed for every patch in the landscape; the resulting patch output file contains a row (observation vector) for every patch, where the columns (fields) represent the individual metrics. The first three columns include header information about the patch:

(P1) Landscape ID.--The first field in the patch output file is landscape ID (LID). Landscape ID is set to the name of the input image obtained from the input file (see Run Parameters).

(P2) Patch ID.--The second field in the patch output file is patch ID (PID). If a Patch ID image is specified that contains unique ID's for each patch, FRAGSTATS reads the patch ID from the designated image. If an image is not specified, FRAGSTATS creates unique ID's for each patch and optionally produces an image that contains patch ID's that correspond to the FRAGSTATS output.

(P3) Patch Type.--The third field in the patch output file is patch type (TYPE). FRAGSTATS contains an option to name an ASCII file (class properties file) that contains character descriptors for each patch type. If the class properties option is not used, FRAGSTATS will write the numeric patch type codes to TYPE.

There are two basic types of metrics at the patch level: (1) indices of the spatial character and context of individual patches, and (2) measures of the deviation from class and landscape norms; that is, how much the computed value of each metric for a patch deviates from the class and landscape means. The deviation statistics are useful in identifying patches with extreme values on each metric. Because the deviation statistics are computed similarly for all patch metrics, they are described in common below:

Patch Deviation Statistics.--In addition to the standard patch metrics, FRAGSTATS computes several deviation statistics for each patch that measures how much it deviates from the class or landscape norm (i.e., how extreme an observation it is) for each metric. Specifically, for each patch and each patch metric, FRAGSTATS computes the following four measures of deviation:

Standard Deviations from the Class Mean
 |  | xij = value of a patch metric for patch ij. i = mean value of the corresponding patch metric for patch type (class) i. si = standard deviation of the corresponding patch metric for patch type (class) i.
Description | CSD equals the value of the metric (x) for the focal patch (ij) minus the mean of the metric across all patches in the focal class, divided by the class standard deviation (population formula).
Units | Same as the metric
Range | -∞ < metric < +∞ Although standard deviation has no theoretical limit, 66.5% of the observations (assuming a normal distribution) will be within +1 standard deviations of the mean, 95% within +2 standard deviations, and 99.7% within +3 standard deviations.
Comments | The number of standard deviations from the class mean is obtained from a z-score transformation of the observed value using the mean and standard deviation derived from all patches in the focal class. This transformation results in a standardized metric that has zero mean and unit variance for the class. Any observation that is, say, more than 2.5 standard deviations from the class mean can be considered an extreme observation. This is a quick and easy way to identify patches with extreme values of a metric. However, it is necessary to assume an underlying normal distribution in order for standard deviations to have a direct interpretation regarding the percent of the distribution greater or smaller than the observed value. CSD can be computed for each patch metric and is reported in the patch output file as the metric name followed by _CSD. For example, the class standard deviation metric for the shape index (SHAPE) would be given the variable name: SHAPE_CSD.

Percentile of the Class Distribution
 |  | xij = value of a patch metric for patch ij. ni = number of patches of the corresponding patch type (class) i.
Description | CPS equals the percentile of the rank-ordered distribution of all patches in the focal class for the corresponding metric (x); that is, the percent of observations in rank order that are smaller than the observed value for the focal patch (ij).
Units | Percent
Range | 0 ≤ metric ≤ 100 CPS = 0 if the observed patch metric is the lowest value for any patch in the class. Conversely, CPS = 100 if the observed patch metric is the highest value for any patch in the class.
Comments | The percentile of the class distribution is obtained by rank ordering observations from lowest to highest and computing the percentage of observations smaller than the observed value for the focal patch. In contrast to standard deviation, this deviation statistic makes no assumption about the underlying distribution; it simply quantifies the percent of the observed distribution that is smaller than the observed value for the focal patch under consideration.

Standard Deviations from the Landscape Mean
 |  | xij = value of a patch metric for patch ij.  = mean value of the corresponding patch metric across all patches in the landscape. s = standard deviation of the corresponding patch metric for all patches in the landscape.
Description | LSD equals the value of the metric (x) for the focal patch (ij) minus the mean of the metric across all patches in the landscape divided by the landscape standard deviation (population formula).
Units | Same as the metric
Range | -∞ < metric < +∞ Although standard deviation has no theoretical limit, 66.5% of the observations (assuming a normal distribution) will be within +1 standard deviations of the mean, 95% within +2 standard deviations, and 99.7% within +3 standard deviations.
Comments | The number of standard deviations from the landscape mean is obtained from a z-score transformation of the observed value using the mean and standard deviation derived from all patches in the landscape. This transformation results in a standardized metric that has zero mean and unit variance for the entire landscape. Any observation that is, say, more than 2.5 standard deviations from the landscape mean can be considered an extreme observation. This is a quick and easy way to identify patches with extreme values of a metric. However, it is necessary to assume an underlying normal distribution in order for standard deviations to have a direct interpretation regarding the percent of the distribution greater or smaller than the observed value. LSD can be computed for each patch metric and is reported in the patch output file as the metric name followed by a _LSD. For example, the landscape standard deviation metric for the shape index (SHAPE) would be given the variable name: SHAPE_LSD.

Percentile of the Landscape Distribution
 |  | xij = value of a patch metric for patch ij. N = number of patches in the landscape.
Description | LPS equals the percentile of the rank ordered distribution of all patches in the landscape for the corresponding metric (x); that is, the percent of observations in rank order that are smaller than the observed value for the focal patch (ij).
Units | Percent
Range | 0 ≤ metric ≤ 100 LPS = 0 if the observed patch metric is the lowest value for any patch in the landscape. Conversely, LPS = 100 if the observed patch metric is the highest value for any patch in the landscape.
Comments | The percentile of the landscape distribution is obtained by rank ordering observations from lowest to highest and computing the percentage of observations smaller than the observed value for the focal patch. In contrast to standard deviation, this deviation statistic makes no assumption about the underlying distribution; it simply quantifies the percent of the observed distribution that is smaller than the observed value for the focal patch under consideration.


LITERATURE CITED

Brittingham, M. C., and S. A. Temple. 1983. Have cowbirds caused forest songbirds to decline? Bio-Science 33:31-35.

Baker, W. L., and Y. Cai. 1992. The r.le programs for multiscale analysis of landscape structure using the GRASS geographical information system. Landscape Ecology 7: 291-302.

Bendell, P. R., and J. E. Gates. 1987. Home range and microhabitat partitioning of the southern flying squirrel (Glaucomy volans). J. Mammology 68:243-255.

Bogaert, J., R. Rousseau, P. Van Hecke, and I. Impens. 2000. Alternative perimeter-area ratios for measurement of 2-D shape compactness of habitats. Applied Mathematics and Computation 111:71-85.

Buechner, M. 1989. Are small-scale landscape features important factors for field studies of small mammal dispersal sinks? Landscape Ecology 2:191-199.

Burrough, P. A. 1986. Principles of Geographical Information Systems for Land Resources Assessment. Clarendon Press, Oxford.

Chasko, G. G, J. E. Gates. 1982. Avian habitat suitability along a transmission-line corridor in an oak-hickory forest region. Wildl. Monogr. 82.

Chen, J., and J. F. Franklin. 1990. Microclimatic pattern and basic biological responses at the clearcut edges of old-growth Douglas-fir stands. Northwest Environ. J. 6:424-425.

Clark, P. J., and F. C. Evans. 1954. Distance to nearest neighbor as a measure of spatial relationships in populations. Ecology 35:445-453.

Dale, M. R. T. 2000. Lacunarity analysis of spatial pattern: a comparison. Landscape Ecol. 15:467-468.

Dale, V. H., S. M. Pearson, H. L. Oferman, and R. V. O’Neill. 1994. Relating patterns of land-use change to faunal biodiversity in the central Amazon. Conservation Biology 8:1027-1036.

Dickman, C. R. 1987. Habitat fragmentation and vertebrate species richness in an urban environment. J. Appl. Ecol. 24:337-351.

Dunning, J. B., B. J. Danielson, and H. R. Pulliam. 1992. Ecological processes that affect populations in complex landscapes. Oikos 65:169-175.

Forman, R. T. T., A. E. Galli, and C. F. Leck. 1976. Forest size and avian diversity in New Jersey woodlots with some land use implications. Oecologia 26:1-8.

Forman, R. T. T., and M. Godron. 1986. Landscape Ecology. John Wiley & Sons, New York. 619 pp.

Forsman, E. D., E. C. Meslow, and H. M. Wight. 1984. Distribution and biology of the spotted owl in Oregon. Wildl. Monogr. 87. 64 pp.

Franklin, J. F., and R. T. T. Forman. 1987. Creating landscape pattern by forest cutting: ecological consequences and principles. Landscape Ecology 1:5-18.

Gardner, R. H., B. T. Milne, M.G. Turner, and R.V. O'Neill. 1987. Neutral models for the analysis of broad-scale landscape pattern. Landscape Ecol. 1:19-28.

Gardner, R. H., and R. V. O’Neill. 1991. Pattern, process, and predictability: the use of neutral models for landscape analysis. Pages 289-307 In M. G. Turner and R. H. Gardner, eds. Quantitative Methods in Landscape Ecology. Springer-Verlag, New York.

Gilpin, M. E., and I. Hanski (eds). 1991. Metapopulation Dynamics: Empirical and Theoretical Investigations. Academic Press, San Diego. 336 pp.

Graham, R. L., C. T. Hunsaker, R. V., O'Neill, and B. Jackson. 1991. Ecological risk assessment at the regional scale. Ecol. Appl. 1:196-206.

Gratkowski, H. J. 1956. Windthrow around staggered settings in old-growth Douglas-fir. For. Sci. 2:60-74.

Gustafson, E. J. 1998. Quantifying landscape spatial pattern: What is the state of the art. Ecosystems:143-156.

Gustafson, E. J., and G. R. Parker. 1994. Using an index of habitat patch proximity for landscape design. Landscape and Urban Planning 29:117-30.

Gustafson, E. J., G. R. Parker, and S. E. Backs. 1994. Evaluating spatial pattern of wildlife habitat: a case study of the wild turkey (Meleagris gallopavo). Am. Midl. Nat. 131:24-33.

Gustafson, E. J., and G. R. Parker. 1992. Relationships between landcover proportion and indices of landscape spatial pattern. Landscape Ecology 7:101-110.

Hansen, A., and F. di Castri (eds). 1992. Landscape Boundaries. Springer, New York.

Hardt, R. A., and R. T. T. Forman. 1989. Boundary form effects on woody colonization of reclaimed surface mines. Ecology 70:1252-1260.

Hargis, C. D., J. A. Bissonette, and J. L. David. 1998. The behavior of landscape metrics commonly used in the study of habitat fragmentation. Landscape Ecol. 13:167-186.

Hayden, I. J., J. Faaborg, and R. L. Clawson. 1985. Estimates of minimum area requirements for Missouri forest birds. Missouri Academy of Science 19:11-22.

He, H. S., B. E. DeZonia, and D. J. Mladenoff. 2000. An aggregation index (AI) to quantify spatial patterns of landscapes. Landscape Ecology 15:591-601.

Helliwell, D. R. 1976. The effects of size and isolation on the conservation value of wooded sites in Britain. J. Biogeogr. 3:407-416.

Iverson, L. R. 1989. Land use changes in Illinois, USA: the influence of landscape attributes on current and historic land use. Landscape Ecology 2:45-61.

Jaeger, J. A. G. 2000. Landscape division, splitting index, and effective mesh size: new measures of landscape fragmentation. Landscape Ecol. 15:115-130.

Kareiva, P. 1990. Population dynamics in spatially complex environments: theory and data. Phil. Trans. R. Soc. Lond. B 330:175-190.

Keitt, T.H., D.L. Urban, and B.T. Milne. 1997. Detecting critical scales in fragmented landscapes. Conservation Ecol. 1(1):4. (online)

Kotliar, N. B., and J. A. Wiens. 1990. Multiple scales of patchiness and patch structure: a hierarchical framework for the study of heterogeneity. Oikos 59:253-260.

Kremsater, L. and F. L. Bunnell.1999. Edge effects: theory, evidence and implications to management of western North American forests.

Kroodsma, R. L. 1982. Edge effect on breeding forest birds along a power-line corridor. J. of Applied Ecology 19:361-370.

Krummel, J. R., R. H. Gardner, G. Sugihara, R. V. O'Neill, and P. R. Coleman. 1987. Landscape patterns in a disturbed environment. Oikos 48:321-324.

Lamberson, R.H., R. McKelvey, B.R. Noon, and C. Voss. 1992. A dynamic analysis of northern spotted owl viability in a fragmented forest landscape. Conservation Biology 6(4):1-8.

LaGro, J., Jr. 1991. Assessing patch shape in landscape mosaics. Photogrammetric Eng. Remote Sens. 57:285-93.

Lande, R. 1987. Extinction thresholds in demographic models of territorial populations. American Naturalist 130:624-635.

Lehmkuhl, J. F., and M. G. Raphael. 1993. Habitat pattern around northern spotted owl locations on the Olympic Peninsula, Washington. J. Wildl. Manage. 57:302-315.

Leopold, A. 1933. Game Management. Charles Scribners, New York.

Levins, R. 1970. Extinctions. Pages 77-107 In M. Gertenhaber, ed. Some Mathematical Questions in Biology, vol 2. Lectures on Mathematics in the Life Sciences. Amer. Math. Soc., Providence, Rhode Island.

Li, H., and J. F. Reynolds. 1993. A new contagion index to quantify spatial patterns of landscapes. Landscape Ecology 8:155-162.

Logan, W., E. R. Brown, D. Longrie, G. Herb, and R. A. Corthell. 1985. Edges. Pages 115-127 In E. R. Brown, tech. ed. Management of wildlife and fish habitats in forests of western Oregon and Washington. USDA For. Serv. Publ. No. R6-F&WL-192-1985.

MacArthur, R. H., and E. O. Wilson. 1967. The Theory of Island Biogeography. Princeton University Press, Princeton. 203 pp.

Mandelbrot, B. B. 1982. The Fractal Geometry of Nature. W. H. Freeman and Co., New York.

Mandelbrot, B. B. 1977. Fractals, Form, Chance and Dimension. W. H. Freeman and Co., New York.

Mader, H-J. 1984. Animal habitat isolation by roads and agricultural fields. Biological Conservation 29:81-96.

McKelvey, K., B.R. Noon, and R. Lamberson. 1992. Conservation planning for species occupying fragmented landscapes: the case of the northern spotted owl. Pages 338-357 In J. Kingsolver, P. Kareiva, and R. Hyey, eds. Biotic interactions and global change. Sinauer Associates, Sunderland, MA.

Milne, B. T. 1991. Lessons from applying fractal models to landscape patterns. Pages 199-235 In M.G. Turner and R.H. Gardner, eds. Quantitative Methods in Landscape Ecology–Then Analysis and Interpretation of Landscape Heterogeneity. Springer-Verlag, New York, NY, USA.

Milne, B. T. 1988. Measuring the fractal geometry of landscapes. Applied Mathematics and Computation 27:67-79.

Moore, N. W., and M. D. Hooper. 1975. On the number of bird species in British woods. Biol. Conserv. 8:239-250.

Morgan, K. A., and J. E. Gates. 1982. Bird population patterns in forest edge and strip vegetation at Remington Farms, Maryland. J. Wildl. Manage. 46:933-944.

Noss, R. F. 1988. Effects of edge and internal patchiness on habitat use by birds in a Florida hardwood forest. Ph.D. Thesis. Univ. of Florida, Gainesville. 109 pp.

O'Neill , R. V., C. T. Hunsaker, S. P. Timmins, B. L. Jackson, K. B. Jones, K. H. Ritters, and J. D. Wickham.1996. Scale problems in reporting landscape pattern at the regional scale. Landscape Ecology 11:169-180

O'Neill , R. V., J. R. Krummel, R. H. Gardner, G. Sugihara, B. Jackson, D. L. DeAngelis, B. T. Milne, M. G. Turner, B. Zygmunt, S. W. Christensen, V. H. Dale, and R. L. Graham. 1988. Indices of landscape pattern. Landscape Ecology 1:153-162.

Patton, D. R. 1975. A diversity index for quantifying habitat "edge". Wildl. Soc. Bull. 3:171-173.

Pearson, S. M., M. G. Turner, R. H. Gardner, and R. V. O’Neill. 1996. An organism-based perspective of habitat fragmentation. Pages 77-95 In R. C. Szaro and D. W. Johnston, eds. Biodiversity in Managed Landscapes: Theory and Practice. Oxford University Press, New York.

Pielou, E. C. 1975. Ecological Diversity. Wiley-Interscience, New York.

Plotnick, R. E., R. H. Gardner, and R.V. O'Neill. 1993. Lacunarity indices as measures of landscape texture. Landscape Ecol. 8:201-211.

Plotnick, R. E., R. H. Gardner, W. W. Hargrove, K. Pretegaard, and M. Perlmutter.1996. Lacunarity analysis: a general technique for the analysis of spatial patterns. Phys. Rev. E53:5461-5468.

Ranney, J. W., M. C. Bruner, and J. B. Levenson. 1981. The importance of edge in the structure and dynamics of forest islands. Pages 67-94 In R. L. Burgess and D. M. Sharpe, eds. Forest Island Dynamics in Man-Dominated Landscapes. Springer-Verlag, New York.

Ripple, W. J., G. A. Bradshaw, and T. A. Spies. 1991. Measuring landscape pattern in the Cascade Range of Oregon, USA. Biological Conserv. 57:73-88.

Ritters, K. H., R. V. O'Neill, C. T. Hunsaker, J. D. Wickham, D. H. Yankee, S. P. Timmins, K. B. Jones, and B. L. Jackson. 1995. A factor analysis of landscape pattern and structure metrics. Landscape Ecol. 10: 23-40.

Ritters, K. H., R. V. O'Neill, J. D. Wickham, and K. B. Jones. 1996. A note on contagion indices for landscape analysis. Landscape Ecol. 11:197-202.

Robbins, C. S., D. K. Dawson, and B. A. Dowell. 1989. Habitat area requirements of breeding forest birds of the middle Atlantic states. Wildl. Monogr.103. 34 pp.

Rogers, C. A. 1993. Describing landscapes: indices of structure. M.S. Thesis, Simon Fraser University, Burnaby, British Columbia. 170 pp.

Romme, W. H. 1982. Fire and landscape diversity in subalpine forests of Yellowstone National Park. Ecol. Monogr. 52:199-221.

Saunders, D., R. J. Hobbs, and C. R. Margules. 1991. Biological consequences of ecosystem fragmentation: a review. Conserv. Biol. 5:18-32.

Schumaker, N. H. 1996. Using landscape indices to predict habitat connectivity. Ecology 77:1210-25.

Shannon, C., and W. Weaver. 1949. The mathematical theory of communication. Univ. Illinois Press, Urbana.

Simpson, E. H. 1949. Measurement of diversity. Nature 163:688.

Stauffer, D. 1985. Introduction to Percolation Theory. Taylor and Francis, London.

Strelke, W. K., and J. G. Dickson. 1980. Effect of forest clearcut edge on breeding birds in Texas. J. Wildl. Manage. 44:559-567.

Taylor, P. D., L. Fahrig, K. Henein, and G. Merriam. 1993. Connectivity is a vital element of landscape structure. Oikos 73:43-48.

Temple, S. A. 1986. Predicting impacts of habitat fragmentation on forest birds: a comparison of two models. Pages 301-304 In J. Verner, M. L. Morrison, and C. J. Ralph, eds. Wildlife 2000: Modeling Habitat Relationships of Terrestrial Vertebrates. Univ. of Wisconsin Press, Madison, WI.

Thomas, J. W., C. Maser, and J. E. Rodiek. 1979. Edges. Pages 48-59 In J. W. Thomas, tech. ed. Wildlife habitats in managed forests, the Blue Mountains of Oregon and Washington. USDA For. Serv. Handb. 553.

Thomas, J. W., C. Maser, and J. E. Rodiek. 1978. Edges--their interspersion, resulting diversity, and its measurement. Pages 91-100 In R. M. Degraff, tech. coord. Proceedings of the workshop on nongame bird habitat management in the coniferous forests of the western United States. Gen. Tech. Rep. PNW-64.

Turner, M. G. 1989. Landscape ecology: the effect of pattern on process. Ann. Rev. Ecol. Syst. 20:171-197.

Turner, M. G. 1990a. Spatial and temporal analysis of landscape patterns. Landscape Ecology 4:21-30.

Turner, M. G. 1990b. Landscape changes in nine rural counties of Georgia. Photogram. Engine. and Rem. Sens. 56:379-386.

Turner, M. G., R. V. O'Neill, R. H. Gardner, and B. T. Milne. 1989. Effects of changing spatial scale on the analysis of landscape pattern. Landscape Ecology 3:153-162.

Turner, M. G., and C. L. Ruscher. 1988. Changes in the spatial patterns of lands use in Georgia. Landscape Ecology 1:241-251.

Voss, R. F. 1988. Fractals in nature: from characterization to simulation. Pages 21-70 In H.O. Petigen and D. Saupe, eds. The Science of Fractal Images. Springer-Verlag, New York.

Wegner, J. F., and H. G. Merriam. 1979. Movements by birds and small mammals between a wood and adjoining farmland habitats. J. Appl. Ecol. 16:349-357.

Whitcomb, R. F., C. S. Robbins, J. F. Lynch, B. L. Whitcomb, M. K. Klimkiewicz, and D Bystrak. 1981. Effects of forest fragmentation on avifauna of the eastern deciduous forest. Pages 125-205 in R. L. Burgess and D. M. Sharpe, eds. Forest Island Dynamics in Man-Dominated Landscapes. Springer-Verlag, New York.

Wiens, J. A., C. S. Crawford, and J. R. Gosz. 1985. Boundary dynamics: a conceptual framework for studying landscape ecosystems. Oikos 45: 421-427.

Wilcove, D. S. 1985. Nest predation in forest tracts and the decline of migratory songbirds. Ecology 66:1211-1214.

With, K. A. 1999. Is landscape connectivity necessary and sufficient for wildlife management? Pages 97-115 in J. A. Rochelle, L. A. Lehmann, and J. Wisniewski, editors. Forest fragmentation: wildlife and management implications. Brill, The Netherlands.

With, K. A., and T. O. Crist. 1995. Critical thresholds in species’ responses to landscape structure. Ecology 76:2446-59.

With, K. A., R. H. Gardner, and M. G. Turner. 1997. Landscape connectivity and population distributions in heterogeneous environments. Oikos 78:151-169.

With, K. A., and A.W. King. 1999a. Dispersal success on fractal landscapes: a consequence of lacunarity thresholds. Landscape Ecology 14:73-82.

With, K. A., and A.W. King. 1999b. Extinction thresholds for species in fractal landscapes. Conservation Biology 13:314-326.

Yahner, R. H. 1986. Spatial distribution of white-footed mice (Peromyscus leucopus) in fragmented forest stands. Proceedings of the Pennsylvania Academy of Science 60:165-166.

Yahner, R. H., and D. P. Scott. 1988. Effects of forest fragmentation on depredation of artificial nests. J. Wildl. Manage. 52:158-161.


RUNNING FRAGSTATS VIA THE GRAPHICAL USER INTERFACE

FRAGSTATS is run via a graphical user interface (GUI). This GUI is intended to facilitate the parameterization process and to provide flexibility in the analysis and choice of metrics. What follows is a step-by-step description of how to parameterize and run FRAGSTATS using the GUI:

Step 1. Starting the FRAGSTATS GUI

Step 2. Setting Run Parameters

Step 3. Selecting and Parameterizing Patch, Class, and Landscape Metrics

Step 4. Working with Batch Files (optional)

Step 5. Modifying Class Properties (optional)

Step 6. Executing FRAGSTATS

Step 7. Browsing and Saving the Results