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1. Introduction
1.1 Purpose
This Software Requirements Specification (SRS) document provides a complete description of the
behavior of the program CamStudio, release number 2.7. It enlists both functional and nonfunctional requirements of the system. CamStudio is an open source program released under the
GNU General Public License. Its purpose is to record screen and audio activity on the user's
computer and create industry-standard AVI video files. It also provides a built-in SWF Producer,
which can convert the produced AVI videos into SWF videos.

1.2 Intended Audience and Reading Suggestions
The intended audience of this document is the developers, the users of the program, testers or
anyone else that needs to understand the system functions and architecture. Below are presented
potential uses for each type of audience:
 Users: A user of the program may read this document in order to better understand and
properly use CamStudio's functions.
 Testers: A tester of the program may read this document in order to have an exact list of its
features and functions that will assist error discovery.
 Developers: CamStudio's developer(s) may consult this document when changes,
modifications or implementations to the program are to be done. In this case, this document
will be helpful so that any update to be done without errors or unwanted changes.

1.3 Product Scope
CamStudio is a tool for recording screen activity into standard AVI video files. Some possible uses
for CamStudio may be:
 Create demonstrations of programs by recording the movement of the cursor, the selection of
menus, the entering of text or the display of messages.
 Create movies used in user trainings.
 Track the progress of a program that executes for a long time.
 Record the sequence of steps that cause the occurrence of bugs in faulty software.
 Record a movie stream.
 Convert AVI files to Flash (SWF) files.
The video files created by CamStudio are saved in the standard AVI format, which is used in many
Windows applications that support video, including Microsoft Office. This ensures maximum
compatibility with other software, and enables the user to edit the output of CamStudio with a third
party video editor.
The figures that follow show some screenshots of the program
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Figure 1.1 – CamStudio Recorder

Figure 1.2 – CamStudio SWF Producer
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1.4 References
More about CamStudio can be found at:
 http://www.camstudio.org/
This is the official site of the program. It contains more information about the program, download
links, as well as a support forum and a frequently asked questions (FAQ) page.
 http://sourceforge.net/projects/camstudio/
In this website there is more information about the project, its source code and also a forum for
discussion and support. It also contains previous releases of the software, bug fixes etc.

2. Overall Description
2.1 Product Perspective
CamStudio is a program that records screen activity and produces AVI or SWF video files. The
program gives the option to record directly into SWF format but also has a built-in SWF producer
that converts AVI files to SWF files. Another plus for CamStudio is that provides its own codec for
the videos. CamStudio Lossless Codec is also free and available for use under GPL.


CamStudio Recorder: as told before, this program captures screen activity and produces a
video file. Apart from that, this main function is enriched by many other features.
 The recording can be paused and continued any other time
 The area or specific window that will be recorded can be selected by the user
 The audio input device can also be chosen
 Screen and video annotations can be added
 The mouse cursor can be customized etc.



CamStudio SWF producer: this built-in program converts AVI video files to SWF files. The
SWF producer can operate in 3 modes: 1) As a standalone program, 2) Used internally by
CamStudio recorder when recording directly to SWF, 3) As a command line program in
silence mode.

2.2 Product Functions
The main functions of the program are the following:


Record video from screen – Start/Stop&Save/Pause/Set automatic stop
This feature offers the ability to record video from the screen, pause it (more than once) and
start recording again. Also stop the recording, name and save the output video in a folder.
There is also the option to set a specific time where the video recording will stop
automatically.
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Select capture region
This feature offers the ability to select a specific screen region that will be captured during
the recording. This region can be a manually set area, a specific window or the whole screen.



Select audio recording device – Set options
This feature gives the option to select the audio recording device. The audio input could be a
microphone, speakers or there can be no audio at all.



Modify cursor – Set options
Using this function the user can modify the way the cursor appears and behaves during the
capture. For example hide the cursor or even highlight it for more emphasis.



Autopan – Enable/disable/set options
This option, when enabled, sets the capture area to follow the cursor during the recording.



Add annotations
This function is used in order to add annotations in the video that is being produced.
There are two types of annotations:





Screen annotations
Video annotations

Change Output Video Format
Using this feature the user is given the ability to select between two different output video
formats, AVI or SWF.



Set Program Options
This feature allows the user to customize the behavior of the program.



Select Language
The program can be presented in two different languages, English or German.



Convert AVI Files to SWF Files
The program offers the feature of converting AVI Files to SWF Files using the built-in
program "CamStudio SWF Producer"

2.3 User Classes and Characteristics


Professional users: CamStudio can be used by professionals that need to create video
tutorials, video help files or any other related material.



Advanced users: Advanced users are people who know well how to use a computer and are
involved in activities that take place online (for example bloggers etc). These users are likely
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to find CamStudio a useful tool for incorporating video tutorials with helpful information in
their websites.


Novice users: Since CamStudio is a very simple program to use, it can be handled by novice
users very easily for any purpose.

2.4 Operating Environment
CamStudio can be installed in the following operating systems: Microsoft Windows 95, 98, Me, NT
4.0, Vista, 7, 8, and 8.1.

2.5 Design and Implementation Constraints
CamStudio must be installed in a computer that meets the following requirements:
 400MHz processor
 64 MB RAM (recommended)
 4 MB of hard-disk space for program installation

2.6 User Documentation
When downloaded, CamStudio offers a compiled HTML help file that guides the user through the
programs features.
There are also various helpful websites:


In the official website of the product, there is a helpful FAQ page
(http://camstudio.org/faq.htm) and a supporting forum (http://camstudio.org/forum/)



There is a supporting YouTube channel by Terry Leigh Britton. This channel includes
many helpful CamStudio tutorials. The link for this channel is:
https://www.youtube.com/playlist?list=PLA57A11C0D77BBF9B

3. External Interface Requirements
3.1 User Interfaces
The basic interface of the program is the following. This window appears on the users' screen the
first time CamStudio is launched. By clicking the toggle button
the user has the ability to
alternate between different window views. This can also be done by selecting:
 View → Normal View
 View → Compact View
 View → Buttons View
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Figure 3.1 – Basic user interface
The following figures show the two possible minimized windows.

Figure 3.2 – Minimized window (1)

Figure 3.3 – Minimized window (2)
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While recording CamStudio's window will be similar to the one in the following figure

Figure 3.4 – Window that appears while recording



Help Button
The help button offers links to the help section, links to CamStudio webpage and some more
information about the program. The following options are offered:


Help → Help
This option leads the user to the help page. It contains a detailed guide on how to use
the program.



Help → CamStudio Homepage
This is a link that leads directly to the program's page on the internet.



Help → CamStudio FAQ
This is a link that leads directly to the program's FAQ page on the internet.
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3.2 Hardware Interfaces


A storing device with enough free space must be available for the video files to be saved.

4. System Features
System features are organized by use cases and functional hierarchy in order to be understandable by
all types of users.

4.1 Start Recording Video from Screen
4.1.1

Description and Priority
It is the main function that this program offers and provides the ability to record video
from the user's screen. When this function is activated, the program starts recording
the user's desktop using the options that are set at the time.
Priority: High

4.1.2

Stimulus/Response Sequences
4.1.2.1 Basic Path
1. User clicks on the (red) record button which appears on the central button bar
4.1.2.2 Alternative Path 1
1. User selects File → Record from the main menu bar
4.1.2.3 Alternative Path
1. User right clicks on CamStudio icon which appears on the notification bar
2. User clicks on "Record"

4.1.3

Functional Requirements
REQ-1: CamStudio must be downloaded, installed and running

4.2 Pause Recording
4.2.1

Description and Priority
This function allows the user to pause the recording that is running at the time. The
pause can last as much time as the user wants. To resume the recording, the user can
click the record button.
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Priority: High
4.2.2

Stimulus/Response Sequences
4.2.2.1 Basic Path
1. User clicks on the (grey/black) pause button which appears on the central button
bar
2. User clicks on the (red) record button which appears on the central button bar to
resume recording
4.2.2.2 Alternative Path 1
1a. User selects File → Pause from the main menu bar
4.2.2.3 Alternative Path 2
1a. User right clicks on CamStudio icon which appears on the notification bar
1b. User clicks on "Pause"
4.2.2.4 Alternative Path 3
2a. User selects File → Record from the main menu bar
4.2.2.5 Alternative Path 4
2a. User right clicks on CamStudio icon which appears on the notification bar
2b. User clicks on "Record"

4.2.3

Functional Requirements
REQ-2: The program must be recording the user's screen in order for the recording to
be paused.

4.3 Stop Recording Video from Screen
4.3.1

Description and Priority
This function allows the user to stop the recording. When this function is enabled, a
dialog box will appear for the user in order to name and save the recording.
Priority: High

4.3.2

Stimulus/Response Sequences
4.3.2.1 Basic Path
1. User clicks on the (blue) stop button which appears on the central button bar.
2. A dialog box appears
3. User names the recording
4. User selects the file in which the recording will be saved
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5. User clicks on "Save" button
4.3.2.2 Alternative Path 1
1a. User selects File → Stop from the main menu bar
4.3.2.3 Alternative Path 2
1a. User right clicks on CamStudio icon which appears on the notification bar
1b. User clicks on "Stop"
4.3.2.4 Alternative Path 3
3. User clicks on "Cancel" button
4.3.3

Functional Requirements
REQ-3: The program must be recording the user's screen in order for the recording to
be stopped.

4.4 Exit CamStudio
4.4.1

Description and Priority
This feature allows the user to exit the application at any time.
Priority: High

4.4.2

Stimulus/Response Sequences
4.4.2.1 Basic Path
1. User selects File → Exit from the main menu bar
4.4.2.2 Alternative Path 1
1a. User right clicks on CamStudio icon which appears on the notification bar
1b. User clicks on "Exit"
4.4.2.3 Alternative Path 2
1a. User right clicks on CamStudio minimized window on windows taskbar
1b. User clicks on "Close"

4.4.3

Functional Requirements
Not any
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4.5 Set Capture Region
4.5.1

Description and Priority
This feature allows the user to define the region of the screen that will be captured.
This can be done by selecting "Region" from the main menu. The user is given four
different options:


Region: By selecting this option, the user will be able to define an arbitrary
rectangular region with the mouse. The cursor turns into a pen on crosshairs
and the user defines a region by click-dragging the left mouse button. This
will occur right before the recording occurs and right after the user selects
"Record".



Fixed Region…: By selecting this option, a dialog window appears that
allows the user to define the size of the capture region in pixels.



Window: This option allows the user to capture one particular window. When
the recording starts, a dialog appears and asks from the user to select a
window to be captured.



Full Screen: When this option is selected, the entire computer screen is
captured.

Priority: High
4.5.2

Stimulus/Response Sequences
4.5.2.1 Basic Path
1. User selects Region → Region from the main menu bar
2. User selects Record feature
3. User selects a fixed region to be recorded by click-dragging
4.5.2.2 Alternative Path 1
1. User selects Region → Fixed Region… from the main menu bar
2. User defines preferred region and options
3. User clicks on "OK"
4. Current options are saved
4.5.2.3 Alternative Path 2
3. User clicks on "Cancel"
4. Current options are not saved, previous options still apply
4.5.2.4 Alternative Path 3
1. User selects Region → Window
2. User selects Record feature
3. A dialog window appears (Click on window to be captured)
4. User clicks on a window to be captured
4.5.2.5 Alternative Path 4
1. User selects Region → Full Screen
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Functional Requirements
Not any

4.6 Set Video Options
4.6.1

Description and Priority
This feature allows the user to optimize video recordings by choosing between file
size, quality and frame rates of the video files. The user can set video options by
clicking Options → Video Options… from the main menu bar. These options are:






Compressor: this select box allows the user to select the encoder for the AVI
file.


The "About" button shows some extra information about the selected
compressor.



The "Configure" button allows the user to configure the parameters of
the selected compressor. The parameters of each compressor are
different and some settings may cause CamStudio's performance to
degrade or behave unpredictably.



The quality setting allows the user to determine the quality of the
video. A high quality setting leads to a larger file size. Some
compressors do not use this value.



Set Key Frames Every ___ frames: this setting allows the user to
determine the keyframe rate. A high keyframe rate leads to a larger
file size.

Framerates


Capture Frames Every ___ milliseconds: this field allows the user to
determine the input frame rate. It determines how often CamStudio
will capture frames while recording.



Playback Rate ___ frames/second: this field allows the user to
determine the output frame rate. A high value of playback rate leads to
a smoother playback.

Auto Adjust


This option allows the user to set the Key Frame Rate and Playback
Rate automatically using a slide bar.

Priority: Medium
4.6.2

Stimulus/Response Sequences
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4.6.2.1 Basic Path
1. User selects Options → Video Options… from the main menu bar
2. A dialog window appears
3. User sets preferred video options
4. User clicks on "OK"
5. Changes are saved
4.6.2.2 Alternative Path 1
3. User clicks on "Cancel"
4. Video options do not change
4.6.3

Functional Requirements
Not any

4.7 Set Cursor Options
4.7.1

Description and Priority
This feature allows the user to modify the way the cursor appears during the
recording. This feature is helpful when the user needs to draw attention to a specific
area. This option offers the following effects:




Cursor Display


Hide Cursor: the cursor is hidden during the recording and it does not
appear in the output video.



Show Cursor: this setting gives the user three different options. Either
use the actual cursor, or use a customized one, or replace the cursor
with one selected from a file.

Cursor Highlight: this option allows the user to add a highlighted area around
the cursor. The shape, size and color of the highlighted area can be modified.

Priority: Low
4.7.2

Stimulus/Response Sequences
4.7.2.1 Basic Path
1. User selects Options → Cursor Options… from the main menu bar
2. A dialog window appears
3. User sets preferred cursor options
4. User clicks on "OK"
5. Changes are saved
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4.7.2.2 Alternative Path 1
3. User clicks on "Cancel"
4. Cursor options do not change
4.7.3

Functional Requirements
Not any

4.8 Select Audio Recording Device
4.8.1

Description and Priority
Using this feature the user has the ability to select which audio recording device will
be used during the recording. There are three options:


Do not record audio: by selecting this option, no audio will be recorded.



Record audio from microphone: by selecting this option, CamStudio will
record the voice input from the microphone while capturing the video.



Record audio from speakers: by selecting this option, CamStudio will record
the voice input from the speakers while capturing the video.

Priority: High
4.8.2

Stimulus/Response Sequences
4.8.2.1 Basic Path
1. User selects Options → Do not record audio, from the main menu bar
2. "Do not record audio" option is selected
4.8.2.2 Alternative Path 1
1. User selects Options → Record audio from microphone, from the main menu bar
2. "Record audio from microphone" option is selected
4.8.2.3 Alternative Path 2
1. User selects Options → Record audio from speakers, from the main menu bar
2. " Record audio from speakers" option is selected

4.8.3

Functional Requirements
REQ-4: In order to use "Record audio from microphone" option, a sound card with an
attached microphone is needed.
REQ-5: In order to use "Record audio from speakers" option, a sound card with
attached speakers is needed.
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4.9 Set Audio Options
4.9.1

Description and Priority
This feature allows the user to optimize the audio in recordings, by setting the audio
parameters, depending on the input audio device. The user is also able to adjust audio
and video synchronization settings.
 Audio Options for Microphone: The dialog window that opens when this
option is selected, allows the user to:
 Select the audio capture device and adjust the volume.
 Select the recording format. This is the format the soundcard uses to
record voice from the microphone.
 Select the compressed format. This is the format that will be saved
with the movie file.
 Interleave video and audio. This allows better synchronization of the
video and sound content.
 Use system method for audio recording. If this checkbox is selected,
CamStudio will use certain system commands (MCI commands) to
perform the recording of audio from the microphone.
 Audio Options for Speakers: The dialog window that opens when this option
is selected, allows the user to:
 Select soundcard device.
 Adjust playback volume.
 Configure the recording line. If the user's computer has more than one
soundcards and the user decides to change the default soundcard, a
manual/automatic search for the new line should be performed.
 Audio and Video Synchronization: This option allows the user to shift the
audio or video stream in order to make them synchronized. This option only
handles the case when the audio stream appears to go before the video.
Priority: Medium

4.9.2

Stimulus/Response Sequences
4.9.2.1 Basic Path
1. User selects Options → Audio Options → Audio Options for Microphone, from the
main menu bar
2. A dialog window appears
3. User sets preferred audio options for the microphone
4. User clicks on "OK"
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5. Changes are saved
4.9.2.2 Alternative Path 1
1. User selects Options → Audio Options → Audio Options for Speakers, from the
main menu bar
2. A dialog window appears
3. User sets preferred audio options for the speakers
4. User clicks on "Close"
5. Changes are saved
4.9.2.3 Alternative Path 2
1. User selects Options → Audio Options → Audio and Video Synchronization, from
the main menu bar
2. A dialog window appears
3. User sets preferred audio and video synchronization options
4. User clicks on "OK"
5. Changes are saved
4.9.2.4 Alternative Path 3
3. User clicks on "Cancel"
4. Audio options do not change
4.9.3

Functional Requirements
REQ-6: In order to set "Audio Options for Microphone", a sound card with an
attached microphone is needed.
REQ-7: In order to set "Audio Options for Speakers", a sound card with attached
speakers is needed.

4.10 Autopan
4.10.1 Description and Priority
When this feature is enabled, the capture area will follow the cursor during the
recording. There are two autopan options:


Enable autopan (a)



Set autopan speed (b)

Priority: Low
4.10.2 Stimulus/Response Sequences
4.10.2a Enable Autopan
4.10.2a.1 Basic Path
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1. User selects Options → Enable Autopan, from the main menu bar
2. Autopan is enabled/disabled
4.10.2b Set Autopan Speed
4.10.2b.1 Basic Path
1. User selects Options → Autopan Speed…, from the main menu bar
2. A dialog window appears
3. User sets maximum pan speed
4. User clicks on "OK"
5. Changes are saved
4.10.2b.2 Alternative Path 1
3. User clicks on "Cancel"
4. Changes are not saved
4.10.3 Functional Requirements
Not any

4.11 Automatically Stop Recording
4.11.1 Description and Priority
This feature allows the user to set a specific period of time, when this period expires
the recording will stop automatically.
Priority: Low
4.11.2 Stimulus/Response Sequences
4.11.2.1 Basic Path
1. User selects Options → Automatically stop recording…, from the main menu bar
2. A dialog window appears
3. User sets a time period
4. User clicks on "OK"
5. Changes are saved
4.11.2.2 Alternative Path 1
3. User clicks on "Cancel"
4. Changes are not saved
4.11.3 Functional Requirements
REQ-8: The program must be recording the user's screen in order for the recording to
be stopped
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4.12 Add Screen Annotations
4.12.1 Description and Priority
This feature allows the user to add captions to the screen during the recording.
Priority: Low
4.12.2 Stimulus/Response Sequences
4.12.2.1 Basic Path
1. User clicks on the (black/green) "Screen Annotations" button which appears on the
central button bar
2. A dialog window appears
3. User creates annotations
4. User clicks on "Close"
5. Dialog window disappears
4.12.2.2 Alternative Path 1
1a. User selects Tools → Screen Annotations, from the main menu bar
4.12.2.3 Alternative Path 2
3. User decides not to create annotations
4. User clicks on "Close"
5. Dialog window disappears
4.12.3 Functional Requirements
Not any

4.13 Add Video Annotations
4.13.1 Description and Priority
This feature allows the user to add captions to the screen during the recording.
Priority: Low
4.13.2 Stimulus/Response Sequences
4.13.2.1 Basic Path
1. User selects Tools → Video Annotations, from the main menu bar
2. The webcam window opens
3. User adjusts the settings and captures a video using one or more Video Annotations
4. User right clicks on Video Annotations window
5. User clicks on close
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6. Video Annotations window disappears
4.13.2.2 Alternative Path 1
3. User decides not to use Video Annotations in the recording
4. User right clicks on Video Annotations window
5. User clicks on close
6. Video Annotations window disappears
4.13.3 Functional Requirements
REQ-9: A webcam must be installed on the system

4.14 Change Output Video Format
4.14.1 Description and Priority
This feature allows the user to choose the output video format. CamStudio has set
AVI format to be the default. However the user is able to change this setting so that
SWF video files are produced.
Priority: Medium
4.14.2 Stimulus/Response Sequences
4.14.2.1 Basic Path
1. User clicks on the (round) "swf" button which appears on the central button bar
2. A small message appears that informs the user the current output video format
4.14.3 Functional Requirements
Not any

For the following features use cases are not included

4.15 Set Program Options
4.15.1 Description and Priority
The user can access this feature by selecting Options → Program Options. This
feature allows the user to set/modify options about the recording. The program
options are:
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Minimize program on start recording:
This option, when selected, minimizes CamStudio on the system tray when
the recording starts.



Hide flashing rectangle during recording:
This option, when enabled, hides the flashing rectangle that appears on the
user's screen while recording.



Save settings on exit:
This option, when enabled, allows the user to save any changes that were
made. Those modifications will still apply the next time the program opens.



Capture translucent/layered windows:
This option is useful for users that have installed CamStudio on Windows
2000 or Windows XP. In those operating systems there are windows that are
translucent/layered and cannot be captured when this option is not enabled.



Play AVI file when recording stops:
This option allows the user to select if the output video will start playing right
after the recording and which player will be used.



Directory for recording:
This option allows the user to select the directory, in which the temporary
files that are created during recording, will be saved.



Recording thread priority:
This option allows the user to select the recording priority of CamStudio over
the priority of other programs or tasks that may be running at the same time.



Name of AVI file:
This option allows the user to select whether the produced video will be
automatically or manually named.



Keyboard shortcuts…:
This option opens a dialog window that allows the user to set or modify the
keyboard shortcuts for some of the basic system features.



Troubleshoot…:
This option opens a dialog window that helps the user to diagnose and resolve
some problems.

Priority: Medium
4.15.2 Functional Requirements
Not any
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4.16 Select Language
4.16.1 Description and Priority
The user can access this feature by selecting Options → Language. This feature
allows the user to select the language in which the program will be presented. Two
language options are available: English end German
Priority: Medium
4.16.2 Functional Requirements
Not any

4.17 Convert AVI Files to SWF Files (Using CamStudio SWF Producer)
4.17.1 Description and Priority
The user can access this feature by selecting Tools → SWF Producer (Converts AVI
to Flash). By selecting this option SWF Producer is launched as a standalone
program. This feature provides the option of converting an AVI video file to a SWF
file in a lossless manner.
Priority: Low
4.17.2 Functional Requirements
Not any

5. Other Nonfunctional Requirements
5.1 Performance Requirements




Sampling issue: if the sampling frequency is too slow, it may not be able to pick up some
cursor movements if the mouse moves too fast. This will result to a recorded video where
the cursor will not appear properly. The sampling issue may also occur when a fast
animation is recorded. If CamStudio cannot record much faster than the changes in the
animation this will result to a not smooth recorded video.
General performance: there are some factors that will affect the performance of the
recording. Those are:
 Computer CPU speed
 Recording a movie that covers a large area
 Recording pictures that contain many colors
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 Running other applications during recording sessions
File size: it is very common to produce video recordings whose file size exceed one
megabyte. Here are some suggestions in order to capture videos with reduced file size:
 Limit the area of the region being captured
 Limit the input frame rate
 Change the compressor and compression quality

Appendix A: Glossary
SRS: Software Requirements Specification
AVI: Audio Video Interleave
SWF: ShockWave Flash
HTML: HyperText Markup Language
FAQ: Frequently Asked Questions
REQ: Requirement

Appendix B: Issues List – Changelog
Version 2.6
1. Record from speakers feature returned
2. Tons of minor GUI improvements
3. Major code refactoring
Version 2.5
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Recorder
1. Added recording region by window
2. Added left and right mouse button visual feedback when clicked
3. Added true multi-language support for Recorder, SWF Producer and Player
4. REMOVED recording audio from speakers due to lack of source code
5. Added recording for a preset amount of time
6. New Effects menu added with:
 Add system time stamp to video
 Add caption to video
 Add watermark to video (transparency not supported, yet!)
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SWF Producer
1. Added redirect URL function so viewers can be taken to another URL immediately
after the video has finished playing.
2. Added a cancel button to the "Converting to SWF" dialog so you can cancel an SWF
conversion at any time. You don't have to wait until it's finished or force it to close
with CTRL, ALT, DEL.
3. Fixed Firefox bug when playing a Flash SWF file (caused due to incorrect HTML)
Outstanding stuff
o When using another language, some menus and options are either missing or still in
English.
o Native Vista compatibility not supported, but workaround listed on the blog using
XP Compatibility Mode.
o Documentation not complete(still working on it)

Version 2.0
1. Flash (.swf) output - you can now produce small, stream-able Flash files with lossless
compression (in perfect quality) with CamStudio. This is made possible with the
introduction of a new module - the SWF Producer - that is distributed with the CamStudio
package. What the SWF Producer basically does is to convert AVI files to Flash (.swf) files.
It can convert almost all AVI files to Flash, including those not produced with CamStudio.
The SWF Producer can operate in 3 modes:
1. Standalone mode
The SWF Producer runs like a normal program. You can launch it by selecting the
Tools -> SWF Producer command inside the CamStudio Screen Recorder, or by
simply double clicking the Producer.exe file in the installed directory.
2. Record Directly to Flash
You can set the CamStudio Recorder to record directly to Flash.
3. Command-line mode (silence mode)
The Producer can also be launched on the command line (in DOS Prompt) by typing
Producer.exe -b filename.avi When Producer is launched this way, it opens the file
"filename.avi" when it starts, automatically converts the AVI movie to Flash, and
then exits. It will not issue any error messages during conversion. You can convert
multiple AVI files this way.
2. With the auto-naming feature you can now avoid giving a name to every AVI you record.
(Options -> Program Options -> Name of AVI file) The name of the file is automatically
formed using the system's date and time of recording and is saved in CamStudio's installed
directory.
3. Improvements to CamStudio Player 2.0 (playplus.exe); the following options are now
available when running playplus.exe in the command line mode:
o playplus -a filename.avi
This will launch the AVI file (filename.avi) and play it automatically.
o playplus -x filename.avi
This will launch the AVI file (filename.avi) and play it automatically. The player will
exit when the playback is completed.
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Version 1.8
1. Screen Annotation
Allows you to display screen captions on your desktop while recording. These captions are
anti-aliased, high quality images that can display text in multiple languages. You can also
make a caption transparent and create a cutout region for it.
2. Video Annotation
Allows you to stream the contents of your web-cam onto your desktop. With this feature,
you can add a personal touch to your recordings by including a movie of yourself into the
AVI. The video annotations window, like the screen annotations, can be made transparent
(Win XP) and assigned a cutout region.
3. You can now pan the fixed region of recording by dragging any of the four corners around it.
4. With the new Audio and Video Synchronization feature, you can now shift the video stream
slightly to make the audio and video streams be in phase.
5. Bugs are fixed for keyboard shortcuts that may not function properly in previous versions.
Version 1.6
1.
2.
3.
4.

Recording of sound from your speakers (for sound cards that support this feature).
Capturing of translucent/layered windows (for Windows 2000/XP).
Update of the controls to Win XP look (for Windows XP users only).
Ability to customize the temporary directory for recording. Setting this to an appropriate
drive can reduce crashes due to lack of free space.
5. Some bug fixes (filtering out certain codecs that crash CamStudio).
Version 1.25
1. Added support for the DivX Codec (for certain image dimensions).
2. Recording with audio in default settings will no longer give a huge file size.
3. You may now specify the interleave factor of audio of video in milliseconds instead of
frames.
4. You may now specify the X and Y coordinates of a fixed region before the recording starts.
Version 1.2
1.
2.
3.
4.
5.

Saving of user settings on exit.
Support for user-customizable shortcuts to start/stop the recorder.
An improved video options panel.
A new button for toggling between different views.
CamStudio now minimizes to the system tray. Double click its icon in the system tray to
restore CamStudio.

