MicroStation PowerDraft V8i for Students

Bentley Institute Course Guide

Bentley Institute

November 2010
Trademarks

AccuDraw, Bentley, the “B” Bentley logo, MDL, MicroStation and SmartLine are registered trademarks; PopSet and Raster Manager are trademarks; Bentley SELECT is a service mark of Bentley Systems, Incorporated or Bentley Software, Inc.

AutoCAD is a registered trademark of Autodesk, Inc.

All other brands and product names are the trademarks of their respective owners.

Patents

United States Patent Nos. 5,815,415 and 5,784,068 and 6,199,125.

Copyrights


All rights reserved.
# Table of Contents

## Introduction

| What is in the MicroStation PowerDraft Student Training Guide? | 13 |
| Who Should Use This Book? | 13 |
| What Software Version is it for? | 13 |
| How to Read This Book | 13 |

## MicroStation PowerDraft Concepts

| System Overview | 15 |
| Positioning the Cursor | 15 |
| Menus | 15 |
| Elements | 15 |
| Levels | 16 |
| Reference Drawings | 16 |
| Views | 16 |
| View Control | 16 |
| Attributes | 16 |
| Real World Coordinates | 16 |
| Snap | 17 |
| Design Plane | 17 |
| Global Origin | 17 |
| Handle Point | 17 |
| Coordinate Entry | 18 |
| Going On From Here | 18 |

## Lesson 1: File Navigation

<p>| File Extension | 19 |
| File Save/Workfile | 19 |
| To Load a File | 19 |</p>
<table>
<thead>
<tr>
<th>Lesson</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>First Things First</td>
</tr>
<tr>
<td>3</td>
<td>Beginning to Draw</td>
</tr>
<tr>
<td>4</td>
<td>Manipulating Elements</td>
</tr>
<tr>
<td>5</td>
<td>Modifying Elements</td>
</tr>
<tr>
<td>6</td>
<td>Changing Element Attributes</td>
</tr>
</tbody>
</table>

**Changing Things**

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Manipulating Elements</td>
</tr>
<tr>
<td>5</td>
<td>Modifying Elements</td>
</tr>
<tr>
<td>6</td>
<td>Changing Element Attributes</td>
</tr>
</tbody>
</table>

**Menu Survey**

<table>
<thead>
<tr>
<th>Menu</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>41</td>
</tr>
<tr>
<td>Edit</td>
<td>43</td>
</tr>
<tr>
<td>Element</td>
<td>44</td>
</tr>
<tr>
<td>Settings</td>
<td>45</td>
</tr>
<tr>
<td>ACCUSNAP</td>
<td>48</td>
</tr>
</tbody>
</table>
# ACCUSNAP SETTINGS

- Tools Menu: 48
- Utilities Menu: 50
- Workspace Menu: 52
- Window Menu: 53
- Help Menu: 54
- Summary: 54

## Input of Precise Geometric Data

**Lesson 7: Key In of Coordinate Data**

- Using Key-In Commands: 55
- The XY= Key-In Command: 55
- The DX= and DL= Key-In Commands: 56
- The DI= Key-In Command: 57
- Key-In of Coordinate Data Using ACCUDRAW: 57

**Exercise 2: Stepped-Shaft**

**Summary**: 59

## Working with Groups

**Lesson 8: Fences**

- Fence Tool Box: 63
- Three Most Common Fence Tools: 64

**Lesson 9: Element Selection Tool**

**Exercise 3: Sprinkler Protector**

**Review**: 67

- File Navigation: 67
- Menus: 68
- Master-Sub Working Units and Grids: 68
- Main and Task Navigator Tool Boxes: 68
- Panning and View Control in Middle of a Command: 68
- Data-Reset-Tentative: 68
- ACCUSNAP: 68
- Accept/Reject: 68
- Tool Settings Window: 69
- Command and Prompt: 69
- Manipulating and Modifying Element: 69
# Table of Contents

- **INPUT FOCUS** .............................................................................................. 69
- **POSITIONAL MAPPING** ............................................................................ 69
- **ACCUDRAW** ............................................................................................... 69
- **COMPANY STANDARD SEED FILE** .......................................................... 70

## Using Levels

- LESSON 10: LEVELS ..................................................................................... 71
  - LEVEL MANAGER DIALOG BOX ............................................................... 71
  - LEVEL DISPLAY DIALOG BOX ................................................................. 72
- LESSON 11: MOVING ELEMENTS AMONG LEVELS ...................................... 73
- LESSON 12: LEVEL LOCKS ............................................................................. 74

## Using Multi-lines

- LESSON 13: MULTI-LINE SET-UP ................................................................. 75
- LESSON 14: PLACING MULTI-LINES ............................................................. 76
- LESSON 15: CLEANING UP MULTI-LINE JOINTS .......................................... 76
- EXERCISE 4: FLOOR PLAN ............................................................................ 77

## Text

- LESSON 16: TEXT SETTINGS ........................................................................ 81
  - FONTS ........................................................................................................ 81
  - TEXT JUSTIFICATION ............................................................................... 81
  - TEXT SIZE AND SPACING ......................................................................... 82
- LESSON 17: PLACING TEXT ......................................................................... 82
  - PLACE TEXT TOOLS .................................................................................. 83
- LESSON 18: EDITING TEXT ......................................................................... 84
- EXERCISE 5: NOTES ON FLOOR PLAN .......................................................... 85

## Cells

- LESSON 19: CELL LIBRARY CREATION ....................................................... 87
- LESSON 20: CELL LIBRARY ATTACHMENT ............................................... 88
- LESSON 21: CREATING CELLS .................................................................... 89
- LESSON 22: PLACING CELLS ...................................................................... 89
  - PLACEMENT ............................................................................................... 90
  - POINT ........................................................................................................ 90
  - TERMINATOR ............................................................................................ 90
## Printing Your Drawing

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEFINING WHAT TO PRINT</td>
<td>117</td>
</tr>
<tr>
<td>VIEW</td>
<td>117</td>
</tr>
<tr>
<td>FENCE</td>
<td>117</td>
</tr>
<tr>
<td>PRINTER AND PAPER SIZE</td>
<td>118</td>
</tr>
<tr>
<td>PRINT SCALE AND POSITION</td>
<td>118</td>
</tr>
<tr>
<td>PRINT DIALOG BOX ICONS</td>
<td>119</td>
</tr>
<tr>
<td>PRINT</td>
<td>119</td>
</tr>
<tr>
<td>PREVIEW</td>
<td>119</td>
</tr>
<tr>
<td>MAXIMIZE PRINT SIZE</td>
<td>119</td>
</tr>
<tr>
<td>PRINT ATTRIBUTES</td>
<td>119</td>
</tr>
<tr>
<td>UPDATE FROM VIEW</td>
<td>119</td>
</tr>
<tr>
<td>PLOTFILE</td>
<td>120</td>
</tr>
<tr>
<td>PRINTING FROM WINDOWS</td>
<td>120</td>
</tr>
</tbody>
</table>

## Summary of 2D and Moving On

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>SELECTED ADVANCED 2D TOPICS</td>
<td>121</td>
</tr>
<tr>
<td>DIFFERENCES BETWEEN MICROSTATION POWERDRAFT AND AUTOCAD</td>
<td>123</td>
</tr>
</tbody>
</table>

## 3D Concepts

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>BASIC 3D CONCEPTS</td>
<td>125</td>
</tr>
<tr>
<td>THE RIGHT HAND RULE</td>
<td>126</td>
</tr>
<tr>
<td>EIGHT STANDARD VIEWS</td>
<td>127</td>
</tr>
<tr>
<td>SCREEN AXIS VS. MODEL AXIS</td>
<td>127</td>
</tr>
<tr>
<td>THE RIGHT HAND RULE FOR ANGLES</td>
<td>128</td>
</tr>
<tr>
<td>VIEW VOLUME</td>
<td>128</td>
</tr>
<tr>
<td>ACTIVE DEPTH</td>
<td>129</td>
</tr>
<tr>
<td>LESSON 29 - UNDERSTANDING 3D CONCEPTS</td>
<td>129</td>
</tr>
</tbody>
</table>

## Precise 3D Input

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCUDRAW IN 3D</td>
<td>133</td>
</tr>
<tr>
<td>EXERCISE 10: 3D MODEL OF A KITE</td>
<td>134</td>
</tr>
<tr>
<td>LESSON 30: PROJECTING 2D INTO 3D MODELS</td>
<td>135</td>
</tr>
<tr>
<td>EXERCISE 11: 2D SHAPES CONVERTED TO 3D</td>
<td>135</td>
</tr>
</tbody>
</table>

## Creating and Manipulating Solid Models

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>137</td>
</tr>
</tbody>
</table>
Lesson 31: Basic Approach ................................................................. 137
Lesson 32: Joining Primitives to Make More Complex Solids .......... 137
Exercise 12: Creating an L Bracket by the Union of Two Slabs .......... 138
Lesson 33: More on Features ............................................................. 138
Modeling Summary ......................................................................... 139
Modeling Hints .............................................................................. 139

Reference Files and Drawing Composition ......................................... 141
Lesson 34: Reference Files ............................................................... 141
Design Reference ............................................................................ 141
Detail Sheets .................................................................................. 142
Title Block and Borders ................................................................. 142
Self Referencing ............................................................................ 142
Reference Raster ............................................................................ 142
Raster Reference Files .................................................................... 143
Lesson 35: Drawing Composition from 3D Models ......................... 144
Creating Sheet Models .................................................................... 145

Rendering and Animation ................................................................. 151
Rendering ....................................................................................... 151
Ray Tracing and Radiosity ............................................................ 151
Animation in MicroStation PowerDraft ......................................... 152
Creating a Flythrough .................................................................... 152
Animation Producer ....................................................................... 154

Appendix ......................................................................................... 157
Shortcut 2D Key-in Commands ....................................................... 157
Introduction

What is in the MicroStation PowerDraft Student Training Guide?

The MicroStation PowerDraft Training Guide is a collection of lessons and lab exercises designed for a CAD course using Bentley Systems’ MicroStation PowerDraft Academic Suite as the software. It is the only book on the market that covers an introduction to MicroStation PowerDraft 2D and 3D. It is also useful for users of other CAD who need to quickly get started in MicroStation PowerDraft.

The exercises are a combination of text and illustrations in a step-by-step format intended to guide you from beginning to intermediate level. Exercises are self-explanatory and can be used self-guided or as a text for a short course or classroom semester course combined with lecture and demonstration.

For additional, in-depth information on MicroStation PowerDraft, refer to the product’s Help file. The Help file supplied with the product includes a Getting Started section, which is very useful. Help is always the most up to date reference information for a particular release of the software. docs.bentley.com is your repository of product help files and books. You can browse through online help for specific information or download it to ensure you have the most recent help available on your computer.

The exercises in this book have been developed through a number of presentations and have been reviewed and perfected with the help of many students and instructors. We sincerely hope that you will find them helpful and useful.

Who Should Use This Book?

Anyone who wants to quickly learn how to use MicroStation PowerDraft to produce technical drawings and 3D models.

What Software Version is it for?

This book is written for MicroStation PowerDraft V8i SELECTseries 1 and later.

How to Read This Book

The MicroStation PowerDraft Training Guide is designed to use minimum words and maximum step-by-step exercises to take you quickly up the learning curve. Each subject is introduced with a very short description and then a step-by-step exercise. You can skip the description and go directly to exercises if you want.

Menu selections are shown with each step separated by “>.” For example, “Settings > Design File > Grids” means that you first select the Settings menu at the top of the screen, then select Design File from the list, and then select Grids.
How to Read This Book
MicroStation PowerDraft

Concepts

If you are new to CAD, read this section carefully; if you are experienced in CAD, you may go directly to Lesson 1: File Navigation on page 15.

System Overview

MicroStation PowerDraft can be operated as a 2D general-purpose drafting program or as a full 3D modeling program. The first few chapters on MicroStation PowerDraft address 2D drafting; 3D will be introduced later. The 2D commands learned also apply to 3D. MicroStation PowerDraft is an extract from MicroStation, intended for the production drafting function. It is essentially the same as MicroStation 2D plus some of the 3D.

Positioning the Cursor

MicroStation PowerDraft receives its graphic input from the mouse or digitizer. This manual refers to the graphic input device as a mouse, i.e., the object you use to move the graphic cursor on the screen. This manual refers to the left mouse button as the data button or the mouse button and the right mouse button as the reset button.

Menus

MicroStation PowerDraft commands appear on menus. A menu is a list of options available to you. Each menu has a specific purpose. For example, the File menu allows you to enter a command to open or retrieve a drawing you have previously saved. A file is a place in the computer where a drawing is stored. This manual interchangeably uses File or Drawings.

Some menu selections cause a dialog box to open. A dialog box provides further options for a menu command.

Some menus can be opened as a tool box. A tool box is a list of little drawings called icons. You can click on an icon to command MicroStation PowerDraft. For example, click on the little circle to command MicroStation PowerDraft to draw a circle.

Elements

MicroStation PowerDraft allows you to create a drawing using basic building blocks called elements. Other CAD software programs refer to these building blocks as objects or entities or primitives. Elements include lines, circles, arcs, French curves (Bézier curves), points, text and more.

Cells (referred to as symbols or blocks in other software) are created from elements and stored in libraries for later use.
Series of elements can be connected such as lines, arcs and curves into “complex chains.” The complex chain can then be treated as an element. Some software call these connected elements a “polyline.” MicroStation PowerDraft also uses the term “SmartLine” for connected elements.

Levels

MicroStation PowerDraft allows you to manipulate an unlimited number of different layers or levels. A level can be thought of as one sheet of clear plastic. All elements with the same level number are on the same sheet. Turning on one level is like viewing only one sheet. Turning on a second level is like placing a second sheet on top of the first.

Reference Drawings

Information can also be separated by use of Reference drawings. When making a new drawing, any existing drawings can be viewed simultaneously with the new drawing. When a drawing is viewed as such, it is called a “reference drawing” since it is being used as a reference for the new drawing. An example would be to view a floor plan as a reference when making a new drawing of the electrical wiring for a house. A new drawing can reference any number of other drawings.

Views

MicroStation PowerDraft can display from 1 to 8 different views of the same file (2D drawing or 3D model). Each view is independent of the other views.

View Control

MicroStation PowerDraft allows you to view your drawing through up to eight windows. You can move each viewing window around, and thus look at different portions of your drawing. In addition, you can shrink the window so that you are looking at a tiny detail of the drawing (magnified to fill the view on your display screen). Or, you can take a “birds eye” view by “zooming out” to look at your entire design from a distance.

Attributes

Each element you create is automatically assigned certain attributes that stay with it. For example, a line will have a ‘linestyle’, i.e. solid, dashed, dotted, etc. Other attributes include color, level number and line width. The attributes of an element can be changed after it is placed.

Real World Coordinates

Each drawing is created using the appropriate “real world” units. Whether the drawing consists of a 100 millimeter machine part or a 1000 foot facilities layout, you can create and position each element in its actual dimensions. All scaling for the sake of putting your design on paper is done at the time you send your design to the plotter.
Snap

Snapping pulls (or snaps) the cursor to a precise X, Y location that you desire. Several different types of snaps can be selected from the Snap menu. Keypoint is the most common. Keypoints are the characteristic points on an element such as end-points and center of a line, center and quarter-points of a circle. You can also snap to the intersection of two lines, tangent or perpendicular, and more. MicroStation PowerDraft also uses AccuSnap, which automatically finds the nearest snap point when Accusnap is active.

Design Plane

MicroStation PowerDraft uses the concept of a design plane. A MicroStation PowerDraft design plane is essentially infinite in either direction. Actually coordinates are stored in 64 bit IEEE floating point which provides a huge range of coordinates that for all practical purposes is infinite.

Global Origin

Since the design plane is really a coordinate system that you draw on, somewhere in the design plane there has to be a point with the coordinates 0,0. This point is referred to as the global origin. This coordinate system is set up for master units. In other words, the coordinate 1,0 lies one master unit to the right of the global origin, and the coordinate 1.5,0 lies one and one half master units to the right of the global origin.

The following illustration shows you the coordinate layout of a design plane.

Handle Point

A handle point is the point on an element by which you control placement or modification. When adding elements to your drawing, you are guided by prompts, such as Place first point of line, Place
When modifying elements, such as moving a rectangle (called a block in MicroStation PowerDraft) you control its movement with the point at which you select it.

**Coordinate Entry**

There are several ways to enter the X and Y coordinates for placement of an element. When a prompt calls for the location of a point, you can move the cursor to the desired coordinates and press the mouse button.

Or, you can type XY=a,b <return> to supply the coordinates a and b from the keyboard. These are called absolute coordinates.

Or, you can type DL=c,d <return> to supply c (the change in X from the previous location) and d (the change in Y). These are called relative coordinates.

Or, you can type DI=e,f <return> to supply the radius “e” and angle “f” of polar coordinate changes from the previous location. These are called polar coordinates.

MicroStation PowerDraft uses a method of entering coordinates called AccuDraw. AccuDraw uses your hand motion to determine whether you want to enter positive or negative, x or y coordinates and then you simply type the number representing the distance. AccuDraw greatly reduces the number of keystrokes required to enter precise coordinates.

**Going On From Here**

At this point you have a basic understanding of the concepts of MicroStation PowerDraft. This is a good time to sit at a computer with MicroStation PowerDraft and begin to get some hands-on experience.

If you have carefully read this introduction, you have a head start in using the MicroStation PowerDraft program. Don’t worry if some of it doesn’t make sense right now; after you have worked with the system for a while, it will fall into place. When you have gained a little experience, come back
and read these concepts again. Also try reading the MicroStation PowerDraft Getting Started in the Help from MicroStation PowerDraft main menu.

From this point, we will shift to a lesson style that includes short readings and hands-on work. After a few lessons, we will shift to an emphasis on exercises where you will quickly learn to produce real designs.

**Lesson 1: File Navigation**

You save and retrieve drawings (called files in computer terminology) using a dialog box. The MicroStation Manager dialog box displays when you first launch MicroStation PowerDraft. Or, you can select File > Open when you are already running MicroStation PowerDraft. In either case, the operation of the dialog box is similar. The drop down list shows the directories (or folders) that you can open to find your file. The list underneath shows the names of the files within the selected directory that meet the Type of file you want. MicroStation PowerDraft files have a .dgn extension so in the MicroStation Manager you will be looking for Files of type: *.dgn. You double-click on directories to change to a different directory and you double-click on file names to load a file. Try these operations:

From MicroStation PowerDraft, select File > Open.

To change directories, click on the drop down list, then click on the folder you want to open.

**File Extension**

Note that MicroStation PowerDraft drawing files have an extension .DGN (similar to AutoCAD .DWG, VersaCAD .2D, etc.)

**File Save/Workfile**

Some CAD software such as VersaCAD or AutoCAD have a Workfile concept. The saved drawing is loaded into the workfile, then work is done. Then the drawing is “saved” from the Workfile back to the Saved file. However, MicroStation PowerDraft works on the saved file directly.

**To Load a File**

Use the File pull-down in upper left corner to load recently used files. Or, double-click on File name shown in left hand box when ready.

**New Design File**

Use a Seed file to start a new design file. A Seed file is like a template.

The Seed file presets settings and parameters conveniently for an application.

As an exercise, try this from the File pull-down on the main menu:

1 Select New.
In the New dialog box, click the Browse button (lower right corner of dialog).

In the Select Seed File dialog box, select the seed file, seed2D.dgn and double-click it or click Open.

Back in the New dialog box, supply the file name (the .dgn extension is added automatically).

Click Save.

Note: Once you save your new file, it may ask if you want to save the file you are working in presently [Untitled1.dgn]. Select No. Then you will be working within your new file.

This creates a new file with name you supplied in step 4. The file will be saved in the directory folder you selected in Save in at top of dialog box. You can click on My Documents on the left and keep all your files there conveniently.

---

MicroStation PowerDraft Menus

MicroStation PowerDraft offers several ways to do commands:

1 Click-click — click on the menu name at the top of the screen. Then click on the menu item in the pull-down.

2 Click/drag/let go — hold the button down over menu and keep it down while moving to menu item in pull-down. Then let go of the button.
3 Powerkey — press <Alt> and underlined letter on main menu. Press only the underlined letter in sub menus.

4 Type in the complete command after opening the Key-in dialog box (Utilities > Key-in).

5 Type-in the command abbreviation See the Appendix (page 140) for a list of command shortcuts.

6 Use the Key-in Browser in Help or Utilities > Key-in.

7 Use the single keystrokes, such as <Q> then <2> to start the Place Line tool. Note the single letters at lower left of each icon.

MicroStation PowerDraft Settings

The first thing to do with any new design file is to set up the working units. Users often set the working units in the company’s standard seed files so you may not have to do this step. But, for new users, it is good to practice settings.

MicroStation PowerDraft has a flexible dimensional unit system for which there are two parts:

- mu - master units (for example, feet)
- su - sub units (for example, inches)

A practical set up would be:

- mu = feet
- su = inches (12 per foot)

Exercises

To experiment with menus and to set up working units before adding any geometry to a new file, try getting to Working Units in three different ways, first:

1 From the main menu, select Settings, then Design File.

2 In the DGN File Settings dialog box, select the Working Units category.

3 Click on Cancel.

Then try:

1 Click on Settings and keep the button depressed.

2 Drag the cursor to Design File, then release button.

3 Click on Cancel.
Finally, try:

1. While pressing the <Alt>, type <S>.
2. Type <D>, then <W>.
3. Change the Master Unit to Feet.
4. Use the <Tab> key to the Label field and key in the mark ‘ ‘ for feet.
5. Use the <Tab> key to go to Sub Unit.
   Sub units were automatically changed to inches.
6. <Tab> to the Label field and enter “ ” to represent inches on drawings.
7. To accept the changes:
   tab until OK is highlighted and then press <Enter>
   or
   type <Alt-O> since O is underlined
   or
   move the cursor to OK and click the button

Your drawing file is now set up for a drawing of feet and inches. To set up a mechanical drawing, use inches or millimeters for master units.

**Grids**

To make your whole file consistent, change the grid which is presently a reference line every 10 inches to every 12 inches:

1. Click on Settings > Design File.
2. In the DGN File Settings dialog box, select the Grid category.
3. Turn on Grid Lock (a check mark in the box).
4. Change Grid Master to 0:1 (i.e., 1").
5. Change Grid Reference to 12.
6. Click OK to close the DGN File Settings dialog box.

You now have set up a normal architectural file. To save these settings for the next time you open this drawing, go to File > Save Settings and click.
Coordinate Readout

MicroStation PowerDraft shows you coordinates in the format: mu:su, for example, 5:4.125. This example means the following: 5 master units and 4.125 subunits. This format is useful when working with master units in feet and subunits in inches, such as architectural drawings. The example 5:4.125 would represent 5'-4.125". For this format, choose Settings > Design File > Working Units and set Format to MU:SU. Set Accuracy to something reasonable, for example 1/16, then above example would show as 5'-4 1/8" (Accuracy means the precision by which coordinates and dimensions will be displayed. Coordinates are stored in the computer to much greater precision.)

When working with units in inches and decimal inches or millimeters and decimal mm as is common for mechanical drawings, the coordinate readout is better understood as 5.4125 rather than 5:4.125.

When working with mechanical drawings, civil drawings or any drawing that is expressed in units and decimal units, choose Settings > Design File > Working Units and then change Format to MU, master units. Change the Accuracy to something appropriate to your requirements, for example 0.12 to represent 2 decimal digits of precision.

Status Bar

The Status bar provides prompts, context-sensitive assistance, and some interactive functionality. It displays at the bottom of the application window. The left most section shows the name of the selected tool or view control and (usually) a prompt for the next step in the normal procedure for using it.

Lesson 3: Beginning to Draw

There are several different ways to display the Main tool box for adding elements and modifying elements after they are added to a file. Normally, when MicroStation PowerDraft is installed and first launched, the Main tool box displays automatically on the left Task panel.
The Main tool box is now always at the top of the Task panel on the left hand side of the drawing. It is split between the Main tools used for modifying elements already in the file and the Drawing task for adding graphics to the file. Here is a screen showing that approach which puts a single row of commands on top of the Drawing task:

The icons on the tool bar on the left are the ones that are used to modify a drawing. This is the Main tool box. The icons underneath the Main tool box are the ones to use to place elements such as lines, circles, text, etc. This is the Task Navigation bar.

Since the XM edition, if you click on a tool in the Main tool box and hold down the mouse button, all of the subtools display in a list with the icon, the single stroke character (positional keyboard navigation) and the name of the command. Positional keyboard navigation is a technique that utilizes a position-mapped keyboard. Position mapping is the mapping of keyboard zones to logical collections of controls in the user interface.

With the V8i SS1 version, you can dock the Main tool box at the left or right side of your screen by using the mouse to place the cursor at the top border of the frame, press down on the left mouse button, and hold it down while you slide the frame firmly to the left or right.

**MicroStation PowerDraft Main Tool Box**

Whether the Main Tool box is docked or broken off, it always remains at the top of the Task panel.

The small black arrow at the lower right corner of each tool means that if you click and hold down, you will see the other tools.

The tools included in MicroStation PowerDraft are the same as the tools in MicroStation. Everything you learn in MicroStation PowerDraft is directly transferable when you use MicroStation.

There are nine different tools in the Main Tool box. Review them here:
<table>
<thead>
<tr>
<th>Element Selection</th>
<th>Used to select a tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Place Fence</td>
<td>Used to place, modify, and manipulate fences and fence contents</td>
</tr>
<tr>
<td>Copy</td>
<td>Used to copy, move, resize, rotate, mirror, and create arrays of elements</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Used to change views such as fit view, zoom in, zoom out, and more</td>
</tr>
<tr>
<td>Modify Element</td>
<td>Used to modify element geometry</td>
</tr>
<tr>
<td>Change Element Attributes</td>
<td>Used to change an element(s) to the active element attribute settings</td>
</tr>
<tr>
<td>Drop Element</td>
<td>Used to drop or create complex elements from their component elements</td>
</tr>
<tr>
<td>Delete Element</td>
<td>Used to remove an element</td>
</tr>
<tr>
<td>Measure Distance</td>
<td>Used to perform measuring operations</td>
</tr>
</tbody>
</table>

### Task Navigation

The Task Navigation tool box contains the Task List and the tools of the active task. In the as-delivered application window layout, the Task Navigation tool box is docked to the left-hand edge of the application window, and the active task is the Drawing task.

### Controlling the view

Briefly review the tools of the View Control tool bar.

You do not need to display the View Control tool bar to access these tools. In the V8i SS1 edition, they are displayed at the top of the view.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update View</td>
<td>Used to update (redraw) the contents of a view window(s)</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Used to increase a view window's magnification, making elements appear larger</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Used to decrease a window's magnification, making elements appear smaller</td>
</tr>
<tr>
<td>Window Area</td>
<td>Used to indicate a rectangular area in the design that is to be displayed in a view</td>
</tr>
<tr>
<td>Fit View</td>
<td>Used to adjust the view magnification so that the entire design is visible in the view</td>
</tr>
<tr>
<td>Rotate View</td>
<td>Used to rotate a view</td>
</tr>
<tr>
<td>Pan View</td>
<td>Used to view a different part of the design without changing the view magnification</td>
</tr>
<tr>
<td>Walk</td>
<td>Used in 3D</td>
</tr>
<tr>
<td>Fly</td>
<td>Used in 3D</td>
</tr>
<tr>
<td>Navigate View</td>
<td>Used in 3D</td>
</tr>
<tr>
<td>View Previous</td>
<td>See previous view</td>
</tr>
</tbody>
</table>
The Reset Button

<table>
<thead>
<tr>
<th>View Next</th>
<th>Come back after previous view</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy View</td>
<td>Used to copy the contents of an entire view and its corresponding attributes to other views</td>
</tr>
<tr>
<td>View Perspective</td>
<td>Used to change the perspective of a view</td>
</tr>
<tr>
<td>Set Display Depth</td>
<td>Used in 3D</td>
</tr>
<tr>
<td>Show Display Depth</td>
<td>Used in 3D</td>
</tr>
<tr>
<td>Setup Camera</td>
<td>Used in 3D</td>
</tr>
<tr>
<td>Render</td>
<td>Used to render views, fences and elements</td>
</tr>
<tr>
<td>View Display Mode</td>
<td>Used to change the display mode of a view</td>
</tr>
<tr>
<td>Apply or Modify Clip Volume</td>
<td>Used to limit the view of your design to a specific rectangular area</td>
</tr>
<tr>
<td>Clip Mask</td>
<td>Used to hide a rectangular area of your design</td>
</tr>
</tbody>
</table>

To Pan across the drawing, press the <shift> key and move the graphics cursor away from the center of the view while holding the data button down.

View control is attached to the bottom of each view. In addition to <Shift-click>, you can Pan with Pan View tool. Also, if your mouse is equipped with a middle or scroll button, you can press and hold that button to Pan.

**The Reset Button**

MicroStation PowerDraft is set up for a two-button mouse or digitizer puck. One of the buttons is the data button, i.e., the button for clicking to select a menu or to enter a coordinate pair (X & Y) location.

The other button is called Reset and is used for different things including to: reset to beginning of commands, reject a tentative selection or select a snap point.

Snapping is one of the basic features of any CAD system. MicroStation PowerDraft offers a number of different types of snap. Right now, we are set up to snap automatically on grid points (every inch) or to a keypoint on an object.

To snap to a keypoint, the reset and data buttons are pressed at-the-same-time. A large cursor will appear showing the “tentative” location you snapped to. If you like it, press the data button once more. If you don't like it, press the reset button, then try again.

Your computer may be setup with a 3 button mouse. In that case, you will want to setup so you can press the middle button on your mouse rather than the reset and data buttons if you do not have or want it set up for panning.

If you have a three-button mouse, and the middle button is not functioning for snapping, go to Workspace > Button Assignments. Highlight tentative in the list box, then move the cursor to the Button Definition Area and press the middle button. Note the change in the list box. Click OK. Then select File > Save Settings. Your middle mouse button should now function for snapping.

Snapping can also be done automatically with AccuSnap. More on AccuSnap later.
Now, we are ready to start drawing or creating our design file.

Let’s start by making a scratch-pad drawing of the most used drawing tools:

1. Use the Place SmartLine tool to draw a line between three dots (grid reference points).

   Note: You may need to zoom in or out to see the dots.

2. Use the Place Block tool to draw a box.

3. Use the Place Arc tool to draw an arc.

4. Use the Place Circle tool to draw a circle until you have drawn one each of everything you can by watching the prompt messages displayed at the bottom of the screen after selecting each drawing tool.

Continuous Draw Mode

MicroStation PowerDraft is in continuous-draw-mode. For example, when drawing lines, after drawing one line, MicroStation PowerDraft is ready to draw the next line, and then the next. There are several ways to stop drawing lines:

1. To stop drawing lines and begin another tool such as circle, click on the Place Circle tool.

2. To stop drawing lines but stay in the line drawing tool, press the Reset button.

3. To stop drawing lines and exit all commands, click on the Element Selection tool.

One exception to above: When drawing curves, you must accept the desired curve using the Reset button before terminating the curve drawing tool.

Tool Settings

The tool settings window’s contents and heading change depending on which tool is in use. The tool settings window opens automatically when you select a tool. It contains all of the settings available for that particular tool.

Note the colored ball at top of screen. This is called PopSet. If green, the tool settings appear right next to the tool you select. It disappears when you move the cursor near the window. If red, the tool settings window is always displayed.

Searching for a Needed Tool

If you’re not sure what function an icon performs, simply move the cursor over it and the short
description of the command displays at the bottom of the screen. Or, if the icon is part of a sub tool box, hold the data button down as you slide over the main icons.

**Input Focus**

Just like any Windows software, you must have the “input focus” on the dialog box where you want to input the data. For example, if you have the tool settings open, and some other dialog at the same time, MicroStation PowerDraft needs to know which dialog box you want to enter data into. Just click the top bar of the dialog box to make it active.
All design drawings will be changed a number of times before final approval and fabrication of the part or construction of the project. That is because a drawing is one of the principal means of communication between the designer and the client. It is supposed to be that way. Consequently, any CAD software should be very good for making changes if it is to be productive.

MicroStation PowerDraft offers a rich variety of commands for changing elements after they have been placed in a drawing file. As discussed in Chapter 1, Lesson 3, three tools from the Main tool box are used to change things:

- The Manipulate Element tools are for using one element to create another. For example, you can scale an element to make a geometrically similar but different sized element. Or, you can copy one element to make another.

- The Modify Element tools are for actually changing an element already in a drawing. For example, delete half of a circle, or extend a line.

- The Change Element Attribute tools are for changing an existing element's color, linestyle, and other attributes.

- The Delete Element tool is for deleting an element. You can also select elements first and then either this tool or the Delete key on the keyboard.

Lesson 4: Manipulating Elements

Let's briefly review the Manipulate tools.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Used to copy an element(s)</td>
</tr>
<tr>
<td>Move</td>
<td>Used to move an element(s)</td>
</tr>
<tr>
<td>Scale</td>
<td>Used to resize an element(s)</td>
</tr>
<tr>
<td>Rotate</td>
<td>Used to rotate an element(s)</td>
</tr>
<tr>
<td>Mirror</td>
<td>Used to mirror an element(s)</td>
</tr>
<tr>
<td>Construct Array</td>
<td>Used to copy an element(s) many times to create an array</td>
</tr>
<tr>
<td>Align Elements by Edge</td>
<td>Used to align an element(s) to the edge of another element</td>
</tr>
<tr>
<td>Stretch</td>
<td>Used to stretch an element(s)</td>
</tr>
<tr>
<td>Move Parallel</td>
<td>Used to move or copy an element parallel to the original</td>
</tr>
<tr>
<td>Move to Contact</td>
<td>Used to move an element(s) in a defined direction until it contacts an existing element in the model</td>
</tr>
</tbody>
</table>
After creating a drawing you will want to scale some objects to make them larger or smaller, copy objects and the like.

Experiment with the manipulate objects commands by:

1. From the Main tool box, open the Manipulate tool box (as we did View Control earlier).

2. Click the Copy tool.

The name of the function appears in the status bar while holding down the data button.

The prompt message at the bottom of the screen says to identify the element. That means to take the cursor to the element and click on it.

3. Try it with one of the lines you entered.

The line is now “glued” to your cursor and you can drag it anywhere.

4. Click again to place the copy. You can make as many copies as you like. Hit Reset to stay in Copy but without element attached.

5. Click the Move tool.

6. Click on the box you drew.

7. Drag and place it.

The original box has moved to a new location rather than a copy as before.

8. Try the Move Parallel, Scale, Rotate, Mirror, and Construct Array tools on your own.

The Move Parallel tool, just like Copy, moves parallel to original element. You can enter an exact distance in the tool settings window. Also, you can check if you want a copy. Note: The side will be where cursor is relative to original element.

- The Move Parallel tool is very powerful. For example, when laying out a floor plan, you can draw parallel lines to locate column centerlines or other key locations such as walls. Then, you can use the extend and trim functions to complete the layout. You can move lines, arcs and even Bézier curves parallel!
Lesson 5: Modifying Elements

Let’s briefly review the Modify tools.

<table>
<thead>
<tr>
<th>Modify Element</th>
<th>Used to move vertices and line segments, scale, modify rounded segments and shapes, change a circle's radius and move dimension text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partial Delete</td>
<td>Used to delete part of an element</td>
</tr>
<tr>
<td>Break Element</td>
<td>Used to break a linear element at a defined point.</td>
</tr>
<tr>
<td>Extend Line</td>
<td>Used to extend or shorten a line or an end segment of a line string or multi-line</td>
</tr>
<tr>
<td>Extend Elements to Intersection</td>
<td>Used to extend or shorten two lines, line strings, or arcs to their intersection</td>
</tr>
<tr>
<td>Extend Element to Intersection</td>
<td>Used to extend or shorten a line, line string, or arc to its intersection with another element</td>
</tr>
<tr>
<td>Trim Elements</td>
<td>Used to trim or cut an element or series of elements at their intersection with one or more cutting elements</td>
</tr>
<tr>
<td>IntelliTrim</td>
<td>Used to trim or extend multiple elements at their intersection with one or more elements.</td>
</tr>
<tr>
<td>Insert Vertex</td>
<td>Used to insert a vertex, attach a line segment, extend a point curve, and add an extension line</td>
</tr>
<tr>
<td>Delete Vertex</td>
<td>Used to delete a vertex or remove an extension line</td>
</tr>
<tr>
<td>Construct Circular Fillet</td>
<td>Used to construct a circular fillet between two elements, two segments of a line string, or two sides of a shape</td>
</tr>
<tr>
<td>Construct Chamfer</td>
<td>Used to construct a chamfer between two lines or adjacent segments of a line string or shape</td>
</tr>
</tbody>
</table>

Modify tool box

From the Main tool box, open the Modify tool box.

The Modify Element tool is actually a scale-in-place tool. Try selecting several of the elements to see how each scales.

The Partial Delete tool allows you to take a bite out of an element. Move the cursor to indicate which part of the object you keep and which you throw away.

The Extend Line tool enables you to stretch a line (in MicroStation PowerDraft, use the Modify Element tool).
The Extend Elements to Intersection tool automatically extends to the point of intersection. To try it, select a line then a circle or arc that the line can intersect.

The Trim Element tool trims or cuts an element(s) at the intersection. Select a line to be “cutter.” Then, select a line, circle or arc it intersects. Click on the side of cutter you want eliminated.

The IntelliTrim tool simultaneously trims or extends multiple elements at their intersection with one or more other elements.

The Insert Vertex tool inserts a vertex in a line, line string or shape. Select a box. Pull out a fifth vertex. (You can even insert a dimension in a chain with this.)

The Delete Vertex tool is the opposite of Insert Vertex tool.

The other Modify Element tools are advanced functions that will be treated later.

### Lesson 6: Changing Element Attributes

<table>
<thead>
<tr>
<th>Change Element Attributes</th>
<th>Used to change selected attributes of an element(s) such as level, color, line style, line weight or class</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change to Active Area (Change Element to Active Area)</td>
<td>Used to change the area attribute of a closed element(s) (shapes, ellipses, complex shapes, or B-spline curves) to the Active Area</td>
</tr>
<tr>
<td>Change to Active Fill Type (Change Element to Active Fill Type)</td>
<td>Used to change a closed element to the Active Fill Type which are none (no fill), opaque (filled with Active color), and outlined and to change the Active color</td>
</tr>
<tr>
<td>Modify Line Style Attributes</td>
<td>Used to interactively modify the line style attributes of an element with a custom line style</td>
</tr>
<tr>
<td>Change Multiline Definition (Change Multiline to Active Definition)</td>
<td>Used to change a multi-line's attributes to the active multi-line definition</td>
</tr>
<tr>
<td>Match Element Attributes</td>
<td>Used to change the active element attribute settings so they match the attributes of an element in the design</td>
</tr>
<tr>
<td>SmartMatch (Match All ElementSettings)</td>
<td>Used to change all active element attribute settings, including those specific to particular element types, so they match the attributes of an element in the design</td>
</tr>
</tbody>
</table>

1 Close all of the tool boxes you have opened by clicking the ‘x’ in the upper right corner of each box. Leave open the tool settings window.

2 Open the Change Attributes tool box.
3 Click on the Change Element Attributes tool.

4 In the Change Element Attributes tool settings window, turn on Color.

5 Hold down the cursor on the colored box and select a new color.

6 Click on any element and see its color change.

- Changing attributes in the Change Attributes tool settings window, changes the attributes to any new element also. So be sure element attribute settings are what you want before adding new elements.

**Exercise 1: Schematic**

In this exercise, you will draw a simple schematic diagram.

You will construct rectangles, polygons, lines and text and learn how to copy elements. This exercise introduces new concepts so be sure to watch the command and prompt at the bottom of your screen as you follow these step-by-step instructions.

**To create a new design file**

1 From the file menu, select New.

   The New dialog box opens.

2 In the File Name field, type in a name for the new file.

3 At the bottom of the dialog box, click on the Browse button.

4 When the Select Seed File dialog box opens, find seed2D.dgn.

To find the seed file, you may have to navigate to C:\Documents and Settings\All Users\Application Data\Bentley\Workspace\System\Seed, if you are using Windows Vista or earlier, or C:\Program Data\Bentley\PowerDraft V8i\Workspace\System\seed, if you are using Windows 7.
Double-click with the cursor placed over seed2D.dgn.

This opens your new file with the information stored in this seed file.

Click Save to save the file and to open the new file for work.

To set the working units and grid settings

1 Click on Settings > Design File. In the DGN File Settings dialog box, select Working Units.

The seed2d.dgn may have units of feet and inches or meters. We’ll change the master units to inches.

2 Click on Master Units and select Inches.

3 Click on Sub Units and change to Mils. (It really doesn’t matter in this exercise as we will only use master units of inches.)

Note your drawing is set up for master units of inches, sub units of thousandths of an inch (mils).

4 In the DGN File Settings dialog box, under Linear Units, change the Format to MU. Since we chose inches as our master unit, MicroStation PowerDraft shows us coordinates in inches and decimal inches rather than with a colon separating master and sub units.

5 In the DGN File Settings dialog box, select the Grid category. Set Grid Master to 0.1 and Grid Reference to 10.

6 Turn on the Grid Lock.

This restrains your drawing to whole tenths of an inch, adequate for this schematic.
7 Click OK to close the DGN File Settings dialog box.

8 If you can’t see the grid, click on Settings > View Attributes and turn on Grid. Then, zoom in the drawing a few times and you will see the grids.

MicroStation PowerDraft automatically turns off grids if they get too close together. The dim dots you see are the master grid and the brighter lines or crosses are the reference grids.

To place the rectangles

1 If the Main tool box is not open, select Tools > Main.

This opens the main drawing and editing tool box.

2 Select the Place Block tool.

The Place Block command is shown in the status bar. The prompt for the next operation is also shown “> Enter First Point.” The options are shown in the tool settings window that is now titled “Place Block.”

3 In the Place Block tool settings window, be sure that Method is set to Orthogonal, Area is Solid, and Fill Type is None. Fill Color is not available when no Fill Type is selected.

4 Using your mouse to visually move the cursor, place the cursor over one of the reference grids. Click the mouse button. Drag the diagonally opposite rectangle corner one reference grid to the right and two down. Click again.

The prompt says “Enter First Point” again. MicroStation PowerDraft is ready for you to enter another rectangle.

5 Instead, click on the Element Selection tool in the Main tool box.

6 From the Main tool box (or Manipulate tool box), click the Copy tool.

The command shown in the status bar and the prompt says “identify element.”

7 Take the cursor to the upper left corner of the rectangle you already placed and click the mouse button. You will see a copy of your rectangle “glued” to your cursor.
Exercise 1: Schematic

8 Try “rejecting” the selection by pressing the right button. Watch the status bar and you will see the prompt is back to asking you to “identify element.”

9 Take the cursor close to a corner of the first rectangle. Press the data button.

10 Move your rectangle copy two reference grid lines to the right and click on the reference point. A new copy appears. Move the cursor two more reference points to the right and click the data button.

11 Now press the Reset button. Congratulations! You have successfully placed three rectangles of identical dimensions precisely on a grid.

To make a correction or change

1 If you inadvertently placed an extra rectangle or if one is at the wrong location, from the Main tool box, click the Delete Element tool. Then click on the bad rectangle. The bad rectangle is deleted. Try it with one of the good rectangles.

2 Now from the Edit menu, select Undo Delete Element and see the good rectangle reappear.

3 From the Task Navigation bar on the left hand side of screen, select the Place SmartLine tool. The Place SmartLine tool is the first icon in the Linear tool box. The command says “Place Smartline” and the prompt says “Enter first vertex.”

4 Take the cursor to a point on the right side of first rectangle. Click the data button.

5 Move the cursor to the left side of the middle rectangle keeping the line horizontal. Click and press the Reset button.

This “disconnects” the line and puts you back ready to enter the first point of another line.

6 Move the cursor to begin the next line. Repeat 3 - 5 to draw all lines representing the conductors in your schematic.

To draw the connectors at the ends of each line, you will use a regular polygon.

7 Move the cursor to the Task Navigation bar. Select the Place Regular Polygon Tool in the Drawing Task. The command says “Place Inscribed Polygon” and the prompt says “Enter point on axis.”

The tool settings window shows that you are drawing a six-sided polygon.

8 Move the cursor to the end point of one of the lines. Click to place the center of the polygon at the end of the line. Move the cursor and then click to set the polygon radius.

10 Select the Copy tool.

11 Click on the polygon. If you accidently get the rectangle or the line, press reset to reject. Keep
rejecting until the polygon is selected. Place copies of the polygon at the connection of each line with a rectangle.

To add text

1 Select Element > Text Styles.

2 In the Text Styles dialog box, create a new Font Style by clicking the New tool.

3 Then, select the Engineering font from the Font option menu on the General tab. Change Height and Width to 0.2 inches.

This makes the lettering on your drawing .2 inches wide by .2 high.

4 Close the Text Styles dialog by clicking on the “X” in upper right corner.

You can move a dialog box by moving your cursor to a point on the title bar, click and hold the mouse button down and move the dialog box.

5 From the Task Navigation bar, Select the Place Text tool in the Drawing Task.

The Text Editor dialog box opens.
Type the numeral 1.

Move your cursor near your schematic and see the numeral 1 follow. Click on a point near connector 1 on your drawing.

Click on the text window. Press the backspace key to erase the 1.

Type the numeral 2. Place it near connector 2.

Repeat for all five connectors.

Your first drawing is complete!

Text Styles

MicroStation PowerDraft supports text styles and provides an interface for constructing text using available system fonts and a wide variety of text attributes. A text style comprises a group of text attributes, such as font type, width, height, and color. Text styles enable you to place text within a model in a consistent and automated manner.

The fonts that are supported natively in MicroStation PowerDraft are the traditional MicroStation PowerDraft fonts, TrueType fonts and AutoCAD Shape fonts (.shx).

To create a text style

1 From the Element menu, choose Text Styles.

The Text Styles dialog box opens.

2 From the menu bar of the Text Styles dialog box, choose Style > New.

A new “Untitled” style appears in the Text Styles hierarchy tree.

3 Key in the desired name for the new text style.

4 Click <Enter>.

The new text style name appears in the Text Styles hierarchy tree.

5 (Optional) From the Advanced tab, modify the values of text attributes as desired. The Advanced Tab contains all the settings from the Spacing, Under/Overline and Background tabs.

6 From the menu bar of the Text Styles dialog box, choose Styles > Save.

The new text style is saved.
Summary

In summary, you have demonstrated that you can:

1. Create a new design file.
2. Setup your working units.
3. Setup your grids.
4. Work with grid lock on.
5. Create graphics with blocks (rectangles), lines and polygons.
6. Setup your text size.
7. Annotate your drawing.
8. Edit by deleting graphics.
10. Copy graphics.

You are prepared to do complex schematic drawings at this point.
Now that we are somewhat comfortable with MicroStation PowerDraft, let’s do a menu survey to see what other things we can do and what other functions we need to learn. Click on each menu listed as you read this chapter. Don’t get bogged down. This is intended to give you an overview of functions that are available and where they can be found.

File Menu

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Element</th>
<th>Settings</th>
<th>Tools</th>
<th>Utilities</th>
<th>Workspace</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl-N</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl-O</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td>Ctrl-W</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl-S</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Compress</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save As...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Item Browser</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Project Explorer</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>References</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raster Manager</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Models</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print Preview</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl-P</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print Organizer</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Associate...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Properties</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protection</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**New**
Creates and opens a design file as the active design file

**Open**
Opens an existing design file or a file of a different type as the active design file. To do it, scroll up and down the list or change directories and scroll.

**Close**
Closes the active design file and opens the MicroStation Manager dialog.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save</td>
<td>Saves design changes to the open DGN file.</td>
</tr>
<tr>
<td>Save As</td>
<td>Opens the Save As dialog box, which is used to save a copy of the design file with a different name, in a different directory, on a different disk, or in a different file format. If just a different name is chosen, the copy becomes the active design file.</td>
</tr>
<tr>
<td>Compress</td>
<td>Reduces the size of the open DGN file by purging empty and unused data resources and clears the application’s undo buffer. When we add and delete elements, all data is kept so we can ‘undo’ things. When we compress the file, all deleted elements are thrown away.</td>
</tr>
<tr>
<td>Save Settings</td>
<td>Saves settings in the active design file. This option is enabled only if the “Save Settings on Exit” preference is set to off in the Operation category of the Preferences dialog box (Workspace &gt; Preferences). This allows you to save settings at will, as they are not automatically saved when you exit the file.</td>
</tr>
<tr>
<td>Item Browser</td>
<td>Allows you to see non-graphical information connected with elements within the drawing.</td>
</tr>
<tr>
<td>Project Explorer</td>
<td>Opens the Project Explorer dialog box, which is used to manage project data within MicroStation PowerDraft.</td>
</tr>
<tr>
<td>Reference</td>
<td>Opens the References dialog box, which is used to adjust reference settings and select reference tools. Allows you to view a separate drawing while working on your current drawing. Great for things like drawing electrical fixtures on someone else’s floor plan. One of MicroStation PowerDraft’s strengths. See Reference Files and Drawing Composition (page 127).</td>
</tr>
<tr>
<td>Raster Manager</td>
<td>Controls the display of one or more raster image, such as photographs or scanned drawings, in a design file view.</td>
</tr>
<tr>
<td>Models</td>
<td>Creates and manages models in a DGN file. You can have several drawings stored in the same file. Each separate drawing is called a model. They can be 2D or 3D models.</td>
</tr>
<tr>
<td>Import</td>
<td>Brings a drawing into MicroStation PowerDraft in any of several formats.</td>
</tr>
<tr>
<td>Export</td>
<td>Sends a MicroStation PowerDraft drawing file out in one of the other formats.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Shows how your drawing will look if plotted with current settings.</td>
</tr>
<tr>
<td>Print</td>
<td>Opens the Print dialog box, which is used to adjust printing settings and create printed output. Where you go to get a hardcopy of your drawing. If you use the Windows driver, you can plot to any windows device.</td>
</tr>
<tr>
<td>Print Organizer</td>
<td>Gives you the ability to plot a whole set of drawings</td>
</tr>
<tr>
<td>Associate</td>
<td>Associates file types with their proper extensions, such as associating a tiff file to open Display Image. Then, when you drag and drop that file type on the MicroStation PowerDraft icon, it loads and runs.</td>
</tr>
<tr>
<td>Properties</td>
<td>Shows the active DGN file’s general properties and usage statistics.</td>
</tr>
<tr>
<td>Protection</td>
<td>Enables protecting a file via a password or other technique.</td>
</tr>
<tr>
<td>Send</td>
<td>Opens a new email message inside of MicroStation PowerDraft with the current design file attached. Address, add comments, and send the message just as you would for any email message outside of MicroStation PowerDraft.</td>
</tr>
<tr>
<td>1..</td>
<td>Numbered list displays file history. If files have been opened previously, lists up to the last ten design files that were most recently opened. Click on</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Exit</td>
<td>Exits MicroStation PowerDraft.</td>
</tr>
<tr>
<td>Undo</td>
<td>Reverses the effect of most recent command</td>
</tr>
<tr>
<td>Undo Other</td>
<td>Undo Other &gt; To Mark negates drawing operations performed after a mark was set by choosing Set Mark from the Edit menu. Undo Other &gt; negates all of the drawing operations recorded in the Undo buffer.</td>
</tr>
<tr>
<td>Redo</td>
<td>Reverses Undo</td>
</tr>
<tr>
<td>Set Mark</td>
<td>Sets a mark in the undo buffer back to which subsequent drawing operations can be undone by choosing Undo Other &gt; To Mark.</td>
</tr>
<tr>
<td>Cut</td>
<td>Removes (cuts) the selected element(s) to the Clipboard for subsequent pasting. The element(s) remain on the Clipboard until another Cut or Copy is performed.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the selected element(s) to the Clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Copies the contents of the Clipboards to the design. After choosing Paste from Clipboard, you must enter a data point to position the element(s) being pasted.</td>
</tr>
<tr>
<td>Paste Special</td>
<td>Opens the Paste Special dialog box which is used to apply a special display format to the contents of the Clipboard. Paste Special is dimmed if there are no elements on the Clipboard. Puts contents of a spreadsheet or Word document onto the drawing as an image, as an embedded spreadsheet or as a linked spreadsheet.</td>
</tr>
<tr>
<td>Element Menu</td>
<td></td>
</tr>
<tr>
<td>--------------</td>
<td></td>
</tr>
<tr>
<td><strong>Group</strong></td>
<td>Consolidates selected elements into a group for manipulation as a single entity.</td>
</tr>
<tr>
<td><strong>Ungroup</strong></td>
<td>Discontinues selected groups. Each ungrouped element can be manipulated by itself.</td>
</tr>
<tr>
<td><strong>Lock</strong></td>
<td>Locks selected elements. The attributes and location of a locked element cannot be changed until Unlock is selected.</td>
</tr>
<tr>
<td><strong>Unlock</strong></td>
<td>Unlocks selected locked elements. Each unlocked element can be manipulated.</td>
</tr>
<tr>
<td><strong>Bring to Front</strong></td>
<td>Brings the selected element to the front of the view display.</td>
</tr>
<tr>
<td><strong>Find/Replace Text</strong></td>
<td>Opens the Find/Replace Text dialog box, which is used to search all the text in a design file for any sequence of letters and numbers and replace some or all instances of the text with other text.</td>
</tr>
<tr>
<td><strong>Select All</strong></td>
<td>Selects all elements in the design and creates a Group of all elements in drawing. To ungroup, click on empty screen.</td>
</tr>
<tr>
<td><strong>Select None</strong></td>
<td>Deselects all elements in the design.</td>
</tr>
<tr>
<td><strong>Select by Attributes</strong></td>
<td>Creates a Group by selecting elements with same level, color, linestyle, object type, etc. A group can then be manipulated using the Manipulate tool box. Use Group and Ungroup to temporarily turn off and on groups.</td>
</tr>
<tr>
<td><strong>DDE Links</strong></td>
<td>Opens the Links dialog which lists the DDE string for each DDE link and lets you maintain links.</td>
</tr>
<tr>
<td><strong>Insert Object</strong></td>
<td>Choosing Insert Object and then defining a rectangle in a view window opens the Insert Object dialog box, which is used to link or embed an object in the active design file from an application that is not currently open.</td>
</tr>
<tr>
<td><strong>Update Links</strong></td>
<td>Updates embedded or linked objects in a DGN file. The Update Links status bar displays while the links are being updated.</td>
</tr>
<tr>
<td><strong>Links</strong></td>
<td>Opens the Links dialog box which is used to update, break, or change the source of a linked object. This is dimmed if there are no linked objects in your DGN file.</td>
</tr>
<tr>
<td><strong>Object</strong></td>
<td>This menu item is dimmed unless you have a linked or embedded object selected in a DGN file. When an object is selected, the Object title changes to reflect the type of file selected. For example, if you select a linked Excel worksheet, the Object submenu title changes to Microsoft Excel Worksheet.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Element Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>B-Splines</strong></td>
</tr>
<tr>
<td><strong>Cells</strong></td>
</tr>
<tr>
<td><strong>Dimension Styles</strong></td>
</tr>
<tr>
<td><strong>Detailing Symbol Settings</strong></td>
</tr>
<tr>
<td><strong>Line Styles</strong></td>
</tr>
<tr>
<td><strong>Multi-line Styles</strong></td>
</tr>
<tr>
<td>Tags</td>
</tr>
<tr>
<td>----------------</td>
</tr>
<tr>
<td>Text Styles</td>
</tr>
<tr>
<td>Element Templates</td>
</tr>
<tr>
<td>Information</td>
</tr>
</tbody>
</table>

### Settings Menu

<table>
<thead>
<tr>
<th>Tool Settings</th>
<th>Toggles the display of the Tool Settings window, which is used to review and adjust settings for the selected tool. The title bar shows the tool name.</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccuDraw</td>
<td>Opens the AccuDraw Settings dialog box, which contains controls relevant to the AccuDraw point input tool. AccuDraw is used to streamline the drawing process by assisting in the rapid and accurate placement of data points while placing and manipulating elements.</td>
</tr>
<tr>
<td>Color Books</td>
<td>Opens the Color Book Editor dialog box, which is used to create and maintain color books.</td>
</tr>
<tr>
<td>Color Table</td>
<td>Opens the Color Table dialog box, which lets you browse and modify a “copy” of the active color table – the color table that is currently attached to the design file or, if none is attached, the default (internal) color table. After you make any desired changes, you can attach this “copy” to the active design file, or you can save it as a separate file for later attachment.</td>
</tr>
<tr>
<td>Database</td>
<td>Control settings related to linkages between elements and rows in a non-graphical database. Used to connect/ disconnect to an external database from within MicroStation PowerDraft. Provides a graphically intuitive means of generating simple and complex queries and joining tables.</td>
</tr>
<tr>
<td>Design File</td>
<td>Opens the DGN File Settings dialog box, which is used to change design file-specific settings.</td>
</tr>
</tbody>
</table>
Display Styles | Opens the Display Styles dialog box, which is used to change the display of the drawing in your design file.

Drawing Scale | Opens the Drawing Scale window, which is used to adjust drawing scale settings.

Levels | Level Manager is used to control level display, level symbology and level filters for the active DGN file and attached references. The Level Manager also allows you to attach and detach references.

Locks | Opens the Locks dialog box, which sets locks and the Fence Selection Mode.

Snaps | Opens the Snap Mode button bar, the buttons on which can be either clicked to set the snap override or Shift-clicked to set the Snap Mode.

View Attributes | Opens the View Attributes dialog box, which is used to set view attributes that affect whether and how certain types and classes of elements are displayed and whether certain drawing aids are displayed. Changes to the selected view take effect immediately. If Apply To All is enabled, changes are applied to all views.

Snaps Menu

You can open the Snaps menu from the icon on the prompt line at the bottom of the screen or you use the Snap Mode button bar (Settings > Snaps > Button Bar).

More or less snaps will be shown on the Snaps menu depending on the current active drawing tool. In other words, only the snaps that are available for the current tool display. To see the maximum, activate the Place Line tool and then select snaps icon at bottom of screen. Or, choose Snaps Button Bar from bottom screen.

| Nearest | Sets the snap override (or snap mode if the <Shift> key is pressed) to Nearest, which causes a tentative point to snap to the point closest to the pointer on an element.

| Keypoint | Sets the snap override (or snap mode if the <Shift> key is pressed) to Keypoint,
which causes a tentative point to snap to a keypoint on an element.

<table>
<thead>
<tr>
<th>Snap Override</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Midpoint</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Midpoint, which causes a tentative point to snap to the midpoint of an element.</td>
</tr>
<tr>
<td><strong>Center</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Center, which causes a tentative point to snap to the center or centroid of an element.</td>
</tr>
<tr>
<td><strong>Origin</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Origin, which causes a tentative point to snap to the origin of a cell.</td>
</tr>
<tr>
<td><strong>Bisector</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Bisector, which causes a tentative point to snap to the midpoint of an entire element.</td>
</tr>
<tr>
<td><strong>Intersection</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Intersection, which constrains an element to intersect another element with the point of intersection at the first element's starting or ending point.</td>
</tr>
<tr>
<td><strong>Tangent</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Tangent, which constrains an element to be tangent to another element.</td>
</tr>
<tr>
<td><strong>Tangent Point</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Tangent Point, which constrains an element to an element to be tangent to another element with the point of tangency fixed.</td>
</tr>
<tr>
<td><strong>Perpendicular</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Perpendicular, which constrains an element to be perpendicular to another element.</td>
</tr>
<tr>
<td><strong>Perp Point</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Perpendicular Point, which constrains an element to be perpendicular to another element with the point at which the first element does or would intersect the second element fixed.</td>
</tr>
<tr>
<td><strong>Parallel</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Parallel, which constrains an element to be parallel to another element.</td>
</tr>
<tr>
<td><strong>Point Through</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Point Through, which constrains an element to pass through a particular point on the design plane.</td>
</tr>
<tr>
<td><strong>Point On</strong></td>
<td>Sets the snap override (or snap mode if the &lt;Shift&gt; key is pressed) to Point On, which constrains an element to begin or end on an element in the design file.</td>
</tr>
<tr>
<td><strong>Multi-snap1</strong>, <strong>Multi-snap2</strong>, <strong>Multi-snap3</strong></td>
<td>Sets the snap mode to Multi-snap 1, Multi-snap 2 or Multi-snap 3. A multi-snap represents a list of grouped snaps.</td>
</tr>
</tbody>
</table>

The main snaps are keypoint, center, intersection, origin, tangent, perpendicular and parallel. The Snap Mode is where the diamond is on the menu. To change mode, hold down the shift key and select another or double-click the icon of the new mode. The mode can be overridden for one snap only.

**To use snapping**

1. Set the snap mode or method to what is desired, such as keypoint, nearest or other.

2. Move the cursor near the point to be snapped.

3. Press the left and right buttons on the mouse (or middle button if you are using a three button mouse). See Workspace > Button Assignments (page 46) to change.

4. Watch the large cursor appear on correct point.
AccuSnap enhances many of the standard snap mode settings by displaying and automatically snapping to the next tentative snap point as you move the pointer over an element. With AccuSnap enabled, you very rarely need to enter a tentative snap point manually. All you need do is move the cursor until the little yellow x symbol comes up near the snap point, and then left click. Your point will be snapped automatically.

AccuSnap Settings

To turn AccuSnap on or off, to turn automatic element highlight on or off, use the settings which are found by clicking the snap icon on the lower right of the MicroStation PowerDraft window and then select AccuSnap. Multi-snaps is used to set up groups of snaps and allows AccuSnap to automatically snap to different snap modes such as all keypoints and all element centers.

AccuSnap works in conjunction with the current Snap Mode setting and, for the most part, is similar in operation to the manual method of tentative snap points - minus the button presses. How close to an element or a keypoint that the pointer must be, before AccuSnap finds it, is governed by the Locate Tolerance setting in the Input category of the Preferences dialog box.

Tools Menu

The more common tool boxes are listed when you select Tools from the main menu. To see all the tool
boxes, click Tools > Tool Boxes.

<table>
<thead>
<tr>
<th>Tool Box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attributes</td>
<td>Toggles the display of the Attributes tool box, which is used to control the attributes (color, level, line weight, and line style) of elements placed in the design. The controls in the Attributes tool box do not affect existing elements.</td>
</tr>
<tr>
<td>Primary</td>
<td>Toggles the display of the Primary Tools tool box, which is used to attach reference files, set up levels, or turn on and off levels, as well as toggle AccuDraw and Popset.</td>
</tr>
<tr>
<td>Standard</td>
<td>Toggles the display of the Standard tool box, which contains icons that enable quick access to commonly used pull-down menu items, such as open file, new file, save, print, cut, copy, paste, undo, redo and help.</td>
</tr>
<tr>
<td>Main</td>
<td>Toggles the display of the Main tool box, which is open and docked when you start MicroStation PowerDraft for the first time.</td>
</tr>
<tr>
<td>Tasks</td>
<td>Toggles the display of the Task Navigation tool box. If you are viewing tasks in the Tasks dialog box, this menu item hides and displays the Tasks dialog box.</td>
</tr>
<tr>
<td>Base Geometry</td>
<td>Toggles the display of the Base Geometry tool box, which contains tools for placing elements.</td>
</tr>
<tr>
<td>Cells</td>
<td>Toggles the display of the Cells tool box, which contains tools for placing and defining cells.</td>
</tr>
<tr>
<td>Change Tracking</td>
<td>Toggles the display of the Change Tracking tool frame, which contains tool boxes for design history.</td>
</tr>
<tr>
<td>Coordinate Systems</td>
<td>Toggles the display of the Coordinate Systems tool frame, which contains tool boxes to define auxiliary coordinate systems.</td>
</tr>
<tr>
<td>Custom Linestyles</td>
<td>Toggles the display of the Custom Linestyles tool box, which contains tools for modifying and dropping linestyles.</td>
</tr>
<tr>
<td>Database</td>
<td>Toggles the display of the Database tool box, which contains tools for attaching and detaching a database.</td>
</tr>
<tr>
<td>Detailing Symbols</td>
<td>Toggles the display of the Detailing Symbols tool box, which contains tools for placing callouts, titles and clouds.</td>
</tr>
<tr>
<td>Dimensions</td>
<td>Toggles the display of the Dimension Tools tool frame, which contains tool boxes to create linear, angular, radial, and miscellaneous dimensions.</td>
</tr>
<tr>
<td>Geographic</td>
<td>Toggles the display of the Geographic tool box, which contains tools for using Google Earth.</td>
</tr>
<tr>
<td>Groups</td>
<td>Toggles the display of the Groups tool box, which contains tools for creating complex chains, shapes and regions, as well as adding and dropping from graphic groups.</td>
</tr>
<tr>
<td>Levels</td>
<td>Toggles the display of the Levels tool box, which contains tools for level display and level manager.</td>
</tr>
<tr>
<td>Manipulate</td>
<td>Toggles the display of the Manipulate tool box, which contains tools for manipulating elements (see above for tools).</td>
</tr>
<tr>
<td>Measure</td>
<td>Toggles the display of the Measure tool box, which contains tools for measuring distances, angles, lengths and more.</td>
</tr>
<tr>
<td>Multi-lines</td>
<td>Toggles the display of the Multi-lines tool box, which contains tools for placing and manipulating multi-lines and component lines.</td>
</tr>
<tr>
<td>Patterning</td>
<td>Toggles the display of the Patterning tool box, which contains tools for defining hatch, crosshatch, pattern and linear pattern areas.</td>
</tr>
<tr>
<td>Project Navigation</td>
<td>Toggles the display of the Project Navigation tool frame, which contains tool boxes for using links.</td>
</tr>
<tr>
<td>Utilities Menu</td>
<td></td>
</tr>
<tr>
<td>----------------</td>
<td></td>
</tr>
<tr>
<td><strong>Properties</strong></td>
<td>Toggles the display of the Properties tool box, which contains tools for matching and changing element attributes and properties.</td>
</tr>
<tr>
<td><strong>Raster</strong></td>
<td>Toggles the display of the main Raster tool box, which contains tools for displaying and controlling raster files.</td>
</tr>
<tr>
<td><strong>Redline</strong></td>
<td>Toggles the display of the Redline tool box, which contains tools to work with redline files.</td>
</tr>
<tr>
<td><strong>Reference</strong></td>
<td>Toggles the display of the References task, which contains tools to manipulate attached reference files, to attach/detach referenced models to the active model and to control the positioning, scaling, clipping, and orientation of attached referenced models.</td>
</tr>
<tr>
<td><strong>Security</strong></td>
<td>Toggles the display of the Security tool box, which contains the tool for creating and using digital signatures.</td>
</tr>
<tr>
<td><strong>Selection</strong></td>
<td>Toggles the display of the Selection tool box, which contains tools for element selection and placing fences.</td>
</tr>
<tr>
<td><strong>Sheet Composition</strong></td>
<td>Toggles the display of the Sheet Composition dialog box, which is used to design the layout of a sheet model.</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td>Toggles the display of the Text tool box, which contains tools for placing and changing text.</td>
</tr>
<tr>
<td><strong>View</strong></td>
<td>Toggles the display of the View Control tool box, which is used to manipulate views in the active DGN file.</td>
</tr>
<tr>
<td><strong>Tool Boxes</strong></td>
<td>Opens the Tool Boxes dialog box, which lists all individual tool boxes.</td>
</tr>
<tr>
<td><strong>Close Tool Boxes</strong></td>
<td>Closes all tool boxes.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Utilities Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Key-In</strong></td>
</tr>
<tr>
<td><strong>3D Warehouse</strong></td>
</tr>
</tbody>
</table>

Here are a number of utilities that are useful. Key-in allows you to key-in commands and distances rather than graphic selections; Cell Selector is very useful for placing cells; Render for shading a 3D model; Install Fonts to bring True Type or other outside fonts into MicroStation PowerDraft and more.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect Web Browser</td>
<td>Opens your default Web browser, which is used to browse the Web.</td>
</tr>
<tr>
<td>Cell Selector</td>
<td>If no cell library is loaded, selecting this menu item opens the Select Cell Library to Load dialog box.</td>
</tr>
<tr>
<td>Image</td>
<td>Controls image settings and display.</td>
</tr>
<tr>
<td>Auxiliary Coordinates</td>
<td>Opens the Auxiliary Coordinates dialog box, which is used to name, save, attach, delete, or import an auxiliary coordinate system (ACS) and to select ACS tools.</td>
</tr>
<tr>
<td>Saved Views</td>
<td>Opens the Saved Views dialog box, which is used to name, save, attach, and delete views. Saving a view allows you to quickly recall a view with specific attributes.</td>
</tr>
<tr>
<td>Named Expressions</td>
<td></td>
</tr>
<tr>
<td>Named Groups</td>
<td>Opens the Named Groups dialog box, which is used to create and modify named groups and hierarchies of named groups.</td>
</tr>
<tr>
<td>Design History</td>
<td>Controls initialize, deletion, revisions, and management of design history.</td>
</tr>
<tr>
<td>Standards Checker</td>
<td>Opens the Standards Checker dialog box, which is used to run standards checks. These checks compare information in your DGN file against standards that you have established.</td>
</tr>
<tr>
<td>Packager</td>
<td>Opens the Create Package wizard, which is used to step you through the process of creating a project package.</td>
</tr>
<tr>
<td>Archive</td>
<td>Opens the Archive dialog box, which is used to open existing archive files and extract their contents and view and verify digital signatures.</td>
</tr>
<tr>
<td>Data Cleanup</td>
<td>Opens the Design File Cleanup dialog box, which is used to identify duplicate elements, overlapping elements and/or gaps between elements in the active design file.</td>
</tr>
<tr>
<td>Dimension Audit</td>
<td>Opens the Dimension Audit dialog box, which is used to search all the dimensions in the active model and report any problems.</td>
</tr>
<tr>
<td>License Management</td>
<td>Opens the License Management Tool dialog box, which is used to check out application and program licenses under concurrent license control of the SELECT Server License Manager to systems that are not continually connected to a network with access to SELECT Server.</td>
</tr>
<tr>
<td>Macro</td>
<td>Displays a list of macros available in the currently loaded Visual Basic projects. Allows for the creation of Visual Basic applications and macros and MicroStation BASIC macros. Provides means to run, edit, or debug MicroStation BASIC macros.</td>
</tr>
<tr>
<td>MDL Applications</td>
<td>Opens the MDL dialog box, which is used to load, unload, and monitor the sizes and memory use of Development Language (MDL) applications.</td>
</tr>
</tbody>
</table>

MicroStation PowerDraft automatically picks up all truetype and AutoCAD shx fonts (if available) and installs them with MicroStation PowerDraft.
Workspace Menu

Allows you to select from a number of different options for your setup. You may not need to go here and the rest of this book is based on the way MicroStation PowerDraft installs without changes.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferences</td>
<td>Opens the Preferences dialog box, which is used to set user preferences – settings that control how MicroStation PowerDraft operates.</td>
</tr>
<tr>
<td>Configuration</td>
<td>Opens the Configuration dialog box, which is used to edit, define, save, and delete configuration variables.</td>
</tr>
<tr>
<td>Customize</td>
<td>Opens the Customize dialog box, which is used to add and manage templates; add custom tool boxes, tools, and tasks, as well as customize menus.</td>
</tr>
<tr>
<td>Function Keys</td>
<td>Opens the Function Keys dialog box, which is used to open, edit, and save function key menus. A function key menu is a file that contains keyboard function key definitions – assignments of actions to function keys. By default, F1 is help, etc.</td>
</tr>
<tr>
<td>Button Assignments</td>
<td>Opens the Button Assignments dialog box, which is used to assign MicroStation key-ins and to add key combinations to logical buttons, thus creating additional button assignments. Used to change the function of mouse or digitizer buttons. Go here if you have a three-button mouse. Change the center button to function as the snap button, the left to be the data button and the right to be used as the reset button. You must click in the wide bar in the dialog to make it work.</td>
</tr>
<tr>
<td>About Workspace</td>
<td>Opens a window in which information is displayed about the active workspace and its components and the active workmode.</td>
</tr>
</tbody>
</table>
Window Menu

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Views</td>
<td>Opens the View Groups window from which you can select a different view group, manage view groups or open or close multiple view windows in tandem. By default, it is docked at the bottom left of your screen above the status bar. Lets you open or close a view window. The numbered items in the submenu are window numbers. The windows marked on are open.</td>
</tr>
<tr>
<td>Cascade</td>
<td>Stacks view windows in numerical order with the lowest numbered window entirely visible and the title bar of each remaining window visible.</td>
</tr>
<tr>
<td>Title</td>
<td>Titles view windows between all docked windows and dialog boxes near the edges of the MicroStation PowerDraft window. This is a quick way to clean up the screen. Divides up the screen evenly between all views.</td>
</tr>
<tr>
<td>Arrange</td>
<td>Resizes all view windows so that they fit tightly within the available space without overlapping. Arrange attempts to preserve the view windows' original size and positional relationships as much as possible. Takes up available screen space with open Windows.</td>
</tr>
<tr>
<td>Scroll Bars</td>
<td>Toggles display of scroll bars and a view control bar in the borders of the view windows.</td>
</tr>
<tr>
<td>Task Navigation</td>
<td>Causes a Task Navigation tool box to be docked to each view window. This enables you to activate different tasks in different views. If Task Navigation in Views is off (the default), only one task is active at a given time.</td>
</tr>
<tr>
<td>View ToolBox</td>
<td>Causes a View Control tool box to be docked in the open view windows. This enables you to activate different view controls in different views.</td>
</tr>
</tbody>
</table>

Copyright © 2010 Bentley Systems, Incorporated
Help Menu

<table>
<thead>
<tr>
<th>Help Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Contents</strong></td>
</tr>
<tr>
<td><strong>Tool Index</strong></td>
</tr>
<tr>
<td><strong>Tool Tips</strong></td>
</tr>
<tr>
<td><strong>Tracking</strong></td>
</tr>
<tr>
<td><strong>Key-in Browser</strong></td>
</tr>
<tr>
<td><strong>Bentley Institute Training</strong></td>
</tr>
<tr>
<td><strong>Online Support</strong></td>
</tr>
<tr>
<td><strong>BE Communities</strong></td>
</tr>
<tr>
<td><strong>About MicroStation PowerDraft</strong></td>
</tr>
</tbody>
</table>

Summary

We are now able to open and create drawing files, navigate the menus, add, manipulate and edit elements and we have an overview familiarity with the entire menu structure. From this point, we will slow down and go more deeply into the most commonly used functions and will gain more hands-on experience.
A very useful feature of MicroStation PowerDraft for precise technical drawing is the key in of coordinate data.

Whenever MicroStation PowerDraft calls for entry of coordinate data, the data may be entered:

- Via the mouse and graphic cursor
- Via coordinates entered from the keyboard.

There are two ways to key in coordinate data from the keyboard:

  - Using key-in commands
  - Using AccuDraw

Lesson 7: Key in of Coordinate Data

Using Key-In Commands

MicroStation PowerDraft allows you to input data point values with the keyboard instead of the mouse. This means that you can create elements that are a certain size, or a certain distance from another element. You can also use keyed-in input to specify the exact location that you want an element to be placed. To use key-ins, select Utilities > Key-in to display the Key-in dialog box.

The xy= Key-in Command

MicroStation PowerDraft allows you to place data points by specifying their absolute coordinate positions, i.e., relative to the global origin. This feature is most frequently used to indicate the exact
position for an element’s origin point. The key-in command that you use to specify coordinate position is xy=. The format for this key-in is:

\[ xy=x \text{ coordinate},y \text{ coordinate} \]

The values for the X and Y coordinates should be specified in working units format, and they can be either a positive or negative value.

You can use this key-in to create a line with initial point at the global origin of the design plane. Here are the steps needed to create this line:

1. Select the \textit{Place SmartLine} tool.
2. Key in xy=0,0<enter> in the Input field of the Key-in utility.
3. Complete the command by entering a data point to visually place the line’s end point or enter another xy= key-in to specify the exact coordinates for the line’s end point.

   • The xy= key-in uses the drawing coordinate system so the coordinates you enter are always placed relative to the global origin.

\textbf{The dx= and dl= Key-in Commands}

You can use the dx= and dl= key-in commands to place a data point at an offset distance from a previous data point or current tentative point. The format for each of these key-ins is:

\[ dx=\text{delta x},\text{delta y} \]
\[ dl=\text{delta x},\text{delta y} \]

The delta values for X and Y are entered in working units format and they can be positive or negative.

The only difference between these two key-ins is that dx= uses the view coordinate system and dl= uses the drawing coordinate system. Unless you are working in a rotated view, you will not see a difference between these two key-ins.

You can use these key-ins to create a line that is 5 feet in length, and its origin point is 3 feet to the right of an existing element. Here are the steps needed to create this line:

1. Select the \textit{Place SmartLine} tool.
2. Use the tentative button to snap to the right side of the existing element, but don’t accept the tentative.
3. Key in dx=3,0. This indicates that you want the origin point of the line to be shifted 3 feet to the right of the current tentative point.
4. Key in dx=5,0. This indicates that the end point for the line is 5 feet from the previous data
point.

The \textit{di=} Key-in Command

The \textit{di=} key-in allows you to place a data point in polar coordinates by referencing a previous data point or a current tentative point. Here you specify the distance and the angular direction of the next data point. The format for this key-in is:

\begin{equation}
di=\text{distance, direction (angle)}
\end{equation}

Distance is entered in working units. Valid angle values range from 0 to 360 measured counterclockwise from positive x. They can be whole numbers or decimal values down to one ten-thousandth of a degree.

You can use this key-in to create a rectangle that is exactly 2 feet wide and 3 feet high. Here are the steps needed to create this rectangle:

\begin{enumerate}
    \item Select the \textit{Place SmartLine} tool.
    \item Enter the origin point for the rectangle. You might do this by visually selecting a data point, entering \textit{xy=} to specify the exact coordinates, or by entering \textit{dx=} to offset from the previous data point or current tentative point.
    \item Key in the following to draw the rectangle:
        \begin{align*}
        \text{di}&=2,0 \\
        \text{di}&=3,90 \\
        \text{di}&=2,180 \\
        \text{di}&=3,270
        \end{align*}

\end{enumerate}

- This key-in uses the view coordinate system, so the angle is always relative to the screen orientation, not the file’s axes.

Key-In of Coordinate Data Using AccuDraw

AccuDraw can be opened by clicking on the AccuDraw icon. In a 2D design file, this opens a coordinate dialog box showing X and Y coordinates. As an example of how to operate AccuDraw, do the following:

\begin{enumerate}
    \item Start a line anywhere. Move your cursor so the line is horizontal.

The line highlights to indicate that it is horizontal. Vertical works the same.
2 Move the cursor horizontally to the right and then type 5 (don’t type <enter>). AccuDraw makes the line 5 units in “X.” Left click the mouse to set the line.

3 Move cursor straight up and then type 3. The line is 3 units in “Y.” Click the mouse to set the line.

4 Touch the space bar to switch between xy mode and polar coordinate mode in AccuDraw. In the polar coordinate mode you enter distance and angle in the coordinate dialog box.

5 When drawing a line, press <Enter> to set Smart Lock. Smart Lock locks the direction in either X or Y depending on the direction at the time you press <Enter>.

6 To start a line at a known distance from a point, tentative-snap to the known point, but don’t accept. Press the letter <O> on the keyboard. Move the cursor using soft lock as explained in step 1. Type the distance from the known point and then left-click to set the beginning of new line.

A useful feature of AccuDraw is an enhancement of the previous key-in command. With input focus on AccuDraw, press the <P> key. Note the dialog box says x,y= with a box to input a number. Here you type the coordinate pair except that AccuDraw has already typed the letters “xy=” for you. Press <Enter> after entering the two coordinates.

If you practice these steps you will find that AccuDraw is the easiest way to enter precise coordinates. We will work with AccuDraw more in later exercises.
Exercise 2: Stepped-Shaft

You will use key-in of coordinate data to create the design file for the following shaft:

1. Select File > New and in the New dialog box, select seed2D.dgn as the seed file. In the File name field, enter your first name. Click Save.

2. Select Settings > Design File. In the DGN File Settings dialog box Working Units category, set the Master Unit to Inches.

3. While still in DGN File Settings, set the Format to MU to use Master Units.

4. Set the coordinate Accuracy to 0.123. Coordinates will display as 1.250 inches. Click OK to close the DGN File Settings dialog box.

5. Turn on AccuDraw, if it is not already on, by clicking on the AccuDraw icon on the Primary tool bar.

6. From the Task Navigation tool bar, select the Place Block tool. Make sure Input Focus is on AccuDraw (click on AccuDraw dialog box). To place first rectangle with corner at 0,0: press the <P> key and type in 0,0 <enter>.

7. Then, move the cursor to the right of the first point and type 4 (without typing <enter>). Then, move the cursor straight up and type 4 (without typing <enter>). Finally, accept by pressing the left mouse button.

8. Fit View to see the 4 x 4 inch rectangle (block).

9. To place the second rectangle, select the Place Block tool and move the cursor to the lower right
corner of the first rectangle until a small x appears. With AccuDraw having the Input Focus, press the letter <O> for Origin to set the AccuDraw origin.

The AccuDraw compass should now be located at the lower right corner of the first rectangle.

10 Move the mouse up along the rectangle’s right side and type 1 and then press the data button. This places the first point of the second rectangle.

11 Move the cursor to the right and type 6 (don’t press <Enter>) for the width of second rectangle. Then, move the cursor up and type 2 for the height of the second rectangle. Press the data button to complete the second rectangle.

12 Fit View to see the first and second rectangles.

13 From the Modify tool box, select the Construct Chamfer tool. In the tool settings, edit both distances to .125 (1/8”).

14 Click on right hand vertical edge of 6 x 2 rectangle. Then, click above on the horizontal edge of the same rectangle. Accept. One corner has been chamfered to 1/8”. Click anywhere on the view to accept. Repeat on the lower right corner of the same rectangle.

15 Draw the vertical line at the chamfer by using the Place SmartLine tool and snapping (using default keypoint snap) at top and bottom.

- Remember the sequence for manual snapping. First, take the cursor near the point to be snapped. It is usually best to put it right on a line near, but not on, the snap point. In this case, on the horizontal line near, but not on, the chamfer point. Then, press both buttons on your mouse at the same time. Your computer may be set to snap with the middle button of your mouse. A huge cursor appears. MicroStation PowerDraft is asking you if it snapped to the right point. If OK, press the data button to accept the tentative point. If not OK, press reset and then try again. If AccuSnap is on, you will see the element highlight and the little symbol by the point with a cross. Just left-click to accept the AccuSnap. Much easier!

16 Reset to disconnect the line.

17 From the Active Line Style drop-down menu (part of Attribute tool box, usually docked at the top of the screen), choose the Center style.
18 Place the centerline by snapping to the center of the vertical edge of the rectangles. Then use the Modify Element tool to extend the line to make the centerline as long as you like.

19 Pan your view to the right to make room for the end-view circles. You pan by using the Pan icon in the View Control tool bar.

20 Change the linestyle back to solid (0).

21 Draw the small outer circle by locating the center by snapping to the centerline, and in the Place Circle tool settings window, set the diameter to 2 inches.

22 Draw a large circle similarly, with a diameter of 4 inches.

23 In the Place Circle tool settings window, change Diameter to Radius. Draw the small circle representing the chamfer by placing the center of the small circle as in step 21 and then using AccuDraw to place a point on the circle by dragging your cursor horizontally to the right and typing 0.875.

24 Select Element > Text Styles. Set the text height and width to 0.200.

25 From the Task Navigation tool box, select the Dimension Element tool. Click on the top horizontal line on the shaft. Drag the dimension up and click.

26 For the 10" dimension, select the Dimension Linear tool. This is a special sequence: Snap to the left hand corner of the shaft. Move the cursor straight to the far right end and click to set the length. Then, move the cursor straight up to set the extension lines. Accept the 10" dimension.

27 Reset.

28 Select Dimension Element again. Identify the 2" circle. Accept the dimension and place it. Identify the .875" radius circle. Accept.

If you want a horizontal leg on your leader, select Element > Dimension Styles. In the Dimension Styles dialog box, go to Advanced > General > Placement > Location > Manual. Enter another data point for the leader, then Reset.

29 To place a center mark for the circles, use the Dimension Element tool and then click on the circle. In the tool settings, turn on Center Mark. Accept.

Summary

You have now completed a medium complexity mechanical drawing including chamfering, key-in of precise coordinates, and dimensioning!

Congratulations!
We will go more deeply into dimensioning in a later chapter. But, you are already prepared for schematics and normal mechanical drafting with your MicroStation PowerDraft.
Working with Groups

There will be times when you will want to perform the same operation on several elements. This can be done by repeating the operation for each individual element, or by temporarily grouping the elements and performing the operation once for the entire group. This chapter covers two different ways that you can create these temporary groupings in MicroStation PowerDraft.

Lesson 8: Fences

One way that you can group elements in your design file is to place a fence around them. Once a fence has been placed, you can move, copy, scale, rotate, delete, or change the attributes of elements that are in the fence. There are three important things that you need to remember about fences:

1. A fence is a temporary structure that you can use to group elements. Place a fence by selecting the Place Fence tool. To turn a fence off, click the same tool.

2. Only one fence can exist in your design file at any given time.

3. MicroStation PowerDraft fences can be in one of six different modes. These modes determine which elements are considered to be fenced. You can set the fence mode when you create the fence, when you perform any operation that uses the fence, or at any time from the Locks dialog box. The three most common fence modes are:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inside</td>
<td>Only elements that lie entirely inside the fence will be affected.</td>
</tr>
<tr>
<td>Overlap</td>
<td>Elements that lie inside or elements that overlap any portion of the fence will be affected.</td>
</tr>
<tr>
<td>Clip</td>
<td>Similar to the Overlap mode, it too affects elements that lie inside the fence or ones that overlap any portion of the fence. The difference is that Clip mode actually breaks overlapping elements at the points where they touch the fence. So only the portions of the broken elements that lie inside the fence are affected.</td>
</tr>
</tbody>
</table>

Fence Tool Box

You can use the tools on the Fence tool bar to place, modify, or move a fence. There is also a tool that allows you to delete the elements in the fence.
Three Most Common Fence Tools

**Place Fence**

You can use this tool to place a rectangular fence. When you activate this tool, you will be prompted to supply two data points. These data points will be the diagonal vertices of your fence.

**Delete Fence Contents**

Unlike the other tools on this tool box, this tool affects the elements within the fence. When you select this tool, you will be prompted to confirm the deletion with a data point. A data point anywhere in an open view confirms this action and deletes the contents of the fence. Remember that the current fence mode determines which elements will be deleted.

**Manipulate Fence Contents**

Essentially, any modification that can be done to elements can also be done to fenced groups.

For example, select the Place Fence tool from the Fence tool box. Click on the corners of a fence so as to include the circles of previous exercise. Then select the Change Element Attributes tool. Turn on Use Fence in tool settings, then click on “color” box, then click on the colored box and hold down the mouse button to expand out the color palette. Go to a bright color and drop the button. Accept. All of the circles will change color.

This same approach changes level, linestyle or any attribute.

Or, we could delete the contents of the fence or move the contents or copy the contents, etc. Note also that several manipulation tools can be found in the Manipulate Fence Contents icon which is the third one in on the Place Fence tool bar. Click on Operation to see the functions that can be done. Other tools in the Fence tool box provide for non-rectangular fences which can be very useful in certain circumstances.

Lesson 9: Element Selection Tool

Another way to temporarily group elements is to use the Element Selection tool found on the Main tool box. This tool allows you to select a single element, a group of elements, or all elements that lie within a specified area. When an element or group of elements has been selected with this tool, handles display around the element(s). The element(s) can now be changed or manipulated the same way you would change or manipulate any single element.

**To select a single element**

1. Select the Element Selection tool from the Main tool box.

2. Identify the desired element. The element now displays with handles indicating that it is selected.
To select multiple elements

1. Select the Element Selection tool from the Main tool box.

2. Press and hold the <Ctrl> key on the keyboard and identify the desired element. Continue this process until all the desired elements are selected.

- In the Element Selection tool, the sequence <Ctrl> key + data button is a toggle. If you issue this sequence on an element that has already been selected, you will unselect it.

To select all the elements within a specified area

1. Select the Element Selection tool from the Main tool box.

2. Position the screen cursor at one corner of the area that you want to select, press and hold the data button, drag the dynamic fence to the opposite corner of the area, and release the data button. All elements that lie completely inside this area now display with handles indicating that they are selected.

- If you hold the <Ctrl> and the <Shift> keys while you are dragging across elements, any element that lies inside or overlaps the defined area will be selected.

Exercise 3: Sprinkler Protector

In this exercise you will create the Plan and Section view of the sprinkler protector.
Exercise 3: Sprinkler Protector

1 Select File > New.

2 In the New dialog box, enter any file name (for example, EXER3) without pressing <Enter>.

3 Click Browse and in the Select Seed File dialog box, double-click seed2d.dgn and click Open.

4 In the New dialog box, click Save to close the dialog.

You will see the name you selected for the new file and you will have it set up with the seed2d.dgn seed file.

5 Select Settings > Design File and in the DGN File Settings dialog box, select the Working Units category. Set Master Units to Inches with the label ". Set Sub Unit to Mils.

6 In the DGN File Settings dialog box Grid category, turn off Grid Lock. Click OK.

You can also turn off the Grid Lock in the View Attributes dialog box. You open this dialog box by clicking the View Attributes icon at the top left of the screen.

To create the Plan View of the sprinkler protector

1 Using the Place Block and Place Circle tools, draw the rectangle and two concentric circles of the plan view using AccuDraw. Place the circle center by changing the Snap to Center method and then snap to an edge of the Rectangle.

2 Use Fit View to see the entire rectangle.

To create the Section View of the spring protector

You will draw one half of the Section View and mirror-copy it to create the other half.

1 Select the Place SmartLine tool, then space the Section View down from the Plan View.

2 With the Input Focus on AccuDraw, move the cursor to the lower left corner of the rectangle until the yellow “x” is on the corner. Then type the letter <O>. Move straight down, with AccuDraw indexed to vertical (you see the heavy white line) to make the first point of the section. Click the data button. Then, move to the right and type 6, but don’t press <Enter>. Then, move up and type 2 then click. Press the letter <V> to reorient to the view. Now, move down, press 6, then click. Move left, press <Enter> to lock to x, then snap to first point. Close the section by snapping again to upper left point.

3 Draw the remainder of the left half of section. Place a few points and three-sided polygons to represent the concrete. (We will learn about automatic patterning later.)
4 Select the Place Fence tool to make the right side of the section.

5 Move the cursor a couple of inches above and to left of the Section and click.

6 Move the cursor a couple of inches below and to the right and click.

You will see a colored rectangle surrounding your left half section.

7 From the Manipulate tool box, choose the Mirror tool. In the tool settings window, turn on Use Fence. Turn on Make Copy, otherwise it will mirror-image your geometry and you will lose the original.

The mirror-image tool is now expecting you to accept the contents of the fence and to simultaneously supply it with the line about which it will mirror.

8 In the Mirror tool settings window set the Mirror About option to Vertical and then click at the exact center of the sprinkler protector plan.

• Use the Keypoint snap and AccuSnap to the center of the horizontal line in top view.

You will see your geometry copied and mirrored to create the right side of the section. You will see another copy also as MicroStation PowerDraft assumes you want to continue. Just hit Reset to leave your original plus one copy.

9 Finish drawing by adding Dimensions as in Exercise 2: Stepped Shaft (page 53).

Review

You can now manipulate groups of elements as well as operating on individual elements.

This is a good point to review what you have learned since you are already capable of preparing fairly complex working drawings using MicroStation PowerDraft.

Here are the main points of what you have covered:

File Navigation

Create a new file using a seed file to get it started or Open an existing file.
Menus

By now you have settled on the way you like to do it. Maybe you like click-click. Or, if you learned on a Macintosh, you like click-drag.

If you are keyboard oriented, you have probably already begun to memorize some power keys. If you really like the keyboard, check the list of abbreviated key-in commands in the Appendix (page 140). You can use the Key-in Browser found on the Utilities menu to learn the longer key-ins for other commands. Also, see Workspace > Function Keys (page 45). You can even set keystrokes for each command. For example, if Input Focus is on “Home” (Press <Esc> first to be sure focus is on Home), type <Q> then <1> to be in Place SmartLine. Or, <E> then <1> to be in Place Circle.

Master-Sub Working Units and Grids

Go to Settings> Design File and in the DGN File Settings dialog box, use the Working Units category to set up working units for any new design file. Use the Grids category to set up grids.

Main and Task Navigator tool boxes

You always want these tool boxes displayed.

Panning and View Control in middle of a command

Pan the drawing using the Pan view control, using the scroll bars (Workspace > Preferences > View Options, turn on Scroll Bars on View Windows) or by pressing <Shift> and mouse button at the same time with cursor near center of screen. Move your hand right, left, up, or down to pan. After panning or any view control, you can return to the command you were in by right clicking the mouse.

Data-Reset-Tentative

If you have a three-button mouse, press the left button to select a command, accept a point or enter a data point. Press the right button to reset to the beginning of continuous operation like entering lines or press Reset to “reject” a selection. Press the middle button to enter a tentative point. If snap lock is on, pressing the middle button manually snaps according to mode set in the Snap menu. See AccuSnap.

AccuSnap

Automatically snaps to the highlighted point and object.

Accept/Reject

Many commands prompt you to Accept/Reject the selection you have made. For example, if you want to delete the contents of a fence, MicroStation PowerDraft asks you to Accept/ Reject fence contents. You must answer that question before continuing. Use the left button to accept and the right button to
Tool Settings Window

The tool settings window opens automatically whenever you select a tool. Always look at it after selecting a tool as it gives you the options for that tool.

Command and Prompt

Remember to watch the Command and Prompt at the bottom of the screen. You may not be where you thought!

Manipulating and Modifying Element

The tools for changing elements that are already on the drawing are found in three tool boxes:

- Manipulate (copy, move, mirror)
- Change Element Attributes
- Modify (delete partial, scale, extend two lines)

You can also use the Delete Element tool.

To find a tool, place the cursor over the first tool and press and hold down the data button while dragging the cursor. Watch the name of each tool appear.

Input Focus

Remember that the input focus must be on the dialog box into which you want to enter data. To change focus to a dialog box, click on it. To change input focus to Home, press the <Esc> key.

Positional Mapping

Positional keyboard navigation is a technique that utilizes a position-mapped keyboard. Position mapping is the mapping of keyboard zones to logical collections of controls in the user interface. MicroStation PowerDraft position maps your keyboard by default. You can show or hide the keyboard mapping through the Preferences dialog box (Workspaces > Preferences), Position Mapping category.

AccuDraw

To start AccuDraw, click on the icon in Primary Tools tool box. With input focus on the AccuDraw dialog box, here are the most popular short cuts:

1. While in the Place Line tool, click a point, then, move your hand in the direction you want the next point, key in the distance and click again to accept. If you see the heavy white line (or index), you know you are going in the x or y direction. This works for drawing a line.
radius of an arc, for moving an element, or really any command that requires a distance or coordinate change.

2 To enter an absolute coordinate, type <P> and the coordinate pair separated by a comma, followed by an <Enter>.

3 If using AccuDraw to enter two coordinate changes (like a line on an angle or a rectangle), move the cursor in the first direction until you see the heavy line, enter the first number without clicking the mouse or pressing <Enter>. Then, move the cursor in the second direction, enter the second number and then click the mouse.

4 If you want to start a line offset from a known point, tentative snap to the known point without accepting. Then, type in the letter <O> (representing Origin). Now, do as described in 1 or 3 to set the start of the line.

**Company Standard Seed File**

One of the first places for any company to standardize is with their seed files. To set up a company standard seed file, just start a new file with Seed2D.dgn, modify it to suit and then save the result in the path of seed files (See File > New > Browse to locate). From then on, you would use your company’s standard seed file to start all new files.
Using Levels

A design file consists of any number of levels. A level is a way of separating CAD data much in the same way as a clear sheet of acetate is used by an architect on “pindrafting.” For example, you might put your floor plan drawing on level 1, your dimensions on level 10 and furniture symbols on level 20. If you turn on all levels, you see the floor plan, dimensions and furniture. Or, if you turn off level 10 and 20 you will only see the floor plan.

Using levels allows you to work on only one part of a design at a time without the clutter of other parts. It also facilitates communication. You might turn off the furniture when sending the file to an electrical designer who only needs the floor plan.

Also, levels facilitate plotting the actual working drawings. From one file you can make a dimensioned drawing for the framer or a drawing with the floor plan and furniture for the interior designer, just by turning levels on and off.

In this chapter, you will learn the details of using levels in MicroStation PowerDraft. Probably the nicest feature about MicroStation PowerDraft’s level setup is that each of the unlimited number of levels can be turned on or off independently. Another nice feature is that each of the eight design views can be set up to display a different combination of levels.

Lesson 10: Levels

Level Manager Dialog Box

The Level Manager dialog box is used to create and delete levels and optionally to set the color, linestyle and lineweight for that level if using ByLevel option for those attributes.

The Level Manager dialog box opens when you select Settings > Level > Manager or when you click the Level Manager icon on the Primary Tools tool box.
To create a level

1 In the Level Manager dialog box, select Levels > New.

A new level is added to the level list in the Level Manager dialog box.

2 Click on any item that you wish to change. If you want to rename the New Level entry under Name, type in the new name you wish for that level.

3 Click on a heading to have the list sort in that order.

Level Display Dialog Box

Even though there are any number of levels that you can draw on, only one level is considered active at any given time. Any elements that you create are placed in the active level. The Level Display settings box can be used to set the active level and to turn levels on and off in the individual views.

You can display this settings box by selecting Settings > Levels > Level Display (or click the Level Display icon in the Primary Tools tool bar). The green highlighted level in the list box is currently the active level. The darkened levels indicate that they are turned on for this particular view.

- Changing the active level only affects elements that are created from that point on. It does not affect any existing elements.
To set the active level

1. From the Settings menu, select the Levels > Display to open the Level Display dialog box (or from the Primary Tools tool box, click the icon).

2. In the dialog box, position the cursor on the level you want to make active, and double click the data button. The level highlights in green.

To turn levels on or off

1. In the Level Display dialog box, single click any level that is not the active level. The active level is always on.

2. To turn off a level, single click it.

3. Position the cursor on the number for the level you want to turn on or off, and single tap the data button. This toggles the level off if it was on or on if it was off. You can also press and hold the data button and drag across several numbers to turn on or off multiple levels.

Lesson 11: Moving Elements Among Levels

After elements have been added to your drawing, you may want to move an element or a group of elements from the original level on which the elements were entered to some new level.

To do that, use the Change Elements Attributes tool. In the tool settings window that opens, turn on the Level check box. Then, select the new level name. Finally, identify the elements that you want changed by clicking on them and then accepting.

You might try this by changing all of the dimensions of the previous exercise to a named level. Then select Settings > Levels > Display and click on the named level. When you click All, the dimensions disappear.

Remember, when you change any attribute, including level, you are also changing the attribute for elements to be subsequently entered.
Lesson 12: Level Locks

You can use the Level Lock feature to restrict element manipulations, so that only elements on the current active level are affected by certain manipulation tools. Trying to select an element on any other level for manipulation when this lock is on, causes the error message Element Not Found to appear in the status bar.

By default, the Level Lock is off. You can turn this lock on through the Locks settings box. To display this settings box, select the Locks item from the Settings menu, and then select Full. Click the data button in the check box beside Level Lock to turn on this lock.
The multi-line feature of MicroStation PowerDraft is very useful for many types of design and drafting, but especially for drawing floor plans. MicroStation PowerDraft will automatically “mitre” the corners, join lines and cap multi-lines as you direct it.

Lesson 13: Multi-line Set-up

To set up your multi-lines, select Element > Multi-line Styles. The Multi-line Styles dialog box opens.

| **Profile/End Caps and Joints tabs** | Contains controls to change one of the lines, the caps or the way joints are handled. |
| **Offset** | Sets the distance of each line relative to the “centerline” of the multi-line. |
| **Level, Color, …** | Sets the attributes of each line in the multi-line independent of the others. Click on the value and change it to what you want. |
| **Fill Color** | If on, the entire area of the multi-line is filled with the selected color. |
| **Picture at bottom** | Shows how your multi-line will look. |
Lesson 14: Placing Multi-Lines

As an example, you probably found multi-line setup for the default with three lines. Two lines are solid, spaced 0.3" above and below the centerline which is at 0:0.

To place a multi-line

1. Select the Place Multi-line tool. It is the first tool on the Multi-lines tool box.

2. In the status bar, the message Place Multi-Line > Enter First Point displays.

3. Move your cursor to the first point of the centerline of the multi-line and click. Then, drag the multi-line to the second point and click.

   The tool settings window gives you the option of placing by Work line, Center, Maximum or Minimum.

4. Move at an angle and see the multi-line mitre the corner.

Lesson 15: Cleaning up Multi-line Joints

After placing some arbitrary multi-lines in your drawing, experiment with cleaning up the joints. In the Multi-lines tool box, select the tools one-by-one and try them on your sample multi-lines.

To clean up a multi-line joint

1. Select one the Multi-line Joint tools.

2. Identify the first multi-line at the joint.
3 Identify the second multi-line.

4 Enter a data point to “accept” the joint.

The joint will be “cleaned up” according to the tool you selected.

Select the centerlines a short distance from the joint. Also, if a joint does not cleanup as you wished, reset before accepting or use Edit > Undo and then try again, clicking on the centerlines in opposite sequence.

Exercise 4: Floor Plan

To set up the wall with a centerline

1 Create a new file with name FLOOR using seed2d.dgn.

2 Select Settings > Design File.

3 In the DGN File Settings dialog box, select the Working Units category and set:
   
   Format: MU:SU Master Unit: Feet with label ' Sub Units: Inches with label " Accuracy: 1/16

4 While still in the DGN File Settings dialog box, select Grid and set:
   Grid Master: 0:1.000 (every 1")
   Grid Reference: 12 (every foot or 12")
Click OK to close the DGN File Settings dialog box.

5 From the Attribute tool box, set:
   
   Level: Default  
   Color: white  
   Style: solid  
   Weight: 0  

6 Select Element then Multi-Line Styles.
   
   Note that the Multi-line dialog box shows the location of each line that makes up the multi-line.
   
   Note the first entry (Centerline). By default, the offset is 0:0 and Override for centerline style 7.
   
7 Select second entry (lower line in graphic figure) by left-clicking on the offset distance. The entry highlights and is available for editing. Change the offset to -0:3.
   
8 Select the third entry and change the offset to 0:3.
   
   This completes setup for a normal 6" wall with centerline.
   
   Close the Multi-line Styles dialog box.

To trace the wall

With AccuDraw active, we will trace the wall.

1 Zoom-Out so that you see an area of about 30' x 20'. You can use the measure tool, or draw a 30 x 20 block, or use the Grid to judge how large an area is covered by the screen.

2 From the Multi-lines tool box, select the Place Multi-line tool.

3 Move the cursor to the near upper left of screen and click the data button.

4 Move the cursor straight up and type 1 (1' long vertical wall). Click the data button.

5 Move the cursor straight right and type 24. Click the data button.

6 Move the cursor down and type 15. Click the data button.

7 Move the cursor left and type 15. Click the data button.

8 Move the cursor up and type 15. Click the data button, then press Reset.
To set up the 3' doorway

1. Still with the Place Multi-line tool, move the cursor so the AccuSnap X is on the first point of the wall, but don’t accept.

2. Type <O> for origin (AccuDraw may need focus), move the cursor straight down and type 3. Click the data button.

The beginning of the new wall will be exactly 3' down from the first point, leaving a 3' opening.

3. Move the cursor down and type 9. Click the data button.

4. Move cursor right to the center of the vertical wall. Use AccuDraw to ensure the line is horizontal. Click the data button, then press Reset.

• If you enter a string of good points as above and accidentally enter a bad one, go to Edit > Undo Last Data Point and you will preserve the good work.

To clean up the joint

We will clean up the joint between the first and second series of multi-lines.

1. From Multi-lines tool box, select the Construct Merged Tee Joint tool.

2. Identify the first multi-line at the joint (the intersection where you want to trim to) by clicking on the centerline.

3. Click on the centerline of the intersecting wall.

4. Click to accept.

5. Repeat for the other joint.

If your multi-lines get distorted when you use the joint tool, reset (or Undo if already placed) and then select the two lines in the opposite order. Your multi-lines are now automatically joined.

To set up the dimensions

We will now create the dimensions on a separate level.

1. Select Settings > Levels > Manager and from the Level Manager dialog box, select Levels > New. Click the new level Name in list box and type “dimensions.” Close the Level Manager.

2. Select Element > Dimension Styles, and in the Dimension Styles dialog box, select the Units tab.

3. Set Label Format to MU label-SU Label (that is X’-X”) and set
Accuracy to 1/16. Close the Dimensions Styles dialog box.

4 Select Element > Text Styles.

5 In the Text Styles dialog box, set the height and width to .5 (or 1/2).

6 Zoom Out to see whole plan and make room for the dimensions.

7 Select the Dimension Element tool.

8 Click on 24' wall and drag up the dimension.

9 Continue dimensioning the drawing.

You have completed the dimensioned floor plan.

To view the design without dimensions, select Settings > Levels > Display (or press <Ctrl-E>). Double-click on the “Default” level to change the active level, then, click on “dimensions” to turn off that level.

All your dimensions should disappear. If it doesn’t happen, select Element > Information and double-click on one of the dimensions. The dialog box shows you a lot of information about the dimension, including its level. You can change things right there. Try changing the dimensions to a different level.
All technical drawings require some annotation. Notes may be call-outs, title-block information, instructions to the shop or construction, or lists of materials.

MicroStation PowerDraft provides a large number of fonts and features for setting up text and for placement and editing.

Lesson 16: Text Settings

Certain settings control the text characters. The easiest way to specify these settings is through the Text Styles dialog box. This dialog box displays by selecting Text Styles from the Element menu.

Fonts

The top line of the list box shows the name of the Text Style. The remainder of the list box shows the font, size, line spacing and other characteristics of the named Text Style. If you want to create your own style, click Style > New and you will be placed in a new, untitled style.

To select the font to use for the new style, click on the drop down box next to “Font.” You will see a list of fonts. Scroll down to pick a font from the list of available ones.

At the bottom of the Text Styles dialog box, you can see how the font will display.

Text Justification

Justification is the orientation of a text element relative to the data point that is used to place it. The current text justification is shown when you click in the list box.
Text Size and Spacing

From the General Tab of the Text Styles dialog box, you change or set following:

**Height** -- Specifies the text height, in working units, in the list box.

**Width** -- Specifies the text width, in working units, in this data field.

**Slant** -- Specifies the slant value for the individual text characters. You can enter a value from -89 to +89. You use this feature to create italicized text.

**Underline** -- Underlines the text automatically.

**Fractions** -- Indicates that fractions, numeric characters separated by a slash, should be treated as one character.

**Vertical** -- Cause the text characters to display in vertical lines instead of horizontal lines.

From the Spacing tab of the Text Styles dialog box, you have options for:

**Line Spacing** – Sets the vertical spacing, in working units, between lines in a multi-line text element, or between text and the specified element when you choose to place text above, below, or along an element.

**Intercharacter Spacing** – Specifies the distance, in working units, between each character.

Lesson 17: Placing Text

The tools on this part of the Drawing task are for placing, editing, and modifying text. Here are the more commonly used text placement tools.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td><strong>Place Text</strong> Used to place text elements in your design file or fill in empty text nodes. Depending on the placement method you select, text will be placed using some or all of the active text settings. The active element attributes: color, weight, and line style, and the active angle can affect the way your text is placed.</td>
</tr>
<tr>
<td>√A</td>
<td><strong>Place Note</strong> Used to place a line of text with a leader line and arrow as a dimension element. It is especially useful for placing geometric tolerance symbols, feature control frames, and quick notes.</td>
</tr>
</tbody>
</table>
### Place Text Tools

You can use the Place Text tool to put text elements in your design file. The Method option menu setting for this tool allows you to choose how you want the text placed.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Text</td>
<td>Used to replace, add, or delete characters from existing text elements.</td>
</tr>
<tr>
<td>Spell Checker</td>
<td>Used to check spelling of entered text.</td>
</tr>
<tr>
<td>Display Text Attributes</td>
<td>Used to see the attributes of existing text elements.</td>
</tr>
<tr>
<td>Match Text Attributes</td>
<td>Used to set the active text settings, the same as the corresponding attributes of an existing text element.</td>
</tr>
<tr>
<td>Change Text Attributes</td>
<td>Used to change the attributes of an existing text element to the active text settings.</td>
</tr>
<tr>
<td>Place Text Node</td>
<td>Used to place empty text nodes in a design to be filled with text later.</td>
</tr>
<tr>
<td>Copy/Increment Text</td>
<td>Used to copy and increment a text element that contains numbers.</td>
</tr>
<tr>
<td>Copy Enter Data Field</td>
<td>Used to copy the contents of one enter data field to another.</td>
</tr>
<tr>
<td>Copy/Increment Enter Data Fields</td>
<td>Used to copy and increment the contents of an enter data field that contains numbers into another enter data field.</td>
</tr>
<tr>
<td>Fill In Single Enter-Data Field</td>
<td>Used to fill in or change an enter data field.</td>
</tr>
<tr>
<td>Auto Fill In Enter Data Fields</td>
<td>Used to fill in all empty enter data fields in a view.</td>
</tr>
</tbody>
</table>
Here are common methods:

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>By Origin</td>
<td>Places text at the current active angle and active text settings. This method must be specified if you are filling text nodes.</td>
</tr>
<tr>
<td>Fitted</td>
<td>Forces text to fit between two data points that you supply. The vertical alignment of the text element is determined by the active text justification. This method overrides the active angle and active text size settings. You cannot use this method to place multi-line text.</td>
</tr>
<tr>
<td>Above an Element</td>
<td>Places text, at the active text settings, above a line or segment of a line string, shape, or multi-line. The active line spacing setting determines how far above the element the text will be placed.</td>
</tr>
<tr>
<td>Below an Element</td>
<td>Places text, at the active text settings, below a line or segment of a line string, shape, or multi-line. The active line spacing setting determines how far below the element the text will be placed.</td>
</tr>
<tr>
<td>On an Element</td>
<td>Places text, at the active text settings, on a line or segment of a line string, shape, B-spline curve, or multi-line.</td>
</tr>
<tr>
<td>Along an Element</td>
<td>Places text along - above or below - a curve, arc, ellipse, line, line string, or shape. Each character that is placed becomes a single text element that is a component of a graphic group. The characters are placed at the active text settings at a distance equal to the active line spacing.</td>
</tr>
</tbody>
</table>

To place text

1. From the Text tool box, select the Place Text tool. The Text Editor and Place Text tool settings windows open.
2. From the tool settings window Method option menu, choose the appropriate text placement method.
3. In the Text Editor window, type in the desired text.
4. Enter data point(s) to position the text.

Lesson 18: Editing Text

The Edit Text tool is used to change text in existing text, text node, or dimension elements.

To edit text

1. From the Text tool box, select the Edit Text tool.
2. Enter a data point to identify the text element that you want to edit.

The current text now displays in the Text Editor window.
3. In the Text Editor window, make the desired changes to the text.
While in this window, you can use the arrow keys to move the displayed cursor. The <Delete> key can be used to delete the character to the left of the cursor. The <Backspace> key can be used to delete the character to the right. Tapping and dragging on text highlights it and puts it overstrike mode.

4 Click on the screen to apply the changes to the text element.

Exercise 5: Notes on Floor Plan

1 Go to File > Open and open the floor plan (FLOOR.DGN) you completed in Exercise 4: Floor Plan (page 69).

2 Annotate the floor plan as shown:

- Hint: Visually note that the letters should be about the same height as the walls are thick.

3 Select Element > Text and set the height to 0:6 or just enter 0.5 (1/2 foot is the same as 6"). Make the width the same.

4 Make the line spacing 6" also.

You can use the Architectural text font, or look for one you like better by pulling down the list of fonts.

5 Place the text by selecting the Place Text tool from the Task Navigation tool bar.

6 Type Reception and click on the floor plan to place it. Continue until all the text is placed.

7 From the Task Navigation tool bar, open the Text tool box and select the Edit Text tool.
8 Change some of the text already placed by identifying it, making changes, then clicking on the screen to apply the changes.

9 Change the color of some of the text by first highlighting it and then clicking on a new color using the Attributes tool box.

You have now learned how to set up text, place text on your drawing, edit or change text after it has been placed and how to change the attributes of the text after placement.
A cell is a group of elements combined into one complex element and stored in a cell library or in your design file as a shared cell. Any cell can be easily recalled and placed, and then manipulated as a single element. Cells reduce repetitive drawing and encourage standardization. With the proper setup, any cell can be used in any drawing. Therefore, everyone working on a project can use the same cells if they are given access to the same cell library.

In order to be able to create and use cells, there are several general steps that you need to perform. Some of these steps must be performed each time you place a cell, while others only need to be performed when you enter the design file, and still others only have to be performed one time. The following list outlines these general steps. Each step is also covered in more detail later in this chapter.

To create and place cells from a library

1. Create the cell library. This step only has to be performed one time. Once you create the library it can be used to store all your cells and used later for other drawings.

2. Attach the cell library to the design file (it is already attached if you just created it). This step will only have to be performed one time for each design file you want to attach the cell library to as long as you File > Save Settings after attachment.

3. Draw the elements that make up the cell.

4. Group the elements that make up the cell with a fence.

5. Define a cell origin. A cell origin is the point with which the cell is placed.

6. Create the cell in the cell library.

7. Make the desired cell active and place it in the design file.

Lesson 19: Cell Library Creation

All cells have to be stored in and recalled from a cell library. If no cell library is available to be used with your design file, you must create one. Creating a cell library is similar to creating a design file.

To create a cell library

1. Select Element > Cells and from the Cell Library dialog box that opens, select File > New.

The Create Cell Library dialog box opens.
2 Enter the name of the new library in the File Name data field. You can either specify a full path for the file in this box or use the Directories list box to navigate to the desired directory. MicroStation PowerDraft automatically appends the standard cell library extension .cel to your filename.

3 Click Save to create the new cell library and close the dialog box.

Unless you change the Save in field, this file is automatically saved to C:\Documents and Settings\All Users\Application Data\Bentley\Workspace\Projects\Untitled\cell, if you are using Windows Vista or earlier, or C:\Program and Data\Bentley\PowerDraft V8i\Workspace\Projects\Untitled\cell, if you are using Windows 7.

Lesson 20: Cell Library Attachment

A MicroStation PowerDraft design file can have only one cell library attached at a time. But, several design files can have the same cell library attached at the same time. When you create a new cell library, that library is automatically attached to your current design file. By default, once a cell library is attached to a design file, if you Save Settings, it remains attached until you manually detach it or attach a different one.

To attach a cell library

1 Select Element > Cells.

2 From the Cell Library dialog box that opens, select File > Attach File. The Attach Cell Library dialog box opens.

3 Enter the name of the desired library in the Name data entry box. Use the Directories and Files list boxes to navigate through the directory structure to the desired file.

4 Click the Open button to attach the specified library and close the dialog box.
Lesson 21: Creating Cells

Once you have created and attached your cell library, you can begin creating and placing cells.

To create a cell

1. Create and/or attach a cell library.

2. Place the elements in your active file that will be used to create the cell. Make sure that you have the desired element attributes set when you place these elements.

3. Place a fence, or use the Element Selection tool, to group the element(s) you want to include in the cell.

4. Open the Cells tool box.

5. Select the Define Cell Origin tool.

6. Define the origin of the cell with a data point.

7. From the Cell Library dialog box, click the Create button.

The Create Cell dialog box opens.

8. Fill in the appropriate name and description, select the type and click Create.

<table>
<thead>
<tr>
<th>Name</th>
<th>Enter the cell name. This name can be any combination of alphanumerics, periods, underscores, or commas. Alphabetic characters can be entered in uppercase or lowercase.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Enter an optional description.</td>
</tr>
<tr>
<td>Type</td>
<td>Choose either Graphic or Point cell type from the option menu. Usually graphic.</td>
</tr>
</tbody>
</table>

The new cell name appears in the Cell Library dialog box.

Lesson 22: Placing Cells

The Cell Library dialog box contains a group box called Active Cells. The buttons in this group box are used to designate a cell as the active cell, active point, active line terminator, or active pattern cell.
Placement

The cell name that displays beside this button is the cell that is placed with the Place Active Cell and Place Active Cell Matrix tool (Cells tool box). The word NONE appears if no cell is currently active.

Point

The name that appears beside this button indicates which cell, if any, will be used as the active point. The active point does not have to be a cell, it can also be a zero-length line element or text character. The words, Element or Character display beside this button if a line or character is the current active point. Do not confuse the active point with a point cell. They are two separate items.

Terminator

The cell name that appears beside this button is the cell that is placed with the Place Active Line Terminator tool (Cells tool box). The word NONE appears if no line terminator cell is currently active.

Pattern

The cell name that appears beside this button is the cell that will be used to pattern an element. Patterning is done with the various tools found on the Patterning tool box. The word NONE appears if no pattern cell is currently active.

To activate a cell

1. From the Cell Library dialog box, click on the desired cell from the list box.

2. From the Active Cells group box, select the appropriate button to activate the cell, for Placement, Point, Pattern or Terminator.

Cells Tool Box

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Place Active Cell</td>
<td>Place the active cell.</td>
</tr>
<tr>
<td>Place Active Cell Matrix</td>
<td>Place a matrix (rows and columns) of the active cell.</td>
</tr>
<tr>
<td>Select and Place Cell</td>
<td>Identify a cell and place an additional instance(s).</td>
</tr>
<tr>
<td>Define Cell Origin</td>
<td>Define the cell origin (the point about which the cell is placed) when creating the cell.</td>
</tr>
<tr>
<td>Identify Cell</td>
<td>Display the name and level of a cell that is in the DGN file.</td>
</tr>
<tr>
<td>Place Active Line Terminator</td>
<td>Add a terminator to a line segment.</td>
</tr>
<tr>
<td>Replace Cells</td>
<td>Replace a cell(s) (or all instances of a shared cell) in the design with another of the same name from an attached library.</td>
</tr>
<tr>
<td>Place Cell Index</td>
<td>Used to create an index of cells within a cell library</td>
</tr>
</tbody>
</table>
The tools on the Cells tool box are used for defining cell origins, placing cells, and displaying information about cells.

**Cell Selector**

Selecting Utilities > Cell Selector automatically opens the Cell Selector dialog box. Each button is associated with a cell stored in a cell library. In the dialog box’s default button configuration, clicking a button has the effect of activating the associated cell and selecting the Place Active Cell tool. You can then dynamically drag the cell and place it. Use Active Angle and Active Scale to vary the angle and scale at which the cell is drawn. You can have several cell libraries loaded in the same cell selector. Use the File menu on the Cell Selector tool to load another cell library.

---

**Exercise 6: Add Symbols to the Floor Plan**

1. Go to File > Open and open the floor plan you completed in Exercise 4: Floor Plan (page 69) and updated in Exercise 5: Notes on Floor Plan (page 77).

2. Choose Settings > Levels > Manager. Create a new level 20. Make level 20 the active level.
   
   You will add all symbols to level 20.

3. Close the dialog box.

4. Select Element > Cells to display the Cell Library dialog box.

5. From Cell Library dialog box, select File > New.

6. Enter the name Fixture for the library.

7. Click Save and then close the dialog box.

8. With the Place Block tool, draw a block 2' x 2'.

9. With the Place Circle tool, place a circle in the center of the block.
This represents a sink.

10 Place a fence around the block-circle.

11 From the Cells tool box, select the Define Cell Origin tool.

12 Click on the corner of block-circle to represent the handle-point that is the point by which you will place this symbol.

13 Select Element > Cells and click the Create button.

14 In the Create Cell dialog box, supply the name (sink), and a description and click Create.

15 Make the cell active by clicking Placement in the Active Cells section of the Cell Library dialog box.

You have now created a library, created a cell, added the cell to your library and made it the active cell for placement.

To place the “sink” cell in the drawing

1 Select Utilities > Cell Selector. The Cell Selector dialog box opens showing the “sink” cell.

2 Click on the button which displays your “sink” cell. This automatically makes the cell active for placement and opens the Place Active Cell tool settings window.

3 Click in the design file to place the sink cell and Reset.

4 Draw additional symbols for a tub, toilet, and some furniture. Add to your symbol library and save the updated library. A large number of cell libraries are supplied with MicroStation PowerDraft. By default they are stored in C:\Documents and Settings\All Users\Application Data\Bentley\Workspace\System\Cell. If you don’t find the Cell folder there, use your Windows Search and find the folder.

5 Experiment by attaching remodel.cel and then open Utilities > Cell Selector and place a few cells.

Cell libraries are one of the most productive aspects of any CAD software.
Patterning and Crosshatching

Patterning Tool Box

These tools are used to pattern areas along linear elements. From the Task Navigation bar, right click the Hatch tool and then click Open as Toolbox.

The available tools are:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hatch Area</td>
<td>Used to hatch an area</td>
</tr>
<tr>
<td>Crosshatch Area</td>
<td>Used to crosshatch and area</td>
</tr>
<tr>
<td>Pattern Area</td>
<td>Used to pattern an area by tiling instances of the active pattern cell</td>
</tr>
<tr>
<td>Linear Pattern</td>
<td>Used to draw a pattern along a linear element</td>
</tr>
<tr>
<td>Show Pattern Attributes</td>
<td>Used to display the angle and scale attributes of a pattern element</td>
</tr>
<tr>
<td>Match Pattern Attributes</td>
<td>Used to set the active pattern angle, scale, and delta settings to match the attributes of an existing pattern element</td>
</tr>
<tr>
<td>Change Pattern</td>
<td>Used to change an existing pattern to match the current attributes or to redefine the intersection point of patterning.</td>
</tr>
<tr>
<td>Delete Pattern</td>
<td>Used to delete patterning</td>
</tr>
</tbody>
</table>

Lesson 23: Hatch Area Tool

You use the Hatch Area tool to hatch an area with lines. The various settings associated with this tool determine how the hatching looks and where it is done.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spacing</td>
<td>Sets the space between the hatching lines. By default, this value is set to zero. You will receive an error message in the Command Window if you do not enter some other value in this data entry box. Values should be entered in working units format.</td>
</tr>
<tr>
<td>Angle</td>
<td>Sets the angle at which hatching lines will be drawn. By default, this value</td>
</tr>
</tbody>
</table>
Lesson 24: Crosshatch Area Tool

The Crosshatch Area tool is very similar to the Hatch Area tool. The tool settings and the procedures are the same, except that there are two additional data entry boxes to specify the spacing and angle of the crosshatch lines. There are two ways that you can use the Spacing and Angle boxes for the crosshatch lines:

- You can enter the desired angle and/or spacing, in working units, in the appropriate data entry box.
- You can leave either value set to zero. If the spacing is zero, the crosshatch lines have the same spacing as the hatch lines. If the angle is zero, MicroStation PowerDraft automatically calculates an angle for you. This angle will be 90 degrees from the angle that you specified for the hatch lines. For example, if you leave both Angle values set to zero, the hatch lines will be at 0 degree angles and the crosshatch lines will be at 90 degree angles.

Lesson 25: Pattern Area Tool

The Pattern Area tool is used to pattern an area by tiling instances of the active pattern cell. There are several settings associated with this tool that determine what cell is used, how it will be spaced, and what area will be patterned.

<table>
<thead>
<tr>
<th>Pattern Definition</th>
<th>Sets whether the pattern is from the cell or from the file.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pattern</td>
<td>Displays the cell that will be used to create the pattern. You can select another cell by entering a different cell name in this box, or by using the Pattern button on the Cell Library dialog box.</td>
</tr>
<tr>
<td>Scale</td>
<td>Sets the scaling factor for the pattern cell.</td>
</tr>
<tr>
<td>Row Spacing</td>
<td>Specifies the desired spacing between rows in this data entry box.</td>
</tr>
<tr>
<td>Column Spacing</td>
<td>Specifies the desired spacing between columns in this data entry box.</td>
</tr>
<tr>
<td>Angle</td>
<td>Specifies the angle at which instances of the pattern cell are placed.</td>
</tr>
</tbody>
</table>
| Tolerance          | Sets the value for the maximum distance between a curved element and these line segments guides. If the tolerance is small, the line segments conform closely to the curve and the approximation is more accurate, but processing time increases. If tolerance is large, line segments do not conform closely to the curve and the approximation is less accurate, but processing time decreases.

If on, hatching is associated with a patterned element and is automatically moved or resized when the element is manipulated or modified. If the patterning method is intersection, union, difference, or flood, a complex shape that bounds the patterned area is created, and the hatch lines are associated to the complex shape. If on, you can snap to the elements in the pattern.
the line segment guides used for patterning.

<table>
<thead>
<tr>
<th>Associative Pattern</th>
<th>Determines whether or not patterning automatically adjusts if the patterned element is modified.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snappable Pattern</td>
<td>Determines whether you can snap to the individual pattern elements.</td>
</tr>
</tbody>
</table>

To pattern an area using the Element, Fence, or Flood method

1. From the Patterns tool box, select the Pattern Area tool.
2. In the Pattern Area tool settings window, set all the desired settings.
3. For the Element method, enter a data point to identify the element.

For the Flood method, enter a data point inside the area enclosed by the set of elements.

For the Fence method, skip this step.

4. Enter a data point to place the origin of one of the pattern cells.

Delete Pattern Tool

Most patterning operations can be undone with the Undo item from the Edit menu. But some patterning operations are so complex that they exceed the capacity of the undo buffer. This means that the only way to undo the patterning is to delete. The Delete Pattern tool provides a quick and easy way to do this.

To delete patterning

1. From the Patterns tool box, select the Delete Pattern tool.
2. Enter a data point to identify the patterning that you want to delete.
3. Enter another data point to accept it.
Hatching Around Text

To hatch around text in an element, create an element and before choosing the Place Text tool, change the area in the tool settings box from solid to hole. Place text inside the element, and hatch element making sure that the associative pattern setting is off. Works for the Element, Fence, and Points Methods but not for Flood.

If you use the Flood method, you can just click on the text or other elements that you want to hatch around and those items will be missed. Click on the down arrow on the lower right of Hatch tool settings.

Exercise 7: Hatch Walls

1. Select File > Open and open the floor plan FLOOR.DGN.
2. From Task Navigation bar, select the Hatch Area tool.
3. In the Hatch Area tool settings window, set the following:
   - Spacing: 3" (0:3)
   - Angle: 45
4. Turn on Associative Pattern.
5. Identify the multi-line wall by clicking anywhere on the wall. It changes color and prompts for “accept-reject.” Click anywhere on the design file to accept.
   - The whole wall will be hatched.
   - This works the same for crosshatch or pattern fill.
6. Select Edit > Undo Hatch Area.
   - The hatching disappears.
7. Select Edit > Redo Hatch Area.
   - Hatch is back.

To scale the laboratory room to make it 1.5 times wider

1. Place a fence around right half of the laboratory.
2. From the Fence tool box, select the Manipulate Fence Contents tool.
3 In the tool settings window, select Stretch.

4 Define the origin and use AccuDraw to enter 6’. Accept.

• Note that dimensions and hatch pattern adapt to the new walls! This is associative dimensioning and associative patterning.
Dimensioning

You were introduced to dimensioning in Exercise 2: Stepped-Shaft (page 51). The basics of dimensioning your design are quite simple. This chapter introduces some additional aspects of dimensioning so you will be prepared for your most comprehensive designs.

MicroStation PowerDraft dimensioning tools place dimensions for your file as a single element. You can delete, move, rotate and perform other operations on your dimension as a single element. Dimension elements have attributes just like other elements. Dimensions will take on the active color, line style width, etc. The text size in a dimension is set by the active text size in real world coordinates.

Since text sizes are expressed in real world units, you have to think ahead to the scale you will use on plotting so you assign the correct real world text size.

Here’s a simple table to help you set text sizes:

<table>
<thead>
<tr>
<th>Plotting Scale</th>
<th>Architectural Height of Text on Paper</th>
<th>Real World Height of Text</th>
<th>Plotting Scale</th>
<th>Mechanical Height of Text on Paper</th>
<th>Real World Height of Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/4&quot; to ft</td>
<td>1/4</td>
<td>1'</td>
<td>1:1</td>
<td>1/4&quot;</td>
<td>1/4&quot;</td>
</tr>
<tr>
<td>1/4&quot; to ft</td>
<td>1/8</td>
<td>1/2'</td>
<td>1:1</td>
<td>1/8&quot;</td>
<td>1/8&quot;</td>
</tr>
<tr>
<td>3/8&quot; to ft</td>
<td>1/4</td>
<td>.67’</td>
<td>1:2</td>
<td>1/4’</td>
<td>1/2’</td>
</tr>
<tr>
<td>3/8&quot; to ft</td>
<td>1/8</td>
<td>.33’</td>
<td>1:2</td>
<td>1/8’</td>
<td>1/4’</td>
</tr>
<tr>
<td>1/2&quot; to ft</td>
<td>1/4</td>
<td>.5’ (6&quot;)</td>
<td>1:4</td>
<td>1/4’</td>
<td>1’</td>
</tr>
<tr>
<td>1/2&quot; to ft</td>
<td>1/8</td>
<td>.25’ (3&quot;)</td>
<td>1:4</td>
<td>1/8’</td>
<td>1/2’</td>
</tr>
<tr>
<td>1/8&quot; to ft</td>
<td>1/4</td>
<td>2’</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Annotation Scale

The above values can be placed automatically, if you know in advance the scale you will use when plotting your drawing. Select Settings > Drawing Scale to open the Drawing Scale dialog box.

In this dialog box, the “A” on the left side toggles on and off the Annotation Scale lock. Set the scale as desired, for example, ½” to the foot, then enter text height and width in the size you want to see on paper. For example, if you want the text to be ¼” high and scale is ½” to ft, enter your text as ¼” in Element > Text Styles. MicroStation PowerDraft actually stores the height as 2’ high so when scaled at ½’ to ft, the letters will be ¼” on paper. You can use Annotation Scale or not as you choose. If not, you do the math as indicated in the table above.

Dimension Element

A dimension element is a special element type. It is composed of combinations of the five following entities.
• Dimension Line -- A line that shows the direction of a measurement or the size of an angle.

• Dimension Text -- The text used to display the length of a measurement or the size of an angle.

• Extension Lines (optional) -- Lines that are used to extend the lines of the element you are dimensioning, to better identify the area that is being dimensioned.

• Dimension Line Terminators (optional) -- Objects, like arrows or strokes, which are placed at each end of the dimension line.

• Mark (optional) -- Used to identify the center of a circular element.

**Dimension Styles**

After you have adjusted all the dimension settings, save them as a Dimension Style. It is really just a file that contains all the settings. You can then switch between one set of settings to another by selecting the style you want from the list of styles in the Dimension Styles dialog box (Element > Dimension Styles).

**Dimensioning tool box**

The tools in the Dimensioning tools are used to perform general dimensioning. They can be found on the Task Navigation bar in the Drawing task.

The Dimensions tool box opened from Tools > Dimensions > Open as Toolbox contains the same tools as the above tool box plus four other tool boxes related to certain types of dimensioning: Angular Dimensions, Linear Dimensions, Radial Dimensions and Misc(ellaneous) Dimensions.

• A dimension element can be dropped to its component lines, line strings, ellipses, arcs, and text elements with the Drop Element tool. This tool is found on the Main tool box.
Lesson 26: Placing Dimensions

The three most commonly used tools on the Dimensioning tool box are:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element Dimensioning</td>
<td>This is the best dimensioning tool of all! This tool dimensions any element such as line, circle or arc in the way that is best for that element. After selecting the tool, identify an element and then press the &lt; Enter&gt; key to switch between modes (the tool settings window must have the Input Focus). For example, you can show the dimensions of a line using arrowheads or tick marks. When dimensioning a circle, you can get the radial, diametrical or other dimensions by first clicking on the Dimension Element icon, then on the circle, then press &lt; Enter&gt; to switch between modes. Use this tool whenever dimensioning a single element.</td>
</tr>
<tr>
<td>Linear Dimensioning</td>
<td>This tool is used to dimension linear size with each dimension computed from the endpoint of the previous dimension and placed in line. Arrows are used as terminators.</td>
</tr>
<tr>
<td>Angular Dimensioning</td>
<td>This tool is used to dimension an angle.</td>
</tr>
</tbody>
</table>

Linear Dimensioning tool

This tool is used to dimension the linear distance between two points. Each dimension, except the first, is computed from the endpoint of the previous dimension. The two settings associated with this tool are described below.

To dimension the distance between two points

1. From the Drawing Task, select the Linear Dimensioning tool.

2. Enter a data point to define the origin.

3. Enter a second data point to define the direction of the dimension line, then move the cursor away from the object to define extension line depth.

4. Continue clicking points to chain the dimension.

5. Reset to place the dimension in the design go back to step 4 to define another dimension endpoint.

6. (Optional) Go back to step 3 to dimension from the last data point in a different direction or Reset and go back to step 2 to start a new size dimension from a different origin.
You can use this tool to create a string or chain of dimensions. If you later want to insert a dimension in the chain, use the insert vertex tool. If you want to remove one of the inner dimensions, use the delete vertex tool.

**Linear Dimension tool box**

Tools in the Linear Dimensions tool box are used to create specialized types of linear dimensions.

**Lesson 27: Placing Angular Dimensions**

The Angular Dimensioning tool is the third tool in the Dimensioning tool box.

**Angular Dimensioning tool**

This tool is used to dimension angles. Each dimension, except the first, is computed from the endpoint of the previous dimension.

**To dimension an angle**

1. From the Drawing Task, select the Angular Dimensioning tool.

2. Enter a data point to define the dimension origin. For example, snap to the end of a horizontal line. The dimension is measured in a counter-clockwise direction from this point.

3. Enter a second data point to define the length of the extension line and the radius of the dimension arc, for example, slightly away from first point.

4. Enter a third data point to define the vertex of the angle.

5. Enter a fourth data point to define the endpoint of the dimension. For example, snap to the end of the first sloped line you want to dimension to.

6. Reset to complete the dimension. OR

   Go back to step 5 to dimension an angle that has its origin at the endpoint of the dimension just placed.

**Angular Dimensions tool box**

Tools in the Angular Dimensions tool box are used to create specialized angular dimensions.
Lesson 28: Placing Radial Dimensions

The tools of this tool box are used to dimension the diameter or radius of a circle or arc and to place a center mark. The most commonly used tools are:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension Radial</td>
<td>Used to dimension the radius of a circle or circular arc.</td>
</tr>
<tr>
<td>Dimension Diameter</td>
<td>Used to dimension the diameter of a circle or circular arc.</td>
</tr>
<tr>
<td>Dimension Diameter</td>
<td>Perpendicular</td>
</tr>
<tr>
<td></td>
<td>Used to dimension the diameter of a circle or a circular arc, with the</td>
</tr>
<tr>
<td></td>
<td>dimension placed perpendicular to the plane of the circle or arc and with</td>
</tr>
<tr>
<td></td>
<td>tangent extension lines extending to the circle or arc.</td>
</tr>
<tr>
<td>Dimension Radius</td>
<td>(Extended Leader)</td>
</tr>
<tr>
<td></td>
<td>Used to dimension the radius of a circle or circular arc with an extended</td>
</tr>
<tr>
<td></td>
<td>leader.</td>
</tr>
<tr>
<td>Place Center Mark</td>
<td>Used to place a mark at the center of a circle or circular arc.</td>
</tr>
</tbody>
</table>

**Dimension Diameter tool**

This tool is used to dimension the diameter of a circle or a circular arc.

**To dimension the diameter of a circle or arc**

1. From the Radial Dimensions tool box, select the Dimension Diameter tool.
2. Identify the circle or arc.
   - If the dimension is to be placed inside the circle, this data point defines the endpoint of the dimension.
3. Enter another data point. If the dimension is placed inside the circle, this data point accepts the dimension.
   - If the dimension is to be placed outside the circle, this data point positions the dimension.

**Misc(ellaneous) Dimensions tool box**

Tools in the Misc Dimensions tool box are used to perform dimensioning that is not specific to linear, angular, or radial dimensioning.
Exercise 8: Dimensioning

By referring back to the preceding three lessons, try your hand at drawing and dimensioning this diagram:

Some suggestions:

- Set the Working Units to inches and tenths.
- Set the Text height and width to .375”.
- Place two circles at 0,0: the first radius a 2 1/16, second radius at 1 11/16.
- Place three circles 7/8” below the first centerline with radii: 1 1/16, 11/16 and 1 7/16.
- Use Break Element by Point tool to break each of the two circles being filleted. Note: Make sure to break the circle past where the fillet will be placed.
- Do the two 1/4” fillets. Truncate both.
- Use the Place Multi-line tool with two lines, space 3/16 off center for key.
- Use the Dimension Element tool for many of the dimensions
Comprehensive Exercise

Exercise 9: City Tract Map

The City Tract Map is a comprehensive exercise that brings together many of the 2D functions that you have learned.

To create a horizontal line and rotate it

1. Create a new file, named citymap.dgn, from 2dseed.dgn and set the working units to feet and inches, then Save Settings.
2. Select the Place Line tool.
3. With Input Focus on AccuDraw, type the letter <P> to open the Data Point Keyin dialog box.
4. Type 0,0 and press <Enter>.
   This puts first point of line at the origin of the design plane.
5. For the end of the line, use AccuDraw and move the screen cursor in the positive X direction. Type 330 in the AccuDraw X field and click the data button to set the end of the line.
6. Right-click and then Fit View.
7. In the Manipulate tool box, click the Rotate tool.
8. In the tool settings window, turn on the Copies check box.
9. Set the Method to Active angle and set the angle to 90°.
10. Identify the element by clicking the horizontal line (at the AccuSnap X) at the center of the line.
11. Locate the pivot point by snapping to the center of the horizontal line.
12. Right-click to end the Rotate operation.
13. Click Fit View.
To create parallel lines

1. From the Manipulate tool box, select the Move Parallel tool.

2. In the Move/Copy Parallel tool settings window, turn on the Distance check box and enter 11 (streets are 22’ wide).

3. Turn on Keep Original.

4. Identify the vertical line.

   The copy is made on the cursor side of the vertical line.

5. Left-click the right side of original line to place a copy.

6. Click the left side to place a copy on the left.

7. Click Reset.

8. Repeat steps 4 - 7 for the horizontal line.

To clip the curb lines

We will use the Window Area tool to zoom in on the intersections and the Partial Delete tool to clip a portion out of the curb lines. When we use the Fillet tool, it will not trim the bottom half of our vertical line.

1. From the View Control bar, select the Window Area tool to zoom in on the intersection of the streets.

2. From the Modify tool box, select the Partial Delete tool.
3 Click a start point and end point to delete the parts of the intersection to be deleted. The intersection should look like this:

To place arcs at each corner

Using the Construct Circular Fillet tool, we will place arcs at each corner of the streets.

1 From the Modify tool box, select the Circular Fillet tool.
2 In the tool settings window, set the Radius to 30 and Truncate to Both.
3 Click the first line and then the second line that makes up the intersection.
4 Click once more to accept
5 Repeat steps 3 and 4 for all four arcs.

To change element attributes

1 With the Change Element Attributes tool, change the element attributes of the center lines by setting the following and clicking on the centerline:
   - Color: yellow
   - Linestyle: 4
   - Weight: 0

2 Reset the elements attributes (Color, Linestyle, and Weight) back to 0.
To shorten the lines

Using the Extend Line tool, we will shorten all three vertical lines at each end of the north/south streets by exactly 30 feet.

1. From the Modify tool box, select the Extend Line tool.

2. In the Extend Line tool settings window, turn on the Distance check box and set the distance to -30. Turn on the From End check box.

3. Click on the outside end of the six vertical lines.

To create the adjacent streets

1. From the Fence tool box (opened from the Main tool box), select the Place fence tool.

2. In the Place Fence tool settings window, set the Fence Mode to Overlap and place a fence around the intersection.

3. From the Manipulate tool box, select the Mirror tool.

4. In the Mirror tool settings window, turn on Make Copy and Use Fence.

5. Accusnap to the end of one of the centerlines, so that the copy of the intersection lines up with the original intersection. Then click to Accept.

6. Fit View to see the two intersections.

7. With the Place Fence tool, place a fence around both intersections.

8. Select the Mirror tool again.

9. In the Mirror tool settings window, set Mirror About to Vertical.

10. Snap to the end of the horizontal line and Accept.
Select the Place Fence tool to turn off the fence.

Fit View to see the four intersections.

To complete the lot

1 Place a fence around the streets in the upper right corner of the street grid. In the Place Fence tool settings window, make sure the Fence Mode to Overlap.

2 Use the Rotate tool to copy the fenced streets at 150 degrees.

The center lines of the streets should be connected.

3 From the Modify tool box, use the Extend to Intersection tool to finish the street lines.

4 Use the Construct Circular Fillet tool to fillet the connections of the streets. In the Construct Circular Fillet tool settings window, set the Radius to 75 feet. Remember to match the element attributes of the lines being modified.

5 From the Linear tool box, select the Place Point or Stream Curve tool to draw a pond.
in the middle block of the streets.

6 From the Manipulate tool box, select the Move Parallel tool and in the tool settings window turn on the Keep Original check box and set the Distance to 124 ft.

Copy the outside streetlines back to make the rear property lines.

7 Use the Extend tools to extend property lines to meet each other and the street edges.

8 Use the Move Parallel tool to make lots 50 feet wide.
• Make property lines the correct length before copy parallel rather than copy and then have to extend them all.

9 Use the Extend tools to complete your lots.

10 Change the element attributes of the lot lines as follows:

   Linestyle: 6
   Color: green
   Weight: 1

Houses and Details for the City Tract Map

1 Open your City Tract Map design file.

2 Set the Element Highlight Color (Settings > Design File > Color) to any color but red. Click OK.

3 Zoom into an unused portion of the file.

4 Create a new level to place the houses on (Settings > Levels > Level Manager). Set the weight to 2, linestyle to 0, and color to red. Name this level “Houses.” Make it the active level.

4 Use the Place Shape tool to draw the house roof outlines on this new level.
Exercise 9: City Tract Map

The dimensions are shown for sizing only. Don’t include dimensions in your cells.

- AccuDraw works really well here.

Leave the above houses in your design file for now. We will make them into a cell library later.

5 Create a Centerlines Level similar to the Houses level we just created. Use the color yellow, line style 4 and weight of 0. Name it Centerlines.

6 Then move the center lines of the streets to the new level.

Select all yellow centerlines by Edit > Select By Attributes. In the dialog box, choose color yellow and click Execute. All the yellow lines are now selected.
Change your active level to Centerlines by clicking on Level on the Attributes tool bar.
This is the fastest way to change any attribute. Just select the element and then change the attribute on the attribute tool bar.

7 Deselect by clicking on the Element Selection tool and then click on the blank part of screen. Change your active level back to Default.

8 Type <Ctrl-E> to open the Level Display dialog box. Click Centerlines to turn off the level that displays the centerline.

9 Create a Stream Level. Set the color to blue, line style to 0, and weight to 0.

10 With the Stream level active, use the Place Curve tool to draw a stream below the city.

11 Create a Golf Course level with color green, line style 0 and weight 0. Draw a curve on this new level to represent a golf course in the center section of the subdivision.

12 On Default level, using color 0, draw a line string at the upper right of your drawing that will
be used as a True North Indicator.

Adding Text to the City Tract

This exercise uses many of the text placement tools discussed earlier.

1. Open your City Tract drawing. Create a level for Text. Set color to 0 and weight 0.
2. Use the Place Text tool with Method set to Above Element to place names on the streets. Use a text height and width of 12, Font 3, and set Line Spacing to 0.5.
3. Set Interchar(acter) Spacing to 0.
4. Label the north arrow using font 0 with a text height and width of 12.
5. Label the City Tract using font 42 and a text height and widths of 30.
6. Use the Change Text tool to change the north arrow text font to 7, and height and width of 20.
7. Use font 42 and height and width of 15 feet to label “Blue River.” In the Place Text tool settings window, set Method to Along Element. Click on the river edge and accept.

NEW SUBDIVISION

To create a cell library and cells

The dimensions shown in the illustrations are for aiding you with your cell creations. They are not part of the cell.

1. From the Element menu, select Cells.
2. In the Cell Library dialog box, select File > New.
3 In the Create Cell Library dialog box, create a new cell library with the name xx.cel where xx represent your initials. It will be attached to your Tract Map file.

4 Create three cells from the three roof outlines you drew previously. Define each cell origin by snapping to the lower left corner of the roof. Name the cells house1, house2 and house3.

5 Set your active level to Houses, weight to 1, and color to anything you like.

6 Using the Place Stream or Curve tool, create a cell representing a tree.

7 Create an arrowhead point cell, which will be used as a line terminator for the True North Indicator. Select the Place SmartLine tool and place a data point.

8 Using AccuDraw with the compass set to distance and angle (hint: hit the space bar to change from x,y to distance, angle) draw the following three lines:

   Distance 24.5, angle 30. Click to accept.
   Press <V> to rotate AccuDraw compass back to View.
   Make sure your mouse is positioned to the left of the first line.
   Distance 24.5, angle 150. Click to accept.
   Press <V> again.
   Distance 14, angle 300. Click to accept.
   Snap back to the starting point, accept it, and then reset.

9 Create a cell representing a chain link fence using the Place Line tool. Each section of the X is 5 feet long. Use the dimension shown as a guide, it is not part of the cell.
10 Place cells of the roof outlines on some lots. Use all three buildings. Utilize your Active Angle when placing buildings on angled lots.

11 Make the tree your active cell and place trees randomly on the drawing.

12 Add a chain link fence somewhere on your drawing. To do this, draw a line string where the chain link fence should be.

13 From the Patterning tool box, select the Linear Pattern tool. In the tool settings window, set Cycle to Complete. Set the pattern cell to the name of your chain link cell, set the scale to 5.0, then click on the line string.
MicroStation PowerDraft has one dialog box for setting up how your drawing file will be printed.

The Print dialog box opens when you select File > Print.

Defining What to Print

You will often want to create several hardcopy drawings from one design file. The architect will want a floor plan with dimensions, and then a floor plan with no dimensions but showing furniture arrangement. Select File > Print to display the Print dialog box. To tell MicroStation PowerDraft which portion of your design file you want to plot there are two methods: Fence and View. To select either one of these methods, see the General Settings > Area on the Print dialog box.

View

Click View in the Area field. Then, select the view number in the View field.

Fence

A print can be created from a fenced area, if a fence exists in the design file (this is the recommended method).
Printer and Paper Size

In this area of the Print dialog box, you select the printer driver, the paper size and orientation of the paper.

Use the Windows driver whenever possible. If you have a special situation, click File > Select Bentley Driver and then select the one you want such as HPGL2.plt if you need to spool a file for HPGL language.

Click on the Paper option menu and choose the paper size from a list of available paper sizes for the selected printer. Included are Letter, A (8.5 x 11), B (11 x 17), C (17 x 22). The list of selections depends on the Windows printer that you select under File > Configure Windows Printer. The Total Area (printable area) that displays takes into account the necessary margin on the paper. You can turn on the Full box to use all of the paper, but see the Tool tip on that check box. Also, click on whether you want to use a portrait or landscape layout.

Print Scale and Position

The Print Scale and Position area of the Print dialog box is used to layout your drawing on the page. The dialog box shows the extreme X and Y dimensions of your drawing given the scale shown. MicroStation PowerDraft automatically calculates the scale that will draw your drawing so either width or height of the extremes of your drawing equals width or height of the page you selected. That is, MicroStation PowerDraft calculates the largest scale that can be used to fit your whole fence or view on the paper. Normally that produces a strange scale, so, if your drawing is to be to a standard scale, you can edit Scale to make it the largest standard scale that will fit.

Note: Scale as used in MicroStation PowerDraft Print dialog box is the reciprocal of mechanical or architectural drafting scales. It is similar to mapping scales.

So, for example, if you want to plot a mechanical drawing in 1/4 scale, you would enter “4” in Scale.

The following table shows the number to enter in Scale field for normal drafting scales:

<table>
<thead>
<tr>
<th>Master Units</th>
<th>Standard Scale</th>
<th>Plot Layout Scale</th>
</tr>
</thead>
<tbody>
<tr>
<td>inches</td>
<td>full scale 1/1</td>
<td>1</td>
</tr>
</tbody>
</table>
MicroStation PowerDraft calculates mechanical or architectural scale for you. Click on the magnifying glass next to Scale to enter what you want on paper to represent a length on your design.

Note the small preview of your plot on the upper right of the dialog box. You can see how large your plot will be on the paper and where it will start. You can shift the small rectangle, that is you can specify where you want the Origin to be. Just edit the X and Y location in the Origin box. You will see the small drawing shift.

Print dialog box icons

You can use the five icons at the top of the Print dialog box as follows.

Print

When the selected printer is the Windows system printer, the print is sent to the printer. When the selected printer is not the Windows system printer, the Save Print As dialog box opens, which lets you select a location and choose a name for the print file. This file can be copied to the relevant printer at a later time.

Preview

Opens the resizable Preview dialog box, which lets you preview the proposed print.

Maximize Print Size

Automatically fits the selected view or fenced area into as much of the printable area as possible.

Print Attributes

Opens the Print Attributes dialog box, which lets you set various printing attributes.

Update from View

Synchronizes the printing settings to that of the model as displayed in the selected view. Useful for updating the printing parameters after adjusting a view’s parameters. If your only change has been to turn levels on or off, you will see this change when you preview or print the output.
Plotfile

A Plotfile is a file that contains all of the instructions to your printer or plotter. If you create a plotfile, nothing is plotted! You will have to leave MicroStation PowerDraft and then send that file to a plotter by one of the ways compatible with your operating system.

If you have connected your printer to the parallel port of your computer or available on your network, here’s how you can print right away:

Printing from Windows

If Windows printer driver is selected, drawings can be printed/plotted by the sequence: File > Print. Printer.plt is referred to as the system printer in Windows. MicroStation PowerDraft uses whatever graphics output device has been setup for Windows through the Windows Control Panel.

To plot a color file in black and white, Select Gray Scale or Monochrome from the Color button on the Print dialog box.
At this point you have a good understanding of the concepts of MicroStation PowerDraft and you have completed eight exercises that cover the MicroStation PowerDraft tools that enable you to produce almost any technical drawing that you would ever want.

More importantly, you have learned your way around MicroStation PowerDraft so you are prepared to develop a deeper understanding and greater skill on your own.

There is much more to learn about MicroStation PowerDraft. Where you go from here depends on your own goals. You will want to read the rest of this book and do the exercises to learn the basics of 3D in any case, since all industries except schematic design are moving in that direction.

If you are keyboard oriented take note of the list of two character commands in the Appendix (see page 140). Also, experiment with the Key-in “Browser” (Utilities > Key-in) to learn the longer type-ins.

The following table lists some of the 2D functions that we didn’t cover and where to look to learn more about those functions. MicroStation PowerDraft Help is excellent and you will find everything you need there. You can print selected pages if you wish. Also, try the Help Search command.

**Selected Advanced 2D Topics**

<table>
<thead>
<tr>
<th>Selected Advanced 2D Functions</th>
<th>Reference (MicroStation PowerDraft Help File)</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccuDraw &amp; AccuSnap</td>
<td>Help &gt; Contents &gt; AccuDraw &amp; AccuSnap</td>
</tr>
<tr>
<td>Configuration variables &amp; Workspaces</td>
<td>Help &gt; Contents &gt; Setting Up Projects</td>
</tr>
<tr>
<td>Custom dimensions</td>
<td>Help &gt; Contents &gt; Detailing Designs</td>
</tr>
<tr>
<td>Custom line styles</td>
<td>Help &gt; Contents &gt; Menus &gt; Element Menu</td>
</tr>
<tr>
<td>Custom multi-lines</td>
<td>Help &gt; Contents &gt; Menus &gt; Element Menu</td>
</tr>
<tr>
<td>Customizing</td>
<td>Help &gt; Contents &gt; Programmed Custom</td>
</tr>
<tr>
<td>Digitizing</td>
<td>Help &gt; Contents &gt; Programmed Custom</td>
</tr>
<tr>
<td>File translation</td>
<td>Help. Then, Search for File Translation</td>
</tr>
</tbody>
</table>
There are a number of software packages designed to supplement MicroStation PowerDraft which are developed by others. You may find it more economical to purchase one of these supplemental packages than to develop it yourself.

Some tips to make good use of MicroStation PowerDraft:

1. Remember to watch the prompts and messages.
2. Practice snapping, tentative then accept, and use AccuSnap.
3. Get in the habit of referring to the tool settings window.
4. Use Reference Drawings.
5. Use AccuDraw for coordinate entry.
6. Set up your own seed files with all your standards.
7. Make heavy use of cell libraries. Purchase one, if possible.
8. When translating files:
   - As often as possible, just use File > Open with Type set.
   - Use Import/Export only when needed for control.
   - Reduce the file to as little as possible before translation. Compress Files before translation.
Differences between MicroStation PowerDraft and AutoCAD

Here are some of the key differences between AutoCAD and MicroStation PowerDraft for those who learned first on AutoCAD:

<table>
<thead>
<tr>
<th>AutoCAD</th>
<th>MicroStation PowerDraft</th>
</tr>
</thead>
<tbody>
<tr>
<td>new file untitled</td>
<td>new file named and start with seed file</td>
</tr>
<tr>
<td>file must be saved</td>
<td>file always saved</td>
</tr>
<tr>
<td>file extension is .dwg</td>
<td>file extension is .dgn or .dwg</td>
</tr>
<tr>
<td>Xref</td>
<td>reference files</td>
</tr>
<tr>
<td>self reference not available</td>
<td>self referencing permitted for details</td>
</tr>
<tr>
<td>64-bit floating point coordinates</td>
<td>64-bit floating point coordinates</td>
</tr>
<tr>
<td>unlimited layers</td>
<td>unlimited levels</td>
</tr>
<tr>
<td>Layer Name &amp; ByLayer standard</td>
<td>independent attributes or ByLayer attributes</td>
</tr>
<tr>
<td>tool settings in command</td>
<td>tool settings in tool settings window</td>
</tr>
<tr>
<td>polyline</td>
<td>SmartLine</td>
</tr>
<tr>
<td>single purpose mouse</td>
<td>three buttons: data, reset, snap</td>
</tr>
<tr>
<td>key in dimensions &amp; type Enter</td>
<td>AccuDraw: visual align, key number, no Enter</td>
</tr>
<tr>
<td>Linear Dimension: 2pts on object then witness depth</td>
<td>Single-click Element Dimensioning (or similar to Acad)</td>
</tr>
<tr>
<td>various trim methods</td>
<td>IntelliTrim</td>
</tr>
<tr>
<td>commands by: Verb/Noun/Enter</td>
<td>Verb/Noun or Noun/Verb method of commands</td>
</tr>
</tbody>
</table>
3D Concepts

MicroStation PowerDraft enables you to approach design from either a 2D or 3D perspective.

Basic 3D Concepts

2D is working with your design as if you were sitting at a drafting table except using the computer to record your ideas rather than a sheet of vellum.

3D is working with a model of your ideas much as if you were building a physical model out of plastic parts.

The seed file you select when you create a new file tells MicroStation PowerDraft whether you will be building a 3D model or whether you will be working in 2D. For your convenience, MicroStation PowerDraft eliminates the 3D menus when you select a 2D seed file.

If you select a 3D seed file such as seed3d.dgn, then MicroStation PowerDraft activates all of the 3D menus for your use.

Certain types of design work are best suited to 2D, such as:

- Electrical schematic diagrams
- Process schematics
- 2D layouts such as sign cutting

However, most mechanical, architectural or industrial design involves products which are 3D in nature, that is, have depth, width and height. The conventional approach has been to reduce 3D objects to 2D by drawing views of the 3D object. While 2D drafting is still very useful and is consistent with the way a large number of designers have been trained, there is a marked trend towards 3D computer aided design.

The benefits of 3D for mechanical and architectural design are manifold:

- If a good 3D model is defined in the computer, drawings can be produced almost automatically.
- When a change is made in the 3D model, the change is automatically made in the drawing files.
- Rendering a 3D model provides a photograph-like image of the design which can be better understood by a broader audience. That means better communication between members of a team: engineer or architect to customers, between office and field, etc.
Printers are now available that can take a 3D computer model and automatically make a 3D physical model.

Before working in 3D you should understand the MicroStation PowerDraft concepts of Chapter 1 and the fundamentals of 2D design, especially Chapters 1 through 5. In addition, there are six new concepts to understand to become proficient in 3D:

1. The “Right Hand Rule” for coordinates
2. The 8 standard views
3. The screen axis system vs. the drawing or model axis system
4. The “Right Hand Rule” for angles
5. The View Volume
6. The Active Depth

The Right Hand Rule

You will recall from 2D that X was always positive to the right and Y was positive up the screen.

We can look at a 3D model from different directions. To keep coordinates straight in our mind, we use the “Right Hand Rule.” Think of your right thumb as the +X axis, your right forefinger as +Y and your middle finger as +Z. No matter how you turn your hand or from where you look, the axes are the same.
Eight Standard Views

The figure shows the eight standard MicroStation PowerDraft views of a model.

Screen Axis vs. Model Axis

There are two coordinate systems available to MicroStation PowerDraft:

- The View or Screen Axis System
- The Model or Drawing Axis

The Screen Axis System is fixed, just as we learned in 2D. Positive X to the right, positive Y up and positive Z coming out of the screen. Think of the Screen Axis System as being glued to the physical, computer monitor. This system follows the right-hand rule.

The Model Axis System is tied to the model or the part or product we are designing, not to how we are looking at it.
The following figure shows the fixed view axis system and the model axis system as it would appear in each of four views.

**The Right Hand Rule for Angles**

The right hand rule for rotation or angles states that an angle is positive: Grab the positive x, y or z axis with your right hand. The direction of your fingers is the direction of a positive angle or positive rotation.

**View Volume**

The View Volume is the portion of a design which can be seen in a particular view. This is also referred to as the Display Volume or Clipping Volume.

Think of it as a box that you wrap around a portion of your design. MicroStation PowerDraft displays everything inside the box, but, does not display parts of your design which are outside the box, that is, clipped from view. The box is defined by the height and width of the View and by the Display Depth. The Display Depth is defined by two screen axis Z coordinates, for example, -10 to +10. These two Z coordinates can be keyed in using the format DP = a, b or the two coordinates can be supplied
graphically from the View Control tool box (Tools > View Control).

Active Depth

The Active Depth is a plane parallel to the screen related to one view where you can currently draw. Think of it as a sheet of clear plastic that you can move anywhere paralleled to your computer screen and then you can draw or construct geometry on that plane. The location of the active plane can be keyed in by AZ = d, or it can be set graphically from the View Control tool box.

Let’s dig deeper into these concepts by some hands-on lessons followed by some exercises.

Lesson 29 - Understanding 3D Concepts

1. Choose File > New to create a new 3D design file to use as a scratch-pad.
2. In the New dialog box, click the Browse button and select seed3d.dgn as the seed file.
3. In the File name field, enter a file name.
   You will see four views with a triad of model coordinates.
4. Set the line weight to 4.
5. From the 3D Drawing tool box, select the Place Slab tool.

   To open this tool box, select Tools > Tool Boxes and from the Tool Boxes dialog box, turn on
   3D Drawing.
6. With the Place Slab tool, place a 2 x 2 x 2 slab.
7. In the AccuDraw window, set X, Y and Z to 2.
8 Click in the Top view and Front view to set the direction of the 3D box (slab) you are placing. Fit View in all views.

9 From the View Control bar at the top of each window, select the Rotate View tool. Try this in the isometric as it works differently than 2D. Using the Rotate View tool settings, you can put any standard view in any of the four windows.

See the colored X, Y and Z in the four views. The associated arrows show the positive direction of the model coordinate system.
10 Open Key-in and type SHOW DEPTH DISPLAY. Press <enter>.

11 Click on each view and in the status bar prompt field, note the Display Depth. It shows two screen z coordinates. The difference between them is the Display Depth.

![Screenshot of Show Display Depth interface]

The Display Volume in that view is the width and height of the view as you see it multiplied by the display depth in the view coordinate system. -z is away from you “inside the screen” and +z is toward you.

13 To demonstrate View Volume, Key-in DEPTH DISPLAY. Press <enter>.

14 Click in the Top view to set the display depth for the Top view.

15 Manipulate the dimension lines in the isometric to make a thin volume. Your first click in the isometric defines the Top view clipping plane closest to you. The second click defines the clipping plane “inside the screen,” that is, away from you. For this to work, Clip Front and Clip Back must be on (Settings > View Attributes) for the Top view (View 1).

If the two planes are close enough, you will no longer see part of the slab you placed. You just see points where you cut the edges of the slab. Or, if View Volume is above the slab, you may see nothing.

16 Restore the original clipping planes (View Volume) by clicking on Fit View and then click on the views.

Fit View expands the clipping planes so you see the whole model.

17 Draw rectangles (Place Block tool) and circles (Place Circle tool) in the Top view. Notice where they are in the isometric.

18 Change the Active Depth (the plane where you are drawing) by using Key-in DEPTH ACTIVE. Click in the Top view, then in the Isometric, move the plane and snap it to the opposite face of the slab. Draw additional circles and see them drawn on this face of the slab.

You can use the Rotate View tool to dynamically rotate the view in any window.

19 Click on the Rotate View icon and set the Method to Dynamic.

20 Click on one of the windows and hold down the data button. As you move the cursor on the screen, the view dynamically follows.
You can also click the View Attributes icon on the View Control bar of any window to open the View Attributes dialog box. In the Display option menu, change Wireframe to Smooth with Shadows. Then, that window will be shaded and will remain shaded while you use the Rotate View tool.
In Chapter 4, we learned how to precisely input geometric data using two key-in methods (like DX=, etc.) and AccuDraw.

The same commands apply in 3D with two additions:

1. We must enter X, Y and Z coordinates, for example XY=a,b,c.

   Note the command is still XY= even though we enter Z.

2. When using coordinate key-ins, use DL= for entering relative distances in model Coordinates. Use DX= for entering view coordinates.

**AccuDraw in 3D**

AccuDraw is particularly useful in 3D, however, there are a few more things to learn to use AccuDraw effectively in 3D:

1. The AccuDraw compass must be aligned to the view in which you are working. With AccuDraw on, if you press the letter <T>, the compass aligns to the Top View. If you press <S>, AccuDraw aligns the compass with the Side View. If you press <F>, the compass aligns to the Front View.

2. You can even use the AccuDraw compass in an isometric view. Just press <T> to work in a plane aligned with the Top View, or <S> for Side View or <F> for Front View.

3. To locate a point relative to a known point, tentative to the known point then type <O> to establish it as the origin, just as in 2D. Then, drag the cursor in the direction of an offset and type the distance. Then, you can drag orthogonal to the first direction and type another offset distance. Then, click the left-mouse button.

4. To align a point under a known point, drag in the direction until AccuDraw highlights the line, then, type <enter> to lock in that direction. You can then snap on the known point and the length of the line will be set.

Key-in precise data is more important in 3D since it is sometimes more difficult to locate geometry graphically.

A typical procedure for building 3D models is to precisely key-in the coordinates of known geometry and then to construct further geometry from the base.

In this exercise we will construct a 3D model of a box kite.
Exercise 10: 3D Model of a Kite

1 Continue in the same 3D scratch file created in Lesson 29 - Understanding 3D Concepts (page 116).

2 Select Edit and Select All.

3 Delete all of the geometry in your file using the Delete tool.

4 Select the Place Block tool and click anywhere in front view.

   If you don’t see the AccuDraw compass, press “S” for side.

5 To place a rectangle for the front face of the kite, with AccuDraw on, move the cursor straight to the right (in x direction) and type 2 (don’t hit <Enter>).

   Then move the cursor straight up (y direction) and type 2. Click the data button.

6 Select Fit View. Click on all four views. The 2D View controls still work, however, using Fit View resets the display depth of the view to just contain the current geometry.

7 Select the Copy tool from the Manipulate tool box. Snap to the block in top view. If you don’t see the AccuDraw compass, press “T” for top. Move the cursor straight up. Type 2. Click the data button, then reset.

   This makes a copy of the front face to save as the back face. Accudraw insures the block moves
straight up in the top view.

8 Fit View again to see both blocks. Make sure the copy is right behind the first block when viewed in the front view.

9 Select the Place Block tool again. Snap on the top left corner of the front block in the isometric (View 2), then adjust the AccuDraw compass so it is in the Side View (press S with focus on AccuDraw). Draw a block to the lower left corner of the back block.

10 Draw a block on top in a similar way. Then, copy the blocks as in step 9. Snap lines between corners to represent the ribs.

Congratulations! You have completed a 3D model!

Lesson 30: Projecting 2D into 3D Models

As you saw in Exercise 10: 3D Model of a Kite, you can build 3D models using most of the commands of 2D, just drawing in the View that gives you the best access to the geometry you need and either keying in precise coordinates or snapping to points in the familiar way, or using AccuSnap.

MicroStation PowerDraft provides much more powerful means to create 3D models, including starting from 3D primitives of sphere, slab and the like, or by first making a drawing in 2D and then extruding that drawing or sweeping the drawing to make a 3D model.

The Extrude tool can be found in the 3D Drawing tool box, which can be opened by selecting Tools > Tool Boxes and in the Tool Boxes dialog box, turning on 3D Drawing. This is a common tool for the architect who wants to draw a floor plan and then extrude or “project” that floor plan to make the walls on a 3D model.

The next exercise takes you through all of the stages to convert a floor plan done in a 2D file into a 3D model. Understand that we could start in a 3D file and then skip the steps of conversion. We will purposefully start in 2D in this exercise to learn how to convert 2D to 3D.

Exercise 11: 2D Shapes Converted to 3D

1 Start a new 2D file, using seed2d.dgn. Set up the working units (Settings > Design File > Working Units) using the Format of MU:SU, Master Unit of Feet and Sub Unit of Inches.

2 Use the Place Block tool to create a block. Also create a Circle, Regular Polygon, and Orthogonal Shape.

3 From the File menu, select Export > 3D. In the Save 2D as 3D dialog box, name the file (remember the directory path). Accept all the default settings.

This saves your shapes as another file, but in 3D format.

4 Open the file you created in step 3.
5 Using the View Groups window (docked at the bottom left hand of the screen) turn on four views.

6 Change the view rotation of each view by using the Rotate View tool on the top of each window so that View 1 is Top, View 2 is Isometric, View 3 is Front and View 4 is Right.

7 To arrange the views, select Window > Tile.

8 Select Fit View and click on each of the four views. You will see your shapes in four views.

9 From the 3D Drawing tool box, select the Extrude tool.

10 Identify the block and accept. Click on the block in the Isometric view and move your cursor up. See the highlighted vertical line. Type 8 for the distance to extrude then click on the Isometric view.

11 Continue to identify and extrude all of your shapes in the same manner.

12 From the View Control bar in the Isometric view, select View Attributes > Display Style > Smooth and then click on the view.

Congratulations! You have created shapes in 2D, exported them to a 3D file, extruded them to create a 3D solid model and rendered the view.

You have now created a 3D model from scratch and by extruding a 2D model into a 3D model. Note that we could have simplified this exercise by starting with a 3D file, drawing the shapes in the top view.
17

Creating and Manipulating Solid Models

Solid modeling tools are built into MicroStation PowerDraft. Using solid modeling is much easier than the 3D exercises of the previous chapter.

Lesson 31: Basic Approach

The basic approach in solid modeling is to choose the solid primitives, extrusions, or sweeps that make up your design, unite those building blocks (as required) and then to modify the primitives with features. It’s that simple. If you look at the 3D Drawing tool box, you see the primitives included with MicroStation PowerDraft. Hold the mouse button down as you drag the cursor across the icons in the tool box. The name of the tool displays in the status bar at the bottom of the screen. After you have reviewed these icons you will begin to remember where to look for a specific function.

A 3D model is a solid model only if:

- The surfaces are represented by the actual surface, not just a bunch of polygons.
- The way that the model was constructed is stored in the computer so the construction can be undone.
- The features are stored as features, not just the geometry that makes them up.

Lesson 32: Joining Primitives to Make More Complex Solids

The primitives are slab, sphere, cylinder, and cone. You decide the key axis, then you supply the dimensions via AccuDraw. You can experiment with each of the primitives later.

Alternatively, you can start from a profile drawn with the 2D tools, then use one of the extrusion tools to make that profile into a solid. These tools are Extrude and Construct Revolution.

Let’s do a simple exercise uniting two slabs to make an “L” bracket.
Exercise 12: Creating an L bracket by the union of two slabs

1. File > Open and create a new file using one of the metric seed files or seed3d.dgn and set working units to millimeters.

2. From the 3D Drawing tool box, select the Place Slab tool. Enter the length, width and height respectively as 100, 100 and 10.

3. Reselect Place Slab and snap to the corner of the existing slab for the first point. Then enter 100, 100, 10 with AccuDraw oriented so this slab is at right angles to the first.

4. Use Fit View to see both slabs. Look in the Front view. The two slabs should overlap at the bottom right corner. This makes an L bracket that is 100 mm on each leg, but the two slabs are not connected.

With full MicroStation, you could unite the two slabs into one L shaped object using the Boolean Union command. You could also fillet the edges, drill countersunk holes and more. Those advanced functions are not included in PowerDraft, so this is as far as we can go with this exercise.

Just that quickly you can create an L bracket with filleted edges.

Lesson 33: More on Features

MicroStation provides six different feature tools that you can use to build your solid model:

- Fillet
- Chamfer
- Create
- Cut
- Thin Shell
We have already used the fillet and chamfer in our 2D exercises. In each case the menus work similarly to what we have done.

**Modeling Summary**

MicroStation is a basic parametric hybrid solid modeler. Hybrid means that it uses both constructive solid geometry and boundary representation. Editing is easy to use.

MicroStation PowerDraft includes a limited set of 3D tools. It is intended to be a production design drafting software, not specifically for 3D modeling. However, MicroStation PowerDraft can be used to create interesting 3D models and can read and display any 3D model created in MicroStation.

**Modeling Hints**

Here are a couple of suggestions that will help you.

1. Solid Modeling is still a combination of science and art. If you try one way to build a model and it doesn’t work, try a different approach.

2. Save your model often as your modeling progresses.

To get deeper into solid modeling, you will want to upgrade to MicroStation or one of the discipline specific products such as TriForma with Bentley Architecture, InRoads for civil engineering, etc.
Lesson 34: Reference Files

MicroStation PowerDraft’s reference file capability is one of its strongest features. It is especially useful for project groups working on the same project. For example, the architect works on the floor plan, the electrical designer works on the power and lighting and the mechanical consultant works on the heating and ventilation. Each works on their own drawing file but can reference the work of the other. When the floor plan changes, the mechanical designer sees the results of the change the next time the drawing referencing the floor plan is opened. This is very useful for organizing work. In addition, reference files are very handy for the individual designer.

There are two types of files or drawings that can be used as reference files for other drawings:

- Design
- Raster

We will take each of these file types one at a time.

**Design Reference**

There are essentially three purposes for using one dgn or dwg file as a reference for another:

1. As an aid in constructing a new file.
2. For putting together sheets of details for a project.
3. As a way of handling title blocks and borders.

**Construction Aid**

As a drill to understand reference drawings quickly, do the following:

1. Open citymap.dgn created in Exercise 9: City Tract Map (page 94).
2. Select File > Save As and name it cityref.dgn.
3. While you have cityref.dgn open, choose Edit > Select All and delete all of the information in the file.

Now we have an empty file with all its settings the same as citymap.
Choose File > References. In the References dialog box, select Tools > Attach and select citymap.dgn to be attached to cityref. Accept all the defaults in Reference Attachments Settings dialog box and click OK.

Experiment with the other tools. Move it, scale it, draw a fence around a portion and clip it.

You can see how the citymap.dgn could be used by the electrical engineers or the mechanical contractors to layout their work using the map as a construction aid. We could layout the sewers so they are exactly in the middle of the streets. The new work would fit exactly. If needed, we can copy elements from citymap.dgn into cityref.dgn and then those elements become a part of cityref.

However, it’s generally best to leave all the elements in citymap.dgn so the public works have their files, the sewer engineers theirs, the electrical theirs and so on. This way, the work can be divided on a large project. Also, when the map changes, the engineers see that revision the next time cityref.dgn is opened.

Detail Sheets

Detail sheets are generally made of various dgn files at different scales arranged in checkerboard fashion on a sheet of paper. Reference files are very handy for this operation. Start with a blank file, then attach, move and scale the details to fit on the detail sheet. You could see how this works by attaching citymap.dgn several times to cityref. Each time, move it to a new location and scale it differently. Also, you could clip out a different portion each time.

Title Block and Borders

Another practical use of reference files is to attach a title and border to a design file before plotting. You will need one copy of your title block file for each combination of sheet size and scale you will want to plot.

For example, if you have a plotter paper that is 22" by 32" in available plot space and you want to plot at ¼" per foot, then draw your border 88' by 128'.

That the scale plots the border as follows:

\[
\frac{1}{4} \times 88 = 22"
\]

\[
\frac{1}{4} \times 128 = 32"
\]

Self Referencing

You may at times want to reference the active file to itself. You must first save the part of the active file that you would like to self-reference as a saved view. Go to Utilities > Saved Views. Select the view you would like to save, give it a name and click the Save button. To reference this saved view, go to File > Reference. In the References dialog box, select File > Attach. Select the active file. In the Reference Attachment Settings dialog box, select the saved view to attach.
Raster files are files that are made up of dots. Each dot is called a raster or a pixel. These files are not like dgn files that contain lines, arcs and things which are referred to as vector files. In a vector file you know that a line is a line. In a raster file, a line is just a series of dots that are turned on.

There are many different types of raster files. There are monochrome, continuous tone and color files. In Monochrome files, each pixel is black or white. Continuous tone files contain shades of grey. And, each pixel can be a different color in a color raster file. There are many different standard formats for raster files, such as TIFF, JPEG, BMP. These are just different methods of coding the dots. For example, if there are 100 white dots in a row, you wouldn’t want to store 100 bits. Instead, TIFF would store a code saying there were 100 white dots.

Raster files can be stored at different resolutions. The file may be stored as 640 x 480 or 1024 x 768. The first would represent 307,200 dots. The second 786,432 dots. The more dots, the better the raster file looks on the screen or on paper, but, the bigger the file to contain it.

**Raster Reference Files**

You can attach a raster file as a reference to a dgn file.

**To attach a raster file**

1. Select File > Raster Manager. In the Raster Manager dialog box, select File > Attach > Raster.

2. In the Attach Raster Reference dialog box, navigate to any raster file on your computer. Search to find any file with extension .JPG or .JPEG or .TIFF or .BMP.

3. Turn on Place Interactively and click OPEN.

4. See the Action dialog box pop up. Click on the Attach button. Then Attach.

5. Click on two corners of a box in which the raster file will display.

In the Raster Manager dialog box, you can change the transparency and other characteristics of the raster file.

Suppose you have a photograph of a site. You scan that into the computer. Open an empty file for the
drawing of your new structure. Attach the photo as a raster reference file with one corner of the file exactly at 0,0. Then, measure how far to an item on the photo such as a fire hydrant. If you know how far the hydrant really is from the first point, you can “warp” the photo so the raster file falls exactly on that point. See Edit > Warp on the Raster Manager dialog box.

Reference files are a very important part of MicroStation PowerDraft in real production work. The reference file feature of MicroStation PowerDraft is one of its very strong features.

Lesson 35: Drawing Composition from 3D Models

Creating Sheet models automates the creation of drawing sheets for printing of your design drawings. This process is similar in a way to how the manual draftsperson works. Where it differs is that instead of redrawing the model’s geometry for each view, like the manual system requires, you simply attach views of the design model as references.

In other words, you attach as references, views of your design geometry for each plan, elevation, section, and so on. The power of this system is that any changes made to the design model then is reflected immediately in each affected view in the drawings. The electronic version of the manual drawing sheet consists of:

Sheet model—The electronic drawing sheet.

Attached models/views—References of the design geometry. Sheet models are created with attached references and saved views. By working with appropriate scaling, you can always create your drawing to the correct size, and then manipulate the output to suit your requirements. For example, with a map, you can place a drawing within a scaled border and then print to whatever size is required. The tools in the reference attachments simplify the process of creating sheet views in a number of ways:

An attached view in a sheet model can be any standard (Top, Bottom, Right, Left, Front, or Back) or any saved view of the model. Attachments can be clipped or set to display only certain levels. The attachments that can be placed via the Attached Reference dialog box, are primarily orthogonal and can be mirrored so no special procedures for placing folded images are included.

An attached view of the model can be placed in any position at any scale. Related attached views can be grouped in a separate Sheet.

References may be mirrored.

The Presentation of any attachments can be set independently, for example, you can show the Right view as hidden line.
Creating Sheet models

There is no hard and fast rule to how you create Sheet models, and display your drawing information from your design models. Commonly, either of two methods are used, one that scales the border to enclose the design, or the other that scales the design to fit the border.

With both methods, for 3D work in particular, it is a good idea to have separate design models and sheet models. This lets you keep the purely drawing information, such as text and dimensioning, separate from the design information. Doing this reduces the likelihood of conflicts where others, for example, wish to reference the same design model for use in a drawing of a different scale.

To create a new Design or Sheet model

1. From the File menu, choose Models. The Models dialog box opens.

2. In the Models dialog box, click the Create a new model icon. The Create Model dialog box opens.

3. From the Type option menu, choose Design, Sheet, Design From Seed or Sheet From Seed.

4. If the Type is Design, choose 2D or 3D from the right option menu.
The Seed Model field displays the name of the seed model.

5 In the Name field, key in the required name.

6 (Optional) In the Description field, key in a brief description of the model.

7 In the Ref Logical field, key in a logical name for the model. The logical name is used to uniquely identify the model when it is attached as a reference.

8 (Optional) Turn on Create a View Group (to create a View Group for the model). Creating a View Group lets you change models via the View Groups window also.

9 If you will use the model as a cell, turn on Can be placed as a cell and select a cell type.

10 Click OK.

To name and save a view

1 Set up the source view so that the desired portion of the design is displayed and the view attributes are as desired.

2 From the Utilities menu, choose Saved Views. Or, from any view window’s control menu, choose View Save/Recall. If you are using the default function key menu, press <F6>.

The Saved Views dialog box opens.
3 In the Saved View dialog box, click the Save View icon.

The Save View dialog box opens.

4 In the Name field, key in a name for the view. The maximum number of characters in the name is limited to 511. Alphabetic, numeric, and special characters are valid. Lowercase characters are interpreted as uppercase.

5 (Optional) In the Description field, key in a description.

6 From the View list box, choose the number of the source view.

7 Click OK.

To attach a reference

1 From the File menu, choose References.

The References dialog box opens.

2 From the Tools menu in the References dialog box, choose Attach.

3 Select the file to attach the references from.

The default file is the last file referenced, which speeds the process.

4 Click Open.

The Reference Attachment Settings dialog box opens.

5 From the Orientation list, choose the desired view (for example, Top) of the reference attachment.

This view starts the layout of the sheet model.

6 If necessary, set the Scale and Nesting.

7 From the Tools menu in the Reference dialog box, choose Attach and attach a border that is contained in a border file or a border file supplied with MicroStation PowerDraft.
8 Attach other Reference or Saved views by choosing the appropriate item from the References dialog box menu and submenus.

9 Place the dimensions.

10 Place the text.

To attach a reference using a saved view

1 Open the Sheet model, if not already opened.

2 Select File > Reference.

3 From the References dialog box, select Tools > Attach.

   The Attach Reference dialog box opens.

4 From the Attach Reference dialog box, select the desired file and model.

5 Select the desired view name to attach from the Attach reference settings, by highlighting it.

6 Click OK.

   The selected view is now attached to the cursor, with the outline lightly highlighted.

7 Place the view with a data point.

To copy a reference

1 From the References dialog box, choose Copy.

2 From the References dialog box, identify the reference to be copied.

3 Enter a data point to define the origin of the copy.

4 Enter a data point to define the destination of the copy.

5 Go back to step 2 to copy another attached view or Reset to finish.
To detach a reference

1. From the References dialog box, select the view to detach.
2. From the Tools menu, select Detach or click the Detach Reference icon.
3. Accept the detachment. The reference is detached and the information is removed from the drawing.

To move a reference

1. From the References dialog box, select the reference to move.
2. Identify an element in the attached view to be moved.
3. Enter a data point to define the origin of the move.
4. Enter a data point to define the destination.

To scale a reference

1. From the References dialog box, select File > Scale or click the Scale References icon.
2. In the Scale fields of the References dialog box, key in the desired relative scale factors.
3. Identify an element in the attached view to be scaled.
4. Identify a point to scale the object about.
5. Accept the attached view.
6. Enter a data point about which the attached view will be scaled.
To change the presentation of a reference

1. From the References dialog box, select the view on which you wish to change the presentation.

2. Select the Set Reference Presentation icon.

3. Select the presentation method.

4. Accept the reference.
19

Rendering and Animation

Advanced rendering and animation is an integral part of MicroStation and is not included as a part of MicroStation PowerDraft.

The MicroStation rendering functions are among the leading 3D photorealistic rendering and animation available in the CAD/CAM industry. MicroStation goes beyond just Smooth rendering, done in MicroStation PowerDraft, with more comprehensive methods such as Phong, Phonganti-alias, ray tracing and more. The following lessons apply to MicroStation.

Rendering

Instead of the flat colors you used to draw lines, you can shade 3D objects in MicroStation PowerDraft with the colors you used to draw the elements. You can also make the materials transparent or translucent. In MicroStation PowerDraft, you can shade by several methods up to Smooth shading. To learn smooth rendering, choose any 3D example file or one of the 3D exercises you did in this book. Use the View Attributes tool on your View Control bar to change the Display Style to Smooth. Click on the isometric view. Your scene will be rendered; you can then Change Attributes to change the colors. If you want a greater mix of colors on your scene, just edit your file.

Ray Tracing and Radiosity

When you render a 3D file with View Attributes > Display Styles > Smooth, you are using a rendering program that allows you to have different colors in your scene but won’t show materials, show shadows and highlights. In MicroStation, you not only get materials and shadows, if you want to make the rendering look even better, you can use AntiAliasing with Phong rendering. (Phong is the name of the inventor of this rendering algorithm.) AntiAliasing simply tries several times to move your image around on the screen to minimize the “jaggies.” It uses a four pass algorithm and takes four times as long as regular Smooth.

In MicroStation, if you want your rendering to be even better, you can select Utilities > Render > Ray Tracing. This is a method of rendering that gives another order of realism. It does take longer for the computer to do since it is more comprehensive. Essentially, the difference is that Ray Tracing shows reflections of reflections of reflections and so on. That is, every ray of light is traced. Consequently, for some models and some purposes, the extra computer time for ray tracing may be worth it.

Radiosity is an even more sophisticated rendering technique. When used with ray tracing, radiosity keeps better track of how light is diffused between surfaces and shows color bleeding where one surface may tint another (like orange carpet makes an orange tint on a white wall), as well as showing light dispersion where the reflection of an indirect light onto other surfaces in a scene.
There are a number of ways to animate your design with MicroStation PowerDraft. The simplest is to click on the Rotate View icon and then click in the scene and move your cursor. Your eye point moves around the view as you move the cursor. With MicroStation, there are many more ways to do animation. You can record animations via the Flythrough method. In this case, you simply draw a curve in your 3D scene using a smartline or curve. Then you direct the camera to follow that curve and either look tangentially along the curve, or usually, have the camera focus on one point in the scene. This produces a .fli file which can then be played back with Utilities > Image > Movie.

With Animation Producer, available in MicroStation, you can create “actors,” place them in a scene and then the actors can be moving while the camera moves around the scene.

Coupled with photorealistic rendering, this method makes the most lifelike animations of your scene and will wow even the most reserved of clients.

Here are a couple of simple examples for making a Flythrough and for animating actors to get you started.

Creating a Flythrough

While not available in MicroStation PowerDraft, as a reference, here is how you would prepare animation in MicroStation:

- Note you can change the number of ticks that each frame delays and other parameters to control the playback. Also, when you record the flythrough, note that you can change the resolution, the type of rendering and many other parameters.

To produce a flythrough sequence

1 Choose Utilities > Render > FlyThrough. The FlyThrough Producer dialog box opens.
2 From the View option menu, choose the source view for the animation.

3 From the Shading option menu, choose Wireframe for “rehearsal” purposes or the desired rendering method for a finished or nearly finished sequence.

4 (Optional) Use the other controls in the dialog box to adjust the camera settings and set the output options (Render > FlyThrough.).

5 Define the path that the camera is to follow and the camera target.

The path can be an existing open element, or you can place an element in the design file.

6 Preview the sequence.

Once you have adjusted the FlyThrough Producer settings and defined the camera path, you can preview the sequence before taking the time to record all the frames.

7 Record the sequence.

8 Go to Utilities > Image > Movies, load the file you just made and play it back.

**To define the path that the camera will travel during the sequence**

1 Place a line, line string, arc, ellipse, curve, or B-spline curve to define the path the camera is to travel. (If you do not want the path to be visible in the sequence, place the path as a construction element, or on a separate level that is not displayed in the source view for the sequence.)

2 From the FlyThrough Producer dialog box’s Tools menu, choose Define Path.

3 Identify the element that defines the camera path at the point at which the camera path is to begin.

4 Accept the element at the point at which the camera path is to end.

**To preview each frame in the output view**

1 (Optional) To see each camera location and viewing volume for each frame along the camera path, choose Camera from the Tools menu’s Preview submenu, in the FlyThrough Producer dialog box.

2 From the Tools menu's Preview submenu, choose View in the FlyThrough Producer dialog box.
Animation Producer

The Animation Producer in MicroStation works generally as follows: Sequences are produced by first defining a set of actors and then scripting their motion. Object motion can be controlled by specifying the position of the actors and keyframes, by defining actor paths, or by explicitly specifying their position, orientation and scaling as a function of time or frame number. Settings for materials and lights also can be specified as a function of time or frame number. The simplest method is keyframing. Here you simply move the 3D object or rotate as you wish for several of the frames which are called “keyframes.” Then, you interpolate the difference between the positions in keyframes to make motion from one orientation to another.

To animate the red block in the figure

The Animation Producer dialog box opens. We will use this dialog box throughout this procedure.

1 In MicroStation, create a small red slab sitting on top of a larger green slab.

We will animate the red slab sliding across the green slab.

2 Select Utilities > Render > Animation.

3 From the Animation Settings tool box (Tools > Visualization > Animation Settings), select the Keyframes dialog tool.

The Animation KeyFrames dialog box opens.

4 Using the Element Selection tool, select both the red and green slabs.

5 On the Animation KeyFrames dialog box, click Create.
6 Enter a name like “start” for this frame.

7 Now, deselect and then move the red slab to the middle of the green slab. Again, select both slabs.

8 Click Create again. Name this frame “mid.”

9 Deselect again and then move the red slab to the far corner of the green slab.

10 Select the red and green slabs.

11 Click Create. Call this one “finish.”

We have created three key frames.

We must next make a script to describe the type of motion between each key frame.

To make the script

1 In the Animation KeyFrames dialog box, highlight the key frame named “start” and click the Script button.

2 In the Script KeyFrame dialog box, click OK to use all defaults.

3 Do the same for “mid” and set the start time to 11.

4 Do the same for “finish” and set the start time to 21.

5 In Animation Producer dialog, make sure the view is set to the one in which you want the animation to occur, then select Tools > Preview.

6 Click the Play button and watch the red slab move across the green slab.

By now, you should have a feel for how this works and you are ready to dig deeper into the Help files to learn more when you have MicroStation available. There is much more to learn. You can make the red block into an actor and have it rotate, jump up and down or morph it into a cylinder. You can place a variety of lights where you want and much, much more to make your designs come to life.
### Shortcut 2D key-in commands

<table>
<thead>
<tr>
<th>Key-in</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>aa=nn</code></td>
<td>sets the active angle to <code>nn</code></td>
</tr>
<tr>
<td><code>ac=cell</code></td>
<td>sets the active cell to the name given, for example “cell”</td>
</tr>
<tr>
<td><code>ap=cell</code></td>
<td>sets the active pattern cell to the cell indicated</td>
</tr>
<tr>
<td><code>ar=cell</code></td>
<td>sets the active cell to “cell” for relative place</td>
</tr>
<tr>
<td><code>as=nn</code></td>
<td>sets the active scale to <code>nn</code></td>
</tr>
<tr>
<td><code>cc=cell</code></td>
<td>creates the cell in the attached library</td>
</tr>
<tr>
<td><code>cd=cell</code></td>
<td>deletes the cell from the attached library</td>
</tr>
<tr>
<td><code>co=color</code></td>
<td>sets the active color</td>
</tr>
<tr>
<td><code>cr=old, new</code></td>
<td>renames a cell</td>
</tr>
<tr>
<td><code>df=</code></td>
<td>displays the Fonts dialog box</td>
</tr>
<tr>
<td><code>di=dist,angle</code></td>
<td>sets the distance and angle to the next data point</td>
</tr>
<tr>
<td><code>dl=del x, del y</code></td>
<td>sets the distance to the next data point in the drawing coord</td>
</tr>
<tr>
<td><code>dv=view</code></td>
<td>deletes the saved view indicated</td>
</tr>
<tr>
<td><code>dx=del x, del y</code></td>
<td>similar to <code>dl</code>, but in the view coordinate system</td>
</tr>
<tr>
<td><code>ff=filename</code></td>
<td>copies the fenced elements to a new design file</td>
</tr>
<tr>
<td><code>ft=font#</code></td>
<td>sets the active font</td>
</tr>
<tr>
<td><code>gr=nn</code></td>
<td>sets the number of units between grid references</td>
</tr>
<tr>
<td><code>gu=distance</code></td>
<td>sets the grid spacing to the working units value</td>
</tr>
<tr>
<td><code>ky=nn</code></td>
<td>sets the snap lock divisor to <code>nn</code></td>
</tr>
<tr>
<td><code>lc=code</code></td>
<td>sets the active linestyle</td>
</tr>
<tr>
<td><code>ld=level</code></td>
<td>places all dimensioning information on the level</td>
</tr>
<tr>
<td>Key-in</td>
<td>Result</td>
</tr>
<tr>
<td>---------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ld=level</td>
<td>places all dimensioning information on the level</td>
</tr>
<tr>
<td>ll=nn</td>
<td>sets the maximum number of characters for a text node (1-255)</td>
</tr>
<tr>
<td>ls=nn</td>
<td>sets the text line spacing</td>
</tr>
<tr>
<td>lv=nn</td>
<td>sets the active level to nn</td>
</tr>
<tr>
<td>on=nn,nn,…</td>
<td>turns on the levels listed</td>
</tr>
<tr>
<td>off=nn,nn,…</td>
<td>turns off the levels listed</td>
</tr>
<tr>
<td>pa=nn</td>
<td>sets the active pattern angle to nn</td>
</tr>
<tr>
<td>ps=nn</td>
<td>sets the active pattern scale to nn</td>
</tr>
<tr>
<td>rc=library</td>
<td>attaches the cell library</td>
</tr>
<tr>
<td>rd=file</td>
<td>closes the current design file</td>
</tr>
<tr>
<td>sd=nn</td>
<td>sets the stream delta to nn</td>
</tr>
<tr>
<td>sf=file</td>
<td>moves the selected elements to a new file</td>
</tr>
<tr>
<td>st=nn</td>
<td>sets the stream tolerance to nn</td>
</tr>
<tr>
<td>sv=name</td>
<td>saves the current view settings under name</td>
</tr>
<tr>
<td>th=nn</td>
<td>sets the active text height</td>
</tr>
<tr>
<td>tx=nn</td>
<td>sets the active scale for cell as line terminator</td>
</tr>
<tr>
<td>tw=nn</td>
<td>sets the active text width</td>
</tr>
<tr>
<td>vi=name</td>
<td>attaches the view named</td>
</tr>
<tr>
<td>wt=nn</td>
<td>sets the active line weight</td>
</tr>
<tr>
<td>xs=nn</td>
<td>sets the active x scale</td>
</tr>
<tr>
<td>xy=nx, ny</td>
<td>sets the next data point at absolute nx and ny</td>
</tr>
<tr>
<td>ys=nn</td>
<td>sets the active y scale</td>
</tr>
</tbody>
</table>